Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGS: Tais' SCI's
Re: BUGS: Tais' SCI's[message #302418] Mon, 26 March 2012 08:35 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
Biernath_J
.30 car - AP is described as FMJ (not the same thing)
.300 winmag - not described as AP
.338 lapua - not described as AP
.45ACP glaser - says 100 rounds, is 50 rounds
.50AE - not described as AP
.50 beowulf - not described as AP
.50 BMG - not described as AP
12.7x108 - not described as AP
12.7/x97 - not described as AP
4.6x30 - not described as AP
4.7x33 - not described as AP
5.45x18 - not described as AP
5.45x39 normal & cold - not described as AP
5.56x45 normal & cold - not described as AP
5.56x45 SCF - not described as AP
5.7x28 - not described as AP
6.8 SPC - not described as AP
7.62x25 normal & cold - not described as AP
7.62x37 - not described as AP
7.62x39 normal & cold - not described as AP
7.62x51 normal & cold - not described as AP
7.62x54R - not described as AP
7.92x57 - not described as AP
9x21 - described as SP-10 instead of AP
9x39 - not described as AP
CAWS - not described as slugs/ap, also both CAWS boxes say 50 rounds, should say 25


Yeah, I left most of those w/out the AP because the game originally didn't have any AP label on ammo that came in AP by default. There seems to be a push for FMJ to be split from AP, so I'm fine with switching them to say AP; it's clearer now anyway.

9x21 is labeled as SP-10, because I figured we may eventually want to add SP-11 ammo as well, but we can just call them AP and Match too.

Errors in box descriptions for quantities will be corrected too.

Thanks!

@DB & Rowa21: thanks for finding and correcting that one -- I hadn't even noticed the guns page was screwy since it was so late by that point Razz We should probably have the ammo say "Size:" and the weapons say "Mag:" (like they both used to) though, if you haven't done that already (haven't had time to check). ...Or they could both say "Rounds:", but I'm not sure there's enough space on the screen...


Re: BUGS: Tais' SCI's[message #302419] Mon, 26 March 2012 08:51 Go to previous messageGo to next message
Biernath_J

 
Messages:166
Registered:August 2003
Location: Poland
The problem about not marking AP ammunition as AP is consistency.
Because, right now, there are some ammo boxes that have, say, 3 types: AP, HP and AET. Or only 2 tyles - AP and HP.

And then, you have another caliber that has 3 types - 'normal', HP and AET. This 'normal' is of course AP.

We should not keep it 'both ways'. Go with one or another.

I would obviously go with clear marking any 'red' ammunition as AP, marked both in the box/magazine name AND BR description.
Re: BUGS: Tais' SCI's[message #302421] Mon, 26 March 2012 08:54 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
It is done. Added corrected items.xml to the GameDir svn folder.


Re: BUGS: Tais' SCI's[message #302644] Sun, 01 April 2012 16:41 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
I've been getting some random crashes in BR's the moment I click the "Accept Order", I have upped the max amount of order items to 50 but that shouldnt have anything to do with it.

First time was a shitload of rifles and pistols, moved around the list of order items a bit and then clicked accept order, the exe crashed, no exception or assertion.

Second time all went well, not the same list of items but still 50 items and they all got delivered to drassen.

Third time I had less items, didn't scroll the list and just went to accept order straight away, I got something of an assertion:
Unhandled exception processing gameloop, unable to recover
Assertion failure on Line 1837 in file sgp.cpp

Fourth and fifth time same story as first time, ordered a few weapons, smg's, shotguns, snipers, ar's, pistols and it just blatantly crashed after clicking the order button when getting the progress bar, also lowered to max 30 items this time but that didn't change anything clearly.

Dunno if anyone else can reconstruct this?

running my own 5116 sci btw Razz (on Win7 x64, windowed mode)

Other stuff that I found was that when I open the laptop the first time my mouse is still stuck inside the laptop screen, when I open it the second time it's free to go anywhere.


Re: BUGS: Tais' SCI's[message #302648] Sun, 01 April 2012 17:53 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
The unable to recover dialog occurs when the crash is not one of the assert checks (usually) and it cannot properly shutdown for one reason or another. Also cannot put up the standard error screen either because of corruption (locked video buffers or something like that).

I would like to breach the possibility of fixing the crash report that is currently being written to the profile area. First its broken with VFS enabled but more its pretty easy to dump the call stack of the crash. I already have that code available.

The main problem is we would have to change distribution procedures for it to be meaningful. Either Release builds have the Symbol (PDB) file build by default or we use ReleaseWithDebugInfo build. In either case I would recommend using /Zi instead of /ZI to avoid EXE bloat. The PDB files are rather large 30 MB but enable writing the callstack of a crash with source code line location. (The other possibility is to create minidumps but those are more headaches than they are worth for this kind of project.

Not saying this would help but it frequently makes it easier to pinpoint incorrect null pointer handling in the code which is rampant.
Re: BUGS: Tais' SCI's[message #302651] Sun, 01 April 2012 18:21 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
You do what you find best to fix this, I am just a mere php coder, I cannot have any opinion about all of this.
All I know is that this is a bug and I'm wondering if other people are experiencing the same, a pattern that I am seeing is that it happens when either guns or miscellaneous items are involved in the buy order, could be a coincidence.


Re: BUGS: Tais' SCI's[message #302657] Sun, 01 April 2012 19:36 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
Just saying if you are willing to release the .PDB files (and do ReleaseWithDebugInfo builds instead of Release). You are the distributor of these releases after all so I would request that you put these in if I turn on the feature. It would be nice if the other coders could chime in if they have an opinion. (Sorry for taking this slightly off-topic).

I'll add this code so we can get better crash dumps and give it to RoWa21 we can decide later if we use it.
Re: BUGS: Tais' SCI's[message #302658] Sun, 01 April 2012 19:55 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
Tais
You do what you find best to fix this, I am just a mere php coder, I cannot have any opinion about all of this.
All I know is that this is a bug and I'm wondering if other people are experiencing the same, a pattern that I am seeing is that it happens when either guns or miscellaneous items are involved in the buy order, could be a coincidence.


I have seen this bug too. It's been in there since the code change to allow more than 10 items per order. Unfortunately simply limiting items per order back to the original 10 doesn't work around it.

I took a very brief look at it a while back but didn't spot any good reason for the crash to occur.


Re: BUGS: Tais' SCI's[message #302659] Sun, 01 April 2012 20:01 Go to previous messageGo to next message
Gambigobilla

 
Messages:709
Registered:July 2008
Many users use Tais' SCIs. If you implement this, many good-for-nothing users like me become beta-testers. Thumbs-up for the idea.
Re: BUGS: Tais' SCI's[message #302660] Sun, 01 April 2012 20:10 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3733
Registered:July 2009
You are Beta testers, didn't you read the opening post? :goodnews:
This will only increase efficiency.


Re: BUGS: Tais' SCI's[message #302664] Sun, 01 April 2012 22:09 Go to previous messageGo to next message
Scouty

 
Messages:76
Registered:April 2008
Using SCI 5116:

Occasionally when exiting the game (either alt+x or quit button), it will hang, using 50% CPU (one core). Sometimes the hang is severe enough to prevent opening the task manager to terminate the process. The only way out in that case is a cold reboot. I'm on XP, anyone else having this issue? It's not that frequent mind you, but I had it three times since the 5116 SCI is out.

Edit - If I recall correctly this is new behavior, not present in the 5066 SCI.

Also, maybe more of a feature request than a bug:

We have this neat system where compatible attachments/ammo get highlighted when mousing over an item. But this works separately for your merc inventory and the sector inventory.

http://i738.photobucket.com/albums/xx23/WOoKie_Scouty/ja2_highlight.png

Note the 7.62x51mm ammo box isn't highlighted when selecting the gun. Wouldn't it be cool if it worked both ways?

[Updated on: Sun, 01 April 2012 22:26] by Moderator

Re: BUGS: Tais' SCI's[message #302665] Sun, 01 April 2012 22:46 Go to previous messageGo to next message
Crazybite

 
Messages:33
Registered:January 2007
Location: Netherlands
Using SCI 5116 unstable,

Only set resolution to setting 14, turned intro off in the ini. No other changes.

Started a new game, reading IMP email, then going to the site in the laptop > CTD before entering xep624.
* tried to reproduce this, but couldn't. (yet. I'm gonna try to.)

Seeing this large resolution made me happy, but in the game when you open a merc inventory there is a small portion left and right of the inventory that does not get re-drawn on the screen.

Picking a resolution in the ini that does not match your screen, does not make the game exit/crash. (screen tells me out of range, have to terminate game with task manager.)

In my second game I noticed that the screen did not get redrawn where your merc info shows over your head where you entered the second sector to deliver the letter. ( I clicked my merc and started walking towards the hideout the name and bars were still there, the other graphic on the info was not.) The graphic got fixed when you moved the screen out of focus of your merc and then back again.

Hope this was usefull.
Re: BUGS: Tais' SCI's[message #302676] Mon, 02 April 2012 04:26 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
Scouty
Using SCI 5116:
Occasionally when exiting the game (either alt+x or quit button), it will hang, using 50% CPU (one core). Sometimes the hang is severe enough to prevent opening the task manager to terminate the process. The only way out in that case is a cold reboot. I'm on XP, anyone else having this issue? It's not that frequent mind you, but I had it three times since the 5116 SCI is out.
My experience with this was that the video subsystem will go into an infinite loop due to one of 2 errors related to being shutdown while doing its final refresh. I've submitted a patch to RoWa21 that should limit the number of attempts when DirectX has errors to 10 before giving up rather than banging its head against a wall forever. The code is written in a strange way that will never exit the loop if there is an error so I really do not understand its intent. I'm not sure if it thinks that if it tries again that things will be better next time for some reason.
Re: BUGS: Tais' SCI's[message #302697] Mon, 02 April 2012 16:53 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
Tried building an sci with the newest release, only thing I am now getting is that I am not allowed to use any other name for the exe than the one that it gets while building, even when I change the targetname so that the pdb and exe come out the same it will still crash on startup, I tried this with a clean install and also another clean source directory and doing a rebuild.
The crash is somehow kinda random so when I call my exe ja2.exe and try running it I get a crash 8 out of 10 times.
When I dont change the name of the exe I get totally no crashes, when I try and recreate the br's crash and it does crash (randomly it seems as I bought 4 full orders of guns and it crashed on the 4th) I get nothing of a stack trace or log anywhere.

Also something new has sneaked into the exe, you cannot keep your mousebutton pressed on a br's item to make it automatically raise the amount, instead we're back to single clicks.....

I dont want to be rude but somewhere I am having the feeling we're going backwards instead of forward in terms of stability..

I am going to release the SCI I have created to see if anyone else is having the same of this shit happen to him..
I will add multiple exe's to this SCI to see if people are having different things happening, please also try windowed mode!

http://kermi.pp.fi/JA_2/v1.13_Releases/Unofficial/English/tais/SVN/SCI_113SVN_r5143_20120402.7z


Re: BUGS: Tais' SCI's[message #302704] Mon, 02 April 2012 20:07 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
No argument here - the new code from last night appears to be quite screwy. Just starting and exiting the exe takes forever, and the exe hangs around after exiting, using 1.7GB RAM and some CPU, until killed in task manager.

EDIT: Actually, I see what's going on now. First try at starting the exe makes it load in the background with 1.7GB ram. 2nd try works fine, especially if you kill the first instance before trying to run it again. Still weird though. It may just be my configuration. Anyone else seeing anything similar?


Re: BUGS: Tais' SCI's[message #302728] Tue, 03 April 2012 07:18 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
My guess is many of the changes I submitted to RoWa21 got incorporated so its likely my changes. Apologies if it was my changes. I do try to test even if it may not seem like it.

I think its unlikely the changes overnight would case this behavior but I suppose anything is possible.

@Tais, the crash report only gets triggered if you are in the GameLoop. If you cannot get through initialization I don't think the default is to capture the exception. Not hard to add if we feel it would be desirable but since it depends on VFS to some degree it could be problematic if VFS is not also properly initialized.

@Madd Mugsy, the 1.7 GB issues sounds like a runaway malloc loop of some sort. Could it be related to ja2_settings or something similar not initialized first time but initialized on second pass. What about the ja2set.dat.xml file as well. That change within past couple of weeks and I dont think is really compatible with current file but might still be around in your profile directory.

@Tais, that could be a result of "fixing" the clicking issues with BR a few weeks ago. I'll see if putting mouse handling explicitly in the screen addresses it. Is there anywhere else with similar behavior? (Submitted fix to RoWa21 for inclusion).

@Tais, regarding building with different target name the following works for me (where msbuild is available from .net folder or from Visual Studio Command Prompt)
msbuild.exe /p:Configuration=Release /p:TargetName=JA2 ja2_VS2010.sln

[Updated on: Tue, 03 April 2012 08:25] by Moderator

Re: BUGS: Tais' SCI's[message #302732] Tue, 03 April 2012 13:23 Go to previous messageGo to next message
Buggler

 
Messages:209
Registered:November 2009
Bug during Merc Preplacement Tactical Screen. Tested w Tai's SCI5116 & today's latest SVN. Working fine in 4870.

[color:#999999]Using hotkeys to activate e placement buttons e.g. 'c', 'g' or 's' will do bonkers to mouse clicking & keyboard input. Only way out is to kill process.
(Mouse click on e placement buttons is all working fine though.)[/color]
+++++
[quote:Tais]cannot keep your mousebutton pressed on a br's item to make it automatically raise the amount, instead we're back to single clicks.....[/quote]
Thanks Tazpn 4 fixing this. Smile E bug was introduced when I submitted e BR hotkeys code way back bf r4870.

This will b fixed in e next [Unofficial patch for 'Official Release Build 4870'] too when it is released.

Edit:
It's e same bug as fixed by Tazpn in BR. Fix already submitted to Rowa.

[Updated on: Tue, 03 April 2012 16:48] by Moderator

Re: BUGS: Tais' SCI's[message #302740] Tue, 03 April 2012 18:03 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
Buggler

[quote:Tais]cannot keep your mousebutton pressed on a br's item to make it automatically raise the amount, instead we're back to single clicks.....[/quote]
Thanks Tazpn 4 fixing this. Smile E bug was introduced when I submitted e BR hotkeys code way back bf r4870.

This will b fixed in e next [Unofficial patch for 'Official Release Build 4870'] too when it is released.

Edit:
It's e same bug as fixed by Tazpn in BR. Fix already submitted to Rowa.


Weird because in r5088 it worked like a charm

and thanks for the /p:targetname, that should make my life a lot easier


Re: BUGS: Tais' SCI's[message #302788] Wed, 04 April 2012 19:10 Go to previous messageGo to next message
Randok

 
Messages:301
Registered:March 2004
JA2+SCI 5143
When I adds: Steel Tube + Duct Tape and Quick Glue I have Runtime Error
Assertion Failure ( Line 1873 in file sgp.cpp )
Atempting to do debug save as SaveGame 247 ( this may fail )
Unhanded exeption processing GameLoop unable to recover
Re: BUGS: Tais' SCI's[message #302791] Wed, 04 April 2012 19:46 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
you sure that wasn't line 1837 like mine Randok?


Re: BUGS: Tais' SCI's[message #302792] Wed, 04 April 2012 20:06 Go to previous messageGo to next message
Randok

 
Messages:301
Registered:March 2004
I checked: 1873
Re: BUGS: Tais' SCI's[message #302793] Wed, 04 April 2012 20:38 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
oh I looked it up, mine was also 1873 then clearly.. my bad!

and tazpn when I do

msbuild.exe ja2_VS2010.sln /p:configuration=Release /p:TargetName=ja2 /t:rebuild
msbuild.exe ja2_VS2010.sln /p:configuration=MapEditor /p:TargetName="Map Editor" /t:rebuild
msbuild.exe ext\export\ja2export_VS2010.vcxproj /p:configuration=Release /t:rebuild
msbuild.exe ja2_VS2010.sln /p:configuration=Release /p:JA2Config=JA2UB /p:TargetName=ja2_ub /t:rebuild

I get messed up builds on ja2 and ja2_ub, some linker error about console.lib that cannot be found


Re: BUGS: Tais' SCI's[message #302794] Wed, 04 April 2012 21:09 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
I believe I squashed that bug yesterday -- at least it works on my PC now! Razz

It was breaking Ctrl+Shift+F as well, when trying to separate attachments from guns.


Re: BUGS: Tais' SCI's[message #302807] Thu, 05 April 2012 07:07 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
@Tais, I'm thinking TargetName on sln overrides everyones TargetName in solution. Honestly rarely do I override TargetName so what might be happening in my testing is the normal build creates all of the standard libs with proper names. When doing the targetname override after that it uses the already built lib files. (Sorry takes too long to do full builds so I didn't do thorough testing before suggesting it. Only tested that it actually worked when tried.)

Perhaps the following is better though will create the additional exe files when doing the sln build.
msbuild.exe ja2_VS2010.sln /p:configuration=Release /t:rebuild
msbuild.exe ja2_VS2010.vcxproj /p:configuration=Release /p:TargetName=ja2
msbuild.exe ext\export\ja2export_VS2010.vcxproj /p:configuration=Release
msbuild.exe ja2_VS2010.sln /p:configuration=MapEditor /t:rebuild
msbuild.exe ja2_VS2010.vcxproj /p:configuration=MapEditor /p:TargetName="Map Editor"
msbuild.exe ja2_VS2010.sln /p:configuration=Release /p:JA2Config=JA2UB /t:rebuild
msbuild.exe ja2_VS2010.vcxproj /p:configuration=Release /p:JA2Config=JA2UB /p:TargetName=ja2_ub

Also, rebuild shouldn't actually be required since VS2010 does a good job of detecting if settings have changed and will rebuild changed files though cannot go wrong with rebuild/clean in an automated build.
Re: BUGS: Tais' SCI's[message #302809] Thu, 05 April 2012 09:27 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
hmmmm I'm gonna run that when I get home from work, sounds like a pretty clear explanation for whats happening.
I always do a rebuild on an sci release just to be totally sure that I am actually making a sane exe.
This automated build script is just part one, next I'll ask for donations for a big ass server and a 100mbit fiber line Razz (j/k)


Re: BUGS: Tais' SCI's[message #302814] Thu, 05 April 2012 13:21 Go to previous messageGo to next message
smeagol

 
Messages:2732
Registered:June 2008
Location: Bremen, Germany
Randok
JA2+SCI 5143
When I adds: Steel Tube + Duct Tape and Quick Glue I have Runtime Error
Assertion Failure ( Line 1873 in file sgp.cpp )
Atempting to do debug save as SaveGame 247 ( this may fail )
Unhanded exeption processing GameLoop unable to recover


That line also crashes the mapeditor when saving a map.


Re: BUGS: Tais' SCI's[message #302816] Thu, 05 April 2012 15:07 Go to previous messageGo to next message
RoWa21

 
Messages:2004
Registered:October 2005
Location: Austria
Randok
JA2+SCI 5143
When I adds: Steel Tube + Duct Tape and Quick Glue I have Runtime Error
Assertion Failure ( Line 1873 in file sgp.cpp )
Atempting to do debug save as SaveGame 247 ( this may fail )
Unhanded exeption processing GameLoop unable to recover


I just tried to reproduce the bug with the latest source code and gamedir files and it works without a crash. So the crash seems to be fixed.


Re: BUGS: Tais' SCI's[message #302817] Thu, 05 April 2012 15:32 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
lets see if that also fixes the br's order accept crash then as it's refering to the same line, will have more info in about two to three hours, if the build succeeds I'll release that.

[Updated on: Thu, 05 April 2012 15:36] by Moderator



Re: BUGS: Tais' SCI's[message #302824] Thu, 05 April 2012 19:13 Go to previous messageGo to next message
Randok

 
Messages:301
Registered:March 2004
@ all
I am glad that I can help a little.
Smile
Re: BUGS: Tais' SCI's[message #302842] Thu, 05 April 2012 23:56 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
Actually that line in sgp.cpp is useless for determining the cause of the error: that line is just called to display the error message on the screen. So every error will show as line 1873 in sgp.cpp.

Also, if you try out the KAC Masterkey, I would suggest you treat it as an Alpha test, not Beta. In other words, dont get frustrated, and don't load it with your only 4 flechette rounds Wink


Re: BUGS: Tais' SCI's[message #302846] Fri, 06 April 2012 00:18 Go to previous messageGo to next message
Scouty

 
Messages:76
Registered:April 2008
SCI 5163

Related to the IIS system:

http://i738.photobucket.com/albums/xx23/WOoKie_Scouty/ja2_iis01.png

I got an interrupt when the enemy moved out of vision range, giving me no firing solution at all. Technically I wouldn't be able to spot her (if the LOS colors are to be trusted).

The next guy was interrupted quicker:

http://i738.photobucket.com/albums/xx23/WOoKie_Scouty/ja2_iis02.png

Unrelated issue:

When holding END to check LOS, press INSERT to switch to the map screen - you end up stuck there, with corrupt graphics:

http://i738.photobucket.com/albums/xx23/WOoKie_Scouty/ja2_end_plus_insert.png

Discovered by accident by holding END and reaching for PRINT SCREEN (and missing obviously). Very Happy

Another one:

When ambushed by bloodcats, your MERCS don't start in the center of the map. Also, the scheduled destination (IE D12) isn't canceled in the strategic squad screen.

For some reason I get very far interrupts at night (well outside vision range), the enemy shot my militia:

http://i738.photobucket.com/albums/xx23/WOoKie_Scouty/ja2_iis03.png

[Updated on: Fri, 06 April 2012 01:31] by Moderator

Re: BUGS: Tais' SCI's[message #302858] Fri, 06 April 2012 06:03 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
Madd Mugsy
Actually that line in sgp.cpp is useless for determining the cause of the error: that line is just called to display the error message on the screen. So every error will show as line 1873 in sgp.cpp.

Not strictly true (or at least shouldn't be). Only unhandled exceptions should trigger that one. Normal asserts should still trigger and show which ever line they were on. There should be a crash report in the Profile directory with name like 'Crash Report_01_04_2012___11_29.txt' which may have more information if we deliver the PDB files with the release.

If we do ship the PDB file then you would get something like this which has a callstack with line numbers.
Toggle Spoiler


The assert was just laziness on my behalf to allow for termination of the game with an error screen. Should probably put something more useful in there.
Re: BUGS: Tais' SCI's[message #302861] Fri, 06 April 2012 10:24 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
FWIW... Asserts are good and all, but the majority of the errors I've seen have been unhandled Wink

The call stack is generally much more useful, so if/when we ship the PDB, I encourage everyone to look there first before posting.


Re: BUGS: Tais' SCI's[message #302866] Fri, 06 April 2012 14:15 Go to previous messageGo to next message
Scouty

 
Messages:76
Registered:April 2008
SCI 5163:

Loading a savegame during an interrupt (IIS), gives you a moving "interrupt" bar at the top. I'm also not sure why I even got an interrupt here, I checked with alt+e where the enemies are, and I can't see any of them. Just hearing is enough?

savegame

===

Regarding the "Inv actions cost AP" option:

When reloading a shotgun, you can drag shells onto it, using up all your AP... then you're stuck with shells on your cursor since putting them somewhere costs AP too.

[Updated on: Fri, 06 April 2012 22:34] by Moderator

Re: BUGS: Tais' SCI's[message #302884] Fri, 06 April 2012 22:40 Go to previous messageGo to next message
Randok

 
Messages:301
Registered:March 2004
JA2+ SCI5163
MILKOR MGL 140
After inserting a grenade (any) to the fifth slot (from top) does not wear indicator.
A similar problem of Retractable Stock when inserted into a slot in weapons.

[Updated on: Fri, 06 April 2012 22:40] by Moderator

Re: BUGS: Tais' SCI's[message #302911] Sat, 07 April 2012 06:21 Go to previous messageGo to next message
tazpn

 
Messages:99
Registered:December 2007
Location: CA, USA
Madd Mugsy
FWIW... Asserts are good and all, but the majority of the errors I've seen have been unhandled Wink

The call stack is generally much more useful, so if/when we ship the PDB, I encourage everyone to look there first before posting.


I submitted a change to RoWa21 to try an locate last known function in the exe with line number and report that instead. It also reports the string associated with the exception. The crash report will continue to be written. I suppose I could also print out the call stack as part of the fail message but I didn't think it would be as valuable as just the last known line. Anyway we'll try it out and if it works well then its a win all the way around.


Scouty
SCI 5163:

Loading a savegame during an interrupt (IIS), gives you a moving "interrupt" bar at the top. I'm also not sure why I even got an interrupt here, I checked with alt+e where the enemies are, and I can't see any of them. Just hearing is enough?

Seems to be. I've stopped using IIS in my games as there are far too many interrupts especially when you get good mercs and get good equipment.
Re: BUGS: Tais' SCI's[message #302912] Sat, 07 April 2012 06:43 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
@tazpn: good stuff! Smile

@Scouty:

I'm using IIS right now as well, and I agree there are a lot of inexplicable interrupts. Extended ears do increase their frequency.

I've also noticed that (at least in IIS mode) enemies often move one tile per regular turn, but will move around lots during an interrupt. I didn't notice this before using IIS.


Re: BUGS: Tais' SCI's[message #302934] Sat, 07 April 2012 14:29 Go to previous messageGo to next message
tais

 
Messages:674
Registered:February 2008
Location: NL
BR's crash report <--- FIRST REAL INFORMATIVE CRASH REPORT! (I hope)

Toggle Spoiler


Re: BUGS: Tais' SCI's[message #302950] Sat, 07 April 2012 19:05 Go to previous messageGo to next message
Madd_Mugsy

 
Messages:635
Registered:July 2005
Location: Canada
Based on that report alone my guess is either a video redraw problem or something to do with keeping the mouse limited to the laptop screen.


Re: BUGS: Tais' SCI's[message #302951] Sat, 07 April 2012 19:07 Go to previous messageGo to previous message
Scouty

 
Messages:76
Registered:April 2008
SCI 5163:

I'm assuming it's a bug that I can fit 6 wire cutters in a medical syringe pocket (part of medical pouch)? Smile

http://i738.photobucket.com/albums/xx23/WOoKie_Scouty/ja2_medicalpocket.png

[Updated on: Sat, 07 April 2012 19:12] by Moderator

Previous Topic: Merc's wisdom stat dropping to 1
Next Topic: Mobile Militia spawn as Elites?
Goto Forum:
  


Current Time: Sat Jul 11 01:19:32 EEST 2020

Total time taken to generate the page: 0.01270 seconds