Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #340942 is a reply to message #340901] Sun, 10 May 2015 15:10 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
Hmm. This can also happen in stock 1.13. Seems to only happen if attached to a gun. For some reason, sometimes a pointer is corrupted, resulting in random behaviour.

Edit: Fixed in r7855. However... the attachment code in general is so messed up I have a hard time determining whether the code is buggy, intended to be this obscure, or the result of some merging accident.

[Updated on: Sun, 10 May 2015 16:09]




You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340966 is a reply to message #340942] Tue, 12 May 2015 19:45 Go to previous messageGo to next message
ExxonValdez

 
Messages:30
Registered:October 2014
Location: Poland, Wrocław
Flugente, http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=12303&goto=340821&#msg_340821 any news ?
Re: BUGZILLA report all bugs here![message #340971 is a reply to message #340966] Wed, 13 May 2015 11:30 Go to previous messageGo to next message
Uriens

 
Messages:329
Registered:July 2006
Using SCI 7835. I'm getting weapons with 100% condition to jam quite frequently. Not sure if that is related to those pointers because the way those jams happen are quite peculiar. Namely, I have like 6 or so same guns in the squad but only one of them will start jamming at 100% or close to 100% condition. Other times (other battle or maybe reload) another gun will start doing that while the previous one will no longer jam.

I'm also getting an error which causes game to crash shortly after: "schedule callback: illegal soldier ID of 0.". It's displayed in the message box in the bottom left corner, not like those assertion fail messages. I don't know to which feature that is connected so I'm reporting it here.

Edit: And just as I reported it, I got 2 guns to start jamming at max condition. Apparently, whatever the bug is, it doesn't have to be one item. Also, the jams are quite frequent, like gun condition is way below 50% so it makes it almost unusable. Never had that happen in the previous SCI so whatever was changed in between 7835 and the one before is likely the cause of it.

[Updated on: Wed, 13 May 2015 12:49]

Re: BUGZILLA report all bugs here![message #340972 is a reply to message #340971] Wed, 13 May 2015 13:08 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
@ExxonValdez: will check once I have time, likely earliest the next weekend.

@Uriens: I assume you are using stock 1.13 on this one... Is overheating or dirt active? Any special things you did, like item transformationss?



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340975 is a reply to message #340972] Wed, 13 May 2015 17:01 Go to previous messageGo to next message
Uriens

 
Messages:329
Registered:July 2006
Nope, dirt and overheating are off. I always have them off, no other changes except for some usual changes I always do to ini file. No modifications to the other files.

Btw. in previous playthrough of UC mod with one version older SCI I had some problems when there was a vehicle present in the sector that was loaded. Problems like AI turn going into endless loop. No matter what I would do it wouldn't pass first AI turn. However, when I would move vehicle away from sector and then tried the same battle again - game would work normally. However, since this was both UC in question and I did use some shift+arrow rearranging of mercs (IIRC that used to mess up indexes while ago) I wasn't really sure what caused it so I didn't report it. That "schedule callback: illegal soldier ID of 0." error is something I saw first time since I play but, in the sector that was currently loaded, there was a vehicle present. It's possible it's related but not sure. Unloading sector and then reloading fixed that error problem and I wasn't able to reproduce it yet.

As far as the jams are concerned, it happens all the time. I'll look into it more closely, see if I manage to find a pattern and what causes it. Odd thing is that it currently only happens on one type of gun but currently I hardly have any other guns.

Edit: Ignore jam part of the report, I may have made a mistake in ja2_options.ini file. I'll check it out of it still happens but so far just ignore.
The "schedule callback: illegal soldier ID of 0." error is still valid though and I'll try to reproduce it.

[Updated on: Wed, 13 May 2015 18:11]

Re: BUGZILLA report all bugs here![message #340982 is a reply to message #340975] Thu, 14 May 2015 17:48 Go to previous messageGo to next message
sevenfm

 
Messages:1839
Registered:December 2012
Location: Soviet Russia
Looks like dynamic aiming levels are shown incorrectly in EDB for mercs with skills, for example, marksman skill lowers shown max. aimlevels value instead of increasing it.
Probably the values for EDB are calculated in NCTH system even when using OCTH.
Actual shooting and aiming works ok.



7609+fix | 7609+AI (r956) | 7609 unofficial modpack | Win8+ fix | Experimental project | Vengeance:Reloaded | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: BUGZILLA report all bugs here![message #340986 is a reply to message #340982] Thu, 14 May 2015 22:48 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
sevenfm wrote on Thu, 14 May 2015 16:48
Looks like dynamic aiming levels are shown incorrectly in EDB for mercs with skills, for example, marksman skill lowers shown max. aimlevels value instead of increasing it.
Probably the values for EDB are calculated in NCTH system even when using OCTH.
Actual shooting and aiming works ok.

That was an easy fix -> r7864.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #340989 is a reply to message #340986] Fri, 15 May 2015 14:58 Go to previous messageGo to next message
smeagol

 
Messages:2718
Registered:June 2008
Location: Bremen, Germany
And another very annoying bug:

I got an endless stop watch during opponents turns. The source of this seems to be if an unmanned vehicle is spotted by the AI. Took some time to figure it out and I'm not yet 100% sure on this one either.

I made an assault on several different sectors during a daytime mission, the vehicles seem to get parked within sight range of enemies each time. When entering turnbased, the game will freeze with the usual stopwatch and end of opponents turn and there is no way to stop the freeze (not even GABBI and Alt+Enter work). If entering the sector without vehicle, all seems to work fine.

Tried in two different sectors (Bigmaps D2 and G2). Will likely be hard to track. :/


Re: BUGZILLA report all bugs here![message #340991 is a reply to message #340989] Fri, 15 May 2015 18:49 Go to previous messageGo to next message
dreamer2008

 
Messages:64
Registered:May 2010
After using the new weapon selection with IMP, I don't get a few of the items I've chosen when I start the game. For example, when I choose to get two NVG I, when I start the game I actually get none. The same with extra Scopes. Didn't test anything else.
I'm using the latest Depri build that came out today.
Re: BUGZILLA report all bugs here![message #340997 is a reply to message #340989] Fri, 15 May 2015 21:03 Go to previous messageGo to next message
Uriens

 
Messages:329
Registered:July 2006
smeagol wrote on Fri, 15 May 2015 11:58
And another very annoying bug:

I got an endless stop watch during opponents turns. The source of this seems to be if an unmanned vehicle is spotted by the AI. Took some time to figure it out and I'm not yet 100% sure on this one either.

I made an assault on several different sectors during a daytime mission, the vehicles seem to get parked within sight range of enemies each time. When entering turnbased, the game will freeze with the usual stopwatch and end of opponents turn and there is no way to stop the freeze (not even GABBI and Alt+Enter work). If entering the sector without vehicle, all seems to work fine.

Tried in two different sectors (Bigmaps D2 and G2). Will likely be hard to track. :/


I had similar thing happen in UC mod. If there was a (empty) vehicle present in the map, during AI turn I'd get a stopwatch. I just wasn't sure what caused it so I didn't report it.
Re: BUGZILLA report all bugs here![message #340998 is a reply to message #340991] Fri, 15 May 2015 21:03 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
dreamer2008 wrote on Fri, 15 May 2015 17:49
After using the new weapon selection with IMP, I don't get a few of the items I've chosen when I start the game. For example, when I choose to get two NVG I, when I start the game I actually get none. The same with extra Scopes. Didn't test anything else.
I'm using the latest Depri build that came out today.

If you pick too many items it can happen that they don't all fit into your merc's inventory. Don't be so greedy. ;)



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341001 is a reply to message #340998] Fri, 15 May 2015 21:48 Go to previous messageGo to next message
smeagol

 
Messages:2718
Registered:June 2008
Location: Bremen, Germany
Did some more investigations on the vehicle stopwatch bug...

seems like it is caused if there are at least two vehicles in a sector (I have Ice Cream Truck and El Dorado atm). If I only bring in one car, all works fine. Two cars -> always stopwatch at end of first turn I spotted an enemy. Enemies are still unaware, happens regardless if they see the vehicles or not (I even increased map size to 480x480 in D2 to make sure the cars don't get seen).


Edit:
On further notice: it actually seems to be caused exclusively by the el dorado... the ice cream truck seems to work fine.

[Updated on: Fri, 15 May 2015 21:51]



Re: BUGZILLA report all bugs here![message #341005 is a reply to message #340998] Sat, 16 May 2015 10:43 Go to previous messageGo to next message
dreamer2008

 
Messages:64
Registered:May 2010
silversurfer wrote on Fri, 15 May 2015 20:03

If you pick too many items it can happen that they don't all fit into your merc's inventory. Don't be so greedy. ;)

Thanks for the reply. I think the problem is that you can't select doubles for certain items, like Scope or NVG. I've restarted several times with different item configuration, and there wasn't a problem with the number of items, just doubles. Noticed the same thing with double holsters as well, I only got one.

[Updated on: Sat, 16 May 2015 11:18]

Re: BUGZILLA report all bugs here![message #341008 is a reply to message #341005] Sat, 16 May 2015 11:41 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
@smeagol: A savegame of such a situation (directly before you begin combat) would be helpful.



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341115 is a reply to message #341008] Sat, 23 May 2015 15:21 Go to previous messageGo to next message
smeagol

 
Messages:2718
Registered:June 2008
Location: Bremen, Germany
And another one:

Seems like the AimLevel modifier doesn't work.

If I understood it correctly, this item tag should reduce the number of aim clicks on guns in ncth to get maximum aim on a shot. But it doesn't...

If using a reflex sight with a -3 aimlevel modifier set, the number of clicks on the gun remains the same to reach maximum aim.


Re: BUGZILLA report all bugs here![message #341116 is a reply to message #341115] Sat, 23 May 2015 16:23 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
smeagol wrote on Sat, 23 May 2015 14:21

Seems like the AimLevel modifier doesn't work.

If I understood it correctly, this item tag should reduce the number of aim clicks on guns in ncth to get maximum aim on a shot. But it doesn't...

If using a reflex sight with a -3 aimlevel modifier set, the number of clicks on the gun remains the same to reach maximum aim.

Works fine in my game. You did remember to switch to corresponding scope mode, didn't you? If you aren't using this sight it will have no effect. Also you need to have the gun in your weapon hand. Otherwise it will have no scope modes except base weapon.

[Updated on: Sat, 23 May 2015 16:24]




Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341178 is a reply to message #341116] Tue, 26 May 2015 16:57 Go to previous messageGo to next message
smeagol

 
Messages:2718
Registered:June 2008
Location: Bremen, Germany
Drunk Larry can't buy stuff from Devin (probably also can't buy from otherr dealers).

http://i.imgur.com/CMr91a0.gif

Get this error message:

assertion 955 shopkeeper interface.cpp
selected merc can't interact with shopkeeper send save AM-1


Re: BUGZILLA report all bugs here![message #341179 is a reply to message #341178] Tue, 26 May 2015 17:15 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
I see Larry but Devin? Is that the guy at the lowest table? If so the reason why Larry can't talk to him is probably that the line of sight check fails which is causing the assertion. The question is how do you even manage to see him through the wall and activate dialogue?



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341183 is a reply to message #341179] Tue, 26 May 2015 22:10 Go to previous messageGo to next message
smeagol

 
Messages:2718
Registered:June 2008
Location: Bremen, Germany
No, Devin was hiding in the toilet, after a gun fight in San Mona. Can't reproduce the bug, seemed indeed be related to some missing line of sight. Nevermind...


Re: BUGZILLA report all bugs here![message #341195 is a reply to message #341183] Wed, 27 May 2015 12:10 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
Using Flug's r7862 'increased max sizes' .exe on AFS v4.50.1 patch

Using Tab+Left click to mark items in sector inventory with any overlay [i.e. red overlay saying 'Militia, do not take this'], and then attempting to merge items/convert ammo to boxes/crates/other ways to manipulate the sector inventory fails to update the items appropriately.

Example: M16A4 is in slot 18, and there are several items that can be merged together, for example right after a battle.
Highlighting this M16A4 with a red overlay (to signal militia not to take it) and then clicking 'Merge Items' will leave the overlay over the box, while moving the item that's supposed to be marked as 'do not take' to a different inventory square.
Re: BUGZILLA report all bugs here![message #341202 is a reply to message #341195] Thu, 28 May 2015 09:16 Go to previous messageGo to next message
Rockstarz
Messages:3
Registered:May 2015
Location: United States
Using unstable build 7823. It's been a few in-game weeks, and i've finally gotten around to going and turning in the get food from drassen quest. When entering sublevel 1, rebel hideout, i have an odd bug where it looks like my screen is trying to continuously scroll right. I can still click and give orders, but it's impossible to really see what I'm doing. Starting a new game, this issue does not persist. I've tried a few older saves, this bug appears to activate at some point after the start of the game, but I haven't been able to pin it down. Any suggestions on a quick workaround?

Edit:

Finally lined my cursor up with the exit from the basement. JA2 exits with error:

Told to use exit grid at 13582 but one does not exist.

[Updated on: Thu, 28 May 2015 09:18]

Re: BUGZILLA report all bugs here![message #341203 is a reply to message #341202] Thu, 28 May 2015 11:27 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
Rockstarz wrote on Thu, 28 May 2015 08:16
Using unstable build 7823. It's been a few in-game weeks, and i've finally gotten around to going and turning in the get food from drassen quest. When entering sublevel 1, rebel hideout, i have an odd bug where it looks like my screen is trying to continuously scroll right.


I only got the permanent scrolling problem when I alt+tabbed out of the game and back and some key was stuck in the game. This could always be fixed by pressing alt, ctrl and all cursor keys (one after the other, not together).
The basement of A9 was always a bit wonky. Whenever I clicked a container or NPC the view would jump around a bit. I don't know what is causing this.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341248 is a reply to message #341203] Sat, 30 May 2015 00:58 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
Two things, both on AFS v4.50.1 + Flug's increased team size JA2_Volitile_r7862.exe

1: Bug moving militia

https://photos-2.dropbox.com/t/2/AAA1hCUyJLXFmlyBXizq0BFGwct4WvBhuNSIJSpJdsSLTA/12/141674227/png/32x32/1/_/1/2/Error%20trying%20to%20move%20militia.png/CPONx0MgASACIAMgBCAFIAYgBygBKAI/bFFkWiZxSbczTS-K4THQC70FYRiC3zTW-rE61_vnz4s?size=1024x768&size_mode=2

To Reproduce:
Create 32 militia in NW Cambria (Hospital)
Move Militia to NE Cambria [battle]
Move Militia to sector E9 [battle] Note: 'Waited' for multiple 'squads' to arrive in same sector
Attempt to move Militia back to NE Cambria, as shown.

To Fix:
Left click on Militia
Right click on sector they're in to cancel movement
Done

2:
https://photos-3.dropbox.com/t/2/AACwDTKY4byM8iDxhqxDWBQS-JnJ03rT-SIoRTpDIzmNog/12/141674227/png/32x32/1/_/1/2/Exited%20vehicle%20through%20wall.png/CPONx0MgASACIAMgBCAFIAYgBygBKAI/XqkJCeDtsJ4NKYgxafZFP54jhv8qoyru87oX8AWbN7U?size=1024x768&size_mode=2
Exiting the vehicle teleported me through a wall when a vehicle is pressed against a wall.
Re: BUGZILLA report all bugs here![message #341269 is a reply to message #341248] Sun, 31 May 2015 00:06 Go to previous messageGo to next message
Anthropoid

 
Messages:145
Registered:February 2014
I'm a bit confused about how to report bugs, and even if it is worth doing for "older" versions.

I've got 7816 installed and I see on Onedrive that there are now two more recent versions. Basically I'm getting hangs and crashes that have to do with backpacks containing things. I can recreate them and provide detailed info (screen caps, logs whatever) if that is worthwhile. To summarize it briefly.

Merc drops his TIMs backpack in the Kingpin nightclub in prep to fight. When clicking then on the small one game hangs up and have to force it to stop using Task manager. This one repeated three times in a row.

Related, dropped backpacks in Chit (dropped each one manually, not using the hotkey to drop all of them in whole squad). I used Shift-M to collate everything. The packs have the blue asterisk, but when you put them back on a merc they are empty.

Somebody let me know if reporting these bugs is worthwhile and I'll keep this install for a while. I'll just make a copy and install the most recent version for continued play and restart a new game.
Re: BUGZILLA report all bugs here![message #341271 is a reply to message #341269] Sun, 31 May 2015 02:53 Go to previous messageGo to next message
Anthropoid

 
Messages:145
Registered:February 2014
Okay, I've installed the latest build (7866). I made a couple of changes in INI to difficulty settings, base damage modifiers, BR settings . . . nothing that I would imagine would impact how backpacks work.

My mercs arrive at Chit, and all have backpacks, many have a complete TIMS set. All have something in their backpacks. I've tried it a couple times, and it happens most of the time (but not all). Dropping backpacks causes the contents to disappear. This seems to happen whether the packs are dropped individually (either with the drop button or "manually") or using the Shift-B hotkey.

Quite simply: drop a pack with stuff in it, pick it up again and its empty.

I did notice in one repeat that this did not occur. The only thing I could speculate might account for it not occuring was that the merc which did it was not in stealth mode nor wearing NVGs.

ADDIT: a bit more 'testing' . . . I think it might be stealth mode that is causing stuff to disappear. If a merc drops a bag or backpack while in stealth mode, the contents of the bag/pack disappear. Reload and redo with same merc not in stealth mode: stuff does not disappear.

ADDIT2: On further testing, nope it is more complicated than just stealth mode. I've had stuff disappear when packs are dropped in normal mode a couple times now.

[Updated on: Sun, 31 May 2015 03:07]

Re: BUGZILLA report all bugs here![message #341273 is a reply to message #341271] Sun, 31 May 2015 08:54 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
You should do your tests in an unmodified version of JA1.13 and see if it happens there. I never had contents from my backpacks disappear so far and I have 9 IMPs with a full TIMS set. I drop these with shift+b before battle and also drop/pick them using the zipper from time to time.
If you could narrow down the reason and provide a savegame with steps to reproduce the issue it would be helpful.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341304 is a reply to message #341273] Tue, 02 June 2015 02:34 Go to previous messageGo to next message
Anthropoid

 
Messages:145
Registered:February 2014
Okay, I'll do a clean install of 7866 and see what I see.

ADDIT:
So weird. I cannot now replicate the disapearing stuff in the dropped packs, using the exact same 7866 build (plenty of changes in INI). I don't quite comprehend how that is possible, but ah well!

[Updated on: Thu, 04 June 2015 02:50]

Re: BUGZILLA report all bugs here![message #341363 is a reply to message #340821] Sun, 07 June 2015 18:05 Go to previous messageGo to next message
ExxonValdez

 
Messages:30
Registered:October 2014
Location: Poland, Wrocław
ExxonValdez wrote on Fri, 01 May 2015 09:22
Hello. I've started my JA2 test-gameplay on the newest release v7816 downloaded from https://onedrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083!583 .
I found blackscreen error occur in evry games after many days (I have tried new game and result was the same). After load savegame just press "next turn" and BS will appear.

savegame:
http://speedy.sh/7cAqk/SaveGame09.sav


Flugente wrote on Wed, 13 May 2015 12:08
@ExxonValdez: will check once I have time, likely earliest the next weekend.

Flugente - did you check it out ?

[Updated on: Wed, 17 June 2015 01:05] by Moderator

Re: BUGZILLA report all bugs here![message #341387 is a reply to message #341363] Tue, 09 June 2015 21:35 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Hi, in this saved game for build 7883 bug is about to manifest in B1. At 21:50 of game time, the unit in B2 (with tank - wow, I love this) which came to take back Chitzena, will attack Ira in B1. If Ira retreats in strategic view, the queen's unit just disappears. If Ira stays and retreats in tactical or fights, the unit stays, just won't move again (which is fine by me - I know it's not a patrol).

I have noticed this behavior with queens counter attack forces before - one can go around it by retreating in tactical, but if you just leave the sector to which is attack heading, the units will disappear too.In tough situations (which are abundant in my game) it feels a bit stupid to leave soldiers behind just so that he can make sure enemy units stay intact happy

http://ulozto.net/xXiEEdkr/enemydisappears-zip
(ja2_options.ini included)
Re: BUGZILLA report all bugs here![message #341441 is a reply to message #341387] Mon, 15 June 2015 21:27 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
A minor glitch: we have a helptext on a merc's silhouette, that nowadays display health, breath, sleep food and disease info. It is possible that the text will be for a different merc than currently viewed in tactical display. The reason is that the game is weird on what it updates when and what not. I currently have no time to fixing that though, perhaps someone else has.



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341444 is a reply to message #341441] Wed, 17 June 2015 01:05 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
ExxonValdez
ExxonValdez wrote on Fri, 01 May 2015 09:22
Hello. I've started my JA2 test-gameplay on the newest release v7816 downloaded from https://onedrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083!583 .
I found blackscreen error occur in evry games after many days (I have tried new game and result was the same). After load savegame just press "next turn" and BS will appear.

savegame:
http://speedy.sh/7cAqk/SaveGame09.sav


Flugente wrote on Wed, 13 May 2015 12:08
@ExxonValdez: will check once I have time, likely earliest the next weekend.

Flugente - did you check it out ?
Eh. I remember fixing a bug on a savegame that looked like this months ago. Not sure if thats the smae or another one of yours. Anyway, with this savegame and a current (r7893) I can play through several turns without any crash happening. Whatever the error is, I can't find it.

I am also incapable in differing editing and replying, it seems.



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341448 is a reply to message #341387] Thu, 18 June 2015 00:10 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
navaroe wrote on Tue, 09 June 2015 18:35
Hi, in this saved game for build 7883 bug is about to manifest in B1. At 21:50 of game time, the unit in B2 (with tank - wow, I love this) which came to take back Chitzena, will attack Ira in B1. If Ira retreats in strategic view, the queen's unit just disappears. If Ira stays and retreats in tactical or fights, the unit stays, just won't move again (which is fine by me - I know it's not a patrol).

I have noticed this behavior with queens counter attack forces before - one can go around it by retreating in tactical, but if you just leave the sector to which is attack heading, the units will disappear too.In tough situations (which are abundant in my game) it feels a bit stupid to leave soldiers behind just so that he can make sure enemy units stay intact happy

http://ulozto.net/xXiEEdkr/enemydisappears-zip
(ja2_options.ini included)

Hmm. Tried that savegame (situation in F9). On the first time I loaded the savegame, effect occured. After that, never again. I even restarted the exe and loaded it again, assuming it was some error depending on some uninitialised variables - nope. Seems random to me. This is bad, not sure how to fix it.



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341474 is a reply to message #166487] Fri, 19 June 2015 23:16 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
edit: F9? The attacks happens next to Chitzena, from B2 to B1. Now I wonder if you over sought this or f9 is just typo.

Wow, it happened to me like 5 times in a row :o I've made another savedgame, in build 7883, just in the minute when the attack happens, hopefully eliminating randomness.
http://ulozto.net/x3YtHFrR/enemydisappears2-zip

I still wonder how there could be this sort of difference, on my system the behavior is same all the time, tried a few times again now. Can behavior of say, random number generator, differ between systems that much? Too bad JA2 doesn't offer remote debugging happy

Thanks for trying tough.


[Updated on: Fri, 19 June 2015 23:18]

Re: BUGZILLA report all bugs here![message #341484 is a reply to message #341474] Sat, 20 June 2015 18:22 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
The new savegame has this happening in B1. The old was in F9, thus me writing that cheeky

Anyway... what happens is that the 83-people strong group needs new orders after arriving at their destination, but missing the player (who retreated). The group then gets a random new assignment. The intention was obviously to get the group moving again (otherwise they wouldn't move and be stuck there).

And, apparently it can happen with the right random numbers picked that the group doesn't get reassigned... It then gets moved back to the troop pool. Which causes it to completely vanish.
There is no code in place to stop this. So... this is not a bug... this is design. suprised

Currently seeking a fix, 'cause this design stinks. thumbs down

Edit: Somewhat fixed in r7895. If a group is ordered ordered to be moved back to the pool during reassignment, we now order them to move there an dissolve then instead of vanishing outright.

[Updated on: Sat, 20 June 2015 19:23]




You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341491 is a reply to message #341484] Sun, 21 June 2015 11:21 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Funny, I had no idea about F9, I was talking about B1 all the time albeit there was quite a bit of game time to pass before the event in the first savedgame happy Nevermind.

Stinky design indeed. Dumbs down queen a lot.
Re: BUGZILLA report all bugs here![message #341492 is a reply to message #341491] Sun, 21 June 2015 16:50 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
Bug: Suppressed enemies with zero breath (knocked out or otherwise) are unable to be attacked with punching, knifes, gunfire. Additionally, another entity (example: Militia) can stand on the enemy's square. This subsequently causes militia to shoot at the militia that is standing on the enemy's square, leading to repeated instances where militia will attack the one militiaman, only for him to die and another militia to attempt to attack the suppressed enemy...only for other militiamen to attack their new target.

Build: Has existed for several months across different builds

Repeatability: Must knock out enemy, then suppress, with militia on map. Militia sometimes do this. Easiest way is to take a Martial Artist, knock out an enemy, then use auto fire above enemy.

Suppression .ini settings, using UC113 v4.6x with 'tested' SCI (7883):
Toggle Spoiler

[Updated on: Sun, 21 June 2015 16:55]

Re: BUGZILLA report all bugs here![message #341493 is a reply to message #341492] Sun, 21 June 2015 21:14 Go to previous messageGo to next message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
Hu. And there I had hoped this was just a one-of-a-time weird effect. Grr.



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341495 is a reply to message #341493] Sun, 21 June 2015 22:23 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
@ Flugente:
I have noticed this bug popping up again and again in wil734's UC113 mod. If it matters, specifically in Atremo Underground (since it's a brawl down there) and Atremo NE if i bring militia with me (attacking the police makes it more likely for militia to have surrounded the station and have them shoot autofire inward)

Edit 1:
Bug: Leaping over short walls sometimes either puts a merc INSIDE the wall, or fails to jump said merc over the wall entirely, wasting APs

Build: Has existed for several months across different builds

Repeatability: Random, unknown cause

https://www.dropbox.com/s/elksvtkofobo09w/cantjumpoverwall.png?dl=0

In the picture above, this merc has attempted to jump from the square SE of where he is now (in the wall) to the square NW of the wall (cursor). On occasion I'm allowed to complete the movement, but in this case i have to crouch-walk back to the square to try again.

[Updated on: Mon, 22 June 2015 07:29]

Re: BUGZILLA report all bugs here![message #341603 is a reply to message #341495] Sun, 05 July 2015 13:03 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Since build 7898 certain items in sector inventory are edible. Like tool kits, locksmith kits, scopes and bipods. Yummy, just like mom used to make.

Bug seems to be that all items starting from camouflage kits (in sector's inventory) can be used on merc's body. In some cases it makes sense and still work as expected, in other cases it doesn't and item just disappears.

Bug does not appear in build 7890.

[Updated on: Sun, 05 July 2015 13:05]

Re: BUGZILLA report all bugs here![message #341604 is a reply to message #341603] Sun, 05 July 2015 13:33 Go to previous messageGo to previous message
Flugente

 
Messages:3456
Registered:April 2009
Location: Germany
navaroe wrote on Sun, 05 July 2015 10:03
Since build 7898 certain items in sector inventory are edible. Like tool kits, locksmith kits, scopes and bipods. Yummy, just like mom used to make.

Bug seems to be that all items starting from camouflage kits (in sector's inventory) can be used on merc's body. In some cases it makes sense and still work as expected, in other cases it doesn't and item just disappears.

Bug does not appear in build 7890.
Well, that was rather stupid. Fixed in r7900.



You gotta wash your hands before picking up a baby. They can see the bacteria burning into their flesh.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Wed Mar 20 07:18:45 EET 2019

Total time taken to generate the page: 0.07828 seconds