Home » MODDING HQ 1.13 » v1.13 Bug Reports » Tileset editing problem (problem with JA2set.dat)
Tileset editing problem[message #344602] Sat, 19 March 2016 10:28 Go to next message
baroni

 
Messages:16
Registered:February 2008
It is not a bug. Rather problem with tileset editing (but I did not know where to describe it)

The problem is that the game does not want to read JA2SET.dat from Data/BinaryData - it only reads this file from from Binarydata.slf (placed in Data folder - i am pretty sure of that)
I wanted to add sandbags to every tileset to build fortification everywhere. I did everything according to this description http://thepit.ja-galaxy-forum.com/index.php?t=tree&th=17774&mid=269120&&rev=&reveal= (I checked several times - mistakes rather not possible)
But the game (& game editor) reads data only from Binarydata.slf and doen not want read modified JA2SET.dat

Should I also change any additional parameter from any .INI or other config file to enable it?

my exe version is 8110
my game dir version 2303

[Updated on: Sat, 19 March 2016 10:28]

Re: Tileset editing problem[message #344608 is a reply to message #344602] Sat, 19 March 2016 13:40 Go to previous messageGo to next message
Scheinworld

 
Messages:924
Registered:December 2007
Location: Baltic Sea, Germany
Hi Baroni,

is it possible your game reads data from XML_TILESETS instead?

Quoted from Ja2_Options.INI file:

;------------------------------------------------------------------------------------------------------------------------------
; Tells the game to load ja2set.dat.xml (located in the MODs "Data" folder) instead of the old "BinaryData\ja2.set.dat" file
; Must be TRUE if NUM_P_ITEMS (below) is > 3
; If an xml file doesn't exist, setting the value to true will create one.
; Issues have been reported using big maps with this value set to TRUE
; Valid values = TRUE or FALSE, Default = FALSE
;------------------------------------------------------------------------------------------------------------------------------

USE_XML_TILESETS = TRUE



Otherwise try to ask Hawkeye for help! He is the tileset expert:
http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=17774&goto=269120&#msg_269120

Good luck!


Best regards; Schein...


Edit: No problem! Glad it works Baroni! :-)

[Updated on: Sat, 19 March 2016 14:08]




JA2 archive | JA2 (v1.13) Wiki & friends
"a mod is never finished, only releasable"

.- Will Gates


Re: Tileset editing problem[message #344609 is a reply to message #344608] Sat, 19 March 2016 13:54 Go to previous message
baroni

 
Messages:16
Registered:February 2008
YYYYYYEEEEEESSSSSS!!!

That was it! Thanks for your helping cheeky
Previous Topic: DifficultySettings.xml values
Next Topic: Purhaps scope (x4) view is incorrect
Goto Forum:
  


Current Time: Sun Nov 17 10:19:30 EET 2019

Total time taken to generate the page: 0.01515 seconds