Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » AIMNAS Archives » AIMNAS Bug reports
Re: AIMNAS Bug reports[message #344345 is a reply to message #344344] Thu, 03 March 2016 16:57 Go to previous messageGo to next message
wolf00

 
Messages:1147
Registered:September 2006
Location: Czech Republic

if you doing fresh instal,there is no need to delete,this is in case,if you have in same directory old data folders for curent mod ... hmm my ja2 1.13 starting fine,no red lines... i think you need update your svn,even just for test ...

[Updated on: Thu, 03 March 2016 17:02]




caliber's: .41Lc,.45Lc,.455british,.380[9x17].410 . not in game at this time ...Dr Zelenka can help you ;o}R.M SgAmb asrock a75m amd x6 3670be 4gb ram hdd 1tbb sgt,zvuk creative x-fi extreme audio case z-7
Re: AIMNAS Bug reports[message #344369 is a reply to message #344345] Fri, 04 March 2016 20:54 Go to previous messageGo to next message
PET

 
Messages:29
Registered:April 2006
Location: Czech Republic
As i was testing february github files i noticed few things:

I cant create molotov merging alcohol bottle with rag

Energy booster syringes is not working, the flash icon appears just for one turn and no ap bonus

If enemy/milita spot merc on roof (sometimes but rather often) they just freezing to 1 fps taking no action for like 30 seconds then their turn is skipped to next enemy soldier, same for milia on roof spotting enemy on ground.

during night if you throw break-light enemys are frreezing after stepping to the light and again no action and skipping turn.

"SOUNDS\Ceramic Armour Insert.wav" does not exist

most of the new maps still using old radarmaps

[Updated on: Fri, 04 March 2016 21:06]

Re: AIMNAS Bug reports[message #344371 is a reply to message #344369] Fri, 04 March 2016 21:22 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3802
Registered:July 2009
It's called a Cocktail for a reason ;)



Chat with us!
#bearpit on IRC
Discord
Get your latest 1.13 Builds
(Pls don't use my forum PMs for general game queries)


Re: AIMNAS Bug reports[message #344386 is a reply to message #307135] Sat, 05 March 2016 08:47 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Is there a way to solve this recurring glitch with enemies invading one of my zones and then NOT showing up on the tactical map from the direction they attacked or showing at all?

I've tested a few times and IF I accept the "go to your mercs" and fight the battle instead of autoresolve there's no one, I hit the get back to the map key and re-enter the same sector and VOILÁ! the enemy is there but occupying the place as if they were there before me (I had my mercs on ambush positions on roofs) so the enemy soldiers are just wandering the streets and then the combat starts.

That method so far as worked 3 out of 10 times, the other 7 I just get a black screen and had to force quit to desktop and reload, of course there's always the option to abandon the sector and come back again but... :/

(Sorry if this is a 1.13 only issue, tbh I only play with AIMNAS so I may be the one messing up here, sorry).

Using 7991 on Feb 2016 Github AIMNAS release

[Updated on: Sat, 05 March 2016 13:07]

Re: AIMNAS Bug reports[message #344387 is a reply to message #344386] Sat, 05 March 2016 09:45 Go to previous messageGo to next message
silversurfer

 
Messages:2292
Registered:May 2009
Torres wrote on Sat, 05 March 2016 07:47

(Sorry if this is a 1.13 only issue, tbh I only play with AIMNAS so I may be the one messing up here, sorry).


I never had this issue so far on standard map size. The enemy always showed up where it was supposed to but I haven't played for quite some time. Maybe it's just a problem on big maps, some calculation going wrong during initial position setup?



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: AIMNAS Bug reports[message #344388 is a reply to message #344387] Sat, 05 March 2016 10:15 Go to previous messageGo to next message
edmortimer

 
Messages:1058
Registered:January 2015
Location: Home Free
Quote:
(Sorry if this is a 1.13 only issue, tbh I only play with AIMNAS so I may be the one messing up here, sorry).



I never had this issue so far on standard map size. The enemy always showed up where it was supposed to but I haven't played for quite some time. Maybe it's just a problem on big maps, some calculation going wrong during initial position setup?


It's definitely happening on regular size maps, as well. It happens to me with Arulco Vacations on 1.13-7435.




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: AIMNAS Bug reports[message #344389 is a reply to message #344387] Sat, 05 March 2016 11:27 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
@silversurfer
@edmortimer

I have to restort to @'s because I'm too dense to know how to multiquote lol. So it is definitely happening to me all the time in sector C9 which is the last sector of Omerta, where the bar and the general store with the asian lady is... aaaand is happening all the time now, I've kept some injured mercs there healing and repairing the new weapons I've taken from the soldiers but every time I have to resort to the "go back to strategic and go back to tactical".

Which is not that annoying to be honest... if this is the only glitch these devs deserve some medals lol. Also @Smeagol, if you need help with any Spain's Spanish/South American Spanish.

Edit: Also thanks for the answers guys! -_- forgot that.

[Updated on: Sat, 05 March 2016 11:28]

Re: AIMNAS Bug reports[message #344403 is a reply to message #307135] Sun, 06 March 2016 17:33 Go to previous messageGo to next message
boslog

 
Messages:26
Registered:July 2012
kerberus is not working i think.. i invaded drassen airport and captured the sam site near drassen to be sure but it still says they there is nowhere to insert them? and i also looked at flugente's screen shot i see that he can select drassen airpot while i see no selection dropdown thingy in mine.

im using feb 14 build and aimnas from github
Re: AIMNAS Bug reports[message #344404 is a reply to message #344403] Sun, 06 March 2016 17:40 Go to previous messageGo to next message
Flugente

 
Messages:3339
Registered:April 2009
Location: Germany
The sector needs a facility that is defined to be an entry point for the PMC. This happens in the TableData/Map/FacilityTypes.xml:
...
<FACILITYTYPE>
	<ubIndex>4</ubIndex>
	<szFacilityName>Small Airport</szFacilityName>
	<szFacilityShortName>Airport</szFacilityShortName>
	<ubTotalStaffLimit>4</ubTotalStaffLimit>
	<pmcentrypoint>1</pmcentrypoint>                      <- this thing right here!
	...
</FACILITYTYPE>
...

If this is missing, the game doesn't find any valid entry point.



“What are you doing?” Joffrey interrupted him.

“… can’t a man give a few last words for his son to carry?”

“…Who told you your son was making it out of this field alive?”

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: AIMNAS Bug reports[message #344410 is a reply to message #344404] Sun, 06 March 2016 21:37 Go to previous messageGo to next message
smeagol

 
Messages:2710
Registered:June 2008
Location: Bremen, Germany
Kerberus is now available via at least 3 different entry points.

I need to activate mobile militia, though... atm they're confined to where you order them to enter Arulco, which is kinda lame...


Re: AIMNAS Bug reports[message #344428 is a reply to message #344410] Tue, 08 March 2016 02:41 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Possible bug that didn't happen prior to updating to Feb AIMNAS, now CRTL+SHIFT+K switches weapons from holster to hands but doing it again to switch back to your usual 2 handed gun will put the pistol in any free slot instead of the intended holster.
Re: AIMNAS Bug reports[message #344690 is a reply to message #344428] Thu, 24 March 2016 11:24 Go to previous messageGo to next message
Perconte
Messages:1
Registered:March 2016
[21.1739] : ERROR : File : vobject.cpp
Line : 967
Location : BltVideoObjectToBuffer
Video object index is larger than the number of subimages

GitHub version on top of a clean install of 8110/2303.

Line of sight onto at least one particular enemy crashes the game with aforementioned error message. It happens during a counterattack on D15. I tried abandoning the sector prior to the attack, but while trying to retake it, the same enemy seems to be present and a line of sight puts an end to my effort.

I can provide a save where I thinned the horde down to ten attackers, the culprit amongst them.

In the end, I had to cheat-kill the remaining enemies to proceed.
Re: AIMNAS Bug reports[message #344804 is a reply to message #344690] Tue, 29 March 2016 21:15 Go to previous messageGo to next message
wolf00

 
Messages:1147
Registered:September 2006
Location: Czech Republic

i have hired merc with marlin 410 shotgun,gun wont fire,on place where you have in situation target,now have here a "?"



caliber's: .41Lc,.45Lc,.455british,.380[9x17].410 . not in game at this time ...Dr Zelenka can help you ;o}R.M SgAmb asrock a75m amd x6 3670be 4gb ram hdd 1tbb sgt,zvuk creative x-fi extreme audio case z-7
Re: AIMNAS Bug reports[message #344805 is a reply to message #344804] Tue, 29 March 2016 21:26 Go to previous messageGo to next message
smeagol

 
Messages:2710
Registered:June 2008
Location: Bremen, Germany
Yeah, I had discovered that already and fixed it. Will be in next github update. The cusor type is set to invalid instead of target, if you want to change it manually, that's what you have to look for.


Re: AIMNAS Bug reports[message #344823 is a reply to message #344805] Fri, 01 April 2016 04:43 Go to previous messageGo to next message
winehouse

 
Messages:91
Registered:October 2012
Upon loading quick save, blue bar sticks at around 80% if mouse is moved the buttons [Load Game] & [Cancel] appear from behind the load screen. Sometime box comes up saying it is an older save attempt to update (which it isn't) Sometimes get Error loading game. Sometimes get Freeze. Always can not play game.

Also, had in an error report 10.bad does not exist in Ambient. I copied another .bad file and changed the name to 10.bad.

*** Thu Mar 31 21:50:22 2016 ***
[ UHATF-DDOSF-0OSHD-RC2CM-TJLW1 ]

[3.53943e-005] :


Edit: This sucks. Spent a lot of time just getting equipped and was about to fortify, airport sector. Have to start all over again. These mods are in DIRE need to be optimized because the bugs are making it very frustrating to enjoy a game. Number 1 on the list of things to add to the mods is OPTIMIZATION. The slow down is unbearable at times and the editors run like snails. Freezes occur unexpectedly but consistently. Other than that good stuff.

[Updated on: Fri, 01 April 2016 04:51]

Re: AIMNAS Bug reports[message #345091 is a reply to message #343087] Sat, 16 April 2016 05:45 Go to previous messageGo to next message
NewAgeOfPower

 
Messages:111
Registered:June 2010
Inukshuk wrote on Tue, 03 November 2015 09:15
That's not what I'm getting Shinobi...I hand Maria over to Angel and get the deed, then go to Kyle to get the money but it just hangs when Kyle should go get the money...no error report (maybe I should be using some kind of setting to get those coming up). In the end I just stole the money and forgot about it.



I have this bug too, running the March 15th (8110) release. I'm guessing it's an AI/pathing issue or something.

[Updated on: Sat, 16 April 2016 05:47]

Re: AIMNAS Bug reports[message #345106 is a reply to message #345091] Sun, 17 April 2016 10:42 Go to previous messageGo to next message
silversurfer

 
Messages:2292
Registered:May 2009
NewAgeOfPower wrote on Sat, 16 April 2016 04:45
Inukshuk wrote on Tue, 03 November 2015 09:15
That's not what I'm getting Shinobi...I hand Maria over to Angel and get the deed, then go to Kyle to get the money but it just hangs when Kyle should go get the money...no error report (maybe I should be using some kind of setting to get those coming up). In the end I just stole the money and forgot about it.



I have this bug too, running the March 15th (8110) release. I'm guessing it's an AI/pathing issue or something.

It usually is a pathing issue which has to be fixed by the mod maker. I had the same issue initially with the WF maps mod. Kyle's NPC file has a chain of waypoints defined that he is supposed to follow when he receives the deed. This chain has to be updated according to the mod map. The same is true for other NPCs like Brenda for example.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: AIMNAS Bug reports[message #345111 is a reply to message #345106] Sun, 17 April 2016 12:43 Go to previous message
smeagol

 
Messages:2710
Registered:June 2008
Location: Bremen, Germany
Topic closed, new thread can be found here.


Previous Topic: AIMNAS WF2012 Part 11
Next Topic: Content of AIMNAS Archive
Goto Forum:
  


Current Time: Mon Jun 25 20:18:25 EEST 2018

Total time taken to generate the page: 0.03463 seconds