Home » MODDING HQ 1.13 » v1.13 Bug Reports » Bugs: 2014 Official 1.13 Release (7435) with 7609 Update
Aw: Re: Aw: Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #346014 is a reply to message #345919] Sat, 25 June 2016 23:01 Go to previous messageGo to next message
ATigersClaw

 
Messages:130
Registered:October 2014
Location: Braunschweig, Germany
Version: 1.13 (7435 + 7609)

1. Placing an ammo box in the second hand slot and then placing one in the first hand slot sometimes results in the second hand box staying in place even though it shouldn't be possible.
http://www.bilder-upload.eu/thumb/8e6d60-1466885707.jpg

2. "really should" instead of "should really"
http://www.bilder-upload.eu/thumb/dbecc1-1466885793.jpg

3. Every now and then when mercs are travelling a message appears.
http://www.bilder-upload.eu/thumb/f779d7-1466885858.jpg



JASP - Jagged Alliance StrongPoint
ja-strongpoint.com
Your source for useful gameplay information about JA 2 1.13
Re: Aw: Re: Aw: Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #346016 is a reply to message #346014] Sun, 26 June 2016 12:02 Go to previous messageGo to next message
silversurfer

 
Messages:2126
Registered:May 2009
1. You are talking about ammo crates not boxes, right? Crates are two-handed items whereas boxes are one-handed. I can't reproduce the bug on the current 1.13 version. When I put a crate in the first hand the crate in the second hand is automatically dropped to the ground (sector inventory). You may have created a scenario where it wasn't possible to drop the second crate and therefore it stayed in inventory so you don't lose it.

2. Not a bug as both versions are grammatically correct.

3. I have never seen that bug before. My mercs wear sun goggles + extended ear or NV goggles + extended ear depending on time of day.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #348401 is a reply to message #335180] Sat, 21 January 2017 21:18 Go to previous messageGo to next message
RasterOps

 
Messages:50
Registered:July 2004
Location: Tempe, Az. USA
Glad to see an update since the last time I played (build 4870 I think). Unfortunately since then there have also been OS updates and who knows what else.

I am getting screen flicker (main menu, options, in-game). I hope someone can help.

SOLVED

If you want to delete this or move to solutions, either is OK.

Helps to follow instructions, e.g. "look for v1.1.38". BTW the provided link in the instructions didn't work. Found the archive here.


Toggle Spoiler

[Updated on: Sat, 21 January 2017 22:53]

Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #349290 is a reply to message #335180] Fri, 17 March 2017 04:03 Go to previous messageGo to next message
Sephok
Messages:2
Registered:March 2017
Bug: Items disappear.

When: Entering the D2 SAM Site. The items do not reappear when using "Militia inspection".

Savegame und INI: https: //drive. google. com/open?id=0B1Tjc_ISpzOGQ2FhX0JEdWJFdG8
(I cannot use links yet and I don't want to spam 10 messages where they are not wanted)

Version: 7609 (English Version, I think) installed over the Steam version.

Additional Info:
An attack on this sector is going to happen very soon. The militia obviously use the items during that fight (you can hear the guns, after all).
After the battle the items will still be displayed.
Only entering the sector actually makes them disappear. Disabling "Militia_USE_SECTOR_EQUIPMENT" changes the results somewhat, but many items disappear anyway.
If you enter the sector before the battle, leave it, wait for the battle and use Auto-Resolve the militia will be using fists and get massacred.
Entering other sectors works fine, no item disappearances there.
Fighting the battle in the sector the helicopter is about to arrive at doesn't change this. I originally fought that battle and then moved the helicopter team
to Drassen before the SAM battle occurs. The results are the same whether you fight that battle or move on directly.
I only noticed this now, but I had been baffled before when during a defense of this SAM site militia decided to use Harsh Language as their weapon, as I had
put enough weapons there. At the time I thought there was too little ammunition or something. I'm pretty sure though that the bug must have happened before,
which would mean that it is tied to that location. It has been quite some time since then, though, so don't put too much stock in this.
Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #349447 is a reply to message #349290] Sun, 09 April 2017 05:43 Go to previous messageGo to next message
Hawkeye

 
Messages:1600
Registered:October 2005
Location: Australia
I'm seeing this in Vengeance reloaded, but wanted to flag it here if anyone can help...

Have throwing knifes always been able to shoot through fences? I've experienced this recently with mercs able to throw their knives at enemies with no obstacles presented by the fence.


Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #349518 is a reply to message #349447] Thu, 13 April 2017 12:30 Go to previous messageGo to next message
Zaphod
Messages:1
Registered:April 2017
Location: Hessen Germany
Hallo at all
at first excuse me, my english is not very well.

I'm playing this game since it came out. A few year's (2015??) ago i've installed 1.13 with the release 7435 and update 7069 under Ubuntu /Wine. Respect, you made a great job.

I'm not sure what's wrong but there is a little problem. When i put a weaponlight with battery's on a rifle and switched ON, yeah it makes a great light in the night. When i switch it OFF, the game crash and closed.

Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #349752 is a reply to message #349518] Tue, 09 May 2017 18:01 Go to previous messageGo to next message
MrFragz
Messages:1
Registered:April 2017
Location: Leer, Germany
Hi,

seems like it's not possible to repair items stored in the hummer inventory. The repair assign is red as if there were no more items to repair.
Same is fine with items in the inventory of the ice cream truck. The Vehicles.xml is nearly identical for both vehicles so there may be a wrong behaviour in the code.

Version 7609 + AR.
Same behaviour with sevenfm's ja2_7609en+fix.exe and ja2_7609en+AI_r381.exe.
Re: Bugs: 2014 Stable 1.13 Release (7435)[message #349999 is a reply to message #349752] Thu, 08 June 2017 09:39 Go to previous messageGo to next message
Firun

 
Messages:5
Registered:June 2008
Location: Switzerland
First off, I am not quite sure if this is the correct place to post this (since I use the WF map mod and I suspect that this is the cause of the bugs I noted), but I have a problem with some item wonkiness and ammo crates / ammo in general. Used the search function beforehand, found nothing.

1. Bug Description
Ammo does not reliably stack to crates or (sometimes) boxes. I have several ammo types that refuse to be converted to boxes or crates (i.e. a stack of 30rd 7.62x39mm AP), some 5.56x45mm tracer ammo that is converted to a lot of ammo boxes with 0 rounds and a single 30rd box, and I've had some ammo that would crash my game when used on a gun. It also appears as if it is not global, as in I have some ammo of a given type that goes into crates like it should whilst some of it does not get converted to crates. I've since deleted most of the "offending" ammo.

Additionally, the SHIFT+M key sometimes does not move a few items. I then have to pick them up manually to pile them on top of my item stack. They are not greyed out or booby trapped or anything, I can pick them up just fine via sector inventory. My item stack holds some 800 items by now (I'm a weapon hoarder), and last night someone seems to have booby trapped it - Merc complains, places blue flag, I have to disarm it - and as soon as I walk up to the pile again my merc complains again. The stuff is 100% repaired, so explosives with low % aren't the cause.

I also have 2 maps in Alma with 10x scopes that are nowhere on the map, yet are shown in sector inv and can't be picked up (greyed out). I've searched all over (GABBI & ALT+E included), but they are nowhere to be found.

2. Detailed steps to reproduce the bug
Not sure. Just play I guess and it will eventually happen?

3. If bug cannot be easily reproduced on a new game, upload the savegame to a file hoster.
Uploading is no problem when needed, just tell me and I'll do it.

4. Any mods & its version running on top of 1.13?
Basic 1.13 mod (7609) on top of a 1.12 Gold install with the current Wildfire 6.07 map mod.

I would have posted this in the relevent mod thread, but it seems as if there is none for just the map mod. Please correct me if I am wrong.

EDIT: Actually, I just realized that I did not execute the 7609 patch after downloading. I'll leave this post intact so that those who know the game's code can decide whether or not it is still relevant given the missed patch.

[Updated on: Thu, 08 June 2017 15:05]




No trees were harmed in the sending of this message. However, a large number of electrons were terribly inconvenienced.
Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #350378 is a reply to message #335180] Sun, 23 July 2017 13:40 Go to previous messageGo to next message
Bibernelle
Messages:1
Registered:July 2017
Hi all,

Playing latest steam version in 1.13.
I guess this is a common Bug: There are a few Items; 12 pieces, wich might be the gear of a dismissed merc, in some of my cleared sectors wich always adds again to the inventory list, whenever i leave inv. and open it again.
Is there a way to fix this, or do i need to deal with it?

thx for help happy

Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #350379 is a reply to message #350378] Sun, 23 July 2017 14:34 Go to previous messageGo to next message
silversurfer

 
Messages:2126
Registered:May 2009
JA2 1.13 on Steam? Only valid sources for 1.13 are the old 7609 stable release and Depri's SCIs of the development trunk. 1.13 can also be downloaded directly from the SVN repository but most players don't use that option.

If you're using the old 7609 release you may be out of luck in regards to bug fixes. Only Sevenfm still works with the old code for mod compatibility reasons. All other coders only work with the current development code.
The problem you describe is unknown to me so I can't give you an advise how to fix it.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update[message #350380 is a reply to message #350379] Sun, 23 July 2017 20:47 Go to previous message
The_Bob

 
Messages:335
Registered:May 2009
Location: Behind you.
I can confirm there's a random item duplication bug in map screen inventory, appears to happen when closing and reopening the inventory screen. Results in appending a bunch of random items from a random recently loaded sector to the inventory pool that was last closed. It seems to be semi-reproducible, but that tends to be random as well - sometimes I could get it to work after loading the same game or repeating some actions, sometimes it would go away. Seems to happen more often when player controlled vehicles are involved.

I've looked but wasn't able to track down this bug. Code up to the point where inventory was saved after closing looked to do what it was supposed to, I got the impression the bug might be in whatever is loading the inventory pool, probably reading too far or getting confused on corrupt data.

Previous Topic: XML Editor Bug Reports
Next Topic: Bugs: Unofficial releases (SCI's), unstable and DEV builds
Goto Forum:
  


Current Time: Wed Jul 26 09:30:35 EEST 2017

Total time taken to generate the page: 0.01554 seconds