Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » JA2 Wildfire » JA2 WF v1.13 (Bug -Version?)
icon5.gif  JA2 WF v1.13[message #349905] Sun, 28 May 2017 03:28 Go to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Hello,

I have a bug, I know I am on v1.13, but not sure what version.

Happens at J9 - Tix in a battle with Mike

Runtime Error
Assertion Failure (Line 1515 in file .\Queen Command.cpp)

Add possible pending enemies to Battle(): Logic Error - by Kris

Cannot seem to play beyond this point, I have save game, last reload
just keeps going back to this error every replay.

Not sure if this is right spot to post.

Please advise.

PAW
Re: JA2 WF v1.13[message #349908 is a reply to message #349905] Sun, 28 May 2017 11:28 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
Press v in the strategic screen and in the message box there you can see the version number. You may have to scroll up a bit.

A bug like you reported was fixed long ago. As long as your version number is unknown I can't give an advice.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #349909 is a reply to message #349908] Sun, 28 May 2017 11:50 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

This is:
JA2 WF v1.13
Smeagol's Item Mod

v1.13 3287 (Build 09.10.23)

Happens right after Mike is killed.

PAW
Re: JA2 WF v1.13[message #349912 is a reply to message #349909] Sun, 28 May 2017 17:59 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
*cough* *cough* *dusts off the screen and removes some spider webs*

Where did you get that old version? The latest so called "stable version" of 1.13 is 7609 from 2014. The current development release is 8404. Regarding your problem I fear nothing can be done. Maybe the 7609 build will run with your savegame but if you want to try that you may better download one of Sevenfm's 7609 based builds which contain additional bugfixes compared to the official 7609 build.

Depending on what you want you may also download a different and more up-to-date mod. Just make sure to get the correct game version that is compatible with the mod.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

icon14.gif  Re: JA2 WF v1.13[message #349933 is a reply to message #349912] Wed, 31 May 2017 01:57 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Darn it!

The game was running perfectly.

I will see about getting my JA2 vanilla up to latest version 1st.

I think that one is out of date as I was getting errors when moving Merc Teams,
arrows all over the place.

PAW
icon5.gif  Re: JA2 WF v1.13[message #349935 is a reply to message #349912] Wed, 31 May 2017 08:00 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

How to Install?

1) Install a fresh copy of Jagged Alliance 2

1.5) Currently my game is here: v1.13 3287 (Build 09.10.23)

2) Install the latest official Release (Build: 7435, 28 August, 2014)
3) Install the latest official Update (Build: 7609, 25 October 2014)

4) Install Ja2_7609+AI
5) Install Ja2_7609+fix

That would give me a new version of 7609 to try.

Since Smeagols Item Mod is working, can I just do steps 2, 3,4 & 5 onto my current Ja2 v1.13 WF Smeagol Item Mod since it is currently at step 1.5? [based on my version - v1.13 3287 (Build 09.10.23)]

PAW

[Updated on: Wed, 31 May 2017 08:28]

Re: JA2 WF v1.13[message #349936 is a reply to message #349935] Wed, 31 May 2017 10:56 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
I'd do a backup of your current JA folder so you can always go back if the newer version doesn't work with the item mod.

Steps 2 and 3 will overwrite files in the Data and Data-1.13 folders inside JA2. So if you made any changes to these files they will be lost. If you remember which files you modified you can manually compare and merge the changes later from your backup. I hope that the item mod is in a separate folder and not part of Data or Data-1.13. Otherwise you'd overwrite the data of the item mod with steps 2 and 3.

You only need step 4 or 5 not both. If you want the fixes and AI improvements you'll use the 7609+AI exe. If you only want the fixes you'll use the 7609+fix exe.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #349939 is a reply to message #349936] Thu, 01 June 2017 01:00 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Silversurfer,

Thx for your help.

Okay, I did 2-4 and then it fired up fine, but it looks like Vanilla again.
Save game doesn't work, as expected, I started game and it works fine, so the game works now.

The map wasn't WF, and splash screen was Vanilla again, not WF Smeagols Item mod.

To get it back to Wildfire,
Can I now just install
https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

So it becomes JA2 WF v1.13?

PAW


Re: JA2 WF v1.13[message #349942 is a reply to message #349939] Thu, 01 June 2017 11:12 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
That's what I feared. The mod files seem to have been overwritten. It would be a tedious task to manually merge them.

The WF maps you are referring to are just the maps. No items are included. By default they are compatible with the latest 1.13 development version but you could replace some files to make it compatible with 7609 (details are in the WF 6.07 Readme file). If you want to use the WF 6.07 maps with the development version you should download the latest SCI and install that on a clean installation of JA2 and after that copy the WF 6.07 maps mod to your JA2 directory. Don't forget to check Data-1.13\JA2_Options.ini afterwards to see if you want to change some default options.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

icon2.gif  Re: JA2 WF v1.13[message #349970 is a reply to message #349905] Mon, 05 June 2017 02:50 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Okay,

I am going to now drop in WF6.06-AIMNASV14 EN

which gives me 2 folders:
Data-AIM
Data-AIM-WF

Should I update with AIMNASV15?

I assume I run JA2_3884_NIIC.exe?

PAW
icon5.gif  Re: JA2 WF v1.13[message #349979 is a reply to message #349970] Tue, 06 June 2017 06:12 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Still stuck, but I think I know what to do. Just need someone to confirm.

This is from WF6.07 instructions:
Installation:
0.) Install Jagged Alliance 2
1.) Install Jagged Alliance 2 1.13 MOD
2.) Create a copy of your "Data-1.13" Ordners in JA2 main directory and rename it to "Data-WildFire6.07".
3.) Now copy the Data-Wildfire6.07 folder of this mod to your JA2 main directory. Overwrite when asked.
4.) Start a new game.


0) - Done
1) - Done I have 7439 stable release and runs fine.
2) - Not sure at this point, I think I copy Data-1.13 to Data-Wildfire6.07, then patch with Data-Wildfire6.07, then copy
everything from Data-Wildfire6.07 back into Data-1.13?

Thx,

PAW

[Updated on: Tue, 06 June 2017 06:13]

Re: JA2 WF v1.13[message #349981 is a reply to message #349979] Tue, 06 June 2017 10:47 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
This is what the readme of WF6.07 maps mod says. Just follow these instructions.

Installation:
1. Install Jagged Alliance 2.
2. Download latest SCI and copy its content to JA2 game directory. Overwrite when asked.
3. Download WF maps 6.07 mod from SVN and copy its content to your JA2 game directory (except for the Data-WildFire6.06 folder which is not needed).
4. Modify Ini settings if you like.
5. Play the game.




Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

icon10.gif  Re: JA2 WF v1.13[message #349986 is a reply to message #349981] Wed, 07 June 2017 00:53 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Silversurver,

Thx for your patience. I appreciate your help. Sorry, I don't have access to Mooo.com

I have JA2 v1.13 Release 7435: Build: 7609 running fine.

I can only use a library computer, and this site is blocked: Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

I got my maps from here: http://kermi.pp.fi/JA_2/Maps/Wildfire/WF6.07/ WF6.07Full.zip Hoping these are the same?

Now, where do I get the latest SCI patch? I have no problem acsessing Kermi FTP site.

My Install:
1) Copy JA2 v1.13 Release 7435: Build: 7609 to JA2 WF v1.13
2) Patch JA2 WF v1.13 with latest SCI (what does SCI mean?) where is this SCI?
3) Put in WF 6.07 maps from SVN (what does SVN mean?) Is Kermi one same as SVN one?

Thx,
PAW

PS - I can also get to Depri's v1.13 Builds Repository - this has an SCI directory on one drive. I have a choice under SCI for AIMNAS or Vanilla, under vanilla
is this the one: SCI_Unstable_Revision_8403_on_GameDir_2363.7z

If it is, then I only need to know is the WF 6.07 Maps the same?

[Updated on: Wed, 07 June 2017 01:01]

Re: JA2 WF v1.13[message #349988 is a reply to message #349986] Wed, 07 June 2017 10:16 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
The version on Kermi's site is outdated and doesn't work with the current SCI. It may work with the 7609 build. Kermi's map version will still have some bugs that are already fixed in the SVN version.

The current SCI requires the WF 6.07 map files from SVN because of feature changes and additions. This is the recommended combination. Maybe you can download the maps with a different computer if the site is blocked on that library computer.

SVN is a repository where we store code and game files. You'd need an SVN client like Tortoise SVN to download from there. Of course you could download file after file with your browser if you got some time... ;-)



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #349990 is a reply to message #349988] Wed, 07 June 2017 13:32 Go to previous messageGo to next message
Scheinworld

 
Messages:907
Registered:December 2007
Location: Baltic Sea, Germany
Hello,

silversurfer wrote on Wed, 07 June 2017 09:16
The version on Kermi's site is outdated and doesn't work with the current SCI. It may work with the 7609 build. Kermi's map version will still have some bugs that are already fixed in the SVN version.


I have updated the version on Kermi's FTP (current revision: 8404). Maybe this helps you PAWJA2.

http://kermi.pp.fi/JA_2/Maps/Wildfire/WF6.07/

Thank you for your work on this silversurfer!


Best regards; Schein...



Kermi's JA2 archive | JA2 (v1.13) Wiki & friends
"a mod is never finished, only releasable"

.- Will Gates


Re: JA2 WF v1.13[message #349991 is a reply to message #349990] Wed, 07 June 2017 13:55 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
Fantastic! This will make it a lot easier for folks who can't/won't install an SVN client to download directly from SVN. thumbs up

@PAWJA2
Use this with the latest SCI and make sure to check Data-1.13\JA2_Options.ini before you play so you can enable/disable features as you like.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #350022 is a reply to message #349991] Sun, 11 June 2017 05:18 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Got it working!

Will post another on how I did it.

PAW
icon1.gif  Re: JA2 WF v1.13[message #350023 is a reply to message #350022] Sun, 11 June 2017 11:47 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Hello,

Okay here goes.

1) Vanilla JA2
2) Install http://kermi.pp.fi/JA_2/v1.13_Releases/Official/English/v7435/ JA2_113_FullRelease_English_7435.exe
3) Install http://kermi.pp.fi/JA_2/v1.13_Releases/Official/English/v7435/Update/ JA2_113_UpdateForRelease7435_English_7609.exe
4) Check game works.
5) Then download & Install from Depri's Build Repository One Drive/Bear's Pit/SCI/Vanilla/ SCI_Unstable_Revision_8403_on_GameDir_2363.7z
6) Then download & Install from Depri's Build Repository One Drive/Bear's Pit/Builds/ JA2_8404.7z
5) Check game works
6) Get WF maps from http://kermi.pp.fi/JA_2/Maps/Wildfire/WF6.07/
7) Check .ini
8) Run WF game

PAW

PS - Thx again for help!!!!
Re: JA2 WF v1.13[message #350026 is a reply to message #350023] Sun, 11 June 2017 12:37 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
Paw, you can skip steps 2, 3 and 4. The SCI includes all necessary files to bring 1.13 to the latest version. There is no need to install the old stable before it.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #350031 is a reply to message #350026] Sun, 11 June 2017 20:02 Go to previous messageGo to next message
Ableton

 
Messages:7
Registered:June 2017
Location: Spain
I would have gotten a high leadership toon swindle him into joining me and then ask him to step into my office big grin
Re: JA2 WF v1.13[message #350037 is a reply to message #350031] Mon, 12 June 2017 12:06 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Silversurfer,

Thx.

Only one issue so far.

The M-79 Grenade Launcher fails to fire. It always does nothing. It sucks the AP,
but no Smoke, No Grenade, nothing.

Where do I post that?

PAW

Re: JA2 WF v1.13[message #350039 is a reply to message #350037] Mon, 12 June 2017 14:40 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
All grenade launchers are not working anymore. The most likely reason is some change in r8404. I already send a PM to The_Bob so he can take a look. I'm sure that this issue will be fixed soon.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #350050 is a reply to message #350039] Tue, 13 June 2017 01:51 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Silversurfer,

Thx, great it has already been logged.

Also, in one of the older versions, in a battle, I dropped my Backpack,
when the battle was over it auto picked up with the correct Merc.

Is this an .ini setting? That is a very cool feature and it keeps me from forgetting
my packs.

PAW
Re: JA2 WF v1.13[message #350053 is a reply to message #350050] Tue, 13 June 2017 11:34 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
Sorry, I forgot to post it here as well - you can already download a fixed English 8407 exe here. Single and multi shot grenade launchers are working correctly with it.

I don't know about the backpacks. I always drop them manually and manually pick them up after a fight.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 WF v1.13[message #350057 is a reply to message #350050] Tue, 13 June 2017 20:29 Go to previous messageGo to next message
sevenfm

 
Messages:1345
Registered:December 2012
Location: Under the Mountain
PAWJA2 wrote on Tue, 13 June 2017 03:51
Also, in one of the older versions, in a battle, I dropped my Backpack,
when the battle was over it auto picked up with the correct Merc.

It was Ja2+AI for stable 7609 or Vengeance:Reloaded mod.
This feature is not present in the main trunk.



Stable 7609+fix (18.10.2017)
Stable 7609+AI (r525 18.10.2017)
Improved weapon sounds, Ambient sounds, LoadScreenHints for Ja2+AI
Youtube channel
Win8+ fix


Re: JA2 WF v1.13[message #350060 is a reply to message #350057] Wed, 14 June 2017 00:54 Go to previous messageGo to next message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Thx Silversurfer,

Can I assume there will be a JA2_UB_8407.exe also?
Could someone post JA2_8407.exe in Depri's Build site or Kermi ftp? If already there, please let me know where?

Much appreciated.

PAW
Re: JA2 WF v1.13[message #350061 is a reply to message #350060] Wed, 14 June 2017 01:22 Go to previous messageGo to next message
silversurfer

 
Messages:2164
Registered:May 2009
Depri will upload the new exe anyway during the next days per his usual schedule.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

icon14.gif  Re: JA2 WF v1.13[message #350128 is a reply to message #350061] Tue, 20 June 2017 07:52 Go to previous message
PAWJA2

 
Messages:124
Registered:December 2009
Location: Melbourne, Australia

Whoever added hints and these smart hot keys was a genius!

Backpacks - drop
[Shift] + B

Pickup after battle
[Ctrl] + [Shift] + F

PAW

[Updated on: Tue, 20 June 2017 07:53]

Previous Topic: Alma mine..
Next Topic: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?
Goto Forum:
  


Current Time: Fri Oct 20 04:20:57 EEST 2017

Total time taken to generate the page: 0.01229 seconds