Home » SIRTECH CLASSICS » Jagged Alliance 2 » JA2 Technical Department » How? What? Where? (I bought JA2 1.12 from GOG. Installed it.. I want 1.13.. how??)
How? What? Where?[message #352115] Mon, 22 January 2018 01:02 Go to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe
I bought JA2 v1.12 from GOG.

I really hoped it would be the latest version but ALL I see is version 1.13 on this site so I don't want to disappoint myself by messing around reinstalling the older GOG version all over again.
Besides, I don't WANT to play an older version when i have heard nothing but positive things about 1.13 for playing on a Win10 64 bit OS, on an Asus Z170PG motherboard, i7 6700 quadcore, Corsair 16GB DDR4 ram, Asus GTX1080 grfx card, Corsair 750watt bronze PSU and on a 40 inch monitor.

TO BE CLEAR-

Can ANYBODY help me with info about finding a stable v1.13 update for my GOG version of JA2 v1.12. By this I mean, give me a link to the 1.13 update that isn't obsolete/doesn't work anymore?
I have heard v1.13 actually runs JA2 1.13 in higher than 800x600 [such a resolution on a 40inch screen would be less than laughable].

Personally, I bought this game because I have wanted to play it for so long but considered the effort pointless as a quadcore 3.4GHz CPU with 8GB of GDDR5X ram on a grfx card alone would simply NOT run such a very VERY old game, AND on a win10 64bit OS??

I am actually bewildered by this entire site and you may as well be talking gibberish as I don't understand anything being discussed. And I am NOT the only person as I have at least 10 friends who simply haven't bothered buying the game as it seems that the amount of time and sheer effort in understanding just WHAT it takes to actually get this game running in anyway is hopeless. Two other friends have bought the game from Steam and, not getting it to run in an reasonable way? simply uninstalled it and gave up. They are gamers, NOT MODDERS! They, like me, know nothing about code or any of the myriad mysterious terms that make no sense to me.
The only thing i know for certain is that running JA2 1.12 is a waste of time on win10 64bit on 40inch monitor so I was hoping to find the 1.13 patch but I simply spent so long hitting dead end links that this post is my last chance at getting some help.
Re: How? What? Where?[message #352116 is a reply to message #352115] Mon, 22 January 2018 01:56 Go to previous messageGo to next message
sevenfm

 
Messages:1534
Registered:December 2012
Everything you need to download and install actual 1.13 is here:
http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=20380&prevloaded=1&&start=0

Quote:
How to use:
0) Install JA2 in a mod friendly location (NOT Progam Files(x86), Program Files or similar folders that are under special UAC protection since Vista)
1) Download the latest SCI
2) Extract the downloaded file over your JA2 installation, allowing it to overwrite existing files
3) Use JA2.exe to play

[TIP] If you are not asked wether to overwrite stuff, something is awry and you probably hit the wrong folder
If you are on Windows 8, please install the Windows 8 compatibility fix, to be found in the 'Docs' folder!


You can also use older stable 7609 release, download from here:
http://ja2v113.pbworks.com/w/page/4218334/Downloads
1. Download 7435, install to your clean Ja2 folder.
2. Download update to 7609, install to Ja2 folder.
3. Apply win8+ registry patch.
4. Set resolution in Ja2.ini using text editor and start Ja2.exe or use INI Editor to set options and run game.



7609+fix | 7609+AI (r713) | 7609 unofficial modpack | Win8+ fix | Experimental project | Youtube

- How did you survive?
- Didn't. Got killed... God, I love that joke.


Re: How? What? Where?[message #352119 is a reply to message #352116] Mon, 22 January 2018 03:55 Go to previous messageGo to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe
hey thnx for the reply, m8!!

But i use win10 64bit.. NOT win8.
But something that completely bewilders me about answers people receive on this site.... you say "You can also use older stable 7609 release, download from here:"

so, I have to ask because it puzzles me... what IS WRONG with just using the stable 7609 patch? is there a reason as to why i shouldn't? I mean, don't we ALL want stability in games?? I'd rather play in 60fps with solid stability than play in 300fps and crash every hour or get grfx glitches.

The 'Program Files ' folder i created myself as i intend to only install GOG games to it but I'm guessing that has something to do with the issue? dammit.

I'll create a 'D:\Jagged Alliance 2' Folder.

And, to be certain? I DON'T NEED the win8 reg error patch because, as i said, I HAVE WIN 10 pro 64 BIT, RIGHT?

Thanks for your help, bud!! Much appreciated!! I had just about given up rooting around google etc trying to find some way of getting this game to run on a modern relatively high spec machine.

YOu know what i mean?
Re: How? What? Where?[message #352120 is a reply to message #352119] Mon, 22 January 2018 04:05 Go to previous messageGo to next message
sevenfm

 
Messages:1534
Registered:December 2012
Win10 has the same problems as Win8, so the patch should be applied. "Win8+" means all windows versions starting from 8.
Ja2 may not work correctly in any system protected folder, it's best to make a separate folder like c:\Ja2 and place all your Ja2 installations there.
Nothing is wrong with using stable 7609 or even 4870.

[Updated on: Mon, 22 January 2018 04:05]




7609+fix | 7609+AI (r713) | 7609 unofficial modpack | Win8+ fix | Experimental project | Youtube

- How did you survive?
- Didn't. Got killed... God, I love that joke.


Re: How? What? Where?[message #352121 is a reply to message #352119] Mon, 22 January 2018 04:23 Go to previous messageGo to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe
ummm... what is an 'SCI'???
Re: How? What? Where?[message #352122 is a reply to message #352121] Mon, 22 January 2018 04:29 Go to previous messageGo to next message
sevenfm

 
Messages:1534
Registered:December 2012
Ras wrote on Mon, 22 January 2018 07:23
ummm... what is an 'SCI'???


http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=20380&prevloaded=1&&start=0
DepressivesBrot wrote on Fri, 19 October 2012 00:15
FAQ
What does SCI stand for anyway?
Single Click Installer - While technically not totally accurate, it underscores the ease of use compared to other setup methods.

I can't open the archive!/What tool did you use for the archives?
The archives were packed with 7-zip 9.20 on 'Ultra' compression, older or different programs might have trouble with this.

The game still shows [some older version] on startup!
The version is written in one of the code files and only gets manually updated once in a blue moon. Don't Panic! The archive/file names are accurate.

Why isn't there any UB related stuff?
Because I didn't want to inflate the package unnecessarily.
Update: I started leaving the UB stuff in since I don't need to keep the 200MB limit imposed by MF anymore.

Will you update this thread?
No. At least not for every new version. I will announce new lines of packages and make additions to this post as required, but you'll have to simply check my skydrive for new releases.

Is there a changelog?
There are txt files with the svn log in every package.

What about savegame compatibility?
No guarantees. Developers try to avoid it for as long as possible, but you have to be aware that every update is a risk and make backups. It's the cost of using the cutting edge version.

What about compatibility with mod [x]?
Modders will generally specify a version of 1.13 that their mod was developed for. Unless you already are an experienced user, use that version and don't attempt to glue something together

I need further support!
Just ask here in the thread or visit the IRC channel #bearpit Note that the usual residents there are mostly European, 0300 GMT might not be the best time to look for support. Also, give some life sign when entering so we don't assume you're another lurker and don't worry if it takes a few minutes for someone to respond happy

to be continued...




7609+fix | 7609+AI (r713) | 7609 unofficial modpack | Win8+ fix | Experimental project | Youtube

- How did you survive?
- Didn't. Got killed... God, I love that joke.


Re: How? What? Where?[message #352123 is a reply to message #352122] Mon, 22 January 2018 06:40 Go to previous messageGo to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe
Hey, thnx for the help but I tried using the INI editor and set the res to 1920x1080 but it always asks for 16bppp.

i can get it running but it only use half the screen and the coors look awful and are unreadable.

one more thing, it seems i have JA2 Gold. Now it mentioned NOTHING about being the GOLD version in GOG which has kinda annoyed me. There are many Gold versions of games that are significantly different.

It would make life a whole lot easier if i had this on CD, it really would. Having to uninstall, regclean, restart then go baxck to GOG to download/install takes some time, I tell ya.

thnx anyway.


anyway, I used the latest SCI from dec last year [i think] though my main concern is simply getting it running on a large screen at least at 1920x1080. Tried it in win98 mode but still get the 'cannot run in 16bppp mode' error.
Re: How? What? Where?[message #352124 is a reply to message #352123] Mon, 22 January 2018 07:08 Go to previous messageGo to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe


Thank you greatly for your help, mate. It's much appreciated but this is such hard work I'll give it another go tomorrow.
Thanks again for your prompt and patient help.
Re: How? What? Where?[message #352125 is a reply to message #352123] Mon, 22 January 2018 09:03 Go to previous messageGo to next message
sevenfm

 
Messages:1534
Registered:December 2012
Ras wrote on Mon, 22 January 2018 09:40
Hey, thnx for the help but I tried using the INI editor and set the res to 1920x1080 but it always asks for 16bppp.

The game requires 16bit in windowed mode. Set fullscreen mode in Ini Editor.

Quote:
one more thing, it seems i have JA2 Gold. Now it mentioned NOTHING about being the GOLD version in GOG which has kinda annoyed me. There are many Gold versions of games that are significantly different.

Version of original game doesn't matters for 1.13 as it mostly uses SLF resources of original game.

Quote:
It would make life a whole lot easier if i had this on CD, it really would. Having to uninstall, regclean, restart then go baxck to GOG to download/install takes some time, I tell ya.

Ja2 is portable, you can install it once and then simply copy game folder somewhere where you want to install 1.13 on top of it. You can have as many Ja2 copies on the HDD as you want, they all will work.



7609+fix | 7609+AI (r713) | 7609 unofficial modpack | Win8+ fix | Experimental project | Youtube

- How did you survive?
- Didn't. Got killed... God, I love that joke.


Re: How? What? Where?[message #352126 is a reply to message #352125] Mon, 22 January 2018 12:13 Go to previous messageGo to next message
grim

 
Messages:307
Registered:July 2006
Location: France
Just a little note here, Bear's pit is a fan site, in no way related to original developers or current IP owners.
The 1.13 version is not really a patch, the idea of labelling it 1.13 as a new patch above 1.12 is nearly a joke, as it contains hundreds of new features and changes compared to 1.12.
1.13 is a constant work in progress (thanks to talented coders and contributors worldwide), that's why there are so much versions around. The "stable" versions are meant to be tested a little thoroughly with a given number of features frozen at a given time. The dev versions are work in progress, and include all improvements and features implemented since. The stable versions however do not include all the fixes implemented in the meantime, it's up to you to decide what you want.
By the way, JA2 was developped in the late 90's, it's not meant to be used on modern computers. Thanks to tweaks implemented in 1.13 it is possible, but if you happen to have an older computer and a smaller screen, it will work just as fine if not better.
Re: How? What? Where?[message #352131 is a reply to message #352126] Tue, 23 January 2018 02:17 Go to previous messageGo to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe
oh, i know all about how old it is. I've wanted to play this game since 2002 when a mate showed me it running and i thought, " I GOTTA have THIS game!!"
But I think a lot of Modders start off looking at certain aspects of a game and maybe think [example] " Well, I can get that working... and the intro screen seems to be causing long term issues in-game as every time I let it run fully, the bloody game never runs for more than an hour before CTDing". A lot of people have told me how great a game it is as i was building/repairing PCs back in the late 90s. I just never got round to playing it because I think i went thru 3 gfs, driving them mad as I played XCOM games & Planescape:Torment until 4am and Jagged Alliance was just one of those games i wanted to play but never quite got around to playing it as it seemed as if there were just too many games to enjoy and whenever i saw it in a store it was rare. I've only seen it ONCE in a gamestore. Also, on floppies in a charity shop.
Ahhh, the good old days!

I remember playing Fallout 1 and 2 and both never played for more than 40-50% as they were so badly bugged [this was running on an old DX4-100 w 8MB ram and onboard grfx chip], even AFTER the Modders' update [the same thing occurred as with Jagged Alliance but JA worked quite well in its day...right?] Fallout 1 and 2 were early days 'open world' isometric - again hardware limitations - but they finally got it right w FO BoS:Tactics as I actually completed that game and thoroughly enjoyed it.
Fallout 3 I really enjoyed as it actually seemed to bring a new perspective to the Fallout genre [the targetting system was amazing for its time... from what I've browsed thru in JA2 it seems you can aim for specific target locations, too? Sounds good].

I've never met a PC gamer who has ever said " I hate Modders". There were some idiots in the GTAO game that ruined that game for people who didn't WANT to hand over cash whilst gaming online with 10-14 buddies but considering the amount of cash Rockstar have been making from the MP Shark cards I think I can relate to what the early 'hackers' were doing... still, that's politics... Different to the console gaming world where 'Modders' are slimy swine who sell cheats to play online multiplayer fps games like COD or other mindless deathmatch games thru knowing maps, reflexes badda bing! that's it. I never got Doom [1 or 2]. I REALLY enjoyed System Shock 1 and 2. They were great games and I found a co-op mod for SS2 which added a whole new element to the game [on a LAN, ofc]. I think that was the days of the Athlon 1900 cpu and voodoo grfx card.

JA2 looks a LOT like Brotherhood of Steel: Fallout Tactics. With the isometric style gaming arena; shoot an enemy in the right arm and his shooting skill is severely affected and having characters w high 'Observation' skills lets you get that all important first shot in or, at least, set up an ambush to bring 3 squads of 10 down with only 1 squad.

Dammit, I gotta get this game running tonight!

Again, thnx for the help!




Re: How? What? Where?[message #352137 is a reply to message #352131] Tue, 23 January 2018 06:27 Go to previous messageGo to next message
Ras

 
Messages:8
Registered:December 2017
Location: europe
Finally got it working!!!

It was the reg patch that fixed it [should have known that but i guess my patience was wearing out at that point although I gotta find a way of increasing the size of the text... I might try lowering the res].

TBPH? I've had far more better results with Win10 [well, without installing that damn win10 upgrade assistant which destroyed everything on my SSD drive so I won't be using that... if it works? DON'T fix it! heh heh] compared to the nightmare of Win 7 Ultimate.

Thank you for your patience and I can see that this game is gonna need me to go thru the .pdf manual as I just got slaughtered on Novice!! Bloody good fun though!! I got about 10 or more m8s who want to know how to get this game running, and THEY have a buncha m8s too. Over 15 yrs wait to play this game!!
Re: How? What? Where?[message #352141 is a reply to message #352137] Tue, 23 January 2018 14:22 Go to previous messageGo to next message
Shanga

 
Messages:3513
Registered:January 2000
Location: Danubia
It's never too late to start with JA2. You will be hooked until the end of your days anyway. big grin


Re: How? What? Where?[message #352142 is a reply to message #352141] Tue, 23 January 2018 15:38 Go to previous message
grim

 
Messages:307
Registered:July 2006
Location: France
@Shanga : So true...

@Ras : I failed to say that 1.13 is a huge modification to the game, with a lot of options and externalizations allowing players and modders to tweak the game, very deep. When familiarized a little more with the game, you can have a look at Data-1.13\ja2options.ini to toggle options or tweak some features, and later have a look at the other files in Data-1.13.
For now, a good start is Docs\JA2_113_Hotkeys.pdf as hotkeys allow you to access the whole gameplay, and if you have time and patience, go through Flugente's magika workshop to learn about the amazing features he implemented.
Be warned though, you can spend a lifetime on these forums and yet not know everything about this game!
Previous Topic: black borders on screen
Next Topic: Ja2 800x600 resolution version
Goto Forum:
  


Current Time: Thu Jun 21 21:09:30 EEST 2018

Total time taken to generate the page: 0.01590 seconds