Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » AIMNAS » Cant get it to run
Cant get it to run [message #352629] Tue, 06 March 2018 08:47 Go to next message
ngc2201

 
Messages:5
Registered:March 2018
Hey guys,
after some years I decided to reinstall JA2 as well as the 1.13 update. After having read about the AIMNAS mod I wanted to give it a try. However for some reasons I can't get it to run.
I am playing on a Windows 10 notebook and here is what I'm doing:

1) Clean installation of JA2 (Gold Version) ... JA2 can be played at this stage
2) Installation of 1.13 mod (Version 7435, German)
3) Installation of Update for release 7435 (7609)
4) Copying the 3 files into the main JA2 folder to get it properly running on Windows 10 (no lagging) ... JA2 with 1.13 can be played at this stage
5) Install latest AIMNAS release from Github
At this stage the game crashes as soon as I try to start a new game.

Am I doing something wrong? Thanks a lot for your help!
Re: Cant get it to run [message #352630 is a reply to message #352629] Tue, 06 March 2018 12:46 Go to previous messageGo to next message
LatZee

 
Messages:85
Registered:December 2015
Latest AIMNAS version requires something quite a bit newer than "stable" 7435/7609...

To be more precise, on github it says:

Quote:

AIMNAS currently requires atleast version 8163 of JA2 1.13 with gamedir atleast at level 2315
Any earlier release of 1.13 will not work correctly with AIMNAS
Re: Cant get it to run [message #352639 is a reply to message #352629] Wed, 07 March 2018 19:53 Go to previous messageGo to next message
ngc2201

 
Messages:5
Registered:March 2018
Thanks for your reply!

Here is what I did now:

1) Full reinstall JA2
2) Install a new version of 1.13 (SCI_Unstable_Revision_8534_on_GameDir_2408)
3) Install a new version of AIMNAS (latest one from Github)
4) All the compatibility steps for Win10 as described in the folder

Now the game starts, however after the settings-screen (which you get when you want to start a new game) the screen turns black and stays black.

Thanks again!
Re: Cant get it to run [message #352641 is a reply to message #352639] Wed, 07 March 2018 21:50 Go to previous messageGo to next message
The_Bob

 
Messages:405
Registered:May 2009
Location: Behind you.
Does the music keep playing after the screen turns black?
Try disabling intro videos in the ini files (manually or using the ini editor). If that doesn't help, continue to the troubleshooting...

things to try:
start the game in windowed mode.
start the game without installing AIMNAS.
use some older executable or SCI (everything newer than 8400 should run fine on win10).

Or better yet, join the Bear's Pit discord channel and have someone there help you out, it might be easier to troubleshoot things in real time.

Re: Cant get it to run [message #352699 is a reply to message #352641] Fri, 16 March 2018 19:51 Go to previous messageGo to next message
ngc2201

 
Messages:5
Registered:March 2018
Hey,
thank you so much for your help!
Reinstalled the game - it works perfectly fine without the AIMNAS mod. However, as soon as I install the mod, I get the black screen after the initial settings-screen (music keeps playing). I disabled the intro video, tried the windowed mode and tried some older versions. Nothing seems to work.
Thank you in advance for your support!
Re: Cant get it to run [message #352736 is a reply to message #352629] Thu, 22 March 2018 15:12 Go to previous messageGo to next message
ngc2201

 
Messages:5
Registered:March 2018
Is there anything I could provide (log files, etc) which would be of help?
Thanks!
Re: Cant get it to run [message #352764 is a reply to message #352629] Sat, 24 March 2018 04:13 Go to previous messageGo to next message
The_Bob

 
Messages:405
Registered:May 2009
Location: Behind you.
I just tested it, it's broken alright. Get rid of the Data-Bigmaps\Scripts\Overhead.lua file and it should start.

I think the file on github is badly out of date, the one that comes with 1.13 is about 150kB, while the one that comes with bigmaps is around 8kB.

Re: Cant get it to run [message #352781 is a reply to message #352629] Mon, 26 March 2018 14:24 Go to previous messageGo to next message
ngc2201

 
Messages:5
Registered:March 2018
Thank you so much for your help, it works now happy Only minor issue I detected was that the overview map is looking quite flashy and only displayed in black and white. Just for clarification, which AIMNAS version should I have used (and where do I get this version) instead of the Github one? Thanks again!
Re: Cant get it to run [message #352796 is a reply to message #352781] Tue, 27 March 2018 12:48 Go to previous messageGo to next message
The_Bob

 
Messages:405
Registered:May 2009
Location: Behind you.
For bigmaps-aimnas, github is the best place to get it. That's the current version. If you want the old version with wildfire maps, you'll find it on Kermi's JA2 FTP Repository. I'm not sure if the old version will work properly with current 1.13 builds.

Re: Cant get it to run [message #353362 is a reply to message #352764] Sat, 05 May 2018 16:13 Go to previous messageGo to next message
x4nPro

 
Messages:19
Registered:October 2010
The_Bob wrote on Sat, 24 March 2018 04:13
I just tested it, it's broken alright. Get rid of the Data-Bigmaps\Scripts\Overhead.lua file and it should start.

I think the file on github is badly out of date, the one that comes with 1.13 is about 150kB, while the one that comes with bigmaps is around 8kB.


Thank you Sir for this post!!
Re: Cant get it to run [message #353363 is a reply to message #353362] Sat, 05 May 2018 18:45 Go to previous messageGo to next message
Radar

 
Messages:12
Registered:August 2016
Location: Czech Republic
You're a godsend man. Had the same problem. Thanks for the help
Re: Cant get it to run [message #353368 is a reply to message #353363] Sun, 06 May 2018 06:38 Go to previous messageGo to next message
boslog

 
Messages:26
Registered:July 2012
Uhmm.. I thought you said the github one is damaged? I downloaded aimnas core files an hour ago and having the same problem but it runs fine now after deleting the overhead

[Updated on: Sun, 06 May 2018 06:40]

Re: Cant get it to run [message #353371 is a reply to message #353368] Sun, 06 May 2018 16:56 Go to previous messageGo to next message
The_Bob

 
Messages:405
Registered:May 2009
Location: Behind you.
It's been logged as a Github issue, I think it's partially solved by now, although the game still doesn't start with the file present.

The only thing I learned from looking at the file was that I've really no idea how any of this Lua stuff works. Also it made my head hurt. I thought I'd have a second look but had to stop because my teeth started twisting around in their sockets.

Re: Cant get it to run [message #353379 is a reply to message #353371] Mon, 07 May 2018 11:40 Go to previous messageGo to next message
Radar

 
Messages:12
Registered:August 2016
Location: Czech Republic
Just as a note for others: Due to the Overhead.lua error you may encounter a bug where Skyrider won't 'see' his chopper to end the escort quest. To fix it simply put the .lua file you removed back in Data-Bigmaps\Scripts The Bob mentioned before.
Re: Cant get it to run [message #353391 is a reply to message #353379] Tue, 08 May 2018 16:34 Go to previous messageGo to next message
boslog

 
Messages:26
Registered:July 2012
If we put back the damaged lua file will ja2 run or do we encounter black screen again?
Re: Cant get it to run [message #353393 is a reply to message #353391] Tue, 08 May 2018 17:16 Go to previous messageGo to next message
Radar

 
Messages:12
Registered:August 2016
Location: Czech Republic
When I put the lua file back I didn't encounter the black screen again, so it seems it will work okay. But I removed it again after completing the quest just to be sure.
Re: Cant get it to run [message #353741 is a reply to message #353379] Mon, 11 June 2018 20:04 Go to previous message
x4nPro

 
Messages:19
Registered:October 2010
Radar wrote on Mon, 07 May 2018 11:40
Just as a note for others: Due to the Overhead.lua error you may encounter a bug where Skyrider won't 'see' his chopper to end the escort quest. To fix it simply put the .lua file you removed back in Data-Bigmaps\Scripts The Bob mentioned before.

I've created a workaround so i'm able to play further.
1. moved the "Overhead.lua" from "\Data-1.13\Scripts" to "\Data-Bigmaps\Scripts" (file size around 146KB)
2. Edit the "Overhead.lua" line 431 from:
if ( ProfileId == Profil.SKYRIDER and CheckNPCSectorBool( Profil.SKYRIDER, 13, SectorY.MAP_ROW_B, 0 ) == true and PythSpacesAway( Profil.SKYRIDER,8842 ) < 11 ) then

to:
if ( ProfileId == Profil.SKYRIDER and CheckNPCSectorBool( Profil.SKYRIDER, 13, SectorY.MAP_ROW_B, 0 ) == true or PythSpacesAway( Profil.SKYRIDER,8842 ) < 11 ) then


Triggers Skyrider in B13.

Greetings x4n
Previous Topic: Roadmap AIMNAS
Next Topic: BigMaps Editing
Goto Forum:
  


Current Time: Mon Sep 24 12:49:09 EEST 2018

Total time taken to generate the page: 0.01147 seconds