Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » Vengeance 1.13 Reloaded » Windows 10 messed up install
Windows 10 messed up install[message #355271] Mon, 08 October 2018 11:58 Go to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Hello,

Install attempt for Vengeance Reloaded-
-using latest sci 02.07.2018 version on top of fresh JA2 1.12
-installed latest exe1944
-copied latest Items.xml and Merges.xml into "\Data-AIMv53\TableData\Items folder"

Get error mssg when starting the game with 1944exe at startup saying something abour "tracer light" and "tracer color" is neither true or false.

In tactical mode enemy hits show an red colored * (asterisk) with no amount of damage (numerical) provided. Also dmg seems very low as enemies take 6 plus hits with a .45 handgun to take them down. Something seems fucked up on install. Is this normal to see a red asterisk and no dmg amount on enemy hits?

Uninstalled, re-installed just the SCI and exe (did not copy the latest xmls) and getting the same error mssg using 1944SCI exe.

[Updated on: Mon, 14 January 2019 01:47] by Moderator

Re: Fucked up install[message #355273 is a reply to message #355271] Mon, 08 October 2018 14:20 Go to previous messageGo to next message
LatZee

 
Messages:113
Registered:December 2015
Check your Ja2_Options.ini in [Tactical Interface Settings] section for the way damage is displayed:

;------------------------------------------------------------------------------------------------------------------------------
; How should the game display the enemy/player hit counter?

; 0 = Show damage inflicted as used to
; 1 = Show "?" as indicator if you scored a hit
; 2 = Do not show anything at all (If you scored a hit you need to tell by target's reaction)
; 3 = Show damage as white asterisks (scale is >0, >10, >30, >60, >100)
; 4 = Show damage as red asterisks
;------------------------------------------------------------------------------------------------------------------------------

ENEMY_HIT_COUNT = 4


putting it to 0 should show the damage numbers instead of red asterisks. Or use any of the other options cheeky
Re: Fucked up install[message #355277 is a reply to message #355273] Mon, 08 October 2018 20:50 Go to previous messageGo to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Thank you !

Any other recommended settings to begin?

Scifi on/off?

Improved Interupt on/off?

Drop all probably best off?, Along with Zombies off?

Difficulty Experienced vs Expert?

Thanks

Re: Fucked up install[message #355286 is a reply to message #355277] Tue, 09 October 2018 03:32 Go to previous messageGo to next message
Hawkeye

 
Messages:1903
Registered:October 2005
Location: Australia
The Sci-Fi mode wasn't heavily supported, though it does work, but I'd suggest turning it off.

Drop all off, having it on generally breaks weapon and money balance, but some just can't live without it. Vengeance is very tight and challenging early on, so expect to 'live off the land' and do plenty of hit and runs before you can get a foothold in Arulco.

Zombies were never tested or even supported so you're in uncharted territory there.

Difficulty level is personal taste, depends what level you have been playing previously. I personally play Experienced and a number of JA veterans have found the mod hard, Arulco this time around is less friendly than it was in Vanilla.


Re: Fucked up install[message #355287 is a reply to message #355286] Tue, 09 October 2018 07:29 Go to previous messageGo to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Thank you.

Finding it quite difficult on experienced and very interesting. Very atmospheric with the various taunts, carnage and bodies about.

Random question. When unlocking crates/storage units is there a particular setting to turn on for items to be highlighted when the container is opened? Currently when a container opens the merc makes a "cool" comment but items are not highlighted/shown until I ctrl key them. I seem to recall items auto highlighting as soon as crate is opened in base 1.13 and other mods? Items on ground are highlighted per usual.
Re: Fucked up install[message #356372 is a reply to message #355287] Thu, 10 January 2019 11:07 Go to previous messageGo to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Sorted out my previous install on Windows 7 desktop. Must of botched the first install attempt as I finally got it running, still getting the error mssg regarding tracers.

Anyway- had to replace my other older computer (laptop WinXp) to a new Windows 10 Laptop. Not liking Windows 10 very much.

Major install headaches trying to get the new Vengence Reloaded v.1.4 running. Using GoG JA2 Version, plays fine as non-modded JA2. It all goes to shit once VR is installed and trying to run. Extremely laggy mouse and gameplay.

Extremely perplexed that my old WinXP laptop ran lots of JA2 mods at 1024x768 resolution with zero hiccups and Win10 is unplayable. My current screen resolution is 1920x1080- I've been able to get it running in window mode but the gameplay screen barely fills up my computer screen so its tiny OR at higher resolutions it goes way beyond my screen borders and I can't see most of the game.

Trying to play in fullscreen results in my mouse lagging all over and the game playing in slomo. Similarly playing at 800x600 or 1024x768 doesn't fill up my screen so it looks weird, higher resolutions are way too tiny, but either low Res or high Res is unplayable anyway due to lag.

I've tried the Win8 fixes included with the VR download, I've also tried the win7-10 fixes found elsewhere on the boards. Still laggy as fuck.
I've tried the Reg fix, the Dlls, compatibility with Win7/8/Xpsp3/ tried the color changes to 16bit, tried to adjust using a single core rather than all 4... None have worked.

I've reinstalled the game 3 times, eventually every time the game crashes and the INI editor becomes unresponsive and no longer lets me adjust anything.

I'll make a few more attempts but it's starting to look like the future of JA2 may be doomed and become fully unplayable on modern systems? Anyone else running Win 10 and managed to get VR running in fullscreen at 1024x768? I can't figure out how to get it running at fullscreen without lag...what was once a simple install, add mod and run has become a technology nightmare cluster.

***
INSTALLATION OF THE PERFORMANCE FIXES:

*** STEP 1: Temporary extract the patch/fix files ***
- Extract the "Windows 7-10 Fix.zip" file to a temporary folder (e.g: C:\Temp\JA2_Fix)

*** STEP 2: Run the PerformanceFix.reg file ***
- Before applying the registry file, open it with a text editor (e.g: notepad) and change the default path to the 1.13 executable ("C:\\Games\\Jagged Alliance 2\\ja2.exe") to your JA2 1.13 Installation directory and executable file
- Run the registry file (double click)

***

Question- When opening the "PerformanceFix.reg file" and editing it- Should it be Edited to the ja2.exe OR the JA2_Vengence.exe ???

[Updated on: Thu, 10 January 2019 12:34]

Re: Fucked up install[message #356375 is a reply to message #356372] Fri, 11 January 2019 01:23 Go to previous messageGo to next message
Hawkeye

 
Messages:1903
Registered:October 2005
Location: Australia
I'd presume it's the JA2_Vengence.exe you'd want to use.


Re: Fucked up install[message #356376 is a reply to message #356375] Fri, 11 January 2019 10:24 Go to previous messageGo to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Copy that, thanks Hawkeye.

So at least a positive update on getting it running on Win 10-

I've tried the registry performance fix multiple times with the same bad outcome, complete crash of the game, locked up unusable INI, and JA2 fatal error crash with no recovery other than uninstall and try again. Hard to say if that was solely the result of the registry fix or also combined with trying to run on only one cpu.

Either way the registry fix did not work on 4 attempts, and it is totally unclear as to whether double \\ or single \ make a difference, or the VR exe pathway needs to be set VengReloaded exe or the JA2 exe?

I was able to get running in windowed mode, but with a tiny screen. No idea why full screen mode is problematic and windowed is not. However I finally got it working in full screen mode by the following-

Using the latest GoG JA2 17794exe (they have done an improved update)
- setting both the JA2 exe and VR exe to "XP sp3" compatibility
- setting both exe to 16bit color
- copying all 3 dll into the main JA2 game folder where the EXE are contained(from the win 8 fix folder included in the VR DL)

- the reg edit fix did not work
- the changing game to run on single core did not work
- pretty sure the 3 dll from the windows 7-10 fix folder also did not work (not positive on this)

It took a series of trial/error multiple install/uninstall/re-installs to finally get it working in fullscreen mode.

Windows 10 apparently has major problems scaling into full screen resolutions, something I never found with Win 7.
There seems to be serious widespread problems with Win10 running older games and with resolutions not scaling to the screen properly (I'm still working on getting mine to scale properly). The internet is filled with people having issues running Win10.
Re: Fucked up install[message #356387 is a reply to message #356376] Sat, 12 January 2019 07:01 Go to previous messageGo to next message
Hawkeye

 
Messages:1903
Registered:October 2005
Location: Australia
By the sounds of it this just gives me another reason not to 'upgrade' to Windows 10 any time soon, though I've held off so far mainly because I'd probably lose use of all my older tools and packages.

I have no experience with running Windows 10, so can't really help. Have you searched posts on here? as I know a number of people have had issues in the past, but seemed to get by eventually. Try contacting Lockie, I think he was one such person?

After getting full screen working did you try any lower resolutions? 1920x1080 is kinda 'up there', but may depend on the size of your monitor and personal preferences. Also it may be obvious. but check your drivers (Graphics card AND monitor) are up to date and make sure any programs running in the background are turned off, or prevented from running at start up, if you can. Also in gameplay options make sure the 'merc lights during movement' box is unchecked, though this should only affect frame rates at night.

I don't know if one JA2 install may be better than the other, perhaps you could try getting another one instead of the GOG version, but I got the impression that was the more preferred choice, but don't quote me on that. Another search on here might help regarding that. Somehow I doubt it would fix what sounds like some severe lagginess though. What specs are your laptop?

As mentioned before Vengeance uses it's own exe, so that would be the one to concentrate on and attempt to get running optimally.

[Updated on: Sat, 12 January 2019 07:01]



Re: Fucked up install[message #356390 is a reply to message #356387] Sat, 12 January 2019 12:03 Go to previous messageGo to next message
silversurfer

 
Messages:2508
Registered:May 2009
This post pretty much sums up the options that you have to run JA2 properly on Windows 10.

@Hawkeye
You don't really want to upgrade to a Windows version above 7 because they are all a pain in the butt. For example Windows 10 updates aren't really updates but new installs where a lot of the previous configuration gets lots in the process. Security patches work the same as on Windows 7 but the updates that come out every few months gave me headaches and wasted a lot of my time so I'm back at Windows 7. When support runs out I'm moving to Linux.

[Updated on: Sat, 12 January 2019 12:08]




Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Fucked up install[message #356393 is a reply to message #356390] Sun, 13 January 2019 00:23 Go to previous messageGo to next message
Hawkeye

 
Messages:1903
Registered:October 2005
Location: Australia
Yeah I've had no reason to change apart from the looming lack of updates and security issues that may come with that. Unfortunately Windows 7 updates are giving me and others headaches too with monthly updates of having errors and looping during installation. The cynical side of me wonders if this is intentional from Microsoft to encourage more existing users to swtitch.


Re: Fucked up install[message #356396 is a reply to message #356393] Sun, 13 January 2019 01:47 Go to previous messageGo to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Thank you for info and encouragement... and making awesome mods and continued development !

I've read loads of posts and thanks for the link as well. I'm not psyched on Win 10 but they pretty much have you by the nuts based on microsofts business ethics. Anyway I did manage to get it running in full screen at lower res settings. Apparently my lap top has 2 graphics cards, Nvidia gtx 1050 and one Intel integrated card- weird.

To adjust scaling playing at low resolution so that the full screen is used (rather than having 2 black bars on each side resulting in smaller game screen) I needed to make scaling adjustments with the Intel graphics card even though my game is using the Nvidia card. Yeah that's fucking intuitive. So you first have to re-adjust the Intel settings to get full screen, then test the Resolution settings via INI to determine if they will work via much trial and error.

I will likely try some other mod installs and report back on what works. I've yet to play the new VR beta so no idea if crashes or lag will appear due to widespread Win10 issues and feedback.

Cheers
Re: Fucked up install[message #356398 is a reply to message #356396] Sun, 13 January 2019 07:15 Go to previous messageGo to next message
Hawkeye

 
Messages:1903
Registered:October 2005
Location: Australia
Maybe consider looking at your graphics card settings, usually you turn off your integrated card if you have a more powerful expansion card installed on top, though it's ages since I've dabbled with any of that. There are heaps of resolutions to use, some are widescreen, some are not, so it will depend what works with your screens aspect ratio too, and then also some resolutions may not be native to your card/monitor.


Re: Fucked up install[message #356401 is a reply to message #356398] Sun, 13 January 2019 11:10 Go to previous messageGo to next message
SmokinGun

 
Messages:72
Registered:June 2007
Location: Land of New Rising Sun
Good to know on turning off the integrated card. Yes loads of different resolution settings, I prefer 1024x768 as I can actually see better and prefer it for all the gear sorting.

Laptop specs are 15inch screen, i5 2.3ghz proc, 8gb memory, NVidia gtx1050 4gb.
Two disc drives, it seemed that installing JA2 on the D drive was problematic (maybe just my imagination) but C drive resulted in getting things working.

I definitely concur that Microsoft is sketchy at best with their operating systems being timed out to no longer work after a point in time. My last laptop was Win Xp that suddenly imploded, years after they no longer "support" the operating system. Windows 10 is a fucking nightmare- they have a Microsoft store "App" bloatware that is constantly trying to sell you Apps (similar to the phone b.s. app scam), constantly trying to "update" bullshit programs that you can't uninstall, trying to track monitor spy and collect EVERY keystroke / site / search etc you make.

Seriously fuck Microsoft- I live in Seattle and know many people who have worked for their cult for many long years. Amazon is far worse and between the two companies they have completely fucked up Seattle in the worst of ways. I've had personal interactions with Bill Gates, long before Microsoft really exploded. I've also dealt with Bezos and he really is a total douchebag.

Anyway- longlive JA2 and Viva La Revolution !!



Into the Dungeon with evil men
The people have risen we're free again
Come out of the closet
Come out of the hole
Come out of the woodwork
Come into the fold
Rebels and fighters, a license to kill
Unite with the bandits down from the hills
Open your windows
Open your doors
Open your minds
To a freedom of thought
Viva la revolution X4
Raise our voices, raise our flag
Smash the symbols of the life we've had
Long live the future
Long live the scheme
Long live our hopes
Long live the dream
Dance in the streets at the carnival
Celebrate the victory now
Drink the wine from the rich man's cask
This revolution won't be the last
Viva la revolution!

Re: Fucked up install[message #356403 is a reply to message #356401] Sun, 13 January 2019 13:26 Go to previous message
edmortimer

 
Messages:1200
Registered:January 2015
Location: Home Free
This little tool shuts down a lot of Win10's annoyances and intrusions: ShutUp 10.




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Previous Topic: Crash during installation
Next Topic: Loyality in Salinas
Goto Forum:
  


Current Time: Sat Mar 23 04:58:58 EET 2019

Total time taken to generate the page: 0.00966 seconds