Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » AIMNAS » AIMNAS Bug Reprts Part 3
AIMNAS Bug Reprts Part 3[message #357709] Sun, 28 July 2019 12:02 Go to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Alright folks... I closed down thread 2 as it became quite full again.

In this thread report all bugs you find with current github version (as of 28th July 2019). This can and should include all kinds of the following bugs:





  • typos (item name and kind of typo)

  • unfinished / not working quests

  • civilians without factions encountered in maps

  • map glitches

  • any kind of game freeze

  • anything else on this list you think could be a bug

I will try to fix the stuff I can fix (that is things in the xml files, sti files and maps mostly... anything code related should be reposted in the official bug thread).

[Updated on: Sun, 28 July 2019 14:47] by Moderator



Re: AIMNAS Bug Reprts Part 3[message #357711 is a reply to message #357709] Sun, 28 July 2019 12:11 Go to previous messageGo to next message
sevenfm

 
Messages:1926
Registered:December 2012
Location: Soviet Russia
There are two AmmoTypes.xml files in github version: Data-AIM\TableData\Items\AmmoTypes.xml and Data-Bigmaps\TableData\Items\AmmoTypes.xml
Which one is correct and shouldn't all item related files be stored in Data-AIM?
Also Data-Bigmaps\NPCDATA contains German speaking edt files which should probably be moved to German branch.



7609+fix | 7609+AI (r1141) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: AIMNAS Bug Reprts Part 3[message #357712 is a reply to message #357711] Sun, 28 July 2019 12:18 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Yes, the two ammo types are deliberate.

The xml editor messes up the ammo types, therefore I need the "real" ammotypes.xml that the game works with in a different folder (in Data-Bigmaps). The ammotypes.xml in Data-Aim is outdated and basically only included so that the xml editor works correctly. Any changes made to ammotypes.xml in the xml editor won't apply in-game.


Re: AIMNAS Bug Reprts Part 3[message #357713 is a reply to message #357712] Sun, 28 July 2019 12:19 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Urgh... not the german .edt files again...

I thought I got rid of those a couple times already. speechless

*grmbl*


Re: AIMNAS Bug Reprts Part 3[message #357715 is a reply to message #357709] Sun, 28 July 2019 13:53 Go to previous messageGo to next message
Radar

 
Messages:17
Registered:August 2016
Location: Czech Republic
I'm not quite sure if it is a bug or I am just missing something. It seems that the G36 and AUG rifle series have no magnification/ red dot in their default state.
The rifle's zoom factor is 1.0 while the zoom factor on the optics is around 3.5. While playing it looks like they behave as if they had basic iron sights.
Re: AIMNAS Bug Reprts Part 3[message #357716 is a reply to message #357715] Sun, 28 July 2019 14:35 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
I'll look into that.

On another note:
Tais investigated the issue with not working training. Looks like administartor assignment added a couple issues there. If you have someone working on admin duty, training works. Of course this isn't really how it is supposed to work (training should be doable without an administrator). A fix for that should be in the works.


Re: AIMNAS Bug Reprts Part 3[message #357717 is a reply to message #357715] Sun, 28 July 2019 14:39 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Radar wrote on Sun, 28 July 2019 12:53
I'm not quite sure if it is a bug or I am just missing something. It seems that the G36 and AUG rifle series have no magnification/ red dot in their default state.
The rifle's zoom factor is 1.0 while the zoom factor on the optics is around 3.5. While playing it looks like they behave as if they had basic iron sights.

Okay, found it... basically all guns with fixed optics / aiming modules (AUGs, G36, SSW, P90) come without default attachments. I'm on it. Gitupdate will follow asap.


Re: AIMNAS Bug Reprts Part 3[message #357718 is a reply to message #357717] Sun, 28 July 2019 15:08 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Okay, think I got them all... some default attachmetns were messed up due to me moving around several attachments. Looks like the xml editor doesn't move around default attachments automatically. This has been fixed and will be updated within next 15 mins.


Re: AIMNAS Bug Reprts Part 3[message #357719 is a reply to message #357711] Sun, 28 July 2019 15:20 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
sevenfm wrote on Sun, 28 July 2019 11:11

Also Data-Bigmaps\NPCDATA contains German speaking edt files which should probably be moved to German branch.

Once I add faction quotes I will most definitely change to English for civilians, until then it makes not much sense to sort all that stuff out, tbh. Especially as there are a couple NPCs in that folder that use English already, so just deleting or moving all the stuff there ain't an easy solution either (like Betty, and probably the two additional Miners as well).

So instead of sorting that out at this point, I'd rather leave it in until I get around to actually add civilian flavour texts and the like.


Re: AIMNAS Bug Reprts Part 3[message #357722 is a reply to message #357718] Sun, 28 July 2019 16:33 Go to previous messageGo to next message
Radar

 
Messages:17
Registered:August 2016
Location: Czech Republic
smeagol wrote on Sun, 28 July 2019 14:08
Okay, think I got them all... some default attachmetns were messed up due to me moving around several attachments. Looks like the xml editor doesn't move around default attachments automatically. This has been fixed and will be updated within next 15 mins.
That was very swift. Great job. happy
Re: AIMNAS Bug Reprts Part 3[message #357727 is a reply to message #357722] Mon, 29 July 2019 01:10 Go to previous messageGo to next message
HellsWind

 
Messages:44
Registered:October 2018
Location: Netherlands
Radio Operator doesn't have a radio set available either in Old Method or New Method of gear selection. Sorry if this is a lame bug report.

Also in AIMNAS getting following error which prevents me from playing due to freezing:
(Jagged Alliance 2 Gold - SCI_JA2v1.13_Revision_8681_on_GameDir_2476)


[72.7324] : ERROR : File : vobject.cpp
Line : 967
Location : BltVideoObjectToBuffer
Video object index is larger than the number of subimages

Not 1000% sure if it's 1.13 or AIMNAS related.

Edit; I have d/l newest, recently updated AIMNAS version and did not have freezes wehere I had previous.

[Updated on: Tue, 30 July 2019 14:42]

Re: AIMNAS Bug Reprts Part 3[message #357828 is a reply to message #357709] Sun, 11 August 2019 05:51 Go to previous messageGo to next message
Franimus

 
Messages:46
Registered:June 2015
Location: USA
In JA2_Options.ini, I think there are a few typos:
* CTH_PENALTY_FOR_COWERING_CROUCHED_TARGET_LEGS_DIVISOR should be CTH_PENALTY_DIVISOR_FOR_CROUCHED_SHOCKED_TARGET_LEGS
* AI_SUPRESS_MIN_MAG_SIZE should be AI_SUPPRESS_MIN_MAG_SIZE
* Your comment change related to STRENGTH_TO_LIFT_HALF_KILO is incorrect. This value gets multiplied by the weight (and divided by strength), so setting it to 0.5 will double your carrying capacity; i.e. this setting is how many points of strength it takes to lift a certain amount of weight.
* Ditto for your comment about REPAIR_RATE_DIVISOR. Merc stats are divided by this value, so increasing it will slow down the activity.
Re: AIMNAS Bug Reprts Part 3[message #357845 is a reply to message #357828] Mon, 12 August 2019 08:59 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Fixed all 4 of those. The comments for strength and repair were probably some old 1.13 comments. Wise advice


How do you people even find those typos???



Re: AIMNAS Bug Reprts Part 3[message #357855 is a reply to message #357845] Tue, 13 August 2019 02:14 Go to previous message
Franimus

 
Messages:46
Registered:June 2015
Location: USA
Doing diffs happy I've tweaked that ini file a good bit in the past and don't like losing all my changes...

Found a few more issues in attachments.xml:
* lines 1784-1787 missing itemIndex entry, I think the whole record can go
* lines 2193-2196 ditto
* lines 3062-3065 ditto
These I dug into because I had a hard time trying to figure out why I couldn't attach ragtops or camo covers anymore, ended up having to generate a little xsd and use VS' auto xml validation. After fixing those, I'm still having a problem with it, so I'm still digging... All I know is that if I use old copies of Items.xml and Attachments.xml from a few months ago (specifically, before the June 30th commit), the helmet attachments all work.

[Updated on: Tue, 13 August 2019 02:53]

Previous Topic: AIMNAS Map Screenshots
Next Topic: AIMNAS Item requests Part 2
Goto Forum:
  


Current Time: Sun Aug 25 14:25:10 EEST 2019

Total time taken to generate the page: 0.01826 seconds