Home » MODDING HQ 1.13 » v1.13 Bug Reports » Bugs: Unofficial releases (SCI's), unstable and DEV builds (Read the first post before posting!)
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #357991 is a reply to message #357989] Sat, 31 August 2019 10:06 Go to previous messageGo to next message
silversurfer

 
Messages:2690
Registered:May 2009
Seems like an incorrect installation. I just started the game, killed every soldier in A9 and Fatima and her boy were right in the middle building. Using r8692 but that shouldn't make a difference because there were no changes to NPCs in the newer revisions.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

icon10.gif  Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #357992 is a reply to message #357991] Sat, 31 August 2019 17:48 Go to previous messageGo to next message
GoddamnMartiansAgain

 
Messages:17
Registered:May 2016
Location: Next to my fridge.
Yup, reinstalling fixed it... kinda. Fatima is there, but I still get german dialogue text, with english audio. Doesn't bother me too much, since I am german .



Ahoi.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358023 is a reply to message #357992] Tue, 10 September 2019 12:11 Go to previous messageGo to next message
3iff

 
Messages:67
Registered:July 2001
Location: Birmingham, UK
A very strange problem I've not seen before. V8684

Captured the central SAM (I8). Saved the game, then went to strategic map. The cutscene offer popped up and the minimap went black. I skipped the cutscene and the minimap stayed black. Odd. I went to another sector and that minimap was also black...and all the inventory had disappeared. Returning back to I8 and that inventory had disappeared too.

Reloaded the game prior to the cutscene offer and this time I accepted the video. On exiting, the minimap was lit up as normal and all inventories were present.

Tried a third time, this time before the cutscene was offered, I loaded another sector (G9 where all my stuff is...), popped back to the strategic map and skipped the cutscene when offered. The minimaps and inventories were all present as normal.

I'm fairly sure all my files are up to date but any idea which files are relevant to this event?

I'm waiting for another cutscene event to see if something similar happens.

-----------------------------------

Another unrelated bug. I've seen it in this version and earlier versions.

A squad arrived in a sector at the same time as an attack by the enemy in a different sector. The remote sector battle (just militia vs enemy) goes to auto battle. When it finishes, I get a 'creature' battle in sector A1 with zero combatants. (Creatures are disabled in my games). The game then locks out and/or crashes. The last time it happened, I managed to use an earlier save and delay the arrival of my squad and no such event happened.

Possibly after the auto battle, the game has incorrect values for the squad arrival and it gets interpreted as a battle. I almost never visit A1.

[Updated on: Tue, 10 September 2019 12:19]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358096 is a reply to message #341931] Tue, 24 September 2019 03:04 Go to previous messageGo to next message
JP'TR

 
Messages:104
Registered:April 2009
Location: Germany
I have a problem in 8684, maybe its known and you can give me some help.

Moved my 2 squads down into the Alma Mine to kill the Crepitus.

Clearing the 1st lower level worked fine, in the second part it regulary starts hanging (clock showing) when i finish my turn.
Everytime when it crashes the whole picture gets brighter. I managed to get through with reloading/restarting the game again, cause it wasn't crashing everytime. Had the feeling it hangs up when Crepitus lost sight contact to my mercs.
But now in the 2nd lower Level the same bug appears. Can't do more then 1-2 turns before it crashes again.


EDIT: Came back few days later for a new try and with just 1 team (8 Mercs), now it works without problems.

[Updated on: Fri, 27 September 2019 18:47]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358112 is a reply to message #358096] Thu, 26 September 2019 01:24 Go to previous messageGo to next message
ZedJA2

 
Messages:205
Registered:January 2018
Have a possible bug in r8646 and was wondering if anyone had ever seen this sort of problem and if the issue if seen had ever been addressed in a later revision, because I thought a while back I had seen a mention of a fix to it.

Revision 8646

My Merc was on a roof and he decided to steal from a nearby enemy, who may have been ko'd or not. Anyway, he was interrupted by an enemy on the ground that saw him, near the building. I believe what occurred next was that the inventory overlay for stealing came up and then it just froze with the infinite circle on screen.

Has anyone ever seen a bug for an interrupt during a steal attempt causing this issue and was it ever addressed by any fix since 8646. I'll see if I can dig up the save, which I do have, but that save will not always cause the interrupt of course.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358198 is a reply to message #358112] Fri, 04 October 2019 22:41 Go to previous messageGo to next message
JP'TR

 
Messages:104
Registered:April 2009
Location: Germany
Small bug / 8646

Arrived with the truck in G9, assigned some passangers directly from the vehicle to another task (Ears to "Snitch/TownRumors", others Patient/Doctor) Rest of the team continued driving away with the truck.

Bug: Ears was in the town as Snitch, but his yellow dot followed the truck, while the assigment "Snitch" started red blinking. Also in the sidebar he was on the move, invisible and not as passanger of the truck.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358289 is a reply to message #358198] Sat, 19 October 2019 11:33 Go to previous messageGo to next message
xxxooo
Messages:1
Registered:October 2019
Hi, here is a bug under 8684.

When an enemy is collapsed after hit on the leg or stun grenade etc, you can go to pillage the enemy.
For me there are almost 50% chance that the item list does not appear (toggle bar and buttons still do) and game gets stuck.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358554 is a reply to message #358289] Mon, 25 November 2019 16:18 Go to previous messageGo to next message
LoTeK_

 
Messages:12
Registered:December 2013
Location: Italy
Hi, before asking for help I wanted to thank for all your work on this awesome game. Still playing.

Now with the issues. Number 1, I'm on "SCI_JA2v1.13_Revision_8704_on_GameDir_2482" as it comes (no AIMNAS no SVN) and I'm struggling because of the slots for attachments on weapons. The slot for them just isn't there anymore even if Bobby Ray tells you can attach that item or the game highlight it when you hover the mouse over them. For example an acog combo 4x to a SCAR-H SV or a small scope 2x to a P90, nope. The FN MAG just supports a bipod, a laser sight and a rifle sling now while I used to run it overcrowded with attachments. I've tried a G3 too no slots for optics/scopes and so on for all other weapons I've tried to adapt my gameplay but I'm really failing. I'm just able to mount scopes on sniper rifles. Suppressors no slot either on any weapon type cept pistols and some SMGs. I feel something is not right here do I missed something in the INI or XML files? There's really a lot of stuff to check.

Number 2, I just took Drassen and the selection at Bobby Ray is really on few items now, there are like 3/4 guns for every type instead of the full list of items I used to have (one type even have no items to show). I've checked the INI file but I didn't find the option to make everything available at start. I'm not playing on "tons of guns mode" I never used to but I now see the other game type is "reduced". Might it be that? I need to play on tons of guns for a complete list on BR at start? Missed something in the INI file again?

[Updated on: Wed, 27 November 2019 18:26]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358567 is a reply to message #358554] Wed, 27 November 2019 18:26 Go to previous messageGo to next message
LoTeK_

 
Messages:12
Registered:December 2013
Location: Italy
Figured it out. It was all about the "Tons of guns" mode, it appears it now has to be enabled for all attachments to work properly and BR selection to be consistent like it always was, and honestly I think it had more sense before. If that had to be changed, I think a selection betweeen:

1-Normal (normal guns with all attachments working)
2-Tons of Guns (tons of guns with all attachments working)
3-Reduced (reduced guns and attachments)

would have been better. Or at least warn the poor guy hes not even gonna get a scope 2x/4x if he doesn't go tons.

Also I hope the change, if it's here to stay, reflects on the enemy militia but it wasn't much feeling like that. I was firing rounds hitting thin air while the enemy apparently had good aim on mid-long range shots so I suppose they were using a scope.. GL with it at insane diff (would need a team of snipers and GLs any other gun it's like throwing rocks).

[Updated on: Wed, 27 November 2019 18:40]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358580 is a reply to message #358567] Sun, 01 December 2019 17:26 Go to previous messageGo to next message
Kitty

 
Messages:172
Registered:October 2017
Location: Germany
The actionItem for BigTearGas is connected to bombItem 267. This item is the portable TV and therefore no action is happening.

This can be solved when adding a 60mm Tear Gas Shell as new item and connect this one with BigTearGas.



I need more details.

(Didi Hallervorden)
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358694 is a reply to message #358580] Sat, 21 December 2019 00:10 Go to previous messageGo to next message
Krugen

 
Messages:6
Registered:December 2019
bug for 8717

quest "saving angel and maria from bounty hunters". nobody appears on the marked locations. no angel and maria, no bounty hunters. if i wait 7 days kingpin sends an email saying somebody else has killed them.
I did a forum search and I read that i am supposed to kill the bounty hunters on the marked locations. but nobody spawns. If this is not a bug please tell me what am i supposed to do because its driving me nuts.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358695 is a reply to message #358694] Sat, 21 December 2019 06:55 Go to previous messageGo to next message
UBAH

 
Messages:23
Registered:October 2007
I don't know if this is a bug or a feature. Can't hear any sound from my mercs (confirmation when selected, gun firing, ammo rechambering) when they are out of screen.

Also in resolution 1280x720 merc inventory in strategic map still hidden under message log

[Updated on: Sat, 21 December 2019 08:58]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358696 is a reply to message #358695] Sat, 21 December 2019 08:57 Go to previous messageGo to next message
UBAH

 
Messages:23
Registered:October 2007
One more thing, which developers might be interested in.
In my current version of Ja 2 1.13 (8704 & gamedir 2499) there is a problem when I try to open maps in map editior with set up AIMNAS or AFS mods. Map is loaded, but when I switch to ITEMS tab editor freezes. Possible cause of this behavior are files, distributed in directory 'Windows Compatibility Fixes' - ddraw.dll, libwine.dll, wined3d.dll. If I replace this files in game dir with files, distributed in earlier version (gamedir 2364) - everything working OK.
Problem appears only if I use datafiles from AIMNAS or AFS - without this modifications editor works correctly.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358697 is a reply to message #358695] Sat, 21 December 2019 15:06 Go to previous messageGo to next message
sevenfm

 
Messages:2219
Registered:December 2012
Location: Russian Federation
UBAH wrote on Sat, 21 December 2019 09:55
Also in resolution 1280x720 merc inventory in strategic map still hidden under message log
Should be fixed in r8718.



7609+AI (r1537) | Unofficial modpack | Win8+ fix | Experimental project | Youtube | Trunk (r8846) | 1.13 Starter Docs

Поживешь подольше - увидишь побольше.


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358712 is a reply to message #358697] Wed, 25 December 2019 09:23 Go to previous messageGo to next message
sevenfm

 
Messages:2219
Registered:December 2012
Location: Russian Federation
Boxing bug: if player boxer is killed and there is another player merc in the same sector, Kingpin men become hostile and the game goes to endless clock on "civilian turn". Tested with r8720.
If there is no merc in a sector, no battle starts, boxing ends and winner is decided, but when going to strategic screen, the game asks if we want to end boxing match.

[Updated on: Wed, 25 December 2019 09:30]




7609+AI (r1537) | Unofficial modpack | Win8+ fix | Experimental project | Youtube | Trunk (r8846) | 1.13 Starter Docs

Поживешь подольше - увидишь побольше.


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358803 is a reply to message #358712] Thu, 16 January 2020 09:21 Go to previous messageGo to next message
ZedJA2

 
Messages:205
Registered:January 2018
THREE POSSIBLE BUGS noted since 8696, but I have a jury-rigged LUA and some chance the Directories are a bit customized wrong:

<<EDIT IN: 1ST BUG IN LIST FIXED, NOT A BUG (STILL CHECKING ON OTHER 2 POSSIBLE BUGS)

SOLVED, NOT A BUG -- POSS BUG ENHANCED DESCRIPTIONS: (8696 and 8730 ADDED EXE)-- SOLVED BY MATCHING DIRECTORIES AND EXEs AGAIN -- SO NOT A BUG
Using Enhanced Descriptions and opening the last or third Tab will crash the game giving an error about exceeding number of Sub-Images. This happens every time I open the Enhanced Descriptions. If I shut the Enhanced Descriptions Off then the crash does not occur since I can't trigger it. Problem is, some gear, weapons, and ammo can only be understood by using the Third Tab, while other items Third Tab is often totally empty. So shutting off Enhanced Descriptions seems a foolish thing to do. This reliably causes a crash every time since around the 8696 time period. I updated the EXE to 8730 to same effect (but I did not update the Directories for that which might matter).

Basically it says that it crashes at line 967 in Function vobject.cpp (or a name close to that), and that it exceeds the number of displayable sub-images. Seems not to happen to Armor or helmets. But does with weaponry. Sometimes takes two attempts to crash. Happens both in Tactical Map and Strategic Map view.>>

-- POSSIBLE BUG WITH PEPPER SPRAY: (8730 ADDED EXE)
Possible that the Pepper Spray does not work at either 2 range or adjacent range. Was using Flo to use it. At first it showed the cursor at grey and almost flickering, but if I clicked it showed as Green very Accurate Cursor. Another click failed to use the device. Now I may be using it incorrectly, as I sort of have this foggy memory that maybe I'm supposed to use burst fire and spread the spray around like with directed autofire. So I have to try it again. But I thought someone might check it in their v1.13 game and see if it works okay for them, or mention how to use it. I'll try it again as soon as I can.

-- POSSIBLE BUG WITH ZOMBIES SPAWNING NEAR FATIMA IN OMERTA CAUSING PERMANENT PROBLEM TO REBEL HQ QUEST (Cannot Give Letter, Dimitri does not move in Omerta East): (only tried in 8696)
Seems you have to keep Zombies Off if you have combat anywhere near Fatima in Omerta. Once the Zombies respawn and you kill them, it seems that the Civilians, who are also on Lazy Civilian setting if that matters, do not know that Combat is finished after all the Zombies are dead. This is also what I think causes this frequent issue of a sector not seeming clear of enemies when it actually is clear. Fatima never gets out of her panicked cowering state, runs around, and cannot be directed to go to the Omerta East sector even if you leave the sector and return. Again, since the Civilians think Combat is still engaged, they never react to conversation, so you can bork the initial mission. This is probably true for any Civilian near enough or in the same sector possibly where a Zombie spawn occurred, even if they are all killed. So any major quest is a problem, and you really have to save before each combat to make sure if you have a quest there that you can turn zombies off first, before you conduct combat. Anyway, this was in 8696 and numerous prior builds. I now usually play with zombies off, but thought it might have been fixed, and Fatima bugged out as usual.

Anyway, I mention it for others to check, on the current build, to see if they can reproduce it. Basically, any Zombie spawned even if killed within 8 tiles or so of Fatima's location, LOS or not, will cause Fatima to enter perpetual panic, making her permanently unresponsive to get to talk to Dimitri near the Rebel HQ entry. To my knowledge, this makes the quest bug out permanently or else maybe you can kill or knock out Dimitri and maybe get in, probably not a good idea.

[Updated on: Tue, 21 January 2020 08:59]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #358997 is a reply to message #358803] Tue, 11 February 2020 01:00 Go to previous messageGo to next message
Mravac Kid

 
Messages:57
Registered:May 2004
Location: Opatija, Croatia
I'm getting a weird bug in the sector along the road right to the west of Cambria, whenever I encounter enemies there my squad report noticing an enemy in the lower part of the map, but he's nowhere to be found. Seems like he's just off the screen, but I can't target him or anything. My mercs report seeing him, and on the enemy turn there's sound of burst fire but nothing comes to the screen. I tried fiddling with resolutions, and it seems to be resolution-dependent, as I'm also getting the bug JP'TR reported a few posts back with some buildings and terrain being just a bit off. My monitor is 1080p native so I started at 1920x1080, but changed to 1600x900 to have the UI a bit bigger, keeping the ratio at 16x9. When I tried switching the resolution back to 1280x768, the enemy appeared at the top of the map.
Running dev version 20.02.01 rev 8741 on a fresh GOG install.



Ride The Wild Wind - Push the Envelope, don't Sit on the Fence
Ride The Wild Wind - Live Life on the Razor's Edge
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359158 is a reply to message #358997] Sun, 08 March 2020 22:58 Go to previous messageGo to next message
awatz

 
Messages:41
Registered:August 2002
Location: Philippines
I'm using Rev 8766 on GameDir 2523. When the game is Windowed my mercs cant exit the sector in Tactical screen. The exit icon doesn't appear.
When the game is in Full screen I can exit the sector but the game is really really slow.
My monitor is 1440p. I tried different resolutions same thing
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359199 is a reply to message #353332] Wed, 18 March 2020 00:20 Go to previous messageGo to next message
fightcancer

 
Messages:211
Registered:February 2005
Location: USA
Reffy wrote on Wed, 25 April 2018 07:47
I have a weird bug regarding training militia.

I just started a new game and I've cleared Drassen airport. I want to train militia in there, but when I click on that option it says: "Drassen is full of militia" Even though there isn't any militia there at all.
What's also weird is that I can't move my squad in the map screen. It says the sector is hostile, even though there isn't anyone there. I even checked with cheats and there are no hostiles.

Do I have to clear ALL of Drassen before I can train militia? I didn't had to do that before.

Using build 8545.
shady lady wrote on Fri, 27 April 2018 09:48
Hi, I'm having the same problem. Playing the latest SCI 8555/2420 (shows 8554 on screen?).I've cleared B13-Drassen Airfield, D13-Drassen Mine, H8-Cambria Mine and I8 Central SAM site. I can't train militia because the sectors are full of militia already (but they're not) and I can't move my mercs in tactical because all of these sectors are hostile (but they aren't). All help, advice, suggestions welcome. Saved games are available if required. Thank you.
Same bug here on build 8675.

The fix was to leave the sector. You don't have to let time lapse. Then cancel the travel plans. Kill remaining enemies. (In my case it was zombies.) Then keep leaving, re-entering until you've killed all enemies. Once you can travel from the Strategic screen (where you can see the laptop button), then train militia.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359345 is a reply to message #341931] Wed, 01 April 2020 07:44 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG BUILD 20.03.01 REVISION 8766 - SKYRIDER HANG - Entering tactical in sector with helicopter with passengers assigned and scrolling to edge of map results in game hang/not responding.

[Updated on: Wed, 01 April 2020 09:13]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359346 is a reply to message #341931] Wed, 01 April 2020 07:57 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG BUILD 20.03.01 REVISION 8766 - ERROR SAVING GAME - Dropping a backpack manually or with Shift-B in tactical and then picking it up most often via strategic sector inventory but also occasionally in tactical results in 'DEBUG: ERROR in SaveCurrentSectorsInformationToTempItemFile()', 'ERROR saving the game!" OK dialog, and 'Missing LBENode for [whatever backpack]' in log.

Attempting to load a game after this occurs may result in 'RUNTIME ERROR -- PRESS (ESC) to EXIT Assertion Failure (Line 1006 in file SaveLoadMap.cpp). Attempting to do DEBUG save...'

[Updated on: Wed, 01 April 2020 08:08]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359347 is a reply to message #341931] Wed, 01 April 2020 08:04 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG BUILD 20.03.01 REVISION 8766 - INACCESSIBLE SECTOR INVENTORY ITEMS - Dropping items in sector inventory via strategic interface without first visiting sector in tactical (loading) results in the items becoming inaccessible once inventory is closed. This was discussed on this site elsewhere last year. Fix is still not implemented or another vector exists that wasn't fixed. Also, sorting and merging a sector with identical inaccessible and accessible items results in all the items becoming inaccessible.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359348 is a reply to message #359347] Wed, 01 April 2020 08:13 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG? BUILD 20.03.01 REVISION 8766 - CURSOR DISAPPEARS OUTSIDE DIALOG BOXES - The cursor disappears when outside dialog boxes such as the Surrender Yes/No dialog, Untrap Yes/No dialog, etc. Minor nuisance when manually training explosives and moving from trap dialog to click cancel speech bubble to speed training.

[Updated on: Wed, 01 April 2020 09:21]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359349 is a reply to message #359348] Wed, 01 April 2020 08:18 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG? BUILD 20.03.01 REVISION 8766 - SKYRIDER COURSE CAN'T BE SET - If 'Show Militias and Enemies' is active, clicking Skyrider to plot a course fails.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359351 is a reply to message #359349] Wed, 01 April 2020 08:52 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG BUILD 20.03.01 REVISION 8766 - ADDITIONAL IMP DELIVERY IN TACTICAL HANG/INSTABILITY - Being in tactical in the sector where and when an IMP is delivered results in crash/hang if map is scrolled to edge before or after IMP delivery. If a squad is present and map not scrolled to edge, the Options, Laptop, and Tactical buttons and Save/Load keyboard shortcuts are disabled when returning to strategic after IMP delivery.

[Updated on: Wed, 01 April 2020 09:12]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359352 is a reply to message #359351] Wed, 01 April 2020 09:27 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG BUILD 20.03.01 REVISION 8766 - BOUNTY HUNTERS NOT SPAWNING FOR KILL ANGEL/MARIA QUEST - No bounty hunters can be found in quest sectors indicated by 'Show Quests & Intel' and quests.lua code. I manually searched each sector in daytime multiple times with a squad and also used ALT-E and ALT-O cheats in all quest sectors and quest still fails when timer expires.

Also, laptop history log entry for quest failure has 'Event' field text duplicated in and overflowing 'Location' field.

[Updated on: Thu, 02 April 2020 09:32]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359376 is a reply to message #359352] Thu, 02 April 2020 09:42 Go to previous messageGo to next message
Melee

 
Messages:24
Registered:March 2020
Location: U.S.
BUG BUILD 20.03.01 REVISION 8766 - 3.11 ITEM CONFIGURATION MIXUP - If two identical items are configured, changing one causes the contents of the other to be dropped or moved. Example: Put a Casualty Response Kit on each leg with a Syringe Pouch in the same position. Removing or moving the Syringe Pouch on one leg causes the pouch on the other leg to have its contents dropped. Same thing occurs with other items, like a Large Thigh Kit and Throwing Knife Sheaths.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359565 is a reply to message #345904] Wed, 15 April 2020 13:31 Go to previous messageGo to next message
46852
Messages:1
Registered:May 2009
Elestir wrote on Sun, 12 June 2016 19:14
I've got into situation when enemy periodically attacks my mercs stationed at San Mona sectors with small group (8 or so) of elite soldiers likely transported there via helicopter (Razor always yells "Bombers." when they arrive). Problem is that after the load screen, game just crashes.
game_log contains:
[32.9227] : ERROR : File : vobject.cpp
Line : 922
Location : BltVideoObjectToBuffer
No Source Object

Workaround is to vacate the sector that will be attacked. Attacking them there once they capture the sector leads to no crash. I am assuming there is supposed to be some helicopter related animation and game crashes while trying to render it.
Do I have some file missing? Or where can be problem?
r8246/2324
I'm running into this issue still, game stops loading and crashes when enemy attacks my sector. Happened with a bandit attack too. I don't have ASD activated, and playing with r8776/2525.

I also can't avoid the crash by loading the area before the attack angry
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359585 is a reply to message #359565] Thu, 16 April 2020 14:26 Go to previous messageGo to next message
Klymp
Messages:1
Registered:April 2020
Here is a link to my save game(r8776).
drive.google.com/open?id=1lPyMdFdoLIFv1C9U55zw9wWy78Lo0OZh
If you fast forward time the enemy will move in to the sam site from south and when trying to enter the battle it will freeze on the loading screen while game music still runs on the background. I have tried it on 2 different win 7 PCs and a win10 PC and it freezes on all of them. Only thing modified in ja2_Options.INI is DROP_ALL = 1.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #359873 is a reply to message #359585] Fri, 01 May 2020 13:09 Go to previous messageGo to next message
Suslik
Messages:4
Registered:April 2020
im playing 1.13 wildfire with 8766.exe and WF 6.07 maps and a german language patch (german voices and some texts)

when i enter the drassen SAM d15 with my spy, give him the assignment to collect intel and fast forward time i get this error a few minutes before the hour is over


Quote:
Assertion Failure [Line 153 in fUnction NumHostilesInSector in file Queen Command.cpp].

(sSectorX) > (MAXIMUM_VALID_X_COORDINATE) but should be less than or equal
there are 12 enemies in the sector at this moment.
it works on other sectors but this particular one crashes the game.


i have not yet enough comments to attach links to my savefile but ill report back if something similar happens later on
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360008 is a reply to message #359873] Mon, 11 May 2020 22:33 Go to previous messageGo to next message
Tuga2112
Messages:2
Registered:April 2020
1 - Map loading hangs forever when defending an area.

2- i cannot attach links because i dont have 5 posts. but if you just add the https usual prefix it should work
save game here.
drive.google.com/open?id=1wmxSwzHFHfuGDhaCLpAH7uo_w7eAqpwU

3- at 19:40 the chizena counter attack arrives, go to sector and wait for the map to load. map never loads.

4- build from 1st april 2020 (8776?)

5- no mods



Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360448 is a reply to message #359352] Thu, 25 June 2020 01:40 Go to previous messageGo to next message
MisterMoe

 
Messages:34
Registered:February 2011
Melee wrote on Wed, 01 April 2020 06:27
BUG BUILD 20.03.01 REVISION 8766 - BOUNTY HUNTERS NOT SPAWNING FOR KILL ANGEL/MARIA QUEST - No bounty hunters can be found in quest sectors indicated by 'Show Quests & Intel' and quests.lua code. I manually searched each sector in daytime multiple times with a squad and also used ALT-E and ALT-O cheats in all quest sectors and quest still fails when timer expires.
Same issue with build 8766, Angel and Maria are spawning but no bounty hunters .
Killing and returning the heads to Kingping trigger any quest dialog either, just anonymous heads that cannot be turned in
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360482 is a reply to message #360448] Wed, 01 July 2020 00:14 Go to previous messageGo to next message
Flugente

 
Messages:3535
Registered:April 2009
Location: Germany
Well, as we've discovered, the bounty hunters only spawn if ALLOW_EXTRA_CIVILIANS is set to TRUE in JA2_Options.ini. Otherwise they never appear, thus one can never kill them.

The heads of Angel & Maria are irrelevant. If one chooses to kill them, Kingpin will send a confirmation and reward several hours later.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360495 is a reply to message #360008] Sat, 04 July 2020 00:12 Go to previous messageGo to next message
Wien1938

 
Messages:15
Registered:May 2017
Location: UK
Tuga2112 wrote on Mon, 11 May 2020 20:33
1 - Map loading hangs forever when defending an area.

2- i cannot attach links because i dont have 5 posts. but if you just add the https usual prefix it should work
save game here.
drive.google.com/open?id=1wmxSwzHFHfuGDhaCLpAH7uo_w7eAqpwU

3- at 19:40 the chizena counter attack arrives, go to sector and wait for the map to load. map never loads.

4- build from 1st april 2020 (8776?)

5- no mods



I had this bug. For whatever reason, the most reliable workaround is to press the keyboard shortcut for "go to sector" and NOT to press the button on screen - this bypassed the loading screen and went straight to the map.
I've actually been running on an r-build (r8804) from Seven's G-drive and have no problems now. So, depends how adventurous you feel.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360499 is a reply to message #360008] Sat, 04 July 2020 22:01 Go to previous messageGo to next message
Flugente

 
Messages:3535
Registered:April 2009
Location: Germany
Tuga2112 wrote on Mon, 11 May 2020 19:33
1 - Map loading hangs forever when defending an area.

2- i cannot attach links because i dont have 5 posts. but if you just add the https usual prefix it should work
save game here.
drive.google.com/open?id=1wmxSwzHFHfuGDhaCLpAH7uo_w7eAqpwU

3- at 19:40 the chizena counter attack arrives, go to sector and wait for the map to load. map never loads.

4- build from 1st april 2020 (8776?)

5- no mods
I've been testing this one, and it's odd. Most of the time the game loads the sector and starts combat just fine, but occasionally there seems to be some sort of memory allocation problem. It's probably a symptom of some wacky pointer hijinks, one only notices it because the game starts to act up in it's display routines . Still trying to find the issue, but I'm not that optimistic at this point.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360508 is a reply to message #360499] Tue, 07 July 2020 10:49 Go to previous messageGo to next message
gougluinn

 
Messages:104
Registered:September 2018
hi i have tried to start a new game and chose old/old about weapons and attachments but in the game magic starts with steyr aug with new 2x-4x scope features instead standart mac-10. if it is wad then whats the point of that feature?
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360520 is a reply to message #360508] Tue, 07 July 2020 14:36 Go to previous messageGo to next message
silversurfer

 
Messages:2690
Registered:May 2009
gougluinn wrote on Tue, 07 July 2020 09:49
hi i have tried to start a new game and chose old/old about weapons and attachments but in the game magic starts with steyr aug with new 2x-4x scope features instead standart mac-10. if it is wad then whats the point of that feature?
I don't know if this is intended, but I found this in "Tactical\Soldier Profile.cpp" function "LoadMercProfiles()":

/* CHRISL: For now, we should only overwrite prof.dat in the new inventory system.  Old system should still use
prof.dat until we're sure we want to replace it with the xml file.
Because the new WF mercs don't have entries in the prof*.dat files, we need to always load their equipment from
MercStaringGear.xml, regardless of the inventory system we're going to use.*/
if(UsingNewInventorySystem() == true || uiLoop >= 170 )
{
// Start by resetting all profile inventory values to 0
	gMercProfiles[uiLoop].clearInventory();

This basically means that if you are using the old Inventory System (which you are), all merc profiles for profile IDs lower than 170 will be loaded from "prof.dat" and there Magic has a Steyr Aug.
In my opinion the option "READ_PROFILE_DATA_FROM_XML" in JA2_Options.ini should take precedence here and currently it doesn't. If this is set to TRUE, the game should load merc data from MercStartingGear.xml, no matter what inventory system you are using.

Any objections against me changing that?



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #360522 is a reply to message #360520] Tue, 07 July 2020 20:45 Go to previous message
Flugente

 
Messages:3535
Registered:April 2009
Location: Germany
No objection.

Though in case you intend to go further on thi sand look at the MercProfiles themselves, keep in mind that we read more data from prof.dat than we'd read from MercProfiles.xml. Better be careful with that.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Previous Topic: XML Editor Bug Reports
Goto Forum:
  


Current Time: Sat Jul 11 18:06:26 EEST 2020

Total time taken to generate the page: 0.02111 seconds