Home » MODDING HQ 1.13 » v1.13 Bug Reports » Frozen loading screen during enemy invasion
Frozen loading screen during enemy invasion[message #359460] Thu, 09 April 2020 20:09 Go to next message
Vell
Messages:4
Registered:April 2020
Hey guys! Recently bought JA2 on steam and decided to try out the 1.13 mod (excited about the increased difficulty and features!). Everything runs well except for the fact that when I have my mercs and militia at the Drassen Mine, when the enemy invaded, I am not able to "Go ro Sector" to manually fight the battle, I can only retreat or auto resolve. Every time I try to "Go to Sector", the game freezes at the loading screen once the loading bar is fully extended.

I tried applying the windows compatibility fix to no avail. Everything else seems to be fine so far. Please help!
Re: Frozen loading screen during enemy invasion[message #359467 is a reply to message #359460] Fri, 10 April 2020 11:07 Go to previous messageGo to next message
RoWa21

 
Messages:2004
Registered:October 2005
Location: Austria
Can you upload a savegame before entering the sector.


Re: Frozen loading screen during enemy invasion[message #359469 is a reply to message #359460] Fri, 10 April 2020 15:22 Go to previous messageGo to next message
Vell
Messages:4
Registered:April 2020
Hey Rowa! Just attached a Save Game file before the enemy invaded. Same issue happening when I try to "Go to Sector"

Update: I can't seem to attach any files, looks like the Maximum File Size allowable for me is 0KB

[Updated on: Fri, 10 April 2020 15:25]

Re: Frozen loading screen during enemy invasion[message #359487 is a reply to message #359469] Sat, 11 April 2020 21:47 Go to previous messageGo to next message
RoWa21

 
Messages:2004
Registered:October 2005
Location: Austria
zip the file and then upload it anywhere and post the link here


Re: Frozen loading screen during enemy invasion[message #359572 is a reply to message #359460] Wed, 15 April 2020 21:03 Go to previous messageGo to next message
Gopas

 
Messages:278
Registered:June 2016
Location: Norway
@Vell

Use Wine 1.1.3.8 version.

[Updated on: Wed, 15 April 2020 21:03]




Nipson anomimata mi monan opsin
Re: Frozen loading screen during enemy invasion[message #359594 is a reply to message #359487] Thu, 16 April 2020 23:05 Go to previous messageGo to next message
Vell
Messages:4
Registered:April 2020
https ://www.dropbox.com/s/nchc34mg84ah87j/SaveGame01.zip?dl=0

Rowa, have a look at my Save file. In a couple of minute (ingame time) there will be an enemy invasion and the glitch seems to occur again. The odd thing is that it does not happen all the time, just occassionally.

@Gopas Seems like more work to use Wine to run the game, the game seems run just fine for me... Except for this odd glitch that happens every so often. Thanks for the heads up about Wine though!
Re: Frozen loading screen during enemy invasion[message #359605 is a reply to message #359594] Fri, 17 April 2020 13:00 Go to previous messageGo to next message
Tuga2112
Messages:2
Registered:April 2020
I have the same issue in the latest build from 1st april 2020
at 19:40 the chizena counter attack arrives.

i cannot attach links because i dont have 5 posts. but if you just add the https usual prefix it should work

save game here.
drive.google.com/open?id=1wmxSwzHFHfuGDhaCLpAH7uo_w7eAqpwU
Re: Frozen loading screen during enemy invasion[message #359637 is a reply to message #359460] Sun, 19 April 2020 04:41 Go to previous messageGo to next message
holyrebelion
Messages:1
Registered:April 2020
Same problem here, frozen on the red loading bar after hitting GO TO SECTOR
Re: Frozen loading screen during enemy invasion[message #359692 is a reply to message #359460] Wed, 22 April 2020 20:53 Go to previous messageGo to next message
CoyoteBongwater
Messages:1
Registered:April 2020
Registered to report I'm experiencing the exact same bug in the exact same location.

After the counterattack arrives in the Drassen mine sector, pressing GO TO SECTOR to begin the battle consistently locks up the game on the loading screen.
Re: Frozen loading screen during enemy invasion[message #359822 is a reply to message #359460] Tue, 28 April 2020 23:13 Go to previous messageGo to next message
Suslik
Messages:4
Registered:April 2020
im experiencing the same bug.
played the 1. april sci and wildfire 6.07

i have 3 sectors in drassen and it happened in all three on different occasions. either bandits attack the airport or bar it freezes, or the army invades the mine and it freezes. no matter which directions theyre coming from.



now im using the ja2.exe from the 1. march version 8766 from depris onedrive and it seems to work, ill post again once im experiencing some crashes
Re: Frozen loading screen during enemy invasion[message #360085 is a reply to message #359822] Mon, 18 May 2020 22:07 Go to previous messageGo to next message
HoundDogZA
Messages:4
Registered:May 2020
I have this exact problem on the 8796 version from 2 May 2020. When I'm attacked in Drassen with a Merc present it freezes on loading screen or black screen. angry

EDIT: I can reproduce the issue as follows:

1. If I have merc present in sector with no militia when attacked, and select yes for reinforcements from adjacent sector, it does not crash.
2. If I have merc present in sector with militia present when attacked, and select yes for reinforcements, it crashes so far 100% of the time.
3. If I have merc present in sector with militia present when attacked, even without reinforcements or select no for reinforcements, it crashes so far 100% of the time.

So the reinforcements don't seem to matter, it's whether there is militia onsite with my merc when attacked that seems to cause the black loading screen. Even if there's just 1 militia onsite it still crashes. But it's fine if I start out with 0 militia and call them in as reinforcements, then it doesn't crash.

[Updated on: Wed, 20 May 2020 21:50]

Re: Frozen loading screen during enemy invasion[message #360137 is a reply to message #360085] Sun, 24 May 2020 10:09 Go to previous messageGo to next message
genox
Messages:1
Registered:May 2020
I'm also having the same issue early game in Drassen.
v1.13 build 8796 with Wildfire maps 6.07 and latest AIMNAS.
95% of the time I will get a black screen and then a softlock right after the load bar finishes after clicking on 'Go to sector' during a defense with mercs + militia.

After playing around with it, I found that I can get around the black screen by repeatedly clicking the 'Go to sector' button (continue clicking it even after it disappears). If you do it right, it ends up doing the zoom-in animation twice. Hope that helps some of you.
Re: Frozen loading screen during enemy invasion[message #360155 is a reply to message #360137] Tue, 26 May 2020 02:55 Go to previous messageGo to next message
Wien1938

 
Messages:15
Registered:May 2017
Location: UK
I've got the same problem (so far) around Drassen. The counterattack comes in and the game locks up on "Go to sector".

Update:

Reinstalled with clean game. Now if enemy arrive in the sector, "Go to sector" causes the game to lock up and become completely unresponsive.

Update 2:

Reverted to 8766 ja2.exe and the game no longer locks up.

Update 3:
Wiped and reinstalled from scratch - game no longer locked up on enemy attack...until today! (2 days later).
Found a workaround:
If you left-click on "Go to sector", the screen locks up and the game is non-responsive. But if you press "E" on your keyboard, the game BYPASSES the loading screen and goes straight to the map!

[Updated on: Fri, 29 May 2020 06:53]

Re: Frozen loading screen during enemy invasion[message #360195 is a reply to message #360155] Sat, 30 May 2020 04:16 Go to previous messageGo to next message
Dew

 
Messages:6
Registered:May 2020
Wien1938 wrote on Tue, 26 May 2020 02:55
I've got the same problem (so far) around Drassen. The counterattack comes in and the game locks up on "Go to sector".

Update:

Reinstalled with clean game. Now if enemy arrive in the sector, "Go to sector" causes the game to lock up and become completely unresponsive.

Update 2:

Reverted to 8766 ja2.exe and the game no longer locks up.

Update 3:
Wiped and reinstalled from scratch - game no longer locked up on enemy attack...until today! (2 days later).
Found a workaround:
If you left-click on "Go to sector", the screen locks up and the game is non-responsive. But if you press "E" on your keyboard, the game BYPASSES the loading screen and goes straight to the map!
This works like a charm for me. Thank you happy
Re: Frozen loading screen during enemy invasion[message #360211 is a reply to message #360195] Sat, 30 May 2020 19:54 Go to previous message
Wien1938

 
Messages:15
Registered:May 2017
Location: UK
Dew wrote on Sat, 30 May 2020 02:16
Wien1938 wrote on Tue, 26 May 2020 02:55
I've got the same problem (so far) around Drassen. The counterattack comes in and the game locks up on "Go to sector".

Update:

Reinstalled with clean game. Now if enemy arrive in the sector, "Go to sector" causes the game to lock up and become completely unresponsive.

Update 2:

Reverted to 8766 ja2.exe and the game no longer locks up.

Update 3:
Wiped and reinstalled from scratch - game no longer locked up on enemy attack...until today! (2 days later).
Found a workaround:
If you left-click on "Go to sector", the screen locks up and the game is non-responsive. But if you press "E" on your keyboard, the game BYPASSES the loading screen and goes straight to the map!
This works like a charm for me. Thank you happy
You're welcome. I notice that it drops you onto the tactical map one turn BEFORE the enemy appear. Very odd - poor Asdow, Seven and Flugente have not been able to replicate from my save games. I'll keep playing the campaign and see if it's just something in Drassen or if it's more wide-spread.
Previous Topic: Cannot get the elite (black) disguise.
Next Topic: Savegame became cursed
Goto Forum:
  


Current Time: Sun Jul 12 23:30:24 EEST 2020

Total time taken to generate the page: 0.01280 seconds