Home » MODDING HQ 1.13 » v1.13 Bug Reports » Build 8900 does not start after renaming to ja2.exe
Build 8900 does not start after renaming to ja2.exe[message #361668] Mon, 26 October 2020 16:15 Go to next message
Karm

 
Messages:5
Registered:October 2020
Hi!
I built a german patch from the latest master SVN (3900) using the latest GameDir + German Files from 3900.
It works so far, but after I tried to rename the exe file to ja2.exe the window stopped showing at all.
Every other name works for the file, as far as I could test it.

What could cause this Bug? Looks like, there is still a dependency somewhere regarding the ja2 name.
ja2.ini and ja2_settings.ini changes didn't do anything.

Windows 10 Home
JA2 1.13 Build 3900
GameDir 2574 + German files (Build 3900)
Visual Studio 2019

Reproduce: Rename JA2_EN*.exe -> ja2.exe
Error: No visible Window, Resolutionchange visible by Cursor Area

Greetings
Karm
Re: Build 8900 does not start after renaming to ja2.exe[message #361710 is a reply to message #361668] Thu, 29 October 2020 22:13 Go to previous messageGo to next message
wanne (aka RoWa21)

 
Messages:1979
Registered:October 2005
Location: Austria
You can rename the Exe-File to whatever you like. It shouldn't make any problems.

But I think the registry fix for Windows 10 is linked to the ja2.exe. Did you run the registry file to fix performance problem with Win 10?
Open the reg-File and replace the ja2.exe with the new filename. Then run the reg-File again.

[Updated on: Thu, 29 October 2020 22:14]



Re: Build 8900 does not start after renaming to ja2.exe[message #361712 is a reply to message #361710] Fri, 30 October 2020 04:30 Go to previous message
Karm

 
Messages:5
Registered:October 2020
I did not install the reg fix, because it was not necessary on my system, never had any performance issues.
Tested the fix with another version though and it just gives me a flickering when starting the game.
But one value automatically was written in the Registry for every ja2*.exe I used. Except for the ja2.exe.
It isn't possible for me to create the entry manually, if I chose ja2.exe as name.
This probably causes the error. Have to check, why I can't create the entry.
Previous Topic: Robot gun issues - "needs 0 caliber ammunition"
Next Topic: "Repairable" issues - Just a heads up
Goto Forum:
  


Current Time: Sat Nov 28 10:11:39 EET 2020

Total time taken to generate the page: 0.01885 seconds