Home » MODDING HQ 1.13 » v1.13 Modding, Customising, Editing » v1.13 Modding, Customising, Editing » Unstable SCI 8918 + WF maps
Unstable SCI 8918 + WF maps[message #362150] Thu, 31 December 2020 11:31 Go to next message
Bullpup

 
Messages:19
Registered:December 2020
Are they compatible? I have GOG JA2, installed latest unstable 8918 and put Wildfire 6.07 maps as instructed. It seems to run just fine but I didnt leave starting area yet. It did show some error in top left corner the first time I launched the game but I didnt have time to read it all.

It was something about INI missing something. The Wildfire maps have its own INI and it overwrites the unstable INI. Will this cause problems later with some features being removed or bugged?
Re: Unstable SCI 8918 + WF maps[message #362151 is a reply to message #362150] Thu, 31 December 2020 11:50 Go to previous messageGo to next message
silversurfer

 
Messages:2795
Registered:May 2009
The messages that you have seen during game launch were probably about missing or out of range parameters in JA2_Options.ini. This usually happens when the version of your JA2.exe is ahead of your game data version. Please make sure that they fit together.

WF maps do not provide JA2_Options.ini. The game uses the file in Data-1.13.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Unstable SCI 8918 + WF maps[message #362152 is a reply to message #362151] Thu, 31 December 2020 11:53 Go to previous messageGo to next message
Bullpup

 
Messages:19
Registered:December 2020
How do I make sure they fit together? I am noob to this INI stuff.
Re: Unstable SCI 8918 + WF maps[message #362153 is a reply to message #362152] Thu, 31 December 2020 12:07 Go to previous messageGo to next message
silversurfer

 
Messages:2795
Registered:May 2009
You should only use packages of exe and GameDir that have been put together by people who know what they are doing. Unfortunately Depri's SCIs are not updated anymore, but there is an alternative -> here.

WF maps should run fine with the latest development build.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Unstable SCI 8918 + WF maps[message #362154 is a reply to message #362150] Thu, 31 December 2020 13:20 Go to previous messageGo to next message
Bullpup

 
Messages:19
Registered:December 2020
What is Depri SCI? I use same thing as what you posted. Its that #605 19 days old r8918 g2579 SCI from that jenkins website. I never used any Depri SCI.

So it should work fine despite that red text error I got on first launch?

[Updated on: Thu, 31 December 2020 13:20]

Re: Unstable SCI 8918 + WF maps[message #362157 is a reply to message #362154] Thu, 31 December 2020 15:48 Go to previous message
silversurfer

 
Messages:2795
Registered:May 2009
I just noticed something else that might be the reason for the messages. Under "Profiles\UserProfile_JA2113WF607" there are other ini files. For example there is Ja2_Settings.INI which holds the parameters that you can set in the ingame options menu. If a parameter is missing and the game starts, it will tell you that the parameter is missing and it will use a default value. You can change that parameter later in the game.

So yes, all should work just fine.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Previous Topic: How do you add the "El Dorado" car into the game?
Next Topic: Creating tiles quick and easy
Goto Forum:
  


Current Time: Sun Jan 17 05:05:17 EET 2021

Total time taken to generate the page: 0.01873 seconds