Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #233104] Sun, 13 September 2009 06:52 Go to previous messageGo to next message
battlelore

 
Messages:8
Registered:January 2009
Location: 5

Found 3 things in v3111

1. When I looked at the financial log in the laptop, the first page had the first entry "$45000 deposited" copied all over the place 10 or more times, instead of stuff like "purchased from bobby for $123"
[img=http://img11.imageshack.us/img11/6995/screen002k.jpg]


2. I had Ira in Drassen airport with 20 militia and went with my IMP into the middle sector to kill hostiles and called my militia as reinforcements. Ira was in the center of the map btw. I killed almost all of them, but 1 fled north into the airport sector. I then order my IMP to go to the airport. Then the game lets me place my mercs before the attack.. I can place the IMP in the bottom, but doesn't let me place Ira anywhere. I was thinking about exiting the game and reloading, but got past that by pressing "spread", and both mercs are now at the bottom of the map and i can press "Done" now. So now I have to attack a sector owned by me instead of the enemy attacking it and me defending, who btw is standing in the center of the map.

3. Apparently if you make an IMP with the same nickname as another IMP (imp's profile filename=nickname) you won't be able to load your saves after exiting the game.

[Updated on: Sun, 13 September 2009 23:23] by Moderator

Re: BUGZILLA report all bugs here![message #234340] Sun, 04 October 2009 11:45 Go to previous messageGo to next message
czar1985

 
Messages:5
Registered:September 2009
"MELEE_DAMAGE_MULTIPLIER" does not affect bare hands.
When damge multiplier is high then martial arts skill is useless.
Re: BUGZILLA report all bugs here![message #234345] Sun, 04 October 2009 12:31 Go to previous messageGo to next message
Logisteric

 
Messages:3275
Registered:December 2008
Location: B
battlelore666
3. Apparently if you make an IMP with the same nickname as another IMP (imp's profile filename=nickname) you won't be able to load your saves after exiting the game.

are you kidding? your imp is saved as 'your imp.dat2' when you try to load that game the exe finds 'your imp.dat2' already opened and crashes when trying to load the second of your imps :gaga:
Re: BUGZILLA report all bugs here![message #237656] Sat, 14 November 2009 04:34 Go to previous messageGo to next message
entar

 
Messages:7
Registered:November 2009
battlelore666
Found 3 things in v3111

1. When I looked at the financial log in the laptop, the first page had the first entry "$45000 deposited" copied all over the place 10 or more times, instead of stuff like "purchased from bobby for $123"
[img=http://img11.imageshack.us/img11/6995/screen002k.jpg]




I too had this error, any idea how to patch it? Doen't harm much but it would be good if this can be settled.
Re: BUGZILLA report all bugs here![message #237692] Sat, 14 November 2009 18:06 Go to previous messageGo to next message
Anonymous
I don't think there is a patch up for this. It is a common denominator among most JA 2 modifications.
Re: BUGZILLA report all bugs here![message #238295] Fri, 20 November 2009 17:09 Go to previous messageGo to next message
entar

 
Messages:7
Registered:November 2009
Oh too bad, if there's something that can cure that error, it would be good.
Re: BUGZILLA report all bugs here![message #239669] Wed, 09 December 2009 02:46 Go to previous messageGo to next message
Skrape

 
Messages:28
Registered:October 2009
Location: Germany

Just started a new game to try out some ideas, and this bug happened (as seen in picture). Strange is, i didnt had this before and i didnt changed anything (no updates or similar) except that i installed MP 1.5. JA2 1.13 version is 3111

http://www.babyglck-aus-wiedenbrck.de/images/ja2bug.JPG
Re: BUGZILLA report all bugs here![message #239702] Wed, 09 December 2009 19:39 Go to previous messageGo to next message
Anonymous
Was it just a graphical error or did it affect functionality?
Re: BUGZILLA report all bugs here![message #239746] Thu, 10 December 2009 12:53 Go to previous messageGo to next message
Skrape

 
Messages:28
Registered:October 2009
Location: Germany

Just graphical, when i click this icon it works as it should work
Re: BUGZILLA report all bugs here![message #239785] Thu, 10 December 2009 21:26 Go to previous messageGo to next message
Anonymous
Things happen like that from time to time. No big deal.
Re: BUGZILLA report all bugs here![message #240400] Tue, 22 December 2009 00:14 Go to previous messageGo to next message
Heast

Messages:3
Registered:December 2009
Location: Germany
Hi all,

i
Re: BUGZILLA report all bugs here![message #240748] Tue, 29 December 2009 11:32 Go to previous messageGo to next message
corplen
Messages:1
Registered:December 2009
HI

USING THE LATEST SCI [3287] WHEN I CLICK THE BOBBY RAY SHIPMENT EMAIL THE GAME CRASHES.
THIS ONLY HAPPENS WITH BOBBY RAY SHIPMENT EMAILS ONLY.
I AM USING ONLY 1.13 LATEST WITH NO OTHER MODS.
Re: BUGZILLA report all bugs here![message #240914] Sat, 02 January 2010 19:46 Go to previous messageGo to next message
Panpiper

 
Messages:41
Registered:February 2007
Location: Montreal, Canada
Pitch black map at night.

Sorry if this has been reported. I really do not want to read through 300 posts to see. It could also be the result of a mod I am using as I found the origin of the problem in Ja2_Settings.INI.

I intalled a new clean copy of 1.06, upgraded it to the latest SVN using JA2 1.13 3287 exe SVN@1203 Full.exe, and added 113_possum_dbb_mod_v4 to it. I also added 1.13add_maps but know that this bug was not caused by that.

The bug was that night fighting occurred on an absolutely black map. The only lights were the very few occasional lights that existed on the map. My own mercs and the area around them were pitch black. If they didn't have little name tags over their heads when selected, it would have been absolutely impossible to locate them on the screen. Wearing night vision goggles 4 didn't improve the situation at all. In short any night engagement was severely hampered.

I isolated the cause and found the fix. In Ja2_Settings.INI the setting of TOPTION_MERC_CASTS_LIGHT was defaulting to FALSE with the admonition preceding of: DO NOT CHANGE THESE UNLESS YOU KNOW WHAT YOUR ARE DOING. Well, fortunately I'm not very good at following instructions and I change the setting to TRUE. Now My mercs have light in their immediate vicinity, I can see where they are and see at least a little bit of their immediate vicinity.

Now it might well be that the game interprets this to mean that the enemy can also see my mercs because they are carrying torches. If that is the case, I would suggest that the problem is not allowing the player to see their mercs, the problem is treating these 'merc lights' like real in game lights. The mercs are not in fact walking around with lanterns. They are simply able to discern at least a little bit of their immediate surroundings, even at night, which for the benefit of the player is the ability to actually see the merc and their immediate surroundings. I might suggest as something for a modder to make this 'light' (that is only visible to the player) dependent upon the skill of the merc, whether they have Night Ops as a Skill, and what sort of night vision gear they are wearing.
Re: BUGZILLA report all bugs here![message #241080] Sun, 03 January 2010 23:55 Go to previous messageGo to next message
datakurs

 
Messages:166
Registered:June 2009
Location: Budapest, Hungary
v3287 (+ wf606 maps + Mapupdate 20090909 + HAM_3.6a), and I had not met these before with earlier versions:
- Hans says I can enter to meet Tony but does not step away. Happens almost always, need to detonate the window to get in.
- Sometimes opponent guys in the ring don't move or fight.
- Must be the same bug: beaten opponents don't leave the ring, and until that I can not start the next match. Only re-entering the sector puts the guys to their default places.
- However when I re-enter Spike does not let us in, no matter how high is my leadership.
- After winning the match Darren sometimes wants to give the money to a specific merc. If he/she is not next to him he will not give any money.
- Kyle gives only $60 for the deed instead of 10000. However this amount can be found in the bar, on a chair.

update: the extreme fighting and the Kyle bugs are in v3111, too.

[Updated on: Mon, 04 January 2010 04:35] by Moderator

Re: BUGZILLA report all bugs here![message #242871] Sat, 30 January 2010 10:14 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
ERROR_REPORT
The value [JA2 Game Settings][bLastSavedGameSlot] = "98" in file [Ja2_Settings.INI] is outside the valid range [-1 , 11]. 11 will be used.

help me

[Updated on: Sat, 30 January 2010 14:43] by Moderator

Re: BUGZILLA report all bugs here![message #242990] Mon, 01 February 2010 10:31 Go to previous messageGo to next message
Starwalker

 
Messages:767
Registered:October 2005
Location: Hannover, Germany
Sot
ERROR_REPORT
The value [JA2 Game Settings][bLastSavedGameSlot] = "98" in file [Ja2_Settings.INI] is outside the valid range [-1 , 11]. 11 will be used.

help me

That is just a warning, the game itself set the variable to the correct maximum.
BTW, what does Ja2_Settings.INI belong to, it does not seem to be a regular part of basic 1.13?


Re: BUGZILLA report all bugs here![message #242991] Mon, 01 February 2010 11:01 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
No, this is not just a warning unfortunately - game crashes in Windows. The game crashes even after correcting the value of 98 on the right. Disable Autosave - still fly, but no longer writes crashreport Smile
I'm playing 1.13 (rev 1205)eng + HAM 3.5(eng)
Save: http://slil.ru/28577684

[Updated on: Mon, 01 February 2010 12:08] by Moderator

Re: BUGZILLA report all bugs here![message #243044] Tue, 02 February 2010 16:37 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Is there any news? Who ever tried to understand what is wrong? Smile
Re: BUGZILLA report all bugs here![message #243063] Tue, 02 February 2010 23:09 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
Sot
[...]The game crashes even after correcting the value of 98 on the right.[...]
Corrected it to what? It has to be a value between 0 and 10 (not -1 to 11).

Re: BUGZILLA report all bugs here![message #243066] Tue, 02 February 2010 23:16 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
I do not understand too. The game itself is used to correct the value 98 to any other after the crash, or I corrected manually. But it did not help.
Re: BUGZILLA report all bugs here![message #243069] Tue, 02 February 2010 23:44 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
There are for example these kind code bits
#define NUM_SAVE_GAMES      11
...
BOOLEAN	gbSaveGameArray[ NUM_SAVE_GAMES ];
...
gbSaveGameArray[ gGameSettings.bLastSavedGameSlot ]
You can access the 'gbSaveGameArray' array with values 0 to 10. With all other values there is a good chance that the game will crash. If you have an invalid value in your ini file the game sets it to 11, an invalid value (that should be fixed). Now, if you set a correct value in the ini file and the game still crashes, then it must be something else. Check other log files, vfs_init.log, game_exceptions.log, errors.log, etc.

Re: BUGZILLA report all bugs here![message #243073] Wed, 03 February 2010 00:27 Go to previous messageGo to next message
AdamRadm

 
Messages:18
Registered:January 2010
Location: USA usually
dethica
hi. first post here.
i'm using "JA2 1.13 3111 exe SVN@1183 Full"
and my team of 5 mercs are getting attacked by 60+ enemies (mostly grey soldiers) in the Drassen mine sector, on the second day.


im at this point, killed off about 20 so far (go pistols go!) anyways i keep getting the game crash and i dont know what the trigger is (i mean whats causing the crash so i can fix/avoid it) it happens anywhere from 1-5 min into my save game says somthing about

Quote:
Assertion error Line 1471 of Queencommand.cpp

also some garbage about debug mode and it tries to save the game, then it crashity crashes.


?? Used the search function and no matchs on the forum

on a semi related note, how do i take screenshots, and where are the files stored once i take one?
Re: BUGZILLA report all bugs here![message #243074] Wed, 03 February 2010 01:08 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
AdamRadm
dethica
hi. first post here.
i'm using "JA2 1.13 3111 exe SVN@1183 Full"
and my team of 5 mercs are getting attacked by 60+ enemies (mostly grey soldiers) in the Drassen mine sector, on the second day.


im at this point, killed off about 20 so far (go pistols go!) anyways i keep getting the game crash and i dont know what the trigger is (i mean whats causing the crash so i can fix/avoid it) it happens anywhere from 1-5 min into my save game says somthing about

Quote:
Assertion error Line 1471 of Queencommand.cpp

also some garbage about debug mode and it tries to save the game, then it crashity crashes.
It looks like an enemy group is trying to enter your sector and somehow the determination of the insertion direction fails. This may not be an option, but you could try get out of the sector before the enemy group arrives. Maybe the erroneous code won't be executed then.

Quote:

on a semi related note, how do i take screenshots, and where are the files stored once i take one?
press the 'print' button (above the 'insert' button). You will find the screenshots in you user profile directory (\Profiles\UserProfile_JA2113).

Re: BUGZILLA report all bugs here![message #243091] Wed, 03 February 2010 11:54 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
BirdFlu
There are for example these kind code bits
Now, if you set a correct value in the ini file and the game still crashes, then it must be something else.
Exactly.


All found: game_exceptions.log

*** Mon Feb 01 20:30:02 2010 ***

>>>>>>>>>>>>>>>>>>>>>
========== Mon Feb 01 20:29:41 2010 ==========
File : .\vfs_file_raii.cpp
Line : 11
Location : vfs::COpenReadFile::COpenReadFile

file "SPEECH\029_011.gap" does not exist

<<<<<<<<<<<<<<<<<<<<<

[Updated on: Wed, 03 February 2010 11:54] by Moderator

Re: BUGZILLA report all bugs here![message #243095] Wed, 03 February 2010 15:03 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
Unfortunately, that "error" is not the source of your crash. The game can work without .gap files well enough.

When does then game crash anyway? What would i have to do to reproduce it? What version do you use? What OS? Where have you installed the game? C:\Program Files\... (or similar) or in some other directory? Do you start the game as an administrator?

Re: BUGZILLA report all bugs here![message #243098] Wed, 03 February 2010 15:55 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
By items:

game crash during the course of the enemy
Save: http://slil.ru/28577684
-I play in the 1.13 rev 1205 + HAM 3.5 on rev 3095 + some of their guns and items
additional files (if necessary): http://slil.ru/28589824
configuration INI: http://slil.ru/28589798
-Windows XP
-C: \ Program Files \ Jagged Alliance 2 Gold
-game start in as an administrator
--disable NOD 32 does not help


Thank you in advance for your help and I apologize for my language.

[Updated on: Wed, 03 February 2010 16:41] by Moderator

Re: BUGZILLA report all bugs here![message #243321] Fri, 05 February 2010 14:37 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
There is news? It was possible to reproduce the bug?
Re: BUGZILLA report all bugs here![message #243325] Fri, 05 February 2010 15:08 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
i will look at it soon

Re: BUGZILLA report all bugs here![message #243341] Fri, 05 February 2010 18:58 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
Could you give me your Map\FacilityTypes.xml file?

Re: BUGZILLA report all bugs here![message #243395] Sat, 06 February 2010 12:26 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Always Smile http://slil.ru/28604075
Re: BUGZILLA report all bugs here![message #243405] Sat, 06 February 2010 14:43 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
I guess i should have found out that earlier, but i'm also missing the files "Map\Facilities.xml" and "Map\DynamicRestrictions.xml" (never played HAM).

error when try to start latest 1.13 release[message #243494] Mon, 08 February 2010 01:39 Go to previous messageGo to next message
praashek
Messages:3
Registered:February 2010
Location: Czech Republic
i get this error message http://b0mb.info/images/qj8yvtxfy95gefcn1mh8.jpg when try to start the game (with JA2.exe)

installed on new clear install of Ja2 with 1.07 patch (tried with 1.06 as well) and then copy the files from unpacked JA2 1.13 3287 exe SVN@1203 Full.exe to the folder with the game.
OS XP SP3
old version (2008_04_28_JA2_v1.13_Release_(EN)_[1.0.0.2085].exe) works well

no weird characters in folder names. anyone can help?
Re: error when try to start latest 1.13 release[message #243496] Mon, 08 February 2010 02:28 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
I assume that the install directory contains non-ascii characters. That "bug" was fixed in the multiplayer version, but the patch wasn't integrated into the main branch (yet). What is you install directory?

Another possibility is that you have a modified ini file that contains non-ascii characters and this files is NOT saved using the UTF8 encoding. Do you have the file game_exceptions.log? It could contains more error messages (or not).

Re: error when try to start latest 1.13 release[message #243497] Mon, 08 February 2010 03:17 Go to previous messageGo to next message
praashek
Messages:3
Registered:February 2010
Location: Czech Republic
it crashes when i try to start the game for the first time, so no weird characters should be there in .ini file, install dir is e:\GAMES\JA2_1_13\ but also tried to renamed it to "games/ja2" only but it didnt work as well
Re: error when try to start latest 1.13 release[message #243499] Mon, 08 February 2010 03:20 Go to previous messageGo to next message
praashek
Messages:3
Registered:February 2010
Location: Czech Republic
eh and sorry for double post - no game_exeptions.log appears in my JA2 dir
Re: error when try to start latest 1.13 release[message #243561] Mon, 08 February 2010 22:42 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
What if you try a current Multiplayer version? Does that one work?

You can try this one for example, it's as good as any other MP version.

Re: BUGZILLA report all bugs here![message #244037] Fri, 12 February 2010 17:55 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Did find a bug?
Re: BUGZILLA report all bugs here![message #244074] Sat, 13 February 2010 00:51 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
You hit the maximum number of corpses (= 250). I increased it to 500, so it should work for a while. Here is an unofficial version (HAM 3500), but i'm not sure i used the right codebase. The number should be increased in the main branch anyway.

Re: BUGZILLA report all bugs here![message #244105] Sat, 13 February 2010 16:08 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Thank you for taking the time to my problem. In the near future will try your exe. Can tell who to contact from the coders, that they have made corrections to the new revision?

PS exe not working...
bugreport: http://slil.ru/28642156

I am embarrassed by the fact that your exe - alfa version. I have not included in the INI second and third points (look in bug reports), and the first can not be corrected using the INI editor (look in bug reports).

Here is my old exe: http://slil.ru/28642197

[Updated on: Sat, 13 February 2010 17:05] by Moderator

Re: BUGZILLA report all bugs here![message #244131] Sun, 14 February 2010 02:12 Go to previous messageGo to previous message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
Sot
Thank you for taking the time to my problem. In the near future will try your exe. Can tell who to contact from the coders, that they have made corrections to the new revision?
Headrock is in charge of HAM.


Sot
PS exe not working...
bugreport: http://slil.ru/28642156
That is actually more of a warning, not an error. You should be able to "fix" the problem by entering the correct values in the correct Ja2_Options.ini.

Also, it seems it did indeed used and older codebase. When you start the game an info string appears and says that i was using an alpha version of HAM 3.5. Headrock should be able to release the right version.


Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Thu Jul 02 14:46:32 EEST 2020

Total time taken to generate the page: 0.02073 seconds