Home » MODDING HQ 1.13 » Depri's v1.13 Builds and Packages » Depri's Builds and Packages - Get your combat supplies here!  () 4 Votes
Re: Depri's Builds and Packages - Get your combat supplies here![message #356111 is a reply to message #356110] Thu, 06 December 2018 23:51 Go to previous messageGo to next message
silversurfer

 
Messages:2586
Registered:May 2009
That's a new feature. You can read about it here.
AIMNAS is probably missing the new tags in AmmoTypes.xml.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Depri's Builds and Packages - Get your combat supplies here![message #356113 is a reply to message #356111] Fri, 07 December 2018 03:01 Go to previous messageGo to next message
Dacen
Messages:3
Registered:December 2018
I didn't know about the change in the code, like you said the AIMNAS AmmoTypes.xml still have the old tags.
After a few tests changing the tags in the Bigmaps folder, it's working correctly now.
Thank you!

Re: Depri's Builds and Packages - Get your combat supplies here![message #356118 is a reply to message #356113] Fri, 07 December 2018 15:33 Go to previous messageGo to next message
Penta

 
Messages:64
Registered:May 2008
I feel terrible for asking, but....A new SCI hasn't been released in over a month. Is there an ETA on the next version?
Re: Depri's Builds and Packages - Get your combat supplies here![message #356120 is a reply to message #356118] Fri, 07 December 2018 19:19 Go to previous messageGo to next message
Dacen
Messages:3
Registered:December 2018
I changed the tags for the AIMNAS ammotype file to match the new 1.13 file, there are a handful of ammo types that didnt have a direct correspondance and i dont know what they usually look like so i improvised. Feel free to modify to your liking.

(Still can't post links so change X to H)
Xttp://www.mediafire.com/file/98rtbojat2711qp/AmmoTypes.xml/file

Override the AmmoTypes.xml in ...\Jagged Alliance 2\Data-Bigmaps\TableData\Items
Re: Depri's Builds and Packages - Get your combat supplies here![message #356121 is a reply to message #356120] Fri, 07 December 2018 21:54 Go to previous messageGo to next message
ZedJA2

 
Messages:175
Registered:January 2018
@ Penta

Usually it gets posted during the first or second weekend of the month. I'm waiting also. I figured the holidays probably delayed things a bit.
Re: Depri's Builds and Packages - Get your combat supplies here![message #356262 is a reply to message #311288] Thu, 27 December 2018 20:49 Go to previous messageGo to next message
Kharnivora
Messages:4
Registered:February 2012
Hi,

it appears I´ve found a pretty old bug, at least I remember I had the same issue with Build 7435. I haven´t played any 1.13 for a long time (because of this bug).

I start a new game, recruit some people, save, quit, load ny savegame -> The first merc I recruited (doesn´t matter whether it´s over IMP, AIM or SPECK) has Barry Ungers Face. Everything else remains the same. When this "Barried" merc then sais something on completing an assignment (like training, arriving in a sector, finishing repairs,... ) I get an assertion error. He/she can engage in regular dialogs however.
Assertion Failure [Line 6600 in File Map Screen Interface.cpp] - I can´t find this file or any file with a ccp extension in the game folder.

I´ve tried with build 7609, with the very latest build from this thread (SCI_JA2v1.13_Revision_8633_on_GameDir_2449), and with build SCI_JA2v1.13_Revision_8633_on_GameDir_2449 with the JA2_8645 exe, over an old JA2 CD I still own (checked, it´s 1.03) and over the steam version (store.steampowered.com/app/12380/) which is JA2 Gold 1.12. I´ve installed the full Win 10 compatibility patch from within the docs folder when running Revision 8633.

I´ve tried with both unchanged and extensively modded ini files.

Although I´ve set the option to save on assertion error, I don´t have any speechless

Screenshot:
up.picr.de/34688989qp.png

PS:
I´ve reported the same bug back in 2012 already:
thepit.ja-galaxy-forum.com/index.php?t=msg&goto=299324&#msg_299324

Two more issues:
My desktop flickers through heavily. At first I could fix this by enabling vsync and installing the compatibility patch, but after a few restarts of the computer, it feels like it´s getting worse.

Multiple options in the ini editor do not work. For example the "enemies drop all gear on death". Editing the corresponding .xml file directly is not taking effect.

[Updated on: Thu, 27 December 2018 23:21]

Re: Depri's Builds and Packages - Get your combat supplies here![message #356263 is a reply to message #356262] Thu, 27 December 2018 23:23 Go to previous messageGo to next message
silversurfer

 
Messages:2586
Registered:May 2009
Kharnivora wrote on Thu, 27 December 2018 19:49

Two more issues:
My desktop flickers through heavily. At first I could fix this by enabling vsync and installing the compatibility patch, but after a few restarts of the computer, it feels like it´s getting worse.

That's an issue with Windows 10. I always had it when the browser was "behind" the game.

Kharnivora wrote on Thu, 27 December 2018 19:49

Multiple options in the ini editor do not work. For example the "enemies drop all gear on death". Editing the corresponding .xml file directly is not taking effect.

The JA2_Options.ini parameters only work with the proper exe version. For "DROP_ALL" this is 8610 and higher.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Depri's Builds and Packages - Get your combat supplies here![message #356273 is a reply to message #356263] Fri, 28 December 2018 10:39 Go to previous messageGo to next message
Kharnivora
Messages:4
Registered:February 2012
Well, I´m running build 8633 with exe 8633 or exe 8645. The issue is this:

up.picr.de/34691718kh.png

The value in the .ini editor can not be changed. Changing the value manually in the corresponding .xml file is not taking effect.

[Updated on: Sat, 29 December 2018 13:06]

Re: Depri's Builds and Packages - Get your combat supplies here![message #356298 is a reply to message #356273] Sun, 30 December 2018 17:03 Go to previous messageGo to next message
oluz87

 
Messages:16
Registered:December 2018
hello i have a question i update the german dir with svn but i need a actually german exe can anybody one make for me please
Re: Depri's Builds and Packages - Get your combat supplies here![message #356302 is a reply to message #356298] Mon, 31 December 2018 00:16 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3804
Registered:July 2009
I've updated the Builds section in the opening post, let me know if anything explodes since I didn't test them.



Chat with us!
#bearpit on IRC
Discord
Get your latest 1.13 Builds
(Pls don't use my forum PMs for general game queries)


Re: Depri's Builds and Packages - Get your combat supplies here![message #356303 is a reply to message #356302] Mon, 31 December 2018 01:34 Go to previous messageGo to next message
oluz87

 
Messages:16
Registered:December 2018
works perfect many many thanks you are the best
Re: Depri's Builds and Packages - Get your combat supplies here![message #356344 is a reply to message #356303] Sat, 05 January 2019 09:12 Go to previous messageGo to next message
Applegong

 
Messages:8
Registered:December 2018
Thanks DepressivesBrot, this is an amazing work of getting the SCIs out to make modding the game a breeze. I know this isn't a thread for troubleshooting reports but just to note I used .dll files from 1.1.38 wined3d executable to make the game run normally with Revision 8633.
Re: Depri's Builds and Packages - Get your combat supplies here![message #356362 is a reply to message #356344] Tue, 08 January 2019 12:27 Go to previous messageGo to next message
ZedJA2

 
Messages:175
Registered:January 2018
Ok, good. I was just going to update my reply to Penta and say that it seems the builds have been updated several times since 8633. I guess the directory has stayed the same and you can just update the build, which is just the exe file.
Re: Depri's Builds and Packages - Get your combat supplies here![message #356412 is a reply to message #356362] Mon, 14 January 2019 09:02 Go to previous messageGo to next message
ZedJA2

 
Messages:175
Registered:January 2018
UPDATED: Speck is not bugged, once I just go ahead and move the game time forward on the Strategic Map (I updated this weeks ago, but it seems it did not take, so updated post again)


Upon updating to the 8646 EXE BUILD, on an existing game, I find that Speck in M.E.R.C.'s page is showing his portrait for only a half second and then saying nothing, with the portrait disappearing almost immediately. I'm thinking that perhaps the MERC option may have been moved to another location, and perhaps that is overwriting the current save with the new build for the exe. Or that since I have not yet actually played with the new build beyond checking out the Laptop and the Strategic Map Screen, that perhaps once I have started the time clock forward this may correct itself.

Nonetheless, since I don't have time to do that tonight, I mention my concern that perhaps Speck's MERC comments, when you are at the M.E.R.C. homepage and wait a bit, may be bugged on an existing save, probably from 8633. I'll look into more in the next couple days, worse case by Weds, Thurs on my days off.

[Updated on: Tue, 29 January 2019 07:31]

Re: Depri's Builds and Packages - Get your combat supplies here![message #356429 is a reply to message #311288] Wed, 16 January 2019 13:20 Go to previous messageGo to next message
KittyK
Messages:2
Registered:January 2019
Hey everyone,

First of all, thanks to Depri and all of the others who have put so much effort in creating and maintaining the 1.13 mod!

Sorry for asking stupid noob questions, but I unfortunately am pretty much of a noob when it comes to modding and programming...

I downloaded the current build and extracted it over my JA2 install. So far, it did seem to work well. Now, my questions are:

- What is that Editor I read about? What's the difference between starting the game from the .exe file or the editor? (I'm pretty sure this information is there somewhere around the internet, but I either did not find it or did just not understand what the stuff I read through in the last couple of hours meant)

- After having extracted the mod files, I checked the ReadMe.txt called "download latest ja2.exe" and downloaded the files I found under the link in the doc. Now I see a couple of .exe files: ja2.exe, JA2_8647.exe, JA2_8647_Editor.exe, JA2_8647_UB.exe. While I understand that the last file mentioned should be "unfinished business", I wonder what .exe to use to start the game. If I remember correctly, I read somewhere that one of the .exe files should be deleted or renamed (?) - does that still apply even after having downloaded the most recent copy of the .exe as described at the beginning of this paragraph? (to me it looks as if ja2.exe and JA2_8647.exe were exactly the same files, is that correct?)

- What's the difference between INI Editor.exe and JA2_8647_Editor.exe?

Sorry again for asking stupid questions, I must admit that although I've always been interested in programming, I never managed to find decent "resources for dummies" to start with *sigh*

Thanks so much!
Re: Depri's Builds and Packages - Get your combat supplies here![message #356546 is a reply to message #356429] Wed, 23 January 2019 10:05 Go to previous messageGo to next message
ZedJA2

 
Messages:175
Registered:January 2018
@ KittyK

In my case, when I last downloaded the latest Build, which was about a week ago I suppose, I got JA2_8646.exe. I just renamed that to JA2.exe and used it as such. It really is just the JA2.exe but with the build number so that you can know what you downloaded.

An SCI includes both the latest build for the SCI and the corresponding data changes for the directories.

I don't use the Editor.Exe files, since they aren't kept updated SUPPOSEDLY and so it is more effective in most cases to simply work with Notepad on the various INI and XML files to customize your game.

My guess is that INI Editor.exe and JA2_8647_Editor.exe would just be the latest version of it included in the 8647 build or SCI. You just rename it. But I cannot guarantee I am right about that. It just would fit the same theme.

Myself, I don't follow those old instructions to download the latest JA2 files. That was put in there long ago during the SVN depository days. When you download the Depri SCI or the Builds, you are already doing this, just in a better packaged and labeled form. My guess is that the one labeled JA2.exe was an example of one downloaded by that other method. It is harder to keep track of what is what, and the labels aren't there.

As for the UB etc files, I believe you are correct, but I just play the JA2 latest SCI or Build from the v113 directory or whatever, so I can't speak to that as it has been way, way too long since I did otherwise. My guess is that if you want to play UB but with the latest v113 enhancements, you simply replace the ja2_UB.exe file with the one with the latest build number and so forth, and then use that, from the UB folder. There should be some explanation somewhere, probably in the first post of this thread, explaining much of this, or in the various .txt files somewhere in the download.

[Updated on: Wed, 23 January 2019 10:06]

Re: Depri's Builds and Packages - Get your combat supplies here![message #356658 is a reply to message #356546] Mon, 11 February 2019 16:03 Go to previous messageGo to next message
GASK3T

 
Messages:169
Registered:March 2011
Location: USA
What happened to the TONS OF GUNS option? It used to be if this was on, enemies would drop 100% of their inventory when they died. I really liked that. Made it feel more real. Now only ~25% of the enemies drop some items.
Re: Depri's Builds and Packages - Get your combat supplies here![message #356659 is a reply to message #356658] Mon, 11 February 2019 17:23 Go to previous messageGo to next message
silversurfer

 
Messages:2586
Registered:May 2009
"Tons of Guns" never caused enemies to drop all their gear. "Enemies drop all" was the option to make them drop everything when they die. This was moved from the start screen to Ja2_Options.ini parameter "DROP_ALL".



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Depri's Builds and Packages - Get your combat supplies here![message #356664 is a reply to message #356659] Mon, 11 February 2019 19:37 Go to previous messageGo to next message
GASK3T

 
Messages:169
Registered:March 2011
Location: USA
ahhh awesome, thank you sir~!

Do i need to start a fresh game for it to work now ?

[Updated on: Mon, 11 February 2019 23:39]

Re: Depri's Builds and Packages - Get your combat supplies here![message #356920 is a reply to message #356664] Fri, 08 March 2019 16:34 Go to previous messageGo to next message
Proof
Messages:4
Registered:June 2010
Possibly a newb question but i have the GOG galaxy version of JA2 now. It is 1.12, is this SCI version compatible with it or do i need another version from elsewhere? (JA gold or whatever from Steam?).

thanks for a great community.
Re: Depri's Builds and Packages - Get your combat supplies here![message #356921 is a reply to message #356920] Fri, 08 March 2019 17:01 Go to previous messageGo to next message
silversurfer

 
Messages:2586
Registered:May 2009
JA2 1.12 is the latest update of the base game. Yes, you can install the SCI on top of it.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Depri's Builds and Packages - Get your combat supplies here![message #356971 is a reply to message #356921] Fri, 15 March 2019 17:47 Go to previous messageGo to next message
Rauno
Messages:1
Registered:March 2019
First, thank you guys for keeping this superb mod in work!
Second, i have a questions.

I do remember when i last played years ago, i could change something in INIeditor to have random battles literally with hundreds of enemys, but now i set MAX_NUMBER_ENEMYS_IN_TACTICAL to 100 but there is pretty much every time 18-32 enemys max (i play with expert setting), except those counterattacks (not enough for me happy ).

Talking about depri build 8670
Re: Depri's Builds and Packages - Get your combat supplies here![message #356974 is a reply to message #356971] Sat, 16 March 2019 11:59 Go to previous messageGo to next message
silversurfer

 
Messages:2586
Registered:May 2009
Increased team sizes are not part of the regular SCI. Look over here.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Depri's Builds and Packages - Get your combat supplies here![message #357063 is a reply to message #311288] Wed, 27 March 2019 05:46 Go to previous messageGo to next message
Kitty

 
Messages:69
Registered:October 2017
Location: Germany
I run into problems with newer map-editors. I can't choose the faction (loyalist,kingpin,rebel,etc.). I click the tab and then nothing pops up.

My installation: JA2 then the 113 build above, as described on download page and done for years. Tested with standard maps, no other mods. The games start and are playable without any problems.

I compared my following downloads:

r8673_on_GameDir_2474 - map-editor delivered with doesn't allow to choose faction.

r8665_on_GameDir_2472 - map-editor delivered withdoesn't allow to choose faction.

r8496_on_GameDir_2397 - map-editor delivered with does allow to choose faction.

Has something be changed between 8496 and 8665? I can't read the what it says when started, too fast, but I think those where different versions (years), not sure.

Edit: narrowed it down,

r8517on2400 (15Jan18) the tab in mapeditor works

r8534on2408 (4March18) the tab in mapeditor does nothing

Since they are published here, I thought this to be the right place to report, if this wrong tell me please.


EDIT: For 8683 a fix for this problem is announced.

[Updated on: Sat, 27 July 2019 17:05]




I need more details.

(Didi Hallervorden)
Re: Depri's Builds and Packages - Get your combat supplies here![message #357467 is a reply to message #357063] Fri, 31 May 2019 14:31 Go to previous messageGo to next message
dreamer2008

 
Messages:65
Registered:May 2010
Mild Drop All sounds like an awesome addition, exactly what I needed, thank you.
Re: Depri's Builds and Packages - Get your combat supplies here![message #357726 is a reply to message #357467] Sun, 28 July 2019 23:52 Go to previous messageGo to next message
spirit99

 
Messages:62
Registered:May 2011
Location: Z., Germany
Thx for the awesome work. It's nice to see there is still progress after all that years.
Re: Depri's Builds and Packages - Get your combat supplies here![message #357728 is a reply to message #357726] Mon, 29 July 2019 01:21 Go to previous messageGo to next message
HellsWind

 
Messages:44
Registered:October 2018
Location: Netherlands
Playing SCI_JA2v1.13_Revision_8681_on_GameDir_2476 and getting this error by which I can't continue, because constantly freezing up. Trying a previous Revision to see if that'll help. There is a slight chance that it's an AIMNAS related problem only.

Error:


[80.1224] : ERROR : File : vobject.cpp
Line : 967
Location : BltVideoObjectToBuffer
Video object index is larger than the number of subimages

edit, I am sorry I just realized that I've already played hours of 1.13 vanilla without any sort of bug or crash or freeze so this had to do with AIMNAS but I'm testing now to see what's really going on, far as 'm concerned you can ignore this message.

However I've played another mod in 8681 and had the same freeze but then I can't figure out if it had to do with the SCI of 1.13 or with the mod itself.

It seems like beyond a point there was a loss of compatibility with 1.13 regarding some mods, but can't be sure because haven't played around with a lot of mods and latest SCI releases.

[Updated on: Mon, 29 July 2019 02:23]

Re: Depri's Builds and Packages - Get your combat supplies here![message #357793 is a reply to message #357728] Wed, 07 August 2019 23:23 Go to previous messageGo to next message
KBfore

 
Messages:32
Registered:April 2011
Hi guys. I have a question. Hope this is the correct subforum. I have installed 8684 onto a fresh GOG Ja2. The Ja2 1.1.3 works fine. I was hoping to play Unfinished Business 1.13. However it just crashes when UB.exe is launched. Ive tried to look here for an answer but i am struggling to find what im looking for. I have GOG Unfinished Business(not installed) but i read that wasnt even needed? Is UB 1.13 even working? Can someone help me? I would also like to play wildfire in 1.13 after UB 1.13. So i guess i have the same question aboout wildfire(1.13?)? Thanks so much! thumbs up
Re: Depri's Builds and Packages - Get your combat supplies here![message #357794 is a reply to message #357793] Thu, 08 August 2019 00:34 Go to previous messageGo to next message
Asdow

 
Messages:5
Registered:August 2010
Did you change the VFS_CONFIG_INI definition to the Unfinished Business one in ja2.ini? If not, comment out the original campaign config, and uncomment the UB one, so it's set up like

; JA2 1.13
; VFS_CONFIG_INI = vfs_config.JA2113.ini

; JA2 1.13 - Vanilla (JA2 Classic)
; VFS_CONFIG_INI = vfs_config.JA2Vanilla.ini

; JA2 Unfinished Business 1.13
VFS_CONFIG_INI = vfs_config.UB113.ini

; JA2 Unfinished Business 1.13 - Vanilla (JA2UB Classic)
; VFS_CONFIG_INI = vfs_config.UBVanilla.ini
Re: Depri's Builds and Packages - Get your combat supplies here![message #357795 is a reply to message #357794] Thu, 08 August 2019 01:00 Go to previous messageGo to next message
KBfore

 
Messages:32
Registered:April 2011
Yep! Thanks. Oops. Easy fix! I guess its been a while. Thanks so much!
Re: Depri's Builds and Packages - Get your combat supplies here![message #357920 is a reply to message #311288] Mon, 19 August 2019 03:02 Go to previous messageGo to next message
Ableton

 
Messages:10
Registered:June 2017
Location: Spain
Its been a while, last I played was 8548 and there seems to be missing options in starting a new game (i found enemies drop all option in the ini) and Im wondering where they went.

The thing that buggs me the most is the new cursor and I cant for the life of me find the setting for it. It kinda looks like the vanilla one, is this normal? I like the NCTH, and I kinda feel like im on OCTH.

For example, the one I remember had the "ammo belt" graphic for autofire and an aperture, while this one has a bar on top an numbers for the auto.
Re: Depri's Builds and Packages - Get your combat supplies here![message #357921 is a reply to message #357920] Mon, 19 August 2019 03:06 Go to previous messageGo to next message
sevenfm

 
Messages:1923
Registered:December 2012
Location: Soviet Russia
This may help:
http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=23855



7609+fix | 7609+AI (r1136) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Depri's Builds and Packages - Get your combat supplies here![message #357922 is a reply to message #357921] Mon, 19 August 2019 11:26 Go to previous message
Ableton

 
Messages:10
Registered:June 2017
Location: Spain
Yeah I´m an idiot alright angry

I could have sworn I searched for the NCTH string in the options.ini, but sure enough, when I actually did, it was there.

Thanks for your help angel
Goto Forum:
  


Current Time: Fri Aug 23 14:09:45 EEST 2019

Total time taken to generate the page: 0.02959 seconds