Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » JA2 Renegade Republik » New beta, known issues!
Re: New beta, known issues![message #208772] Fri, 13 February 2009 18:50 Go to previous messageGo to next message
Nosko

 
Messages:15
Registered:May 2008
Location: Slovenia
and what, start playing again from day 1? Wink

[Updated on: Fri, 13 February 2009 18:51] by Moderator

Re: New beta, known issues![message #208817] Sat, 14 February 2009 19:22 Go to previous messageGo to next message
herb

 
Messages:422
Registered:September 2007
Location: Slovenija
Nosko

Lep pozdrav!

To je se vedno beta verzija.


few phrases between mates...
Re: New beta, known issues![message #208878] Mon, 16 February 2009 00:35 Go to previous messageGo to next message
Nosko

 
Messages:15
Registered:May 2008
Location: Slovenia
Aja sj res Smile sm mislu, da ni vec, ko je bla enkrat 2007 prva objava Very Happy

LP

[Updated on: Mon, 16 February 2009 00:35] by Moderator

Re: New beta, known issues![message #211873] Thu, 02 April 2009 03:20 Go to previous messageGo to next message
Hieronymos

 
Messages:26
Registered:December 2007
Nosko: don't train 100% of militia in any city sector to veteran (dark blue), or game will lock frequently.
Re: New beta, known issues![message #211885] Thu, 02 April 2009 08:49 Go to previous messageGo to next message
usrbid

 
Messages:1580
Registered:December 2008
I am playing SpaceViking's Many Mercs Mod ja2_release_SV_B005 which is based on version v1.13 2296 I believe and didn't have problems with elite (dark blue) milita at 100%.

Only sector with looong delays is Alma shooting range (top left Alma sector), and delay happens after explosion.


Re: New beta, known issues![message #213026] Mon, 13 April 2009 08:09 Go to previous messageGo to next message
musky420
Messages:3
Registered:March 2009
Hello, I seem to be havnig a problem in sector d5 when trying to bribe "buster bruiser" to let me into the club... no matter how much money i offer him he says " what i need is money not that crap" any ideas?
Re: New beta, known issues![message #215523] Wed, 06 May 2009 12:25 Go to previous messageGo to next message
Ramirez

 
Messages:85
Registered:January 2004
Location: M
Hello,

thought I'd give this mod a shot. Created new folder named renegade, copied my basic installation with SVN-updated data and data-1.13 into it. Then unpacked mod and all-in-one-patch into it.

Unfortunately I get a message 'cannot init FONT file FONTS\CLOCKFONT.sti'.

I searched the web for this file, found one and copied it into that folder, but message still appears Sad.

Any ideas?

Greetz
Re: New beta, known issues![message #215535] Wed, 06 May 2009 13:50 Go to previous messageGo to next message
lockie

 
Messages:3968
Registered:February 2006
Location: Scotland
Quote:
FONTS\CLOCKFONT.sti'.


Think you should be able to copy / paste from another JA installation .


Re: New beta, known issues![message #215549] Wed, 06 May 2009 14:41 Go to previous messageGo to next message
Ramirez

 
Messages:85
Registered:January 2004
Location: M
@lockie - just checked. Odd, there is no such file in any other installation?? They do start properly. Maybe someone would be so kind and send me his via email? Contact me through PM, then I'll give the address.

edit: New page: The requested file is CLOCKFONT.sti

[Updated on: Wed, 06 May 2009 14:42] by Moderator

Re: New beta, known issues![message #215552] Wed, 06 May 2009 14:59 Go to previous messageGo to next message
Native_Elder

 
Messages:58
Registered:April 2009
it's a typical installation issue.

sometimes installs of ja2 or ja2 mods are faulty insofar as the game can't read fonts.slf and thus reports some or all font files as missing

a popular way to fix this is to extract the contents of fonts.slf into ja2/data/fonts folder (yes, this folder may have to be created first). you can use slf explore for such, or other tools that are around
Re: New beta, known issues![message #215577] Wed, 06 May 2009 16:53 Go to previous messageGo to next message
Ramirez

 
Messages:85
Registered:January 2004
Location: M
Thx, Native. That problem is solved but now I'm getting a Runtime Error. "Problem initializing Animation Profiles" - AARGH.


Edit: Finally I got it running. Fresh installation and then a hand to hand folder copy made it work. Hope the mod is worth the effort Wink.

[Updated on: Thu, 07 May 2009 11:52] by Moderator

Re: New beta, known issues![message #227396] Thu, 16 July 2009 08:00 Go to previous messageGo to next message
cubemonkey
Messages:3
Registered:July 2009
Ok here's my problem, I just installed RR after playing through plain 1.13 and UC (both excellent). Anyway the game CTD's whenever I try to create an IMP or hire a merc,if I selected New Inventory option. I have tried ja2_RR_2322 and RR_ja2_2124 exe's and get the same issue with both. I have 2085 version of 1.13 installed to 1.12 gold and have installed RR and all in one patch.

I saw this issue mentioned in previous posts, but the poster decided to play using old inv and didnt follow up. I would really like to play with new inv if possible. Any ideas?

EDIT:Just wanted to add that the patch Lockie sent me worked, thanks Lockie!

[Updated on: Sun, 19 July 2009 18:50] by Moderator

Re: New beta, known issues![message #227423] Thu, 16 July 2009 12:23 Go to previous messageGo to next message
lockie

 
Messages:3968
Registered:February 2006
Location: Scotland
NIV should work as there was a patch for installing . Umm , I'll look tonight at my install and get back .


EDIT : yup , there is an RR to NIV patch , though the link seems to be down , if you can't find it anywhere pm me and I'll send out to you .

[Updated on: Thu, 16 July 2009 21:19] by Moderator



Re: New beta, known issues![message #230266] Mon, 03 August 2009 04:04 Go to previous messageGo to next message
cubemonkey
Messages:3
Registered:July 2009
OK has anyone come up with a fix for the bug with explosions? Where when certain explosion animations occur, you get a message that says cannot open .pcx file or some such and a prompt to press esc to exit.

This happens to me everytime the bad guys lob a mortar round. It's also kept me from using mortars for my mercs, which sucks because I love indirect fire weapons Smile

EDIT: Ok, thanks to Scorpion's advice, I reinstalled the allinone patch and that seems to have done the trick. Thanks Scorpion.

[Updated on: Mon, 10 August 2009 17:33] by Moderator

Re: New beta, known issues![message #231660] Tue, 25 August 2009 18:53 Go to previous messageGo to next message
marekzgdanska
Messages:9
Registered:November 2003
Location: New York, NY
Hello,

I am trying to run RR with 1.13 version 3111. RR actually runs fine (so far) but it seems that I am missing some features of 1.13, such as the Enhanced Description Box.

Has anyone else encountered/solved this problem?




Re: New beta, known issues![message #231663] Tue, 25 August 2009 19:50 Go to previous messageGo to next message
lockie

 
Messages:3968
Registered:February 2006
Location: Scotland
http://www.bookgallery.co.il/JA2PublicPosts/DescBox.asp

Scorpion didn't include EDB in RR , so if you wish to try for an install , the link is above . Have a copy of RR made just incase this causes CTD's .


Re: New beta, known issues![message #231685] Tue, 25 August 2009 23:23 Go to previous messageGo to next message
marekzgdanska
Messages:9
Registered:November 2003
Location: New York, NY
Thank you for the response. I actually did try to include the files from the website you referenced, but this produced no result. I'm guessing it's because even if I copy the files to the RR folder, the executable still doesn't use them. I guess I'll just play without the enhancements.
Re: New beta, known issues![message #231688] Tue, 25 August 2009 23:49 Go to previous messageGo to next message
lockie

 
Messages:3968
Registered:February 2006
Location: Scotland
Did you read the threads ? I thought it could be easily added in , hasn't got an exe . I'm pretty sure... hmmmmm , guess I should go check , or ask the Master , Headrock .


http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=195362&page=9#Post195362
Link to thread .

[Updated on: Tue, 25 August 2009 23:54] by Moderator



Re: New beta, known issues![message #231692] Wed, 26 August 2009 00:46 Go to previous messageGo to next message
marekzgdanska
Messages:9
Registered:November 2003
Location: New York, NY
I was using EDB version 1.3, from the website. It does come with its own JA2 exe file. However, RR needs to be played with a different .exe file that doesn't seem to take advantage of EDB.



Re: New beta, known issues![message #231713] Wed, 26 August 2009 10:50 Go to previous messageGo to next message
lockie

 
Messages:3968
Registered:February 2006
Location: Scotland
In fact , there's very little chance of this ever being implemented in either RR or vengeance , it seems . Oh well .


Re: New beta, known issues![message #246727] Thu, 11 March 2010 12:55 Go to previous messageGo to next message
luk3Z

 
Messages:22
Registered:December 2006
Location: Poland
In my old save I had the situation where Skyrider hang up between 2 sectors and don't move anymore Very Happy
Re: New beta, known issues![message #247988] Sun, 28 March 2010 05:35 Go to previous messageGo to next message
Hawkeye

 
Messages:1653
Registered:October 2005
Location: Australia
Don't know if anyone is still really supporting this mod, but came across a weird glitch last night. Was walking around E4 - Hills and half of my Mercs seem to freeze up while crossing the river. They stopped mid animation and I couldn't select or move them afterward, other Mercs carried on though to the other side. I switch to the map and then got back into combat mode, and was able to reselect and move mercs, but strangely enough had the same glitch with other mercs on the other side of the river.

Wasn't a huge issue a save and then reload seemed to fix it.

Never came across anything like this before, but thought someone may be interested. I'm playing Beta 17.


Re: New beta, known issues![message #249863] Thu, 22 April 2010 09:50 Go to previous messageGo to next message
Hawkeye

 
Messages:1653
Registered:October 2005
Location: Australia
Another bug, arriving at Batumi I3, during a battle I threw a grenade up on that little rooftop alcove in the NE part of the sector, when I did a character called Yeung showed his disdain and said something about destiny, turns out throwing this grenade made Yeung consider it an attack even though he was waiting way down in the SE part of the sector. Hank and Mr Wong also weren't pleased and Yeung proceeded to attack my team.

I knew this seemed a bit suss so replayed, and found out all three characters were part of a quest, a quest I would've missed out on if I hadn't replayed.


Re: New beta, known issues![message #264479] Fri, 08 October 2010 03:37 Go to previous messageGo to next message
Hawkeye

 
Messages:1653
Registered:October 2005
Location: Australia
Still plugging along here in Russia, and still having fun. Came across a very weird set of what I presume is a bug.

After releasing and following Thug to I-12 with Avi, I followed him to the diamonds and attempted to grab a handful from one of the chests. When doing so a window opened, like the one you get when trading with someone but this featured Avi and the four diamonds were already in the trading slots at the bottom, marked with red crossed out circles. Avi then said 'Nice fire miss, nice miss fire' or something like that, and then said 'Bummer looks like my lungs are gone' when selecting other objects. Thug seemed very repetitive with his responses also, and it seemed there was no difference with his answers in either 'friendly' or 'direct.'

Don't know if anyone else has had this happen, but seemed very strange, didn't seem fatal to the game mind you, so I carried on playing.


Re: New beta, known issues![message #311804] Mon, 05 November 2012 17:43 Go to previous messageGo to next message
Crim
Messages:1
Registered:November 2012
No replies in two years, huh? Still trying to find an unbroken and clear download and if it merges with 1.13...
Re: New beta, known issues![message #311853] Wed, 07 November 2012 02:06 Go to previous messageGo to next message
Hawkeye

 
Messages:1653
Registered:October 2005
Location: Australia
Renegade was developed years ago, and did work once with a very older version of 1.13, but has it's fair share of bugs. You can still download it from Kermi's folder here...

http://kermi.pp.fi/JA_2/Mods_v1.13/Renegade_Republic/





Re: New beta, known issues![message #326471] Fri, 11 October 2013 09:36 Go to previous messageGo to next message
mor

 
Messages:13
Registered:October 2013
So I suppose this several years old beta is dead. It might be a good idea to move it from the finished mods list.
Re: New beta, known issues![message #326496] Fri, 11 October 2013 18:37 Go to previous messageGo to next message
lockie

 
Messages:3968
Registered:February 2006
Location: Scotland
ALL the mods are , in effect , Beta !


Re: New beta, known issues![message #328141] Thu, 14 November 2013 12:31 Go to previous messageGo to next message
niculinux

 
Messages:86
Registered:January 2012
Location: Italy
Since it's an aged mod, I'd recommed to play it with the 1.13 2085 build, you can get it at kerm'is archive:

http://kermi.pp.fi/JA_2/v1.13_Releases/Official/English/v208 5/

Anyway dont't know if usin updates provided here may break the mod :roulette:

[Updated on: Tue, 13 January 2015 21:29] by Moderator

Re: New beta, known issues![message #334986] Thu, 14 August 2014 11:35 Go to previous message
sevenfm

 
Messages:1344
Registered:December 2012
Location: Under the Mountain
Merc/NPC speech slightly improved - normalized sound level, removed some noise. Also converted most of the files to .ogg format to save some space.
https://www.dropbox.com/s/u6ynjhbvcgcbi0f/RR_speech_en.7z
Note: backup and delete BattleSNDS, Speech and NPC_Speech dirs in your Data-Renegade folder first, then unpack this, or you will probably hear original wav files instead of new ogg.

Fixed bug with EnemyGunChoices.xml, that was introduced in allinone patch - at certain progress level the number of choices was greater than actual number of supplied items, that most likely caused crash at the start of the battle.
https://www.dropbox.com/s/7dsijkm7x8z4gfy/EnemyGunChoices.xml

Fixed MovementCosts.xml (mismatching opposite directions)
Note: 2085 exe will run even with wrong movement costs, but having them fixed is better, also it will be needed if someone will try to port this mod to 4870 or recent revisions
https://www.dropbox.com/s/ejg9irjvxfpcjfp/MovementCosts.xml?dl=0

Great mod, best use with 2124 exe and allinone patch installed, NIV on.
Nearly no bugs apart from very few quest/script related issues.

[Updated on: Mon, 27 October 2014 19:57] by Moderator



Previous Topic: quests clean up
Next Topic: Installing RR ["Allinone" - Single Click Installer]
Goto Forum:
  


Current Time: Thu Oct 19 20:54:48 EEST 2017

Total time taken to generate the page: 0.01660 seconds