Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #244132] Sun, 14 February 2010 02:39 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Sorry, I put it wrong ... exe works, but gives ERROR_REPORT ...
Furthermore.
The fact is that in my INI to point BULLET_HIDE_INTENSITY is set to Current Value: 100, which can not be changed with an editor (and for some reason, indicated ERROR_REPORT you select FALSE).

Paragraph LIMITED_SUPRESSION_AP_LOSS_PER_ATTACK and paragraph LIMITED_SUPRESSION_AP_LOSS_PER_TURN in my INI absent.
Re: BUGZILLA report all bugs here![message #244134] Sun, 14 February 2010 02:58 Go to previous messageGo to next message
BirdFlu

 
Messages:444
Registered:September 2007
Location: Lampukistan
You can set/add the values in the ini file manually by opening it with a text editor. But anyway, i used an alpha version of HAM and the values of some options probably changed in the following versions. You can ask headrock if he can increase the number of corpses in his exe files.

Re: BUGZILLA report all bugs here![message #244159] Sun, 14 February 2010 15:05 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Ok. Thanks again for your help.
Re: BUGZILLA report all bugs here![message #244391] Tue, 16 February 2010 23:56 Go to previous messageGo to next message
RoWa21

 
Messages:2002
Registered:October 2005
Location: Austria
Sot

The fact is that in my INI to point BULLET_HIDE_INTENSITY is set to Current Value: 100, which can not be changed with an editor (and for some reason, indicated ERROR_REPORT you select FALSE).


The INI-Editor does not support the new HAM properties yet. After HAM 3.6 is included in main 1.13 source code, I will alter the INI-Editor to work with all the new HAM properties. Meanwile you could just open the INI-File with a text editor and edit the file there instead of using the INI-Editor.


Re: BUGZILLA report all bugs here![message #245275] Thu, 25 February 2010 10:06 Go to previous messageGo to next message
Kaerar

 
Messages:2047
Registered:January 2003
Location: Australia :D
Just got this crash when I shot Grunty in the back of the head testing out a new UI animation. The two STI's are the same length so shouldn't cause this crash.

http://www.wmwiki.com/hosted/ja2/Web%20Previews/murdercrash.png

Solved. DON'T put p_dead.sti or p_close.sti in root Data\Interface folder as well as the override folders Wink

Ok update its still occuring if I kill my mercs (testing still). Reproduce-able but seems a tad random on cause conditions.

[Updated on: Thu, 25 February 2010 14:32] by Moderator



Re: BUGZILLA report all bugs here![message #246737] Thu, 11 March 2010 15:12 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
Catch a bug
http://imagepost.ru/?v=72/TYkajNO.jpg

REV 1214 (RUS rev3383)

[Updated on: Thu, 11 March 2010 15:16] by Moderator

Re: BUGZILLA report all bugs here![message #246747] Thu, 11 March 2010 17:19 Go to previous messageGo to next message
Headrock

 
Messages:1774
Registered:March 2006
Location: Jerusalem
LOL @ Cigara!!!


Re: BUGZILLA report all bugs here![message #246754] Thu, 11 March 2010 19:23 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
?
Re: BUGZILLA report all bugs here![message #246904] Sat, 13 March 2010 10:22 Go to previous messageGo to next message
usrbid

 
Messages:1542
Registered:December 2008
Hi Sot, I think he means your IMP name Сигара.

[Updated on: Sat, 13 March 2010 10:23] by Moderator



Re: BUGZILLA report all bugs here![message #246919] Sat, 13 March 2010 14:08 Go to previous messageGo to next message
Headrock

 
Messages:1774
Registered:March 2006
Location: Jerusalem
Actually it's not an IMP, it's Stogie. Most of the characters have completely different nicknames in that Russian version (as can be seen on the merc list)


Re: BUGZILLA report all bugs here![message #246954] Sat, 13 March 2010 20:28 Go to previous messageGo to next message
Anonymous
Translation please.
Re: BUGZILLA report all bugs here![message #247016] Sun, 14 March 2010 18:35 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
And then a Cigar? My IMP name is Kulibin Smile I'm talking about the error - Assertion Failure [Line 1212 in file. \ ArmsDealerInvInit.cpp]

[Updated on: Sun, 14 March 2010 18:43] by Moderator

Re: BUGZILLA report all bugs here![message #247017] Sun, 14 March 2010 18:49 Go to previous messageGo to next message
Headrock

 
Messages:1774
Registered:March 2006
Location: Jerusalem
Something's being done wrong when a shopkeeper is trying to order new items at midnight. I'm unfamiliar with how the system works, but I might be able to figure it out. It could take a while though.


Re: BUGZILLA report all bugs here![message #247018] Sun, 14 March 2010 19:27 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
At midnight? But the game crush at 8:55.

This save game, may be useful http://slil.ru/28793694

Debug autosave http://slil.ru/28793700

[Updated on: Sun, 14 March 2010 19:45] by Moderator

Re: BUGZILLA report all bugs here![message #247022] Sun, 14 March 2010 19:56 Go to previous messageGo to next message
Headrock

 
Messages:1774
Registered:March 2006
Location: Jerusalem
Dunno, the function is named "DAILY", and those generally run at midnight. I'll do a more thorough check when I get home.


Re: BUGZILLA report all bugs here![message #247186] Wed, 17 March 2010 01:40 Go to previous messageGo to next message
Sot

 
Messages:86
Registered:April 2009
to Headrock
Apparently you were right about the sellers. I reduced the count of some items (I previously added to the game) and the game did not crash.

Question. Apparently there is a maximum amount of all items are available from vendors (in particular to Bobby Ray )...? Is it possible to increase it?

[Updated on: Wed, 17 March 2010 18:32] by Moderator

Re: BUGZILLA report all bugs here![message #247447] Sun, 21 March 2010 19:05 Go to previous messageGo to next message
pambos

 
Messages:14
Registered:July 2005
revision 1215

bug one :

\data 1.13 \ja2_options.ini

MELEE_DAMAGE_MODIFIER = 100

for some reason it affect gun damage

bug two:

I recall that when you trained civilians in city and you sleep and wake up the time used to count .it does not anymore



edit : spelling

[Updated on: Sun, 21 March 2010 19:08] by Moderator

Re: BUGZILLA report all bugs here![message #247527] Mon, 22 March 2010 23:25 Go to previous messageGo to next message
clbg

 
Messages:35
Registered:February 2007
Location: Moscow, Russia
Can somebody confirm that flashbang grenades really work? It seems for me, that they dont work properly (only stun damage, no eye blind). Tried several latest builds.

Edit: Shame to me. Solved.

[Updated on: Tue, 23 March 2010 02:44] by Moderator

Re: BUGZILLA report all bugs here![message #247610] Tue, 23 March 2010 18:14 Go to previous messageGo to next message
Ormus n2o

 
Messages:31
Registered:March 2010
Location: Poland; Wielkopolska; Pi&...
http://img232.imageshack.us/img232/1520/screenshot007fl.jpg

It happends before but never with weapons. I think this is conected with using CTRL + SHIFT + M (In Tactical Map, Merges all mergable items while stacking and sorting. This means medkits, toolkits, canteens, gas cans, alcohol, first aid kits, ammo). It happends with repair kits and camo kits.

@Edit.
Found another bug.
http://img683.imageshack.us/img683/3301/screenshot008z.jpg
Helicopter disappear lol. I don't know what to say.
Helicopter has arrived to sector XX ...

[Updated on: Tue, 23 March 2010 19:23] by Moderator

Re: BUGZILLA report all bugs here![message #247715] Wed, 24 March 2010 22:31 Go to previous messageGo to next message
Faithless

 
Messages:442
Registered:October 2009
Location: The safe end of the barre...
While trying to debug my mod I stumbled into a 1.13 bug.
It has nothing to do with my mod because it also happens with the default 1.13 exe.
Basically that leaves my install at SVN revision 3320, without anything else.

Sequence of events, 100% reproducible :
  • Load save.
  • Speed up till alma lower left gets invaded.
  • Load the map.
  • Load the same save again.
  • Push the down arrow to zoom in on the map before the invasion.
The game will now CTD because it tries to access an empty ButtonList when trying to update the interface panels.
Can't really find the cause myself, I've never seen this part of the code before.

Savegame and ini's

[Updated on: Wed, 24 March 2010 22:31] by Moderator

Re: BUGZILLA report all bugs here![message #248005] Sun, 28 March 2010 17:32 Go to previous messageGo to next message
Buggler

 
Messages:208
Registered:November 2009
Minor Lockpicking Bug since JA2 Gold 1.12

'Lockpicking' (both real-time & turn-based mode) increases energy(+2) instead of sapping it off(-2).
'Kicking' & 'Using Crowbar' worked as advertised.

To reproduce: Any locked door. (E locked room in e sector west of Drassen Airport is e 'nearest' testing ground that I can think of)

Thanks in advance if committing e fix to SVN. Smile

Build: JA2 1.13 pure B3358 SVN1215
Re: BUGZILLA report all bugs here![message #248021] Sun, 28 March 2010 21:43 Go to previous messageGo to next message
Anonymous
@Buggler

Does it occur every attempt even if the attempt is a failed lock pick?

or

Does it occur after successful lock pick?
Re: BUGZILLA report all bugs here![message #248055] Mon, 29 March 2010 04:46 Go to previous messageGo to next message
Buggler

 
Messages:208
Registered:November 2009
@taoteching
It applies to all cases of lockpicking (both failed & successful attempt). FYI, locked chests also have e same bug.

So my hunch will b that e modifier sign for lockpicking code is mistakenly coded as '+' instead of '-' for the energy level.
Re: BUGZILLA report all bugs here![message #248056] Mon, 29 March 2010 04:52 Go to previous messageGo to next message
Anonymous
Very weird...... :et5:
Re: BUGZILLA report all bugs here![message #249584] Sat, 17 April 2010 23:06 Go to previous messageGo to next message
genzo
Messages:1
Registered:April 2010
I installed JA2 v1.13 using the "JA2 1.13 3358 exe SVN@1220 Full.exe" file.

when I try to attack Drassen from the North the game crashes with the following error (I think somebody had a similar issue time ago in a different location)
http://i39.tinypic.com/fa7vx4.jpg

no debug save can be created.

I tried to reload the game from different save files but nothing to do, always the same crash.

is it a bug or something that can be corrected via configuration?

thanks
Re: BUGZILLA report all bugs here![message #251010] Thu, 06 May 2010 10:35 Go to previous messageGo to next message
Beka

 
Messages:90
Registered:November 2009
Location: Vault 13
V.3358 German (language probably won't matter)

Problem with the INI setting preventing civilians from becoming hostile:

CAN_TRUE_CIVILIANS_BECOME_HOSTILE = FALSE

It's weird when dealing with Doreen: After talking her out of exploiting the kid she walks off. This is in my usual games the moment to attack her to get loyality increase for both talking and killing.
With this INI setting she won't enter combat mode while in her walking sequence and thus can't be hit.
This is probably not a bug but anyway an issue to fix?

-Beka
Re: BUGZILLA report all bugs here![message #251011] Thu, 06 May 2010 10:47 Go to previous messageGo to next message
Logisteric

 
Messages:3294
Registered:December 2008
Location: B
you are wrong - that could happen in vanilla - it's not related to ham - i had to run after her to shoot her years ago


... and so what loyality is easy in 1.13
Re: BUGZILLA report all bugs here![message #251012] Thu, 06 May 2010 10:54 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1487
Registered:March 2009
Location: Broadwurschd-City
she cant walk away since she always is surrounded by mercs.

btw the time she is polished off I normaly do have allready 100%
Re: BUGZILLA report all bugs here![message #251013] Thu, 06 May 2010 11:01 Go to previous messageGo to next message
Beka

 
Messages:90
Registered:November 2009
Location: Vault 13
Okay, I guess My description needs to be more precise.

In Vanilla JA2 she would also walk off once we've talked her out of her evil doings - but when shooting at her while she's walking away she would call us an idiot an enter combat mode.

Now, she walks away - but when shooting her she won't say anything and just continue her slow escape. No combat mode.

bla, bla... loyality doesn't matter... and how am I supposed to surround her with just three mercs around?

-Beka
Re: BUGZILLA report all bugs here![message #251014] Thu, 06 May 2010 12:13 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1487
Registered:March 2009
Location: Broadwurschd-City
I spare her 'till I have enough mercs :nerd:

The reason why I suround her is, that sometimes she behaved in vanilla exactly as you desripted for Your current game.

But, nowadays she alsways behaves so (btw Brenda, too)

:goggle:
Re: BUGZILLA report all bugs here![message #251015] Thu, 06 May 2010 13:17 Go to previous messageGo to next message
Beka

 
Messages:90
Registered:November 2009
Location: Vault 13
I also managed to do it with my few mercs:
after talking to her she tried to walk away but I just fired a few rounds behind her. Good thing I didnt hit one of the kids by accident. One hit was enough to make her fall to the ground as good as dead (Glaser ammo). Then I could kill her like usual and get the merc's comment.

-Beka
Re: BUGZILLA report all bugs here![message #251156] Sat, 08 May 2010 20:39 Go to previous messageGo to next message
Beka

 
Messages:90
Registered:November 2009
Location: Vault 13
Okay, don't know if this's actually a bug:

In the latest version I have trouble with training militia in other sectors than those where you could train in the original game. I imported my modified cities.xml from my old 1.13-install to the newest one and all of a sudden militias can only be trained in "old" sectors.

Is it a bug? Anyone els having trouble like this?

-Beka
Re: BUGZILLA report all bugs here![message #251159] Sat, 08 May 2010 20:55 Go to previous messageGo to next message
Wil473

 
Messages:2842
Registered:September 2004
Location: Canada
Do the sectors you want to train in have a facility in it that allows militia training? The current SVN has a new facilities feature (with its own XML).


Re: BUGZILLA report all bugs here![message #251164] Sat, 08 May 2010 22:15 Go to previous messageGo to next message
Beka

 
Messages:90
Registered:November 2009
Location: Vault 13
Okay, seems like I was caught by this new facility feature. Now everything is working right. Thanks mate!
Re: BUGZILLA report all bugs here![message #254184] Thu, 17 June 2010 21:30 Go to previous messageGo to next message
Airbus

 
Messages:5
Registered:June 2010
Location: Russia, Moscow

In version 3478, in Co-op multiplayer game I received stable "clock" while merc was interrupted by enemy.

Also, randomly one of clients became inadequate. It refused to respond to "L" pressing (so I had to turn mercs via interface). It refused to move screen when mouse pointer was at the edge of screen. It also refused to choose mercs by clicking on their portraits (I had to choose them on tactical screen, by clicking on their figures). And, best of all, mercs became to move backwards... =)
Re: BUGZILLA report all bugs here![message #254273] Fri, 18 June 2010 21:24 Go to previous messageGo to next message
Airbus

 
Messages:5
Registered:June 2010
Location: Russia, Moscow

Still playing v.3478. Got two falls of the game.

The first one was during assault on east SAM, and I don't know why it felt. I load quicksave and move one merc to another tile, and then continue playing as if nothing had happened.
The second one was when I came to the north-west sector of Cambria, placed mercs and clicked "Ready". As it was in first time, I load quicksave and do the same, except reloading weapons. This helped me. Smile

Maybe I have crashlogs for this falls, but I don't know where they are, and I am writing from another computer. By the way, where JA2 v1.13 place crashlogs?
Re: BUGZILLA report all bugs here![message #259705] Tue, 17 August 2010 17:17 Go to previous messageGo to next message
bbm
Messages:1
Registered:August 2010
Hi,

this has probably been reported already as you have a lively community here indeed but i can't help but vent my frustration over this. I was denfending Drassen mine with my three mercs against some 97 invaders when all of a sudden this bad boy pops up:

http://dc179.4shared.com/img/362978017/6b7c85ae/s7/Image1.png

This is particulary nasty as I was playing in Iron Man Mode. Can anyone tell me what might be causing this? I'm not an expert on these cryptic messages. Maybe disabling a line in a .ini might help? Here is the savegame:

Link to Savegame 97

I patched the english versio of the game from 1.02 to 1.06 and the applied "JA2 1.13 3356 exe SVN@1227 Full". I'm using XP x86 SP3. Hope someone can shed some light on this issue. Thanks!
Re: BUGZILLA report all bugs here![message #259709] Tue, 17 August 2010 18:21 Go to previous messageGo to next message
RoWa21

 
Messages:2002
Registered:October 2005
Location: Austria
It has nothing to do with an INI property, I will try to debug the code and see what causes the problem.


Re: BUGZILLA report all bugs here![message #260516] Tue, 24 August 2010 23:15 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Hi, I ran into a bug with the helicopter:
I attack a sector (squad 1), while at the same time a second squad lingers already above the sector in the helicopter.

1. If I unload the heli-squad before the attack begins, they stay in the enemy-occupied sector without starting a fight, which has always been hat way. But if first squad enters the sector, the formerly-airborne squad can not be placed on any edge of the map, therefore the game has to be manually exited. 'Clear' or 'Spread' causes a debug-message.

2. If I proceed with the attack, I can place the second squad on the same edge as the first one, which would be fine. The battle starts, but the second squad is not placed on the map. The sound of people moving is played, even in turn-based mode.
I can go to strategic view, unload squad the heli-squad and enter tactical again. The new squad is placed where it should be, except for one soldier (my Imp 'Shred' in this case) that is placed on another edge of the map (which is where the heli entered the sector from). If she was with the others, I'd be happy with this Smile

I played this with revision 3585 with NAS 0.61b + STOMP 1.20, though I guess it doesn't have to do with the mods 8being a heli/merc-placement-issue and all).

Savegame from before the incident (just continue, skip the waiting for another squad):

http://www.mediafire.com/file/absaajkbvfdat4y/SaveGame18.sav



Re: BUGZILLA report all bugs here![message #262333] Sun, 12 September 2010 13:54 Go to previous messageGo to previous message
Jolly_Reaper

 
Messages:47
Registered:August 2002
Location: The Netherlands

Now this is odd.
After fighting three rounds in the San Mona boxing ring, Shadow (my victim) decided to start a new life on his own.
He seems to behave like a militia or whatnot, walking around without me ordering him. When I tell him to crouch and aim he will, but will stand up on his own and walk off eventually.

Can't find anything on Bugzilla. I wonder, did anyone ever had something like that?
Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Fri Feb 28 21:01:24 EET 2020

Total time taken to generate the page: 0.02328 seconds