Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #319859] Thu, 16 May 2013 18:53 Go to previous messageGo to next message
alex662

 
Messages:12
Registered:May 2013
Gambigobilla
IFK if i get it right but, if you run vanilla exe after installing 1.13 it messes your whole installation. Reinstall and don't even touch original exe. To be honest i delete ja2.exe after installing ja2 because the sci's don't overwrite it. They come with a name like ja2_6082.exe so if you run ja2.exe instead of ja2_6082.exe then *boom* gone is the day's work.


reinstalled the game and i launched it via INI
still getting the same error msg as above.
Re: BUGZILLA report all bugs here![message #319860] Thu, 16 May 2013 19:09 Go to previous messageGo to next message
Sam Hotte

 
Messages:2005
Registered:March 2009
Location: Middle of Germany
Alex, there is a dedicated board to UC-1.13. which contains a FAQ thread with detailed instruction what and how to install and which things to adjust in the ini-editor to run UC-1.13.
Furthermore there are newer Versions than the one you are using and a bug report section there.

I'd suggest you go there for more detailed help targeted especially at UC-1.13.
Re: BUGZILLA report all bugs here![message #319861] Thu, 16 May 2013 19:36 Go to previous messageGo to next message
alex662

 
Messages:12
Registered:May 2013
Sam_Hotte
Alex, there is a dedicated board to UC-1.13. which contains a FAQ thread with detailed instruction what and how to install and which things to adjust in the ini-editor to run UC-1.13.
Furthermore there are newer Versions than the one you are using and a bug report section there.

I'd suggest you go there for more detailed help targeted especially at UC-1.13.


can you please give me a link?
(pretty easy to get lost in this forum... at least for me Smile)
Re: BUGZILLA report all bugs here![message #319877] Thu, 16 May 2013 23:40 Go to previous messageGo to next message
Sam Hotte

 
Messages:2005
Registered:March 2009
Location: Middle of Germany
alex662
went to this link : http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/236264/Urban_Chaos_1_13_Deidranna_Liv.html#Post236264

Go there again.

PS: You must have found it, as you've posted there already ... Smile
Re: BUGZILLA report all bugs here![message #319878] Thu, 16 May 2013 23:50 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Dragonlord

2) After adding the different scopes toggle scopes don't work anymore as intended. Previous to that you got different magnifications while now you slap a x10 scope and you get bonus x10 even if the guy is standing next you weird that no one has noticed that pretty much makes x10 and x7 scopes the best. If you disable scope toggle scopes return to normal behavior.

3)Not a bug but a a question though the default behavior of scopes x10 and even x7 seem to be useless since a x10 needs more than 60 squares away to be in optimal range and that means that you won't even see with the scope so far so what is the catch?

4) Explosions sometimes cause mercs to fall on their back and stay there trapped unable to do anything even if they have full energy they are stuck and if you choose to do anything with them it stucks and you have to wait for the 30 seconds timeout.

5) The new cower effect produces alot of bugs. It seems it was intended for civilians hence now alot of times cowering guys can[t be killed or even be shot while in that state. I have even see my mercs enter an immortal state while in that state and while the battle is on and die when it's over.

6) Using switches in ALMA to open doors crashes the game don't know if it is a n old one this one.

2) That is intentional for scope modes. Without scope modes, scopes magically adjust to best magnification. As that is stupid in my books, I impeded that behaviour when using scope modes.

3) Long range scopes are only useful for long ranges, yes.

4) That was fixed a while ago, don't know the exact revision anymore.

5) See 4)

6) Need more input. Which map, which switch, which doors?


Re: BUGZILLA report all bugs here![message #319887] Fri, 17 May 2013 00:52 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
Flugente
Dragonlord

2) After adding the different scopes toggle scopes don't work anymore as intended. Previous to that you got different magnifications while now you slap a x10 scope and you get bonus x10 even if the guy is standing next you weird that no one has noticed that pretty much makes x10 and x7 scopes the best. If you disable scope toggle scopes return to normal behavior.

2) That is intentional for scope modes. Without scope modes, scopes magically adjust to best magnification. As that is stupid in my books, I impeded that behaviour when using scope modes.


I was experiencing the same on v5951, and that was one of reasons why I finally ditched NCTH. As of HAM documentation (probably outdated but ideas were clear), scopes below "best" range should give increasing penalty. But actually there is no penalty. I'm not sure what is meant about being intentional for scope modes, even if it's intentional, it simply doesn't work as it was expected. Another problem which greatly amplifies 10x scope problem is that 10x scopes usually do not require additional aiming at all to achieve maximum accuraccy. So guns with 10x scopes are the most accurate in general at any range, and at about >=20 square range are taking least time to shoot accurately (as 10x scope guns have longer base aiming/shooting times but they win because they require no extra aiming).
Re: BUGZILLA report all bugs here![message #319987] Fri, 17 May 2013 23:34 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
I just complained about interrupts on v6061, and I did experience another bug which I don't think could be caused by map mod (Arulco Revisited).
Simply, I did spend all my AP with a merc (some 3-6 AP left), and was able to get interrupt with full AP, and then after I used up AP in interrupt, again got full AP for next turn. This happened when I was healing this merc with another merc, probably there is some cause between those.
P.s. I'll move to report bugs to the new bugzilla soon:)
Re: BUGZILLA report all bugs here![message #319989] Fri, 17 May 2013 23:44 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
Seems that bugzilla at discussrock.org is a bit forgotten.. Bugs submitted in last year are untouched.
Re: BUGZILLA report all bugs here![message #319997] Sat, 18 May 2013 00:30 Go to previous messageGo to next message
grim

 
Messages:344
Registered:July 2006
Location: France
An image is worth many words:
http://img594.imageshack.us/img594/2807/outoffuel.jpg
Bug: When you move from a sector to another with a running out of fuel vehicule, the above message appears, with (null) as vehicle name.

History: Hrvg had this problem on the french latest version he has, while checking his traduction, and asked me if he had made a mistake somewhere. I checked on my latest game build (JADL 1.13 v4.41, exe 6020 and data 1652), and i had the same result. Can someone else confirm with a more recent build?

[Updated on: Sat, 18 May 2013 00:33] by Moderator

Re: BUGZILLA report all bugs here![message #320002] Sat, 18 May 2013 01:09 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Fixed in r6085.


Re: BUGZILLA report all bugs here![message #320024] Sat, 18 May 2013 16:51 Go to previous messageGo to next message
merc05

 
Messages:86
Registered:January 2013
(r6085)

- when hiring guys from M.E.R.C. and then quiting to main menu and starting a new game the M.E.R.C. account does not get reset and I have "unsettled bills" text over the mercs I hired in my previous gameplay

- still problems with compiling a build in MapEditor mode (the Release mode was fixed) with ModularizedTacticalAI in VS2010

Quote:
11>LINK : fatal error LNK1181: cannot open input file 'ModularizedTacticalAI.lib'
Re: BUGZILLA report all bugs here![message #320027] Sat, 18 May 2013 17:39 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
I just upgraded everything to v6077, and all interrupt problems I complained on v6061 gone (and also performance back to normal).
Re: BUGZILLA report all bugs here![message #320070] Sun, 19 May 2013 13:16 Go to previous messageGo to next message
choijaeho

 
Messages:6
Registered:August 2010
Making Tony to follow bobby ray's coolness progression level seems broken.

I'm playing unstable JA2_6082 and revision 1677 with Arulco Revisited 1.4 and Strohmann's NCTH data overhaul mod

kinda felt Tony's inventory broken, so I tested with a new game with tons of guns, sci-fi, BR quality and quantitiy both set to x10

I used TONY_USES_BOBBY_RAYS_SETTING = TRUE in the ini file, of course

Started a new game, travelled to San Mona and checked Tony but he only has low coolness stuffs and quantitiy is also low.

I noticed this problem was already mentioned in this post in 2011: http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/285580/Is_Tony_s_Inventory_Working_Co.html

So it seems it still hasn't been fixed or the glitch reappeared
Re: BUGZILLA report all bugs here![message #320113] Mon, 20 May 2013 16:49 Go to previous messageGo to next message
RoWa21

 
Messages:2002
Registered:October 2005
Location: Austria
merc05
(r6085)

- when hiring guys from M.E.R.C. and then quiting to main menu and starting a new game the M.E.R.C. account does not get reset and I have "unsettled bills" text over the mercs I hired in my previous gameplay

- still problems with compiling a build in MapEditor mode (the Release mode was fixed) with ModularizedTacticalAI in VS2010

Quote:
11>LINK : fatal error LNK1181: cannot open input file 'ModularizedTacticalAI.lib'


both are fixed. one is already committed and the other fix will be committed soon.


Re: BUGZILLA report all bugs here![message #320133] Mon, 20 May 2013 21:40 Go to previous messageGo to next message
choijaeho

 
Messages:6
Registered:August 2010
(r6082)
Another bug with UFC match at Kingpin's nightclub.
If you kill all the competitors, and talk to Darren he will still accept the fight money even though the boxers are all dead, call Kingpin to watch the show, ring the bell, but when I move a merc inside the ring nothing happens.
Trying getting back to strategic window shows the message "you sure you want to abandon the fight"

Well if all of the competitors are dead, obviously, none of them can step inside the ring but hurting all of them below OKLIFE seems to activate this glitch as well.

Re: BUGZILLA report all bugs here![message #320171] Tue, 21 May 2013 21:28 Go to previous messageGo to next message
choijaeho

 
Messages:6
Registered:August 2010
fantazma
Making Tony to follow bobby ray's coolness progression level seems broken.

I'm playing unstable JA2_6082 and revision 1677 with Arulco Revisited 1.4 and Strohmann's NCTH data overhaul mod

kinda felt Tony's inventory broken, so I tested with a new game with tons of guns, sci-fi, BR quality and quantitiy both set to x10

I used TONY_USES_BOBBY_RAYS_SETTING = TRUE in the ini file, of course

Started a new game, travelled to San Mona and checked Tony but he only has low coolness stuffs and quantitiy is also low.

I noticed this problem was already mentioned in this post in 2011: http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/285580/Is_Tony_s_Inventory_Working_Co.html

So it seems it still hasn't been fixed or the glitch reappeared


By scanning through the code file it seems in armsdelaerinvinit.cpp the file only refers to merchants.xml but not the actual ja2_options.ini file.
The part that refers to ja2_options.ini in armsdealerinvinit.cpp is commented out with /* */

[Updated on: Tue, 21 May 2013 22:26] by Moderator

Re: BUGZILLA report all bugs here![message #321042] Tue, 28 May 2013 01:51 Go to previous messageGo to next message
Parkan

 
Messages:448
Registered:April 2010
Location: Russia,Sevastopol

I don't know is thig bug related to my option or not.
In ja2_option.ini i turned off completly-supression fire,supression fire from explosive,supression shock.During combats enemy\militia soldiers go to cower stance and can be invulnerable to shoots and punches(punches inaccesible and geting 30 seconds clock-cursor).Plus sometimes during combat if enemy change postion(like when lying on ground change position to another angle)i get 30 seconds lockdown(cursor-timer ).
Version of exe 6099(such things happened before such version too)
Re: BUGZILLA report all bugs here![message #321079] Tue, 28 May 2013 17:52 Go to previous messageGo to next message
Hazapuza

 
Messages:264
Registered:February 2009
Location: Finland
I'm experiencing a strange deadlock under 6100. It occurs when I order a merc with full APs and the Athletics trait (Magic in this case, but also happens with an IMP) to run as many tiles as possible, in a straight/almost straight line. After 93 or so APs are spent, the merc stops and the deadlock starts. I can then take the last step after the timer has run its course. This can be reproduced reliably.
Re: BUGZILLA report all bugs here![message #321081] Tue, 28 May 2013 18:39 Go to previous messageGo to next message
LootFragg

 
Messages:344
Registered:August 2009
Location: Berlin, Germany
I can confirm Hazapuza's deadlock as I've had it in previous versions since the Athletics trait allowed mercs to run 30+ tiles. No idea what the critical limit was but moving over many tiles without stopping caused a sudden break.
Re: BUGZILLA report all bugs here![message #321090] Tue, 28 May 2013 20:46 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
This is an ancient bug that afaik dates back to the original vanilla. The problem occurs once you move more than 30 tiles in turnbased in one move. In ancient days, it was never a problem, as it only occured in very rare instances (high agility merc and serious abuse of drugs). With Athletics, it is much more common.

The problem seems to be that for some reason, the game decides to still be busy - during testing, the 'unsetting' of the 'busy' flags occurs much later, and in a very different location, if one runs 31 tiles compared to 30 tiles. I neither now why nor where exactly that happens, and I've wasted enough time on that today...

Fix: Make pauses when running :transform: With NO_STANDING_ANIM_ADJUSTMENT_IN_COMBAT to TRUE you won't even lose APs on stops.

[Updated on: Tue, 28 May 2013 21:03] by Moderator



Re: BUGZILLA report all bugs here![message #321098] Tue, 28 May 2013 22:14 Go to previous messageGo to next message
merc05

 
Messages:86
Registered:January 2013
Thanks for fixing those Cool .

(r6102)
Recent bug happening after the cleanup update where in Strategic AI.cpp this code:

if( ubIntention == PURSUIT )
	{  //Make sure that the group isn't moving into a garrison sector.  These sectors should be using ASSAULT intentions!
		if( SectorInfo[ ubSectorID ].ubGarrisonID != NO_GARRISON )
		{
			//Good place for a breakpoint.
			pGroup = pGroup;
		}
	}


was replaced with this code:

//Make sure that the group isn't moving into a garrison sector.  These sectors should be using ASSAULT intentions!
    Assert(ubIntention != PURSUIT && SectorInfo[ ubSectorID ].ubGarrisonID != NO_GARRISON );


This causes an assertion error when the last member of enemy squad is killed although not on every encounter. It's definitely this part though cause reverting this part of the code prevents the crash.

(r6102 and sooner)
Noticed some problems with commanding EPC's/robot (generally every character without a merc bodytype). It's possible to make every character (including the robot) do a window jump with Shift+J. The character just gets teleported. Also every character (including the robot) can be made to climb the roof. Again they get teleported there. In the latter case I can't get the robot back down. Also making EPC's strafe with 'Alt' button makes them disappear. Maybe some check for bodytype could be performed to disallow these from happening?

(r6102 and sooner)
I have some update on a bug reported before, where multiple-shot launcher ammo was missing one shot from clips. It seems it is only true for rocket launchers. Grenade launchers (like XM-25) have proper amount of ammo in clips.
Re: BUGZILLA report all bugs here![message #321103] Tue, 28 May 2013 23:23 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
True, the first statement is unnecessary, fixed in r6103.

Also, as of r6103, robots cannot climb roofs, windows, fences or walls anymore.

Regarding the rocket display error: With what weapon do you experience that? RPG-7 works fine for me.


Re: BUGZILLA report all bugs here![message #321104] Wed, 29 May 2013 01:11 Go to previous messageGo to next message
merc05

 
Messages:86
Registered:January 2013
Thanks a lot for the fixes. I'm gonna check that out tomorrow. Smile As for the rocket launchers, here is the item code from my XMLs:

Items.xml

		1833
		M202
		M202 FLASH
		Built to replace vintage flamethrowers in the U.S. Army the FLame Assault SHoulder weapon has greater range and less weight. Too bad Geneva Convention forbids its use.
		M202 FLASH
		One of our favourite fire making devices. The four-tube launcher is equipped with front and rear hinged protective covers, a folding sight and trigger handle assembly and a collapsible tube structure to provide compact carrying and storage capabilities.
		16
		1
		1833
		3
		2
		172
		52
		7
		2800
		9
		-6
		1
		1
		1
		1
		1
		1
		1
		1
		1
		1
		1
		10
		1
		100.0
		10
		20.0
		
		
		
	
	
		1834
		M74
		M74 quad rocket pack
		The only thing better than an incendiary rocket is four of them.
		M74 quad rocket pack
		The only thing better than an incendiary rocket is four of them.
		256
		2048
		2048
		1
		116
		2
		173
		69
		32
		1
		2400
		9
		-6
		1
		1
		1
		1
		1
		1
		1
		1
		100.0
		
		
		
	


Weapons.xml

		1833
		M202 FLASH
		3
		5
		30
		80
		90
		2
		4
		500
		200
		100
		100
		10
		428
		111
		157
		20
		90
		1
		10
		476
		1
		4000
		5000
		1600
	


Launchables.xml

		1834
		1833
	


Explosives.xml

		116
		8
		40
		40
		7
		75
		2
		9
		3
		5
		4
		1
		0
		0
		0
		0
		0
		0
		0
	


This should be a fire-missile launcher that is loaded with quad-packs and allows 4 shots before reloading. With the above setting 3 shots will empty it so I have to set MagSize to 5 in order to make it work like I want to. If it can't be replicated maybe I'm just dumb and there is no error in the code but in the xml Sad? But I can't find anything wrong with it, everything works fine except the number of rounds.
Re: BUGZILLA report all bugs here![message #321151] Wed, 29 May 2013 23:50 Go to previous messageGo to next message
Hazapuza

 
Messages:264
Registered:February 2009
Location: Finland
A rather strange bug: bonuses/penalties to recoil values caused by attachments (a muzzle break in this case, playing UC1.13) only show up in the description screen if the weapon is equipped. but not if the weapon is in the sling slot/backpack or sector inventory. Also, when the weapon is in a merc's hands, all other full auto capable weapons magically show the same recoil reduction in their descriptions.

In addition to these, the recoil reduction shown in the weapon's description is more than it should be. The AK Muzzle Brake in question lists -2 vertical recoil and -1 lateral recoil, but the end result is -2,-2, or from 15.5 to 13.3.
Re: BUGZILLA report all bugs here![message #321153] Wed, 29 May 2013 23:59 Go to previous messageGo to next message
pheloncab

 
Messages:281
Registered:August 2004
Location: So. Cal. or texas
have you compared your xml to one of the multi-grenade launchers that work? that might show you a missing flag or mis-set attatchment code.
Re: BUGZILLA report all bugs here![message #321164] Thu, 30 May 2013 02:08 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
The issue with magazine-fed GLs/RPGs having one less shot than expected is fixed in r6104.

When we remove a grenade/rocket from a magazine, we reduce the status of the magazine item by 100/magsize. We remove the magazine object when (pseudocode)
magazine.status <= 100/magsize
When using a mag of size 4, we obviously removed the mag after the third shot, as 25 <= 100/4. I thus changed it to '<'.

I know this issue also popped up in some other thread recently... whoever you were, this also fixes your issue, person I've forgotten. :whoknows:


Re: BUGZILLA report all bugs here![message #321201] Thu, 30 May 2013 15:38 Go to previous messageGo to next message
Hazapuza

 
Messages:264
Registered:February 2009
Location: Finland
Playing with the latest UC1.13 4.45.1a (revision 1678, exe 6103), I encountered an assertion failure:

http://i240.photobucket.com/albums/ff60/Hazapuza_2007/Random%20shit/SCREEN000_zpsfea59db2.png~original

The cause seems to be the window breaking after being hit by a grenade. I reverted back to 6100 and the error doesn't occur. I assume this doesn't have anything to do with not starting a new game after upgrading from 6100 to 6103.

I can provide a save.

[Updated on: Thu, 30 May 2013 15:39] by Moderator

Re: BUGZILLA report all bugs here![message #321224] Thu, 30 May 2013 22:13 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Hmm. I cannot reproduce that error with r6104, but I don't want to install an entire mod just out of curiosity... any more input? Did that grenade also hit someone?

Edit: Wait a minute... idea...

Edit2: r6105 should fix your problem. Please test, if that specific location still produces errors, we have a real problem.

[Updated on: Thu, 30 May 2013 22:36] by Moderator



Re: BUGZILLA report all bugs here![message #321292] Sun, 02 June 2013 16:14 Go to previous messageGo to next message
Emufarmers

 
Messages:7
Registered:May 2013
fantazma
Another bug with UFC match at Kingpin's nightclub.
If you kill all the competitors,

I get this with just the first competitor dead. There goes that cash flow. Sad

[Updated on: Sun, 02 June 2013 16:15] by Moderator

Re: BUGZILLA report all bugs here![message #321293] Sun, 02 June 2013 16:16 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Quite a few bugs were fixed recently. As r6105 is savegame-compatible to r6082, you could try that exe out, and see if the error still occurs.


Re: BUGZILLA report all bugs here![message #321302] Sun, 02 June 2013 20:35 Go to previous messageGo to next message
Emufarmers

 
Messages:7
Registered:May 2013
Flugente
Quite a few bugs were fixed recently. As r6105 is savegame-compatible to r6082, you could try that exe out, and see if the error still occurs.

It still occurs.
Re: BUGZILLA report all bugs here![message #321304] Sun, 02 June 2013 20:57 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Well, what is the exact error then? What does it say?


Re: BUGZILLA report all bugs here![message #321306] Sun, 02 June 2013 21:07 Go to previous messageGo to next message
Emufarmers

 
Messages:7
Registered:May 2013
Flugente
Well, what is the exact error then? What does it say?

It doesn't say anything. It's the same as what fantazma reported: You give Darren the money and step into the ring and then nothing happens. (I assumed it was because I killed one of the fighters, but now that I reread his post, maybe it's just that all three were sufficiently injured.)
Re: BUGZILLA report all bugs here![message #321307] Sun, 02 June 2013 21:15 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Try jumping into the ring from another side and see if that helps.


Re: BUGZILLA report all bugs here![message #321310] Sun, 02 June 2013 21:23 Go to previous messageGo to next message
Emufarmers

 
Messages:7
Registered:May 2013
Flugente
Try jumping into the ring from another side and see if that helps.

Nope, that doesn't seem to have any effect.
Re: BUGZILLA report all bugs here![message #321343] Mon, 03 June 2013 22:38 Go to previous messageGo to next message
MasterN

 
Messages:44
Registered:February 2011
Location: Berlin - Ger
Running AR 1.4 on 1687 / 6105.exe
solved...

[Updated on: Mon, 03 June 2013 23:11] by Moderator

Re: BUGZILLA report all bugs here![message #321344] Mon, 03 June 2013 22:41 Go to previous messageGo to next message
Flugente

 
Messages:3481
Registered:April 2009
Location: Germany
Did you take into account the scope modes?


Re: BUGZILLA report all bugs here![message #321345] Mon, 03 June 2013 22:57 Go to previous messageGo to next message
Hazapuza

 
Messages:264
Registered:February 2009
Location: Finland
Sweet O - Try putting the weapon on someone's hands. The aiming level bonus should then be visible. I posted a similar issue concerning recoil modifiers on the last page. There certainly seems to be something wrong with the UDB.

[Updated on: Mon, 03 June 2013 22:58] by Moderator

Re: BUGZILLA report all bugs here![message #321346] Mon, 03 June 2013 22:58 Go to previous messageGo to next message
MasterN

 
Messages:44
Registered:February 2011
Location: Berlin - Ger
solved.... sorry...

[Updated on: Mon, 03 June 2013 23:12] by Moderator

Re: BUGZILLA report all bugs here![message #321709] Wed, 19 June 2013 00:13 Go to previous messageGo to previous message
weidox

 
Messages:43
Registered:March 2013
Another bug to already boring long list (not counting anymore) - binoculars/scopes sight radius (tunnel vision) and sight range mostly do not work. Compact binoculars, quality binoculars, 7x and 10x scopes have daylight different tunnel vision % (70%, 40%, 70%, 90% accordingly) but their sight radius is the same when in hands. 4x scope has tunnel vision as 20% but actually there's no change to sight radius with this scope in hands.
Sight range is also inconsistent. While there is progression as increasing sight range % gives an actual increase, there's huge jump from no scope to using 4x scope with 20%, and then small increases till compact binoculars at 100% sight range bonus. I checked those on a merc with Scouting skill. Also tried a bit scopes on weapons without Scouting skill - 4x scope and 7x scope are giving the same sight radius, similar to binoculars.
Using 6077 on 1676 with Arulco Revisited mod (no item changes).
Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Fri Feb 28 21:12:11 EET 2020

Total time taken to generate the page: 0.03145 seconds