Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #341605 is a reply to message #341484] Sun, 05 July 2015 15:44 Go to previous messageGo to next message
Flugente

 
Messages:3476
Registered:April 2009
Location: Germany
Flugente wrote on Sat, 20 June 2015 15:22
The new savegame has this happening in B1. The old was in F9, thus me writing that cheeky

Anyway... what happens is that the 83-people strong group needs new orders after arriving at their destination, but missing the player (who retreated). The group then gets a random new assignment. The intention was obviously to get the group moving again (otherwise they wouldn't move and be stuck there).

And, apparently it can happen with the right random numbers picked that the group doesn't get reassigned... It then gets moved back to the troop pool. Which causes it to completely vanish.
There is no code in place to stop this. So... this is not a bug... this is design. suprised

Currently seeking a fix, 'cause this design stinks. thumbs down

Edit: Somewhat fixed in r7895. If a group is ordered ordered to be moved back to the pool during reassignment, we now order them to move there an dissolve then instead of vanishing outright.
I've altered this part in r7901: If the player retreats from an enemy attack that was targetted at this sector, the enemy group pursuits instead of being given new orders. In the savegames posted about this error, this means that if one retreats to another town sector, the AI follows (with a 5-minute delay for internal reasons - if player and enemy groups arrive at the same time, bad things happen during tactical deployment).
Not sure how much harder this will make the game - I figure I'll just wait until someone comes crying and then make it optional (you wussies! angel ).



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341606 is a reply to message #341605] Sun, 05 July 2015 18:42 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Flugente wrote on Sun, 05 July 2015 14:44
If the player retreats from an enemy attack that was targetted at this sector, the enemy group pursuits instead of being given new orders. In the savegames posted about this error, this means that if one retreats to another town sector, the AI follows (with a 5-minute delay for internal reasons - if player and enemy groups arrive at the same time, bad things happen during tactical deployment).
Not sure how much harder this will make the game - I figure I'll just wait until someone comes crying and then make it optional (you wussies! angel ).


This certainly makes sense. Why would the enemy troops just stop and let the mercs run? They wouldn't! They would chase the mercs until they are dead. So better retreat into the wild and have a survival specialist with you or run to your militia boys crying for help. cheeky



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341648 is a reply to message #166487] Thu, 09 July 2015 16:04 Go to previous messageGo to next message
Kalindro
Messages:3
Registered:July 2015
If anyone is alive big grin Version 7989 from onedrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083%21583, and in my case other versions too, when I choose new method of my merc equipment, i have no weapon or ammo to choose (only option to choose is "no weapon") angry
Re: BUGZILLA report all bugs here![message #341657 is a reply to message #341648] Thu, 09 July 2015 19:21 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Kalindro wrote on Thu, 09 July 2015 15:04
If anyone is alive big grin Version 7989 from onedrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083%21583, and in my case other versions too, when I choose new method of my merc equipment, i have no weapon or ammo to choose (only option to choose is "no weapon") angry

That was probably my mistake when I overhauled the automatic selection of items. angry
I forgot to let the new IMP item selection code read the new sidearm category from IMPItemChoices.xml. So if you selected traits that didn't include any special guns (like SMGs for auto weapons, rifles for marksman, shotguns for hunters, additional pistol for gunslinger ambidextrous etc.) you were left without any gun to choose from. I wonder why nobody reported this any sooner. Fixed in r7908.

[Updated on: Fri, 10 July 2015 09:17]




Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341664 is a reply to message #341657] Fri, 10 July 2015 04:55 Go to previous messageGo to next message
Kalindro
Messages:3
Registered:July 2015
One thing to mention: Taking gunslinger (even 2 points in gunslinger) doesn't help, there are still no weapons, but when I take auto + heavy weapons I can finally choose one cheeky

[Updated on: Fri, 10 July 2015 04:56]

Re: BUGZILLA report all bugs here![message #341665 is a reply to message #341664] Fri, 10 July 2015 09:19 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Ah, yes. The gunslinger doesn't get another gun. The ambidextrous merc gets it. Sorry for the confusion. Gunslinger gets a laser pointer or something.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #341707 is a reply to message #166487] Sun, 12 July 2015 14:16 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Another post, anoter problem. This saved game here for build 7898 is about to encounter assertion failure, when mercs enter sector A6. It doesn't matter whether you choose to call militia or not. When you choose to enter sector to have a battle, problem occurs. There seems to be problem with entry points for those few mercs Oo.

Assetion that failed:
http://img21.imagevenue.com/loc226/th_685394373_assertionFailureOnEnteringSector_122_226lo.jpg

Saved game and ini:
http://ulozto.net/xzkG9vfV/assertiofailureonenteringa6-zip

Re: BUGZILLA report all bugs here![message #341826 is a reply to message #341707] Tue, 21 July 2015 10:52 Go to previous messageGo to next message
tim110011

 
Messages:7
Registered:August 2012
Useing 113 and Chinese GameData, differ directory names is causing problem in case-sensitive Linux system.
here are some differ names i found:
Mercedt MercEdt
NpcData NPCData
Re: BUGZILLA report all bugs here![message #341861 is a reply to message #341707] Sat, 25 July 2015 14:42 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
navaroe wrote on Sun, 12 July 2015 13:16
Another post, anoter problem. This saved game here for build 7898 is about to encounter assertion failure, when mercs enter sector A6. It doesn't matter whether you choose to call militia or not. When you choose to enter sector to have a battle, problem occurs. There seems to be problem with entry points for those few mercs Oo.



I have noticed in SVN comment to revision 7903 states what looks like fix to this bug - "Fix: possible crash if entering a sector with more enemies present than map placements" (thanks to Flugente).
There is one more similar bug around, I guess:

This assertion failure happens when I enter K13 sector, where currently 64 enemies march towards Alma.

http://img220.imagevenue.com/loc733/th_823153955_assertionFailureOnEnteringK14_122_733lo.jpg

Saved game for build 7917 and ja2_options.ini:
http://ulozto.net/xm9N8LZa/assertionfailureonenteringk14-zip


Edit: Same thing happens later in J13. These country sector's really aren't for big battles, are they?


More edit: This thing appears all over the place. Do I guess correctly, that this problem wouldn't occur with MAX_NUMBER_ENEMIES_IN_TACTICAL set to default 32? I have 40 now. In that case comment to this property in ja2_options.ini should state something about this, as this is really annoying and cannot be reset during game. not sure

[Updated on: Thu, 30 July 2015 23:01]

Re: BUGZILLA report all bugs here![message #341889 is a reply to message #166487] Wed, 29 July 2015 04:07 Go to previous messageGo to next message
Franimus

 
Messages:47
Registered:June 2015
Location: USA
I keep getting frozen on this line of code, vobject.cpp line 967:
SGP_THROW_IFFALSE( hSrcVObject->usNumberOfObjects > usIndex, L"Video object index is larger than the number of subimages");

While debugging, I did see it at one point just prior to this hit line 1715, an fAssertError gubVODebugCode "DeleteVideoObjectFromIndex" but I have no clue if that means anything or if it's normal.

I think it may be occurring during Handle UI.cpp line 1343 SetCurrentInterfacePanel( TEAM_PANEL ); call.

This happened to me on r7889 or thereabouts when that was latest. I shelved it for a bit, came back now and updated to r7938 (gamedir r2267) and started a completely new game, now I'm getting the same freeze. I managed to capture two end-turn saved game files where the first turn works fine and the second turn always freezes. It displays the "Saving..." dialog and does not pop anything up. Is there a recommended spot to upload them & options INI?
I'm using AIMNAS Bigmaps (r63).
Re: BUGZILLA report all bugs here![message #341890 is a reply to message #341861] Wed, 29 July 2015 04:16 Go to previous messageGo to next message
Franimus

 
Messages:47
Registered:June 2015
Location: USA
Edit to previous post: I've uploaded the .sav and .ini here:
ulozto.net/xeQE4Hkr/freezeonendturn-zip

Running Win 7 NVIDIA GeForce 9600 GT drivers are up-to-date

Also, I've tried most of the suggestions in the Win 8.1 compatibility thread, no luck.

[Updated on: Wed, 29 July 2015 05:27]

Re: BUGZILLA report all bugs here![message #341907 is a reply to message #341890] Thu, 30 July 2015 04:58 Go to previous messageGo to next message
Franimus

 
Messages:47
Registered:June 2015
Location: USA
Well I saw a commented out try/catch block around it, so based on that I ended up just putting this statement in and I got past it, at least:
if (hSrcVObject->usNumberOfObjects <= usIndex) return(TRUE);
Instead of the SGP_THROW it was failing.
Re: BUGZILLA report all bugs here![message #341908 is a reply to message #341907] Thu, 30 July 2015 10:57 Go to previous messageGo to next message
Flugente

 
Messages:3476
Registered:April 2009
Location: Germany
A video object (graphics) is not what is expected. Easiest way to get this is by a faulty install - maybe you installed in the wrong order, thereby overwriting bigger with smaller .sti-libraries.
As you are able to reproduce it, you could debug and look at the call stack. With luck you'll be able to identify the bad picture.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #341930 is a reply to message #341908] Sun, 02 August 2015 14:03 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
I think I've solved this one: http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=12303&goto=341861&#msg_341861

The problem occurs, when there is mobile group of enemies as well as static group in sector you are attacking and the number of slots available is lower then sum of all groups.

Here is the diff - just one line of comment and changed max to min...
Toggle Spoiler


After bit of ingame testing, everything seems to be ok.
Re: BUGZILLA report all bugs here![message #341932 is a reply to message #341930] Sun, 02 August 2015 15:52 Go to previous message
DepressivesBrot

 
Messages:3745
Registered:July 2009
Locking this one for excessive length, use the new one here



Chat with us!
#bearpit on IRC
Discord
Get your latest 1.13 Builds
(Pls don't use my forum PMs for general game queries)


Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Tue Nov 19 17:22:20 EET 2019

Total time taken to generate the page: 0.04373 seconds