Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #331924] Sat, 26 April 2014 09:54 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

I tryed to compile last unstable exe with vs2008 and vs2013-both have one bug:Game saves not working.The is some errors in campaigh.cpp in line 1631.version of exe 7164.
Re: BUGZILLA report all bugs here![message #331927] Sat, 26 April 2014 13:22 Go to previous messageGo to next message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
Parkan
I tryed to compile last unstable exe with vs2008 and vs2013-both have one bug:Game saves not working.The is some errors in campaigh.cpp in line 1631.version of exe 7164.


it is not a bug, it is a feature externalization: locks and keys:
old savegames are not compatible with this new externalization.


Re: BUGZILLA report all bugs here![message #331935] Sat, 26 April 2014 18:39 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

You not understand.I made a fresh install of game,Gamedir,compiled a new exe.Started a new game.Save game-load game=error.Campaign.cpp line 1661.

[Updated on: Sat, 26 April 2014 18:41] by Moderator

Re: BUGZILLA report all bugs here![message #331936] Sat, 26 April 2014 18:42 Go to previous messageGo to next message
sevenfm

 
Messages:1935
Registered:December 2012
Location: Soviet Russia
@Parkan
Did you try making a clean build?


Re: BUGZILLA report all bugs here![message #331937] Sat, 26 April 2014 18:44 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

Yes.First of all i maded a cleaning in both VS2008 and 2013.And after that i start to compile.
Re: BUGZILLA report all bugs here![message #331938] Sat, 26 April 2014 18:52 Go to previous messageGo to next message
sevenfm

 
Messages:1935
Registered:December 2012
Location: Soviet Russia
Line 1661 in campaign.cpp is a comment
        // When the "Alternate Progress Calculation" is activated, the program selects only the HIGHEST of the 

In both stable and dev branches.
Something is probably wrong with your source files Smile


Re: BUGZILLA report all bugs here![message #331939] Sat, 26 April 2014 18:54 Go to previous messageGo to next message
hrvg

 
Messages:158
Registered:August 2012
Location: France
Hi,
English version.
Problem with backpack error message: Rutine error -- Press ESC...

Backpacks is dropped (tactical screen)...
When I click on 'Stack and merge items' (strategic screen)...
http://zupimages.net/up/14/17/h2ju.jpg

Backpacks are picked (tactical screen)...
Backpacks are still in the inventory area (strategic screen).
http://zupimages.net/up/14/17/f218.jpg

If I take Russian 106 vest or TIMS backpack...
Message: Rutine error -- Press ESC...
http://zupimages.net/up/14/17/317e.jpg

Or other...
Items disappears or changes.
It's strange.

Regards.

[Updated on: Sat, 26 April 2014 18:56] by Moderator

Re: BUGZILLA report all bugs here![message #331940] Sat, 26 April 2014 20:45 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

Fully redownloaded development brunch of 1.13 mod source files.Created both exe in VS2008 and VS2013.Both exe have same bug:Made a quick save or save game to slot then try to load it and game crash with assertion failure in line 1631 of Campaign.cpp


Edit:I just recreated exe with previus revesion 7164.And all working fine.Game save and load normaly.Something weird going with 7165.

[Updated on: Sat, 26 April 2014 22:54] by Moderator

Re: BUGZILLA report all bugs here![message #331951] Sun, 27 April 2014 08:10 Go to previous messageGo to next message
JosephCKohn

 
Messages:40
Registered:February 2014
There something wrong with any given instance of Executable 7164 SVN Game Dir 2020 as any save game cannot be loaded.

I have done countless clear reinstalls, remods. No custom JA2.ini or JA2_Options.ini files, no other mods. Simply put:
  • Run an instance of Executable 7164 SVN Game Dir 2020
  • Create a save game, any type will do
  • Exit game via main menu
  • Run game and attempt to load any save
Re: BUGZILLA report all bugs here![message #331953] Sun, 27 April 2014 09:47 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

Yup.that i was said too.Something weird going with Locks feature in 7165 version.Previus version of exe(7164,7163) work fine.
Re: BUGZILLA report all bugs here![message #332052] Thu, 01 May 2014 20:44 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
As of r7179, I am somewhat confident to have repaired an annoying boxing bug. Basically, loading during boxing removed the boxer property and disqualified your boxer. This was actually a fix for another bug that caused mercs to be treated as boxers on other occasions. Hopefully, that is now history. If not, contact me.


Re: BUGZILLA report all bugs here![message #332110] Fri, 02 May 2014 20:32 Go to previous messageGo to next message
Decoy

 
Messages:30
Registered:April 2004
Game crashes if I left click on specter thig rig sling and try to equip ammunition. I also wonder why the specter thig rig only has room for a gas mask and nothing else.

Savegame

http://oi58.tinypic.com/zwxfmx.jpg
Re: BUGZILLA report all bugs here![message #332155] Sat, 03 May 2014 20:17 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
Decoy
I also wonder why the specter thig rig only has room for a gas mask and nothing else.
The "Specter Thigh Rig" does not have any pockets beyond the "Carabiner Ring" until you attach a MOLLE pouch to it. This however begs the question of why you are being given the option to fill it with ammo - which probably is related to the crash.


It looks like Anv's fix to the UBW bug I reported has not been implemented yet as of SCI_Unstable_Revision_7178_on_GameDir_2027 - bug is still present and the change logs make no mention of it. Bug was also reported in BUGZILLA: 663.


Not really a bug per sec, but are there any challenges to getting JMich's current Revision 162 XMLEditor into the SVN?


Re: BUGZILLA report all bugs here![message #332156] Sat, 03 May 2014 20:28 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

I tryed to use new Jmich xml editor with Stronhmans overhaul(alpha version)and after saving changes to xml files via xml editor it broke enemy inventory(all enemies spawned only with pistol regardless of game progress and no armor at all),but looking with notepad+xml files(enemy choices and other stuff)no any broke was found.game just not load their inventory.bug was fixed when i overwrite them with defaults xml files.
Re: BUGZILLA report all bugs here![message #332157] Sat, 03 May 2014 21:08 Go to previous messageGo to next message
Randok

 
Messages:326
Registered:March 2004
JA2 + SCI_Unstable_Revision_7178_on_GameDir_2027.7z

1. Bug: I'm in town. I have enabled functions "do not show roofs".
Birds sit on the body. Once undermine flight, turns on the function "show roofs".

2. Bug: enemy in fire.
I throw in enemies Molotov Cocktail ( one turn ).
In the next turn of enemies to move in fire and clock spins without end.

3. Question: before enemies were running on a shot in the air ( for example, when I shoot the edge of the sector where they have come ). Now they do not care.
Is this a bug or a new strategy enemies?

I have saves ( bird and fire ). I can send them but only mail ( interested are asked to address the in PM ). Sorry.
Smile
Re: BUGZILLA report all bugs here![message #332158] Sat, 03 May 2014 22:02 Go to previous messageGo to next message
Decoy

 
Messages:30
Registered:April 2004
If I equip Ivan with the CETME ameli, i get his perks shown by overlapping symbols at his portrait. A mouse over reveals what perks he has. Is this a bug or a feature? If it's a feature, it's a bit strange.

http://oi59.tinypic.com/apa0zc.jpg


EXE Source
Completed: At revision: 7181

Data Source
Completed: At revision: 2031
Re: BUGZILLA report all bugs here![message #332159] Sat, 03 May 2014 22:52 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3804
Registered:July 2009
That has nothing to do with his traits, it shows that the Ameli is taking ammo from special pockets or a dedicated loader before touching the loaded belt.


Re: BUGZILLA report all bugs here![message #332160] Sat, 03 May 2014 23:14 Go to previous messageGo to next message
Decoy

 
Messages:30
Registered:April 2004
Thanks for the explanation, I was confused by the tooltip. Just figured out that's the default tooltip when you hover above someones portrait.
Re: BUGZILLA report all bugs here![message #332177] Sun, 04 May 2014 16:22 Go to previous messageGo to next message
Decoy

 
Messages:30
Registered:April 2004
I have a savegame where two mercs are training Militia, but the Militia will never appear. They just keep on training forever without anything to happen.

I can workaround the bug: If I give them the order to train militia again, I have to pay for it and it will work.

Savegame

http://oi57.tinypic.com/4uxb9e.jpg


EXE Source
Completed: At revision: 7181

Data Source
Completed: At revision: 2031
Re: BUGZILLA report all bugs here![message #332182] Sun, 04 May 2014 19:45 Go to previous messageGo to next message
Parkan

 
Messages:451
Registered:April 2010
Location: Russia,Sevastopol

yes i can confirm that bug too.it happen sometime,but i don't understand when it appear.
Re: BUGZILLA report all bugs here![message #332213] Tue, 06 May 2014 17:26 Go to previous messageGo to next message
sevenfm

 
Messages:1935
Registered:December 2012
Location: Soviet Russia
Stable 7193 build fails with:

Map Screen Interface TownMine Info.cpp(438) : error C2065: 'PRISONER_OFFICER' : undeclared identifier
Map Screen Interface TownMine Info.cpp(444) : error C2065: 'PRISONER_OFFICER' : undeclared identifier



Re: BUGZILLA report all bugs here![message #332230] Wed, 07 May 2014 01:34 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
Fixed in r7194.


Re: BUGZILLA report all bugs here![message #332293] Thu, 08 May 2014 11:01 Go to previous messageGo to next message
RunAwayScientist

 
Messages:85
Registered:September 2001
All funds made from facilities with a negative XML value defined in FacilityTypes.xml do not save into permanent memory.


The value is updated in the strategic screen or when withdrawing money, but when viewing the Laptop's Financial Screen or viewing your current finances after manually withdrawing cash the value is reset to its previous amount.


My guess is that there are two separate variables being accessed or the game's current finances variable is being overwritten/refreshed by another value in the backend somewhere.


Encountered in 7178 and it has apparently been occurring with versions before r7178.

[Updated on: Thu, 08 May 2014 11:03] by Moderator


Re: BUGZILLA report all bugs here![message #332414] Sun, 11 May 2014 09:06 Go to previous messageGo to next message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
RunAwayScientist
All funds made from facilities with a negative XML value defined in FacilityTypes.xml do not save into permanent memory.


The value is updated in the strategic screen or when withdrawing money, but when viewing the Laptop's Financial Screen or viewing your current finances after manually withdrawing cash the value is reset to its previous amount.


My guess is that there are two separate variables being accessed or the game's current finances variable is being overwritten/refreshed by another value in the backend somewhere.


Encountered in 7178 and it has apparently been occurring with versions before r7178.


Fixed in revision 7199 (by Buggler)

[Updated on: Sun, 11 May 2014 09:40] by Moderator



Re: BUGZILLA report all bugs here![message #332415] Sun, 11 May 2014 09:41 Go to previous messageGo to next message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
Decoy
I have a savegame where two mercs are training Militia, but the Militia will never appear. They just keep on training forever without anything to happen.

I can workaround the bug: If I give them the order to train militia again, I have to pay for it and it will work.

Savegame

http://oi57.tinypic.com/4uxb9e.jpg


EXE Source
Completed: At revision: 7181

Data Source
Completed: At revision: 2031


fixed in rev. 7199 (by buggler)


Re: BUGZILLA report all bugs here![message #332580] Wed, 14 May 2014 08:09 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
BASIC_RELIABILITY_ODDS in CTHConstraints will be set to 100 upon startup if user sets between 100 and 10000 as advertised in the description:

Quote:

; This is the basic chance PER SHOT to lose 1 point of weapon condition with each
; bullet fired. The formula for this chance is 1 in BASE_DEPRECIATE_CHANCE, so higher
; values result in slower degradation.
; The default value for OCTH is 15, but NCTH requires a **much** higher
; expenditure of bullets, resulting in severely-reduced weapon condition after every
; battle. Therefore, the default for NCTH is currently 150.
; Valid range is 0-10000.
BASIC_RELIABILITY_ODDS = (some number)


This bug's been around for at least a year.
Re: BUGZILLA report all bugs here![message #332635] Thu, 15 May 2014 09:23 Go to previous messageGo to next message
arkanglesk

 
Messages:29
Registered:June 2011
Hi guys, I'm having 2 3 issues with exe 7178, gameDir 2027 (Depri's build):

1) Tooltips don't show up in tactical view. Not even the tooltip for mercs' health/energy.

2) Sometimes I get guns (e.g. Beowulf and KAC PDW, to name a couple. There's more but I haven't tested them all) that have no ammo. They can be refilled with GABBI's Alt+R but mags can't be extracted.

2a) If I manage to get the ammo elsewhere, its crates do not generate at all, either by Ctrl+Shift+A or button on strategic.

3) I just noticed it won't let me order a merc or squad to move out of a sector via map edge in tactical view.

-It should be easily reproducible, only changes on game data are: size of all crate magazines = 20000 (values above 32000 cause problems too); suppression/fear = 200%; gun,explosive damage = 190%,250%

-I play with ctrl+GABBI on. (if you think its' related let me know. Otherwise, don't judge me. Or do it if you dare.)

Savegame should be available on Dropbox: https://www.dropbox.com/s/2k9k0ryy9oykwk4/SaveGame02.sav

[Updated on: Thu, 15 May 2014 10:29] by Moderator

Re: BUGZILLA report all bugs here![message #332639] Thu, 15 May 2014 10:42 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3804
Registered:July 2009
Reproduce 2&2a with a clean install, it's more likely that you just messed up the formatting.

[Updated on: Thu, 15 May 2014 10:43] by Moderator



Re: BUGZILLA report all bugs here![message #332669] Thu, 15 May 2014 21:33 Go to previous messageGo to next message
arkanglesk

 
Messages:29
Registered:June 2011
Hi, you're right... I tried to reproduce with a clean magazines.xml (this game has taught me the hard way to ALWAYS keep a backup) and crates work, guns have ammo Smile

As for 1 and 3, I also noticed mercs' animations don't play while on tactical(they don't blink or move their mouth, but if they say something like "time for the enemy to say its prayers" then the dialog appears and animations play normally).
I also forgot to mention I play with some modded faces... But if I had messed something up there strategic ui would also be broken, wouldn't it?

[Updated on: Thu, 15 May 2014 21:45] by Moderator

Re: BUGZILLA report all bugs here![message #332695] Fri, 16 May 2014 16:46 Go to previous messageGo to next message
Floh
Messages:4
Registered:June 2006

Hi,

just downloaded the latest SCI from Depri's thread (7205), installed on a fresh Steam gold edition installation (copied to a new folder).
I created 9 custom mercs and landed in Drassen, on second turn I got a runtime error:

Assertion Failure [Line 4861 in file strategicmap.cpp]
Sarge is not in a valid group (pSoldier->ubGroupID is 0)

On two retries the same error occurred, once with a different merc, once after I ended the turn quickly without doing much (clarification edit: error came during my next turn). The error does not seem to be directly connected to any action, the mercs in question behaved normally before and were not selected when the error occurred.

Can anybody help me with that?

[Updated on: Fri, 16 May 2014 16:51] by Moderator

Re: BUGZILLA report all bugs here![message #332696] Fri, 16 May 2014 18:21 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
I don't know how this problem arises but you can "fix" it by reassigning the mercs in your group to a different group number and then back to the original number. This will reset their group ID and should fix the problem in your savegame.

When I got this problem before I thought that is is related to Alt+Tabbing out of JA2 and back and pressing a certain key. Alt key is still stuck at that moment because of the previous Alt+Tab action (game remembers that Alt was pressed). I wasn't able to reproduce it though. If you know a reliable way to reproduce the issue please let us know.

Whenever you Alt+Tab out of the game and go back to the game press Alt to get it released.

[Updated on: Fri, 16 May 2014 18:22] by Moderator


Re: BUGZILLA report all bugs here![message #332718] Sat, 17 May 2014 08:30 Go to previous messageGo to next message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
@moth_hunter: please upload the savegame so we an reproduce the bug


Re: BUGZILLA report all bugs here![message #332721] Sat, 17 May 2014 13:18 Go to previous messageGo to next message
Floh
Messages:4
Registered:June 2006

The debug save seems to have failed, unfortunately all Autosaves were overwritten when I successfully tried the workaround posted earlier in this topic for this problem: I went to the strategic map and reassigned my mercs from squad 1 to squad 2.


PS: @silversurfer: Thanks for the reply, must have missed it earlier.
I definitely did alt-tab out a lot during character creation since I was completely unfamiliar with the new character traits

[Updated on: Sun, 18 May 2014 23:22] by Moderator

Re: BUGZILLA report all bugs here![message #332751] Sat, 17 May 2014 22:21 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
M16AMachinegun
BASIC_RELIABILITY_ODDS in CTHConstraints will be set to 100 upon startup if user sets between 100 and 10000 as advertised in the description:

Quote:

; This is the basic chance PER SHOT to lose 1 point of weapon condition with each
; bullet fired. The formula for this chance is 1 in BASE_DEPRECIATE_CHANCE, so higher
; values result in slower degradation.
; The default value for OCTH is 15, but NCTH requires a **much** higher
; expenditure of bullets, resulting in severely-reduced weapon condition after every
; battle. Therefore, the default for NCTH is currently 150.
; Valid range is 0-10000.
BASIC_RELIABILITY_ODDS = (some number)


This bug's been around for at least a year.
Fixed in r7208. It's now 0-10000, like the ini says.


Re: BUGZILLA report all bugs here![message #332759] Sun, 18 May 2014 02:57 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
Another bug

Windows 7 64-bit: Lack of Windows Aero support

Game image stops updating when User Account Control dims the desktop

https://www.dropbox.com/s/najxfrazf0znjix/0517141955-00.jpg like this
Re: BUGZILLA report all bugs here![message #332760] Sun, 18 May 2014 03:22 Go to previous messageGo to next message
Slax

 
Messages:1448
Registered:July 2006
Location: People riding polar bears...
No aero when running on 16-bit graphics.

Re: BUGZILLA report all bugs here![message #332776] Sun, 18 May 2014 10:53 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
Totally incompatable, huh?

Thanks for the heads up. I figured out how to remove the screen-dimming 'feature'.
Re: BUGZILLA report all bugs here![message #332945] Wed, 21 May 2014 20:02 Go to previous messageGo to next message
M16AMachinegun

 
Messages:306
Registered:September 2013
I made a detailed post in http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/317593/7/Arulco_Folding_Stock_Discussio.html regarding a nasty visual glitch i've been having since early May
Post #332012

Re: BUGZILLA report all bugs here![message #332959] Thu, 22 May 2014 02:42 Go to previous messageGo to next message
sevenfm

 
Messages:1935
Registered:December 2012
Location: Soviet Russia
When trying to fire beyond the weapon range, merc often says "bad chance to hit" quote and refuses to fire (you have to click again to fire).
It's very annoying in NCTH, because weapon's range is not a big problen in this system - you can fire at 1.5x normal weapon range and hit.

Another problem is that AI uses the same routine to determine chances to fire or taking cover.
INT8 ChanceToGetThrough( SOLDIERTYPE * pFirer, FLOAT dEndX, FLOAT dEndY, FLOAT dEndZ )

And if this function does not work correctly (in NCTH), maybe it can also cause the known "AI refuses to fire" problem?



Re: BUGZILLA report all bugs here![message #332976] Thu, 22 May 2014 10:21 Go to previous messageGo to previous message
Slax

 
Messages:1448
Registered:July 2006
Location: People riding polar bears...
Sevenfm
When trying to fire beyond the weapon range, merc often says "bad chance to hit" quote and refuses to fire (you have to click again to fire).
It's very annoying in NCTH, because weapon's range is not a big problen in this system - you can fire at 1.5x normal weapon range and hit.

Another problem is that AI uses the same routine to determine chances to fire or taking cover.
INT8 ChanceToGetThrough( SOLDIERTYPE * pFirer, FLOAT dEndX, FLOAT dEndY, FLOAT dEndZ )

And if this function does not work correctly (in NCTH), maybe it can also cause the known "AI refuses to fire" problem?


Quoted for truth. Possibly very disorienting for new players. Definitely annoying for veterans.

Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Sat Sep 21 03:50:52 EEST 2019

Total time taken to generate the page: 0.04743 seconds