Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #334729] Thu, 31 July 2014 14:45 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1540
Registered:March 2009
Location: Broadwurschd-City
this map editor bug is in 4 quite a while
Re: BUGZILLA report all bugs here![message #334730] Thu, 31 July 2014 16:00 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Then this needs to be fixed quickly :thumbsup:
Re: BUGZILLA report all bugs here![message #334734] Thu, 31 July 2014 21:47 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
Wow. I have no idea on what exactly you are talking about (map editor bug about non-appearing items? That also affects normal gameplay? Explain the error dammit!), but your condescending tone doesn't exactly motivate to solve the problem either. Good luck then.

Is it so hard to describe the error before whining?


Re: BUGZILLA report all bugs here![message #334738] Fri, 01 August 2014 09:19 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Go in the Mapeditor
Set an Item (not vanila)
Open game an enter the sector with the new item
The item was not present
Which affects some Items (not vanila) such as rocket launchers, weapons and explosive that I have tested

better?
Re: BUGZILLA report all bugs here![message #334739] Fri, 01 August 2014 09:22 Go to previous messageGo to next message
JMich

 
Messages:569
Registered:January 2011
Location: Greece
DocSchuh
Go in the Mapeditor
Set an Item (not vanila)
Open game an enter the sector with the new item
The item was not present
Which affects some Items (not vanila) such as rocket launchers, weapons and explosive that I have tested

better?
Question, are you using the Vanilla VFS or the 1.13 one? If you use the vanilla one, quite a few options are not available, including items above 350.
Re: BUGZILLA report all bugs here![message #334740] Fri, 01 August 2014 09:27 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Hello JMich,

i have this tested with 1.13 - 7337 (English exe) and the Release Candidate 1.13 with English and German ja2.exe from this Thread: http://www.ja-galaxy-forum.com/ubbthreads.php/topics/334670/Re:_2014_Stable_Unofficial_Rel#Post334670
Re: BUGZILLA report all bugs here![message #334741] Fri, 01 August 2014 09:32 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Did you save the map in new format? If it is saved in old format all non-vanilla items are stripped off the map.

Re: BUGZILLA report all bugs here![message #334742] Fri, 01 August 2014 09:48 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
I think in new format!

Get this afternoon look again at home. Cant here at work just look.
Re: BUGZILLA report all bugs here![message #334743] Fri, 01 August 2014 10:17 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1540
Registered:March 2009
Location: Broadwurschd-City
how to save in new / old format are there more buttons?
Re: BUGZILLA report all bugs here![message #334744] Fri, 01 August 2014 10:58 Go to previous messageGo to next message
JMich

 
Messages:569
Registered:January 2011
Location: Greece
DocSchuh
i have this tested with 1.13 - 7337 (English exe) and the Release Candidate 1.13 with English and German ja2.exe from this Thread: http://www.ja-galaxy-forum.com/ubbthreads.php/topics/334670/Re:_2014_Stable_Unofficial_Rel#Post334670
All recent (including the 4870 stable one) versions of 1.13 include both a vanilla VFS and a 1.13 one. But the default is the 1.13 one, so I guess you didn't mess with that part.

P.S. You are modifying a map you haven't yet visited, right?
Re: BUGZILLA report all bugs here![message #334745] Fri, 01 August 2014 11:15 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Gorro der Gr

Re: BUGZILLA report all bugs here![message #334746] Fri, 01 August 2014 12:24 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Ah.. thanks JMich and Silversurfer I check this at home!
Re: BUGZILLA report all bugs here![message #334752] Fri, 01 August 2014 16:08 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1540
Registered:March 2009
Location: Broadwurschd-City
is there an ini or xml to remove this bloody idio... fine feature?
Re: BUGZILLA report all bugs here![message #334753] Fri, 01 August 2014 16:25 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Gorro der Gr

Re: BUGZILLA report all bugs here![message #334757] Fri, 01 August 2014 16:37 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1540
Registered:March 2009
Location: Broadwurschd-City
since this editor kills at least each 3rd big change, You have to do it part by part and got Your chance to miss this "feature" with each save. -> after any save You have to copy and rename the map (security 4 the work so far)

-> in my eyes this "feature" is solid crap and a source of errors and endless frustration

to have a crippling feature as unchangeable default reminds me to the idiotic smokers' argument: they never did complain about somebody NOT smoking
Re: BUGZILLA report all bugs here![message #334761] Fri, 01 August 2014 17:37 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Thanks Gorro so is it!

The Problem with the feature is, I musst all Maps for complete Arulco new save. :headbanger:

And if I forget once the hook to take the frustration out everything big when the Items fail.....

My Mod has 236 new Maps :wb:
Re: BUGZILLA report all bugs here![message #334762] Fri, 01 August 2014 17:49 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
I have no idea why this was changed. Saving non-vanilla items in old map format caused some problem but I don't remember it exactly anymore. Ask Kriplo, our editor master. Razz

Re: BUGZILLA report all bugs here![message #334763] Fri, 01 August 2014 18:22 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
I's ok with the feature. The item as in the sector when save in right format.

Thank for your help.

I go save all new map in new format! :headbanger:
Re: BUGZILLA report all bugs here![message #334785] Mon, 04 August 2014 15:52 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
If I move my soldiers in Combatmode at Tactical, then set this at your destination no longer out.

Is this is a bug or desired?
Re: BUGZILLA report all bugs here![message #334790] Tue, 05 August 2014 14:25 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Sorry, I don't understand what you mean. You are in combat and have a soldier at the map border? Then you click the arrow to move him across that map border to the neighboring sector? Now you are not able to cancel this movement order anymore on the strategic map?

If that was your question then yes, I believe it is working as intended. I suppose this is done to prevent the player from exploiting the feature and 'park mercs in transit' until the danger is gone on that border.

Re: BUGZILLA report all bugs here![message #334792] Tue, 05 August 2014 14:58 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Sorry i mean sit down the merc on our target destination. He remains in a crouch attitude. in 4870 she sitting on target destination.
Re: BUGZILLA report all bugs here![message #334793] Tue, 05 August 2014 16:57 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Ah, now I understand. You move your crouched merc to some destination and he remains in a stance that looks like he is still 'moving'. This is working as intended. It's a feature that allows to continue movement with less AP because the merc is still in 'movement mode'. As soon as you perform another action this 'movement mode' will be gone. The same applies to walking and crawling.

Re: BUGZILLA report all bugs here![message #334802] Tue, 05 August 2014 23:07 Go to previous messageGo to next message
waSchtl

 
Messages:92
Registered:February 2007
Location: Bavaria, Germany
Okay i understand. Thanks
Re: BUGZILLA report all bugs here![message #335043] Sun, 17 August 2014 15:02 Go to previous messageGo to next message
darkelf1986

 
Messages:23
Registered:February 2014
Using latest build SCI_Unstable_Revision_7393_on_GameDir_2100 - When opening Encyclopedia game freezes.
I can't say i need it, but...

P.S. Previous version worked fine, just checked

Any suggestions?

[Updated on: Mon, 18 August 2014 07:56] by Moderator

Re: BUGZILLA report all bugs here![message #335072] Tue, 19 August 2014 15:01 Go to previous messageGo to next message
darkelf1986

 
Messages:23
Registered:February 2014
Is there someone reading this forum section? Give some explanation please...
Re: BUGZILLA report all bugs here![message #335076] Tue, 19 August 2014 19:09 Go to previous messageGo to next message
Gambigobilla

 
Messages:714
Registered:July 2008
lurking this thread...
please continue
Re: BUGZILLA report all bugs here![message #335078] Tue, 19 August 2014 20:29 Go to previous messageGo to next message
darkelf1986

 
Messages:23
Registered:February 2014
I'll wait for the next release then, hope this will be fixed.
Re: BUGZILLA report all bugs here![message #335100] Wed, 20 August 2014 22:29 Go to previous messageGo to next message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
darkelf1986
Using latest build SCI_Unstable_Revision_7393_on_GameDir_2100 - When opening Encyclopedia game freezes.
I can't say i need it, but...

P.S. Previous version worked fine, just checked

Any suggestions?


It seems the "Diseaes-Feature" broke the Encyclopedia. Flugente is already informed.


Re: BUGZILLA report all bugs here![message #335106] Thu, 21 August 2014 17:20 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
AS said before, I still cannot reproduce that. I just did a clean new installation, start the exe, start a new game, open encyclopedia and it works. I do not experience any glitches here.


Re: BUGZILLA report all bugs here![message #335109] Thu, 21 August 2014 19:48 Go to previous messageGo to next message
darkelf1986

 
Messages:23
Registered:February 2014
So did I, installed from scratch, Encyclopedia now opens but menu's inside are freezing when "Downloading".

P.S. reinstalled once again to another folder - Encyclopedia doesn't open again

Flugente - are you using 1CD from gold version + patch 1.12 + latest SCI build?

P.P.S. Well, i noticed a strange thing - after changing resolution to 800X600 Encyclopedia opened but links inside still ended up with game freeze.

[Updated on: Thu, 21 August 2014 20:20] by Moderator

Re: BUGZILLA report all bugs here![message #335118] Fri, 22 August 2014 23:50 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
I can reproduce the problem in revision 7402 with a release exe but not with a debug exe. Sad
I used an old savegame, went to the encyclopedia web site and clicked on "Locations".

Re: BUGZILLA report all bugs here![message #335120] Sat, 23 August 2014 11:54 Go to previous messageGo to next message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
I can also confirm the freeze happens with a release exe


Re: BUGZILLA report all bugs here![message #335123] Sat, 23 August 2014 14:44 Go to previous messageGo to next message
buggerbot

 
Messages:32
Registered:October 2008
Same thing happening for me with encyclopedia.

Installed fresh Jagged Alliance 2 Gold v.1.10 english
Updated with v1.12 patch

Copied files from SCI pack SCI_Unstable_Revision_7393_on_GameDir_2100

My system is Windows 8.1 Pro 64bit.
Running Ja2.exe with settings:
- run as administrator
- compatibility mode Windows XP SP3
Changed in ja2.ini:
- resolution in game and in editor to 7 (1366x768)
- disabled intro
Also copied content of win8 fix to gamedir (files wined3d.dll, ddraw.dll and libwine.dll)

No other changes in inis, xmls and no mods. Started fresh new game with no changes in settings. New game parameters (difficulty, squad sizes etc) default. No changes.

After that, when new game starts i try to open encyclopedia before i do anything(not even hiring new mercs or creating own merc) the in game laptop loading bar appears, loads a little bit and then game stops. Sound still plays but i cant move in game cursor and pressing keyboard buttons does nothing.
Task manager does not mark application as "unresponsive".

ps. When running game and its loading (with SIRTECH LOGO) it says in top left corner:

"VERSION: RELEASE V1.13.7384 (DEVELOPMENT BUILD) BUILD 14.08.10"

[Updated on: Sat, 23 August 2014 15:00] by Moderator

Re: BUGZILLA report all bugs here![message #335124] Sat, 23 August 2014 20:01 Go to previous messageGo to next message
darkelf1986

 
Messages:23
Registered:February 2014
That's because of a new Disease feature i think. By the way, this feature can not be enabled in INI editor - it is always set to disabled.
Re: BUGZILLA report all bugs here![message #335125] Sat, 23 August 2014 21:03 Go to previous messageGo to next message
buggerbot

 
Messages:32
Registered:October 2008
I just want to mention it happens not only with encyclopedia but game is very unstable with ingame laptop in various places. Getting freezes during browsing bobbys rays all over the place.
Re: BUGZILLA report all bugs here![message #335129] Sun, 24 August 2014 15:03 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Randok

2. Bug: enemy in fire.
I throw in enemies Molotov Cocktail ( one turn ).
In the next turn of enemies to move in fire and clock spins without end.

I was finally able to find a fix the problem in revision 7405.

Fixed another problem with fire as well. The damage modifiers for movement through gas clouds were not applied to fire causing insane amounts of damage to the victim. Don't be surprised if your opponent can now exit fire clouds more easily. Before they were a certain death trap. Fixed in revision 7407.

Re: BUGZILLA report all bugs here![message #335130] Sun, 24 August 2014 20:20 Go to previous messageGo to next message
darkelf1986

 
Messages:23
Registered:February 2014
While creating a second or third IMP character, if choosing a Personnel button (where you see your created or hired mercenaries) causes the game to freeze most of the time.
Re: BUGZILLA report all bugs here![message #335137] Mon, 25 August 2014 19:00 Go to previous messageGo to next message
hrvg

 
Messages:158
Registered:August 2012
Location: France
Hi,

English version = SCI_Unstable_Revision_7393_on_GameDir_2100.7z
French version = JA2_FR_7365_Stable.exe


There is a little problem with "Rifle Pouch" item.
The item disappears when its slots are occupied by other items. (To screenshots):


http://zupimages.net/up/14/35/plez.jpg

Bobby Ray, ok. (English/French version)

http://zupimages.net/up/14/35/4rim.jpg

Before taking "Rifle Pouch". It's good. (English/French version)

http://zupimages.net/up/14/35/woyj.jpg

"Rifle Pouch" disappeared (NADA). It's not good. (English/French version)

http://zupimages.net/up/14/35/2xr0.jpg

"Rifle Pouch" disappeared (NADA). It's not good. (English/French version)


http://zupimages.net/up/14/35/i2to.jpg

Slots "Rifle Pouch" are free.... It's good. (English/French version)


Unless I am mistaken (if I'm not mistaken)...

[Updated on: Mon, 25 August 2014 23:06] by Moderator

Re: BUGZILLA report all bugs here![message #335139] Mon, 25 August 2014 23:12 Go to previous messageGo to next message
hrvg

 
Messages:158
Registered:August 2012
Location: France
Hi,
I have another problem...
For English version = "SCI_Unstable_Revision_7393_on_GameDir_2100.7z". Only, no french version "JA2_FR_7365_Stable.exe"

There is a big problem with Bobby Ray... If I click "Shipments"... My game crashes (blocked).
http://zupimages.net/up/14/35/xf2z.jpg
Re: BUGZILLA report all bugs here![message #335140] Tue, 26 August 2014 00:32 Go to previous messageGo to previous message
RoWa21

 
Messages:2030
Registered:October 2005
Location: Austria
@hrvg: I cannot reproduce the crash on Bobby Ray. I have sent you a PM.


Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Wed Sep 18 02:02:00 EEST 2019

Total time taken to generate the page: 0.03038 seconds