Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #325910] Sun, 29 September 2013 13:17 Go to previous messageGo to next message
Elvis_A

 
Messages:282
Registered:December 2012
Location: exUSSR
silversurfer
E1vS

Did you see the bug in my savegame when enemy soldiers could not finish their turn?

I saw the bug but I didn't find the problem in the code. I don't do AI stuff because I have no idea how that is build. Sorry.


Thanks anyway!

If you can handle this bug to someone that could look at it that would be great.
Re: BUGZILLA report all bugs here![message #325911] Sun, 29 September 2013 13:24 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
We don't "hand over" bugs to anyone. All of the work is voluntary. If someone wants to fix bugs he will look here anyway.

Re: BUGZILLA report all bugs here![message #325924] Sun, 29 September 2013 17:03 Go to previous messageGo to next message
E3245

 
Messages:46
Registered:August 2013
I found a bug in the latest build but I'm not sure if is just my build.
When you kill all hostiles in the map, TRIUMPH_MUSIC doesn't play. Instead it skips over to MUSIC_NOTHING. Autoresolve plays TRIUMPH_MUSIC though.
Re: BUGZILLA report all bugs here![message #325927] Sun, 29 September 2013 17:22 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
This could be related to the new music system that was revoked lately. Maybe one instance of the code still uses it. As long as the game doesn't crash because of that I would be too worried. As soon as the new music system is fixed it will be activated again.

Re: BUGZILLA report all bugs here![message #325929] Sun, 29 September 2013 18:06 Go to previous messageGo to next message
E3245

 
Messages:46
Registered:August 2013
Why was it revoked? Did it not work?
Re: BUGZILLA report all bugs here![message #325930] Sun, 29 September 2013 18:20 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
Yeah, it was causing several issues so it had to be disabled.

Re: BUGZILLA report all bugs here![message #325931] Sun, 29 September 2013 18:45 Go to previous messageGo to next message
Gambigobilla

 
Messages:709
Registered:July 2008
It was the much unneeded feature. You cannot even play any formats other than wav and ogg. Muting ingame music and playing music on winamp is much is much better. I won't mind it if it's optional but causing bugs is another story.
Re: BUGZILLA report all bugs here![message #325960] Mon, 30 September 2013 12:40 Go to previous messageGo to next message
Elvis_A

 
Messages:282
Registered:December 2012
Location: exUSSR
silversurfer
We don't "hand over" bugs to anyone. All of the work is voluntary. If someone wants to fix bugs he will look here anyway.


what I am trying to say is do coders have some bug database\to-do list?
Because some of bugs I posted earlier got ignored until recently somebody else posted them.

it would be easy for everybody if something like this will be done for clean 1.13
http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/288132/Arulco_Folding_Stock_FAQ_Read_.html#Post288134
Re: BUGZILLA report all bugs here![message #325968] Mon, 30 September 2013 16:04 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
There is a bug tracker site which is linked in the very first post of this thread -> http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/166487/BUGZILLA_report_all_bugs_here.html#Post166487

Anybody can report bugs there and add attachments to the report. However, you shouldn't expect that these bugs are resolved quicker just because they are on the official bug tracker. Wink

Re: BUGZILLA report all bugs here![message #326000] Mon, 30 September 2013 22:10 Go to previous messageGo to next message
Elvis_A

 
Messages:282
Registered:December 2012
Location: exUSSR
silversurfer
There is a bug tracker site which is linked in the very first post of this thread -> http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/166487/BUGZILLA_report_all_bugs_here.html#Post166487

Anybody can report bugs there and add attachments to the report. However, you shouldn't expect that these bugs are resolved quicker just because they are on the official bug tracker. Wink


OK. thanks for your info!
Re: BUGZILLA report all bugs here![message #326017] Tue, 01 October 2013 02:10 Go to previous messageGo to next message
Faalagorn

 
Messages:156
Registered:February 2012
Location: Poland
silversurfer
However, you shouldn't expect that these bugs are resolved quicker just because they are on the official bug tracker. Wink

I had the impression that it's actually even the opposite, and bugs reported to bugzilla are fixed rarer Sad. Which is quite a shame, since an issue tracker should be a better tool than a forum. Maybe the jaggzilla and the main infromational thread on reporting bugs could use some love? I'd love to switch back to using it knowing it would help resolving bugs quicker Smile.
Re: BUGZILLA report all bugs here![message #326111] Wed, 02 October 2013 17:09 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
Just in case anybody wonders why he can't drop all backpacks anymore with Shift+B during an interrupt - this bug was fixed in revision 6464. Only interrupters can drop their backpack now. Razz

Re: BUGZILLA report all bugs here![message #326134] Wed, 02 October 2013 21:42 Go to previous messageGo to next message
Uriens

 
Messages:332
Registered:July 2006
I liked that bug. Sad
Oh well. It was an exploit so lets give it a proper funeral :rip: and move on. :walking:
Re: BUGZILLA report all bugs here![message #326209] Thu, 03 October 2013 23:46 Go to previous messageGo to next message
Kriplo

 
Messages:261
Registered:February 2008
Location: Zagreb - Croatia
r6465 contains:

Brief: //dnl ch73
- Fixing bad APs deduction when using blade or blunt weapons and punching in general from different stances when need turn to your target.
Details:
- Fix wrong APs deduction and animation change when go to attack with knife or punch from prone.
- Fix no APs cost for martial artist when perform turning.
- When target was prone there was several problems in defining turnover and stance cost as range to them could vary depending of obstacles between, and as punch or stub in general use same logic put all stubbing and punching under one function MinAPsToPunch which should solve current problems with APs calculations.
- Still there are no turning cost when going to stub or punch from moving, but this problem is not related with MinAPsToAttack but with UIPlotPath which don't add turning cost, hope someone in the future will add this feature which never exist.


Although this will fix most APs problems with punch and stub, sometimes if you perform move to your target cursor will show 1AP more then real cost due to BPs change, as CalcActionPoints will show less full base APs then before attack because breath was changed. Unfortunately BPs calculation is total mess as spread to several functions and couldn't find how to estimate BPs cost before moving to your target.

Planting explosive, exchanging items or throwing items between mercs also show incorrect values, well except that if anybody find more problems related to bad APs will try to fix it next week.
Re: BUGZILLA report all bugs here![message #326218] Fri, 04 October 2013 14:30 Go to previous messageGo to next message
E3245

 
Messages:46
Registered:August 2013
I found another bug. There was a bloodcat ambush between Drassen and Alma, but there was no wildcats. The mobile militia was there as well, so I assumed that they killed the bloodcats. I went to the tactical screen and tried to move my troops, but I couldn't because you cannot move troops in tactical until the hostiles have been dealt with. I went to autoresolve and there was no enemies, so the mobile militia automatically won.

I don't have the savegame to reproduce this, sadly. I Just wrote this down to let you know about this bug.
Re: BUGZILLA report all bugs here![message #326227] Fri, 04 October 2013 17:41 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
There was probably one cat left somewhere in the sector. Bloodcats are handled a little different than enemy soldiers. They will not trigger combat on the map screen but the game will still tell you that there are enemies around. I have only encountered them with my team and no militia around so maybe there is some strange game behaviour. I wouldn't worry about it much since it doesn't break anything.

Re: BUGZILLA report all bugs here![message #326256] Sat, 05 October 2013 13:24 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Hallo to everyone,
I just filled a bug report and thought I might state that here as well in case forum is more popular among developers to read that bugzilla :confused:

http://ja2.discusrock.org/bugzilla/show_bug.cgi?id=634

Basically, using JA2_6465.exe (or any older possible) with newest gamedir, the game hangs up in civilian turn in Alma academy sector, if any merc dies from mortar shot or some certain other way.

If I should explain more, made any mistake or even just used some non-traditional way in report, let me know (e.g. should I use attachments or do you prefer to associate URL to file-sharing service like I did?)

Thanks
Re: BUGZILLA report all bugs here![message #326280] Sun, 06 October 2013 00:58 Go to previous messageGo to next message
Faalagorn

 
Messages:156
Registered:February 2012
Location: Poland
Speaking of Bugzilla, that thing has been crossing my mind for the past few days - ]like I mentioned before, the original one is kinda outdated and unpolished, and with no proper instructions how to submit bugs and overall low awareness, so the bugs are often reported in the forums instead in the issue tracker (Well, despite having an account, even I'm doing it myself, feeling it's not worth the effort). However, the issue tracking tool is still better than the forum, for example bugs reported to the tracker won't be forgotten as easily as the ones reported on forum some time ago.

So here's my questions/ideas:
  • First of all - I suspect JAPH, the thread creator, is the current maintainer of JaggZilla - is he still around there?
  • Aside from upgrading to the newest version of bugzilla, the bug reporting window could use some improvements, especially the "Version" section of it. I suggest using simple "stable" and "development" with additional field to state the revision number (like 4870 or 6465)
  • And finally, some additional guides/instructions/guidelines on how to use JaggZilla and how to report bugs could be useful.
If any help will be needed related to this manner, I will be glad to help Smile. It would be nice to see 1.13 issue tracker improved and easier to use Smile
Re: BUGZILLA report all bugs here![message #326284] Sun, 06 October 2013 01:28 Go to previous messageGo to next message
dieMaus

 
Messages:11
Registered:December 2010
Well, so i finally started a game, made my IMP, assembled the team, still there is a reproducable problem :/ (Version 6462)
I dunno if i should post this somewhere else (bug section?), pls tell me if so Smile

The game wont make a save, but i got a quicksave, and every time i load it, the same error appears after some seconds. Maybe its another "quick fix" thing? So, the following error is displayed:

Assertion Failure [Line 4861 in file strategicmap.cpp].....
Dr. Q is not in a valid group (pSoldier -> ubGroupID is 0)


Thx in advance for any help!

Edit: Hm, seems i can prevent the game from crashing. I went to strategic view, assigned all 3 from Squad1 to Squad2. Now no crash. Strange...
Re: BUGZILLA report all bugs here![message #326316] Sun, 06 October 2013 23:31 Go to previous messageGo to next message
derek

 
Messages:149
Registered:April 2010
In 6471 where are the names of M.E.R.C. JA1 mercs? (they don't show up)



p.s. Copied JA2 gold, downloaded SCI_Unstable_Revision_6471_on_GameDir_1806.7z and interested, and downloaded JA2_6471.7z and inserted.
Re: BUGZILLA report all bugs here![message #326321] Sun, 06 October 2013 23:46 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
No idea. It's working fine here. These two for example:

http://img809.imageshack.us/img809/9803/yd0m.png

Using revision 6473 with GameDir 1808. There haven't been any changes in M.E.R.C display from your revision.

Re: BUGZILLA report all bugs here![message #326323] Sun, 06 October 2013 23:49 Go to previous messageGo to next message
derek

 
Messages:149
Registered:April 2010
Don't know... I'm missing it and their stats.
Re: BUGZILLA report all bugs here![message #326547] Sat, 12 October 2013 19:53 Go to previous messageGo to next message
dieMaus

 
Messages:11
Registered:December 2010
2 more questions/probably bugs:

First, the cleaning kit - option team - only cleans the weapons from the merc holding the kit. Also the other option only cleans his/her guns.

Second, the BIO from MERC soldier "Raffi" hints he "could" have some medic skills, still his medic skill is on 4... Not that "immersiv" Wink
Re: BUGZILLA report all bugs here![message #326552] Sat, 12 October 2013 21:34 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
His medic skills are probably fighting pain with drugs. Wink

Re: BUGZILLA report all bugs here![message #326557] Sun, 13 October 2013 10:48 Go to previous messageGo to next message
E3245

 
Messages:46
Registered:August 2013
I have another bug to report. When you have incompatible attachments (for example Kobra and PSO-3), the UI buttons grey out and you have to click a blank box in the sector inventory many times before you can do anything again.

Another thing, sometimes the NADA item appears and if you click a empty box in the area where you apply weapon attachment, the game crashes or hangs. If you constantly click on a empty box in the sector inventory, the NADA disappears.

One more bug to report, applying the rifle sling to an AN-94 crashes the game.
Re: BUGZILLA report all bugs here![message #326562] Sun, 13 October 2013 15:10 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
E3245
I have another bug to report. When you have incompatible attachments (for example Kobra and PSO-3), the UI buttons grey out and you have to click a blank box in the sector inventory many times before you can do anything again.

Just click at an empty spot in the attachment area and the UDB will be closed. Or click an empty field in sector inventory with your item at the cursor. The item will be placed in that empty slot. It's one click and not many. Can't reproduce your problem with stock 1.13.

E3245

Another thing, sometimes the NADA item appears and if you click a empty box in the area where you apply weapon attachment, the game crashes or hangs. If you constantly click on a empty box in the sector inventory, the NADA disappears.

There shouldn't be any NADA items in stock 1.13. Probably mod related.

E3245

One more bug to report, applying the rifle sling to an AN-94 crashes the game.

Not a stock 1.13 problem. I can attach the rifle sling to the external slot of the Abakan just fine. Must be mod related.

Re: BUGZILLA report all bugs here![message #326571] Sun, 13 October 2013 21:38 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
I don't know if some players were abusing this bug but from revision 6486 it is not possible anymore to fly to an enemy sector and start any assignments like training, repair etc...
As soon as one merc leaves the heli (is assigned to a squad) the rest of the passengers is forced out as well and combat is initiated.

No more lallygagging in enemy sectors! Razz

Re: BUGZILLA report all bugs here![message #326616] Mon, 14 October 2013 23:00 Go to previous messageGo to next message
Parkan

 
Messages:446
Registered:April 2010
Location: Russia,Sevastopol

After adding MOLLE there is some glitch with enemy inventory.Sometimes after death of enemy soldier there is a chance of spawn of ammo crate of some ammunition(example 4.6*30 mm ammo crate which weight 50 kg).Plus there is a glitches with some ammunition too:
If IMP char starts with Mp5\10A whic have 10mm ammunition,it start with two magazines,but those magazine have a description and image of 8 round pistol magazine.(sometime it has type of glaser ammunition,sometime Armor piercing,but in all those ammo is grey ammo)

[Updated on: Mon, 14 October 2013 23:01] by Moderator

Re: BUGZILLA report all bugs here![message #326617] Mon, 14 October 2013 23:06 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
Oh oh, I have a feeling that this has something to do with the changes in items.xml that have been done with the outdated XML editor.

Re: BUGZILLA report all bugs here![message #326619] Mon, 14 October 2013 23:18 Go to previous messageGo to next message
Parkan

 
Messages:446
Registered:April 2010
Location: Russia,Sevastopol

There is a misunderstandings in Ammo section.Some magazines\crates(some crates has ammo capacity of 8 rounds so they spawned in enemy inventory,but has a huge weight) has wrong ammo-rounds\description or caliber.I looked with xml editor(with updated editor by Jmich)
Re: BUGZILLA report all bugs here![message #326620] Mon, 14 October 2013 23:35 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
Yes, definitely related to the changes in Items.xml. The for lots of ammo items was changed and now points to the wrong ammo type. Too tired to fix this now. Will do it tomorrow.

Re: BUGZILLA report all bugs here![message #326623] Tue, 15 October 2013 14:37 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
Ok, fixed the for all items in GameDir 1825. They are now back on their original value.
Also added some missing tags to MercStartingGear.xml but this needs more work. There are lots of tags missing and I'm not sure at them moment if they have a default value (item status for example).

Re: BUGZILLA report all bugs here![message #326624] Tue, 15 October 2013 16:24 Go to previous messageGo to next message
Elvis_A

 
Messages:282
Registered:December 2012
Location: exUSSR
dir 1825
exe 6478

It was working before molle system introduction.

cannot start the game:
*** Tue Oct 15 18:03:57 2013 ***
[ 9WL54-7DTTB-CKBTI-3FCLY-OX3OX ]

[7.60445] : ERROR : File : Init.cpp
Line : 1409
Location : InitializeJA2
Loading external data failed
File : Init.cpp
Line : 292
Location : LoadExternalGameplayData
Items\Items.xml
Re: BUGZILLA report all bugs here![message #326626] Tue, 15 October 2013 17:22 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
:headscratch:
I don't know. Just started the current exe 6495 with GameDir 1825 and it starts fine.

edit: You can try this exe and see if it helps.

https://ja2svn.no-ip.org/source/ja2/branches/silversurfer/JA2_6495.exe

edit: Maybe your old 6478 exe doesn't like the new tag in Items.xml.

[Updated on: Tue, 15 October 2013 17:33] by Moderator


Re: BUGZILLA report all bugs here![message #326630] Tue, 15 October 2013 18:32 Go to previous messageGo to next message
Elvis_A

 
Messages:282
Registered:December 2012
Location: exUSSR
silversurfer
:headscratch:
I don't know. Just started the current exe 6495 with GameDir 1825 and it starts fine.

edit: You can try this exe and see if it helps.

https://ja2svn.no-ip.org/source/ja2/branches/silversurfer/JA2_6495.exe

edit: Maybe your old 6478 exe doesn't like the new tag in Items.xml.


I guess I am noob in SVN software. Embarrassed I reverted files, now it works fine. Thanks for response.


edit
1)russian molle pistol holster looks weird - goes off slot
2) any chance to change picture of shotgun holster? now it looks like smg
3) is it possible to change syringe slot image?

[Updated on: Tue, 15 October 2013 18:39] by Moderator

Re: BUGZILLA report all bugs here![message #326633] Tue, 15 October 2013 19:33 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
E1vS

1)russian molle pistol holster looks weird - goes off slot

This has the wrong pocket. *fixing*

E1vS

2) any chance to change picture of shotgun holster? now it looks like smg
3) is it possible to change syringe slot image?

There is no silhouette graphic for shotgun and syringe. Must be created first.

Re: BUGZILLA report all bugs here![message #326637] Tue, 15 October 2013 21:21 Go to previous messageGo to next message
silversurfer

 
Messages:2760
Registered:May 2009
Fixed the Russian Molle pistol holster in GameDir 1827.
In addition to that I created a new silhouette for the shotgun holster.

Re: BUGZILLA report all bugs here![message #326638] Tue, 15 October 2013 22:49 Go to previous messageGo to next message
Parkan

 
Messages:446
Registered:April 2010
Location: Russia,Sevastopol

thank you for quick fix =)
Re: BUGZILLA report all bugs here![message #326829] Sat, 19 October 2013 19:35 Go to previous messageGo to next message
Elvis_A

 
Messages:282
Registered:December 2012
Location: exUSSR
kit drop pouch does not hold camo kit but supposed to
edit.
I am pretty sure that in previous version Glock 18 supported C-mags. I have even merc with glock 18 from old savestate with 30 rounds

[Updated on: Sat, 19 October 2013 20:05] by Moderator

Re: BUGZILLA report all bugs here![message #326835] Sat, 19 October 2013 20:20 Go to previous messageGo to previous message
Flugente

 
Messages:3542
Registered:April 2009
Location: Germany
E1vS
I am pretty sure that in previous version Glock 18 supported C-mags. I have even merc with glock 18 from old savestate with 30 rounds
Wut? Not in the trunk. :armsfolded:


Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Wed Oct 28 01:48:25 EET 2020

Total time taken to generate the page: 0.03746 seconds