Home » SIRTECH CLASSICS » Jagged Alliance 2 » JA2 Crashes, Bugs and Fixes » Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video
Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #191251] Sun, 20 July 2008 05:28 Go to next message
sleet01
Messages:2
Registered:July 2008
Location: Seattle, WA
I finally pulled out my old "Conquest Pack" copy of JA2 and UB and installed them on my laptop so I can get back in practice in time for JA3 and the NDS JA - practice takes me a while - and I've been having the most annoying problem:

95% of the time the various incarnations are unplayable due to slowness. The opening movie (for 1.12 and UB) seems to cause a ton of disk thrashing, and freezes for an little bit every second or so. The main menu in all cases is so laggy as to be nearly-unnavigable; the 2 FPS frame rate makes it pretty hard to maneuver . I tried going into a saved game one time and had to sit for about 20 seconds while the game decided whether it was going to bring up the menu so I could quit or not.

I say 95% because one time, just one time, the game ran smoothly and I was happily playing along until bed time. I was able to make two save games without issue, and I looked forward to continuing this process until the end of the game, but it was not to be. The strange thing is, this occurred on the second or third time I tried playing, not the very first. I have not had another instance of that good performance in the week or so since, either.

My system specs are as follows:
IBM Thinkpad with Core Duo @ 2GHz
1 GB of RAM
Mobility Radeon x1400
XP Pro SP3

I've update all the drivers, uninstalled and reinstalled various portions of the game at separate times and altogether, and switched all manner of performance, networking, and antivirus (in this case Symantec) on and off in an attempt to recreate that one instance of smooth performance, but no dice. I'm at my wits' end!

Does anyone have any suggestions for getting that early good performance back?
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #191816] Sat, 26 July 2008 03:58 Go to previous messageGo to next message
sleet01
Messages:2
Registered:July 2008
Location: Seattle, WA
Well, I made some progress.

This afternoon I installed Diablo 2: Lord of Destruction on the laptop and messed around with it for a little while. LoD loaded and ran very well, without any blips, except for a brief stutter at the very beginning of the opening movie. Heartened by this success and by the memory that I had experienced the first smooth, playable JA2 game soon after installing Diablo 2 itself, I exited LoD and started JA2 1.13 again, and lo and behold, it ran at a normal speed. Menus were smooth, the game was all-around playable, and I was able to kill off all enemies in the first mission without any problems.

I quit the game again and let the laptop go to sleep, and then tried it again an hour later. Running LoD first did not help this time, and JA2 was again a sluggish, uncontrollable mess. I even tried running both at the same time; this just made the problems of before worse. The only other thing I did the first time that I did not attempt subsequently was running the Diablo 2: Lord of Darkness patch before starting JA2.

I'm starting to suspect that there's something screwy with the Core Duo's power-ramping, and that some programs are able to kick it into full-speed mode long enough to start JA2 where just starting JA2 doesn't give the CPU its queue to provide more cycles. That, or the laptop worships Satan and my attempts to patch Diablo II games temporarily pleased it enough to run JA2.
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #191826] Sat, 26 July 2008 07:50 Go to previous messageGo to next message
SpaceViking

 
Messages:760
Registered:January 2004
Location: Rochester, Minnesota, USA
Have you run System Update on your ThinkPad? That can update some internal things that otherwise don't get updated. Depending on the age of your machine it may or may not be installed. If not you can get it from Lenovo (search on their web page for "ThinkPad System Update").

In any case I've run JA2 on my ThinkPad T61p which has a CoreDuo CPU I believe and it runs just fine.


Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #312588] Wed, 28 November 2012 17:51 Go to previous messageGo to next message
phoenicksCZ
Messages:2
Registered:November 2012
Gentlemen.

I found a solution to most performance and low framerate issues with Jagged Alliance 2.

I am running JA2 Gold 1.13 v4870. I was getting extremely low framerate and lags, a single bullet would fly for like 5-10 seconds. Then I remembered a solution to a very similar problem in Planescape: Torment.

The solution:
...is to make JA2 engine run on WineD3D instead of regular DirectX. WineD3D is a component of Wine and is generally used to run Windows apps on non-Win systems, but can also be used on Windows.

How to do that:
1) Download wined3d.exe from http://www.nongnu.org/wined3d/
2) Don't run the program! instead, extract it's contents with 7Zip or somesuch http://www.7-zip.org/download.html
3) Copy ddraw.dll, libwine.dll and wined3d.dll from extracted $SYSWIN folder into the root folder of your JA2 installation (e.g. C:\Games\Jagged Alliance 2 Gold\)
4) Run the game. It may take a bit longer to start
5) Enjoy one of the best games ever in as high FPS as your hardware can handle

Credits:
- Guys who made WineD3D
- aqrit on Spellhold Studios board for the Planescape: Torment FPS solution, of which this is a shameless duplicate

This may work with other oldies as well. Use at your own risk.

Cheers,
phoenicksCZ
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #323406] Mon, 29 July 2013 04:18 Go to previous messageGo to next message
Geotrismegistos
Messages:2
Registered:June 2007
Location: Greece
phoenicksCZ
Gentlemen.

I found a solution to most performance and low framerate issues with Jagged Alliance 2.

I am running JA2 Gold 1.13 v4870. I was getting extremely low framerate and lags, a single bullet would fly for like 5-10 seconds. Then I remembered a solution to a very similar problem in Planescape: Torment.

The solution:
...is to make JA2 engine run on WineD3D instead of regular DirectX. WineD3D is a component of Wine and is generally used to run Windows apps on non-Win systems, but can also be used on Windows.

How to do that:
1) Download wined3d.exe from http://www.nongnu.org/wined3d/
2) Don't run the program! instead, extract it's contents with 7Zip or somesuch http://www.7-zip.org/download.html
3) Copy ddraw.dll, libwine.dll and wined3d.dll from extracted $SYSWIN folder into the root folder of your JA2 installation (e.g. C:\Games\Jagged Alliance 2 Gold\)
4) Run the game. It may take a bit longer to start
5) Enjoy one of the best games ever in as high FPS as your hardware can handle

Credits:
- Guys who made WineD3D
- aqrit on Spellhold Studios board for the Planescape: Torment FPS solution, of which this is a shameless duplicate

This may work with other oldies as well. Use at your own risk.

Cheers,
phoenicksCZ


Thank you so much for this phoenicksCZ. I tried running JA2 on Windows 8, but after the run as admin/ xp sp3 compatibility, the game was horribly slow.
I tried ur method and after a lot of trial and error i made it work.

Download this version of the software(Because at this date there are newer versions that didnt work for me):
http://ftp.cc.uoc.gr/mirrors/nongnu.org//wined3d/1.1.37/wined3d.exe

Then use the 3 files from the folder "SYSDIR"
Enjoy the best game of all times, with the best mod ever.
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #323440] Mon, 29 July 2013 18:42 Go to previous messageGo to next message
Geotrismegistos
Messages:2
Registered:June 2007
Location: Greece
The game also runs on my netbook with Puppy Linux OS using wine.
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #330762] Fri, 21 February 2014 16:43 Go to previous messageGo to next message
Diango
Messages:2
Registered:February 2014
Sorry for bumping an extremely old thread, but I still love this game Sad.

I recently installed the new UC1.13 following a youtube instruction video... and I had to resort to this .dll trick just to get it running.

Basically, like many users are experiencing, the game runs incredibly sluggish, just unplayable.

This .dll trick makes it a bit less sluggish. A bit.

As soon as I enter the subway (lots of people there) the game grinds to a stumbling halt.

I (am trying to!) play this game on my laptop, which has a dualcore i7, 4GB ram, SSD, Intel Graphics 4000 on-board and running Windows 8.1 (don't shoot me, it came with the machine).

I'm using the game as bought from GOG with the 1.13 mod (latest unstable version), UC and UC1.13 installed.


As mentioned by the poster I am quoting, only THAT specific version of the files extracted from the Wine3D.exe file will get the game to run at all. All other versions will crash it on startup.

I'm at wits end here... what do I have to do to play this game like in the old days?
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #334788] Mon, 04 August 2014 23:03 Go to previous messageGo to next message
Huberclim

 
Messages:34
Registered:May 2011
Location: Germany
Wow, that trick works like a charm!
Thank you very much.

I'm using Win8 64 bit with i7 and 8GB ram and 256GB SSD and it was horribly slow (bullets like flying 3,4 seconds...)

I used the three files in the downloadlink from Geotrismegistos, it works now at full speed.

Thanks again!
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #335292] Sun, 31 August 2014 08:46 Go to previous messageGo to next message
igorsdad
Messages:2
Registered:August 2014
Geotrismegistos


Download this version of the software(Because at this date there are newer versions that didnt work for me):
http://ftp.cc.uoc.gr/mirrors/nongnu.org//wined3d/1.1.37/wined3d.exe

Then use the 3 files from the folder "SYSDIR"
Enjoy the best game of all times, with the best mod ever.


Ok, this fixed the performance issues (slowdown stuff) for me on Windows 8.1. BUT, now the campaign map is unusable/blurry, looks like this:

http://i57.tinypic.com/2ps0sqg.jpg

PLEASE HELP
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #335344] Mon, 01 September 2014 00:15 Go to previous messageGo to next message
Huberclim

 
Messages:34
Registered:May 2011
Location: Germany
That is normal, it should show the not explored yet terrain.
You can turn that blurry vision off in the options I think.
Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #335345] Mon, 01 September 2014 00:38 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3806
Registered:July 2009
No, that is not normal. You should get a greyscale map, not some blurr.
But try changing it back from b/w to the old darken effect in the options.

[Updated on: Mon, 01 September 2014 00:39] by Moderator



Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #335362] Mon, 01 September 2014 23:17 Go to previous messageGo to next message
Firestorm_01
Messages:1
Registered:May 2011
I have same issue even on helicopter map(red blur) and roaming militia map (white blur). So there is problem in map filters itself while using this dlls.

But standart b/w map works fine. Perhaps there is should be option to enable default filter on all type of maps. Maybe it is dirty but it is looks like simple solution.

[Updated on: Mon, 01 September 2014 23:20] by Moderator

Re: Jagged Alliance 2, UB, and 1.13 all run extremely slow w/choppy video[message #336009] Mon, 22 September 2014 15:12 Go to previous message
martinistripes
Messages:2
Registered:September 2014
Geotrismegistos
Download this version of the software(Because at this date there are newer versions that didnt work for me):
http://ftp.cc.uoc.gr/mirrors/nongnu.org//wined3d/1.1.37/wined3d.exe

Then use the 3 files from the folder "SYSDIR"
Enjoy the best game of all times, with the best mod ever.


Big thanks for this. Took me a while searching, but it was this post that got me playing.

Newer versions of WineD3D are missing the ddraw file.

[Updated on: Mon, 22 September 2014 15:13] by Moderator

Previous Topic: Win7 JA2 1.13 - can't place mercs on map
Next Topic: Can't train militia at SAM site
Goto Forum:
  


Current Time: Wed May 23 04:35:51 EEST 2018

Total time taken to generate the page: 0.00909 seconds