Home » SIRTECH CLASSICS » Jagged Alliance 2 » JA2 Technical Department » Unable to patch 1.10 Gold to 1.12 Gold
Unable to patch 1.10 Gold to 1.12 Gold[message #211075] Wed, 25 March 2009 11:41 Go to next message
banshee256
Messages:3
Registered:March 2009
I have a annoying problem. I have recently dug Jagged Alliance 2 Gold edition out of the closet, because there simply aren't any good games being made anymore and wanted to play something I knew was worth my time. But since I last played it, I've bought a new computer... With Vista pre-installed. So I made a pot of coffee and prepared myself for an epic battle between man and machine, the price being getting JA2 to work.

Turns out I didn't even manage to drink the first cup before I claimed victory over the wicked machine. Put in CD -> click install -> install -> launch, no problems (I must admit, I was a little disapointed that Vista gave up so easily). Rather confused I started to look for a patch and sure enough, there is the 1.12 Gold patch. But it seems that Vista had lured me into a false sense of security, because I can't install the patch. I can the same error every time: "We are unable to locate Jagged Alliance 2 Gold on your computer." or something to that effect. But I have installed it, played it and it works. But not the patch? That's a low blow, even for Vista.

I'm not one to give up a good game that easily, so I've googled for a couple of days, but I can't find a single post, blog, comment or anything else from anyone else, who has the same problem. Not one. So I was kind of hoping that one of the gurus here could help?

Oh, and something else. I'm a purist, so I'm not installing 1.13. It has some nice features, but it also changes the balance, adds items/mercs and so forth and I don't like that sort of thing.

Thank you for any and all help you can give me Smile
Re: Unable to patch 1.10 Gold to 1.12 Gold[message #211106] Wed, 25 March 2009 14:44 Go to previous messageGo to next message
cougar

 
Messages:260
Registered:March 2000
You could try to install JA2 in a different folder (like c:\games\ja2) instead of program/program files since they seem to have extra protection that can cause problems. Another thing you could try is to set both ja2.exe and the patch file to compatibility mode for XP or windows 98.
Re: Unable to patch 1.10 Gold to 1.12 Gold[message #211108] Wed, 25 March 2009 16:28 Go to previous messageGo to next message
banshee256
Messages:3
Registered:March 2009
I have the games installed in my games folder on my secondary partition (i.e. D:\Games\JA2), so I don't think that that is the issue.

I haven't tried setting ja2.exe in any form of compatibility, but I'll give that a shot when I get home.
Re: Unable to patch 1.10 Gold to 1.12 Gold[message #211143] Thu, 26 March 2009 00:59 Go to previous messageGo to next message
mgl

 
Messages:254
Registered:December 2007
Location: France
Banshee256
Oh, and something else. I'm a purist, so I'm not installing 1.13. It has some nice features, but it also changes the balance, adds items/mercs and so forth and I don't like that sort of thing.

Then you may want to try Tron's Stracciatella.
It fixes many bugs from 1.12 but doesn't change anything.
Though I don't know if stracciatella will work with the data for 1.10.

Take a look at its dedicated forum.

The latest official release is "v0.11 - Liquorice" (several languages available)
But the latest binaries for Windows I noticed are at http://tron.homeunix.org/ja2/ja2.ENGLISH.5482.exe.gz (english version only).

There is a FAQ on how to install it.
Basically, you need an installation of the original game.
Then you install the binaries for Windows of stracciatella where you want.
Run stracciatella's program "ja2.exe" once.
It will create the configuration file "JA2.INI" somewhere. Edit it to point to the folder where the original game stores its data.
Run straciatella's "ja2.exe" again and play.

Re: Unable to patch 1.10 Gold to 1.12 Gold[message #211157] Thu, 26 March 2009 08:30 Go to previous messageGo to next message
banshee256
Messages:3
Registered:March 2009
mgl
Banshee256
Oh, and something else. I'm a purist, so I'm not installing 1.13. It has some nice features, but it also changes the balance, adds items/mercs and so forth and I don't like that sort of thing.

Then you may want to try Tron's Stracciatella.
It fixes many bugs from 1.12 but doesn't change anything.
Though I don't know if stracciatella will work with the data for 1.10.

Take a look at its dedicated forum.

The latest official release is "v0.11 - Liquorice" (several languages available)
But the latest binaries for Windows I noticed are at http://tron.homeunix.org/ja2/ja2.ENGLISH.5482.exe.gz (english version only).

There is a FAQ on how to install it.
Basically, you need an installation of the original game.
Then you install the binaries for Windows of stracciatella where you want.
Run stracciatella's program "ja2.exe" once.
It will create the configuration file "JA2.INI" somewhere. Edit it to point to the folder where the original game stores its data.
Run straciatella's "ja2.exe" again and play.


Thanks for the tip, mate Smile I'll be looking into that tonight.

I found something... odd yesterday. When I launched the game, it said version 1.12 in the sir-tek intro. Now, I KNOW that I haven't been able to patch it and I KNOW I haven't done anything to the installation of JA2 after doing a completely fresh install. Does anyone know if there was a Gold version launched with the patch pre-installed? Is there anyway to check if it is in fact installed, besides the intro?

[Updated on: Thu, 26 March 2009 08:30] by Moderator

Re: Unable to patch 1.10 Gold to 1.12 Gold[message #212350] Tue, 07 April 2009 18:48 Go to previous messageGo to next message
Shanga

 
Messages:3516
Registered:January 2000
Location: Danubia
JA2 Gold should be patched to the latest vanilla/original version. You don't need to repatch it.

[color:#CC0000]LATER EDIT: Oh, you managed to find an old v.10 Gold... Sorry for you Smile. I tested the stupid patch exe and it does the same on XP. I suspect it's just a lame installer which looks for the default path or registry entries.[/color]


As for the default path, remember that telling JA2 to install on Vista is like telling a grandma to send you her recipes over YIM. Vista locks a lot of registry and ini files and unless you used "Install/Run as Administrator" option, I doubt you can patch anything. You might even have trouble saving, because of the same reason.

Quote:
Oh, and something else. I'm a purist, so I'm not installing 1.13. It has some nice features, but it also changes the balance, adds items/mercs and so forth and I don't like that sort of thing.


Give it time. After you have taken Medune 1000th time, with your IMP armed only with a knife, you'll want... heck... you'll CRY to play the (in)famous Drassen counterattack.

[Updated on: Tue, 07 April 2009 19:30] by Moderator



Re: Unable to patch 1.10 Gold to 1.12 Gold[message #212359] Tue, 07 April 2009 19:23 Go to previous messageGo to next message
lockie

 
Messages:3929
Registered:February 2006
Location: Scotland
Quote:
Give it time. After you have taken Medune 1000th time, with your IMP armed only with a knife, you'll want... heck... you'll CRY to play the (in)famous Drassen counterattack.



Knife ........ huh , sissy boy , bare nuckle fighting is the only way for a man , :superman:


Re: Unable to patch 1.10 Gold to 1.12 Gold[message #212363] Tue, 07 April 2009 19:26 Go to previous messageGo to next message
Shanga

 
Messages:3516
Registered:January 2000
Location: Danubia

Actually when my IMP walks in an enemy sector the redshirts get a pop-up on the screen saying "Surrender to Shanga?". And there're only two buttons on it "YES" and "DIE".


Re: Unable to patch 1.10 Gold to 1.12 Gold[message #212364] Tue, 07 April 2009 19:35 Go to previous messageGo to next message
lockie

 
Messages:3929
Registered:February 2006
Location: Scotland
Very Happy , well MY IMP causes mass distraction whenever he appears huntin' (bare) Surprised


Re: Unable to patch 1.10 Gold to 1.12 Gold[message #229812] Thu, 30 July 2009 06:41 Go to previous messageGo to next message
malamute20

 
Messages:6
Registered:July 2009
Sorry to interrupt, here, but I have the same problem as the OP -- but I'm running Windows XP SP3, and have never had Vista installed on my machine.

Just trying to update JA2 Gold from 1.10 to 1.12, and I get the same message, "Unable to locate an installation of JA2 on your computer."

I've searched Google, I've run through these forums and this thread obviously is where I need to address my issue, but I don't want a mod, I want the 1.12 patch. How can I get it installed? I am my system administrator, I only have one (admin) login for XP. What exactly am I missing?

Thanks in advance for any info on how to workaround this issue.

**EDIT**

Checking on something mentioned earlier, when I start up the game it DOES say v1.12, without having been patched. Does this mean that I bought JA2 Gold already patched? If so, why is there a Gold patch upgrading from 1.10 to 1.12?

[Updated on: Thu, 30 July 2009 06:43] by Moderator

Re: Unable to patch 1.10 Gold to 1.12 Gold[message #229814] Thu, 30 July 2009 06:49 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Looks like it. There were two Gold editions. 1.10 and 1.12. Earlier CD's are 1.10 and some later CD's are 1.12. If you grab the 1.13 mod then it covers all the 1.12 patch stuff too. Then get HAM and prepare for the most tactical version of JA2 yet Wink


Re: Unable to patch 1.10 Gold to 1.12 Gold[message #229822] Thu, 30 July 2009 07:01 Go to previous messageGo to next message
Blue_Fox

 
Messages:588
Registered:September 2006
Location: Netherlands
I have a JA 1.12 Gold Setup on Harddisk (628 MB), maybe an option to upload it.
You can install new version without CD.

[Updated on: Thu, 30 July 2009 07:08] by Moderator

Re: Unable to patch 1.10 Gold to 1.12 Gold[message #229922] Thu, 30 July 2009 20:18 Go to previous messageGo to next message
Majek

 
Messages:444
Registered:January 2003
Location: Slovenia
i think dvornik's page still works so look for the "patch" there. If that doesn't work, i dobut anything will Smile
http://members.lycos.co.uk/dvornik/



Re: Unable to patch 1.10 Gold to 1.12 Gold[message #345740 is a reply to message #229922] Mon, 30 May 2016 04:05 Go to previous messageGo to next message
Julix

 
Messages:92
Registered:June 2010
Location: Germany

I just realized that the Gold version I had been using forever was 1.10 ! - no wonder I had all those issues...
Re: Unable to patch 1.10 Gold to 1.12 Gold[message #345741 is a reply to message #345740] Mon, 30 May 2016 05:20 Go to previous messageGo to next message
edmortimer

 
Messages:1078
Registered:January 2015
Location: Home Free
Have you tried here:

http://www.fileplanet.com/118981/110000/fileinfo/Jagged-Alliance-2-Gold-1.12-




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: Unable to patch 1.10 Gold to 1.12 Gold[message #345743 is a reply to message #345741] Mon, 30 May 2016 06:04 Go to previous messageGo to next message
Julix

 
Messages:92
Registered:June 2010
Location: Germany

I managed to find a patch that I had stored away somewhere and then found I had the GOG installation file too somewhere. It's just been many years, so I went to the wrong folder first - twice. big grin
So now I have a 1.10->1.12 and a direct 1.12 JA2 installation (in different folders) - and the first one crashes on exit saying something about "demo version needed to be closed" and the second one says doesn't say demo, but just Jagged Alliance 2. Googled it and found an old thread about it saying not to worry about it, probably when I put 1.13 on either version I'll be fine. - I'll probably turn one into Vacation and the other into 8k, like you suggested happy
Re: Unable to patch 1.10 Gold to 1.12 Gold[message #345747 is a reply to message #345743] Mon, 30 May 2016 08:32 Go to previous message
edmortimer

 
Messages:1078
Registered:January 2015
Location: Home Free
Enjoy!




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Previous Topic: Crowdfunding Campaign: JA2STI Editor
Next Topic: How to change my Merc's voice?
Goto Forum:
  


Current Time: Tue Oct 16 17:29:47 EEST 2018

Total time taken to generate the page: 0.01117 seconds