Home » MODDING HQ 1.13 » v1.13 Modding, Customising, Editing » v1.13 Time Capsule (How-to Library) » editing IMP's in 1.13
Re: editing IMP's in 1.13[message #230406] Wed, 05 August 2009 05:46 Go to previous messageGo to next message
pheloncab

 
Messages:265
Registered:August 2004
Location: So. Cal. or texas
using vista???

if so, it has a tendency to lose the saves into the virtual store, if you go in there and copy paste them back into the main folder it works...



i haven't tried it with this editor, but i know that happens on the normal multiple IMP files
Re: editing IMP's in 1.13[message #232530] Fri, 04 September 2009 03:34 Go to previous messageGo to next message
LootFragg

 
Messages:344
Registered:August 2009
Location: Berlin, Germany
Hi. The German translation of IMPAct (v0.5b2 build 20090408) contains some mistakes:

Translation
- Hand to Hand is translated with "Beidh
Re: editing IMP's in 1.13[message #232545] Fri, 04 September 2009 11:48 Go to previous messageGo to next message
Logisteric

 
Messages:3500
Registered:December 2008
Location: B
it is a german programm

that you don't see those sounds, does not mean you don't have them - they are stored in 'speech.slf' - you see sounds that are eather added or altered in the 'speech'-folder
Re: editing IMP's in 1.13[message #234005] Mon, 28 September 2009 23:21 Go to previous messageGo to next message
TrashMan

 
Messages:64
Registered:November 2005
Location: Croatia
I don't get this.

I have a fresh JA2 and 1.13 installation + Night Ops.

I can't create a merc with this (cause I can't save), I have no idea where these .dat2 files are to be found (I can't find any) and I can't load the .imp file either (something about length)
Re: editing IMP's in 1.13[message #234006] Mon, 28 September 2009 23:26 Go to previous messageGo to next message
Logisteric

 
Messages:3500
Registered:December 2008
Location: B
night ops is not 1.13 compatible - you have a brand new mix-up, that won' work
Re: editing IMP's in 1.13[message #234010] Tue, 29 September 2009 00:16 Go to previous messageGo to next message
TrashMan

 
Messages:64
Registered:November 2005
Location: Croatia
What? It's NOT compatible??

And all this time I though it was a 1.13 mod. Frak. Now I have to re-install everything.

Damn...
Re: editing IMP's in 1.13[message #234290] Sat, 03 October 2009 20:01 Go to previous messageGo to next message
akmatov

 
Messages:77
Registered:September 2009
Location: Tucson, AZ
Just used this program and it is GREAT! Wunderbar! Ochen Xhoroshow! Etc

Many thanks. Now I can send my guy into trouble not dressed in shorts and flip-flop with a plinking pistol. Vast improvement.
Re: editing IMP's in 1.13[message #235433] Mon, 19 October 2009 01:55 Go to previous messageGo to next message
Riyaah
Messages:2
Registered:October 2009
I tried to use JA2IMPAct with 1.13 + HAM & WF & AIM (followed the guide by goc_man), but it gave me the same error an earlier poster had:

http://www.shrani.si/f/3E/5M/1zDNHSKM/ja2impact.jpg

Scharfrichter writes "You can also run multiple installations (e.g. for each mod you installed one). It just needs an own directory for every installation.", so I figured it should work with a modded v1.13, any idea what might be causing the trouble?
Re: editing IMP's in 1.13[message #235566] Wed, 21 October 2009 07:16 Go to previous messageGo to next message
curtwine
Messages:3
Registered:October 2009
I did the same thing and am getting the same error message. Anyone know what we are doing wrong or how to work around this? Thanks.
Re: editing IMP's in 1.13[message #235573] Wed, 21 October 2009 10:51 Go to previous messageGo to next message
Logisteric

 
Messages:3500
Registered:December 2008
Location: B
Majek
edit: oh i found out what the problem was. I had my WFItemMod Data named as 1.13 so i could use the Map editor and this program couldn't work with that.

It works now.
Re: editing IMP's in 1.13[message #235591] Wed, 21 October 2009 16:41 Go to previous messageGo to next message
curtwine
Messages:3
Registered:October 2009
I don't know if that's the issue, but doesn't whatever modded xml item file you are using have to be named 1.13 for it to work? So, if we want to use the modded xml file from Wildfire (in this case the AIM version), can we do that with JA2IMPAct? If so, what do we need to do to correct our issue? Does the modded xml item file have to be named something else? And if so, will that still work in 1.13? If anyone knows, your help will be greatly appreciated. Thanks.
Re: editing IMP's in 1.13[message #235709] Thu, 22 October 2009 23:14 Go to previous messageGo to next message
Riyaah
Messages:2
Registered:October 2009
Ok, I was under the impression that 1.13 would work even with mods, but when I think about it it's not surprising that the ItemMod breaks the program.

Well, I'll do with IMP-interface, but curtwine, maybe you could try and create your mercs before installing WF and WFItemMod. This might create problems with the starting items, but that is hopefully minor or just considered an extra challenge. Smile

If I change my mind and make a try I'll report back here.

[Updated on: Thu, 22 October 2009 23:16] by Moderator

Re: editing IMP's in 1.13[message #235743] Fri, 23 October 2009 04:52 Go to previous messageGo to next message
curtwine
Messages:3
Registered:October 2009
Actually, I created some IMP mercs using JA2IMPAct in regular 1.13 and they worked fine. Then I tried the WF/AIM overwrite suggested by goc_man, just like Riyaah did. That overwrite worked fine also (thanks goc_man!) but it didn't allow me to use JA2IMPAct to create new mercs as decribed by Scharfrichter above. However, the mercs I already created with JA2IMPAct do work in the overwritten WF/AIM version of 1.13 I am now playing - they just don't have access to the WF/AIM inventory - they only use the items from the regular 1.13 NIV. I was just hoping I could figure out a way to add the WF/AIM inventory items to my IMP mercs with JA2IMPAct. I am pretty inexperienced with modding JA2, so I don't really know how to edit the IMP's with one of the editors. If anyone knows of a way to use JA2IMPAct with goc_man's WF/AIM version of 1.13, please let me know. Thanks.
Re: editing IMP's in 1.13[message #242393] Sat, 23 January 2010 22:56 Go to previous messageGo to next message
vikcasar
Messages:9
Registered:November 2009
Any chance of version compatible with HAMSTOMP?
Re: editing IMP's in 1.13[message #257997] Sat, 31 July 2010 07:22 Go to previous messageGo to next message
qL67o0j7

 
Messages:181
Registered:March 2004
Er- Probably a data format change problem, but when I try to edit an IMP file created with a fresh install of JA 1.13 3356 - SVN 1224, JA2IMPAct-0-5-20090408-EN-BETA2 tells me "File [Path to IMP dat2 file] Does not equal the calculated size!".
It also seems to look for them inside "[JA 1.13]\Data\", instead of inside "[JA 1.13]\Profiles\UserProfile_JA2113" where the app seems to store them.

Is this a "version incompatibility" or an "user incompatibility" type issue?...
Re: editing IMP's in 1.13[message #258001] Sat, 31 July 2010 10:58 Go to previous messageGo to next message
Logisteric

 
Messages:3500
Registered:December 2008
Location: B
i could probably work if you rename and move some folders temporarely and of course you need to move your imps afterwards (as vfs did not exist when scharfrichter wrote impact) - just try it out
Re: editing IMP's in 1.13[message #258024] Sat, 31 July 2010 16:25 Go to previous messageGo to next message
qL67o0j7

 
Messages:181
Registered:March 2004
Logisteric
i could probably work if you rename and move some folders temporarely

Thanks! Any idea which ones?
I tried to move my .dat2 files to the folder where JA2IMPAct looks for them, but I still get the checksum error ("Does not equal the calculated size").


Logisteric
(as vfs did not exist when scharfrichter wrote impact)

What is "VFS"?
Re: editing IMP's in 1.13[message #258026] Sat, 31 July 2010 16:38 Go to previous messageGo to next message
Logisteric

 
Messages:3500
Registered:December 2008
Location: B
'variable file system' or somesuch - the piece of code that uses the profiles-folder - from a modder's perspective it's great: you put your new stuff into profiles xXx, and when it works ou move move it to data_xXx, thus you can not kill already tested stuff - you also could run n different mods in one directory, but i know noone who does that - it's a logistix device that should be a lot more promoted, but most users deem it to be ??????? and hence don't touch it.

as to which folders - earlier in this threat is an example with wildfire
Re: editing IMP's in 1.13[message #258027] Sat, 31 July 2010 16:43 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3728
Registered:July 2009
Quote:
but I still get the checksum error ("Does not equal the calculated size").

Maybe the file structure has been changed since this tool was created? Don't know, never used it.

Quote:
What is "VFS"?

Virtual File System
Basically, it allows you to keep all the mod-data in separated folders in one JA2 install.
e.g. Data-1.13, Data-WF, Data-HAM, Data-STOMP ...
You can then tell the game into what folders and in which order it shall look for files and create different mod combinations and profiles.
It's by far the cleanest and most sophisticated way to install multiple mods for 1.13 (the other and seemingly more prevalent method being dump everything into data-1.13) as it allows you to update each mod individually without having to worry about overwriting files needed by something else and reusing customized mods (like tweaked item mods and facilities) later without having to worry about traces from other mods being in that folder.


Re: editing IMP's in 1.13[message #258030] Sat, 31 July 2010 17:19 Go to previous messageGo to next message
qL67o0j7

 
Messages:181
Registered:March 2004
Logisteric
it's a logistix device that should be a lot more promoted, but most users deem it to be ??????? and hence don't touch it.

Sad, but lack of clear (and easy to find!) instructions are an old problem of the JA modding community. I'm playing JA since JA1, and come here every couple years to get me a new version - And despite having thus followed all the projects from birth, I feel each time like I'm unearthing a long-lost civilization... Very Happy

(Yes, I know, I could read the last 2 years worth of posts, but I'd rather spend my weekend playing, than reading about playing...)


Logisteric
as to which folders - earlier in this threat is an example with wildfire

Not the same error, my JA2IMPAct starts just fine (with a successful "building database" step); What it doesn't want to do is load one of the IMP .dat2 files I made.

(Anyway, if I rename the Data-1.13 directory, JA2IMPAct complains about it, meaning it is able to find the XML tables.)

Re: editing IMP's in 1.13[message #258032] Sat, 31 July 2010 17:30 Go to previous messageGo to next message
qL67o0j7

 
Messages:181
Registered:March 2004
DepressivesBrot
Maybe the file structure has been changed since this tool was created? Don't know, never used it.

Well, the plot thickens.

I tried to run it on an old install of JA2 1.13 2296 - SVN 1031 (from back in 2008). Well, I get the exact same error about the checksum!
Seems my version of JA2IMPAct is broken, period.
It is JA2IMPAct-0-5-20090408-BETA2-WIN32-EXE, downloaded yesterday from Sourceforge (http://sourceforge.net/projects/ja2impact/files/). I've downloaded and tested the english and the german versions da ich kein Problem mit Deutsch habe Wink , both give the same error, and strange enough, the error message of the german version is written in english too.
Re: editing IMP's in 1.13[message #258034] Sat, 31 July 2010 17:47 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3728
Registered:July 2009
As already asked in another thread: What do you want to change anyways? You can set all those optical stuff directly when creating an IMP and change the starting gear with the xml editor.


Re: editing IMP's in 1.13[message #258035] Sat, 31 July 2010 18:03 Go to previous messageGo to next message
qL67o0j7

 
Messages:181
Registered:March 2004
Stats, mostly.
Bypass the 35-85 limits, like for instance having 10 in medical and 90 in Dexterity.
Oh well.
Re: editing IMP's in 1.13[message #258036] Sat, 31 July 2010 18:07 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3728
Registered:July 2009
You know you can set min/max and starting stats in the options.ini?

Toggle Spoiler

[Updated on: Sat, 31 July 2010 18:11] by Moderator



Re: editing IMP's in 1.13[message #258037] Sat, 31 July 2010 18:16 Go to previous messageGo to next message
qL67o0j7

 
Messages:181
Registered:March 2004
Well, no, I didn't know; That solves my problem. Thanks!
Re: editing IMP's in 1.13[message #264201] Mon, 04 October 2010 04:37 Go to previous messageGo to next message
Kelron
Messages:6
Registered:October 2010
I keep reading here how "easy" it is to edit IMP starting gear in the XML, but it's killing my head and I'd love a way to do it with a GUI. I came across this program but I'm getting the same as Kurt. Has anyone found a way round it or is it simply incompatible with newer versions of 1.13?
Re: editing IMP's in 1.13[message #264223] Mon, 04 October 2010 13:44 Go to previous messageGo to next message
usrbid

 
Messages:1580
Registered:December 2008
Most mods require some technical know how, this is the case with other mods as well, for example Morrowind, Oblivion, Dragon Age and so on. We have multiple sections on this board and a Wiki explaining how to modify the game to your liking. http://ja2v113.pbworks.com/


Re: editing IMP's in 1.13[message #264239] Mon, 04 October 2010 16:02 Go to previous message
Kelron
Messages:6
Registered:October 2010
It was getting on for 3am when I wrote that, I've had another look at XML editing now and finding it simple enough. Still would be nice to customise gear for each IMP directly, but I can make do.
Previous Topic: Ham InI Setings.
Next Topic: "How does it work?" Part 11: Enemy Gun Selection
Goto Forum:
  


Current Time: Fri Mar 24 21:45:41 EET 2017

Total time taken to generate the page: 0.00938 seconds