Home » MODDING HQ 1.13 » v1.13 Idea Incubation Lab  » Single Click Installer for 1.13
Re: Single Click Installer for 1.13[message #253186] Sun, 06 June 2010 05:09 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
The "ja2_3329" = EXE version. The changes to this are generally in the source side of the SVN until it's reached another stable release milestone. Then it gets released into the normal SVN. Currently I believe it's 3358.

The "SVN@xxxx" = the latest version of the compiled source code freely available on SVN. This includes any released EXE changes and other file changes like additional weapons/alterations and fixes for instance. The latest version of the SVN is 1225 but there was only a minor fix to the German Items.xml between 1224 and 1225 so I haven't released 1225 as standalone version.

If you notice 1220 and 1224 share the same EXE version showing that there were no EXE updates in that period that were committed to SVN.


If you want to go on the latest version get the latest SVN. Other mods may actually include newer versions of the exe as they edit the working version in the SVN Source branch. This is something I know Headrock does and sometimes Warmsteel.


Re: Single Click Installer for 1.13[message #253225] Sun, 06 June 2010 15:32 Go to previous messageGo to next message
Dyson

 
Messages:203
Registered:December 2008
Thank you for your reply and the explanation.


I've downloaded via https://81.169.133.124/source/ja2_v1.13_data/GameDir from this thread: http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=56723&page=1#Post56723. This should be the newest release.

There a two questions left:

a) Which is the link to the most actual repository (3358)? Or is the "ja2.exe" in the SVN-folder the latest version 3358 and the additional file "ja2_3329.exe" only the last stable release before?
(Edit: Things, I've could check ou myself I: Actually, the "ja2.exe" is the most actual. Indeed it is the revision 3356@1225. Loaded via Tortoise.)
b) The size of the SVN-Release (1225) on my disk is round about 660MB (without the .svn folder). The size of the SCI is about 350MB. Where are all the other files?

Thx again

[Updated on: Sun, 06 June 2010 17:31] by Moderator

Re: Single Click Installer for 1.13[message #253329] Tue, 08 June 2010 05:14 Go to previous messageGo to next message
Never Darktide

 
Messages:88
Registered:July 2009
Is there a changelog somewhere? If there is, I can't find it for the life of me.

Edit: INI editing is giving me issues (latest version), there are a lot of "MISSING: PROPERTY DESCRIPTION" things popping up in the INI editor. I have never noticed this before.

[Updated on: Tue, 08 June 2010 05:30] by Moderator

Re: Single Click Installer for 1.13[message #253332] Tue, 08 June 2010 09:47 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
@Never_Darktide - Sorry I don't post changelogs at the moment. As for the INI editor did you install the latest to a clean JA2 install or over a previous one? If it was over a previous one old ini files maybe causing an issue.

@Dyson - I can't check my repository at the moment as my mobo died yesterday. Currently running on an old Athlon single core at the moment Surprised

I hope I didn't typo the current exe version, I could swear it was 3358, but then I could be wrong Wink


Re: Single Click Installer for 1.13[message #253350] Tue, 08 June 2010 15:26 Go to previous messageGo to next message
Never Darktide

 
Messages:88
Registered:July 2009
I did a clean install. A few fields in the general 1.13 settings were missing (and as I said, I hadn't noticed this with previous versions; when I installed 3287/1205, there was nothing missing), as well as the editor being totally baffled on the HAM and STOMP INIs, but maybe that's just because of limitations. No big deal, I think I got my setup working.
Re: Single Click Installer for 1.13[message #253377] Wed, 09 June 2010 02:56 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
There is a specific file that deals with those captions in the INI Editor. Unfortunately I haven't got access to any version of JA2 until my new motherboard arrives, so can't tell you which file.


Re: Single Click Installer for 1.13[message #253458] Thu, 10 June 2010 00:21 Go to previous messageGo to next message
Dyson

 
Messages:203
Registered:December 2008
Mobos always die at the wrong time^^

Checked it again with a new SVN-Download. Ja2.exe is at 3356 on my disk.



Re: Single Click Installer for 1.13[message #253486] Thu, 10 June 2010 07:52 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
OOOPs please ignore my typo then Wink


Re: Single Click Installer for 1.13[message #253534] Thu, 10 June 2010 15:11 Go to previous messageGo to next message
Dyson

 
Messages:203
Registered:December 2008
I really think there are more dramatical things on earth than that Very Happy

Re: Single Click Installer for 1.13[message #253664] Fri, 11 June 2010 02:49 Go to previous messageGo to next message
BoogieMan

 
Messages:22
Registered:March 2007
Location: FL
This is happening to me too. I installed the single click installer over a fresh install of Jagged Alliance 2 Gold. "Missing Property Description" on a few entries here and there. Not a lot.. Dunno if that's normal so I thought I'd just report that.

[Updated on: Fri, 11 June 2010 02:57] by Moderator

Re: Single Click Installer for 1.13[message #253682] Fri, 11 June 2010 11:42 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Thanks for reporting it. May want to report it in the Bugs thread as it's something RoWa21 will need to check Smile


Re: Single Click Installer for 1.13[message #253876] Mon, 14 June 2010 06:14 Go to previous messageGo to next message
Cr0aker

 
Messages:5
Registered:June 2010
Location: Canada
I'm running 3358, and I'm having this really annoying issue in the rebel base. Earlier in the game, when I first got there, every time I opened a locker in the base or picked up an item, the screen seemed to "shift" upwards, and it wasn't movable with the arrow keys or mouse cursor. I got around it by frequently leaving and re-loading the zone as I looted the lockers.

However, now that I've returned to recruit Miguel and Carlos, the screen just autoscrolls off the map before I can even move my character. The only way to reposition the 'camera' is to click on the map, and then it shuffles away faster than I can move my mouse to click anywhere. All I get is a screen full of lime green, so I can't even move my merc out of the base because I can't get to the stairs. Luckily I saved before this, but it's still annoying.

Anyone have any ideas?
Re: Single Click Installer for 1.13[message #254542] Tue, 22 June 2010 12:14 Go to previous messageGo to next message
clasko
Messages:2
Registered:June 2010
Hi kaerar,

Any way you can upload the latest version using the free hosting site? Like rapidshare, megaupload and stuff. My download kept getting stopped halfway through and it's really frustrating.. My last download stops at 86+ mb grrr.. Im currently playing the 2085 ver. i think and i just wanna try the 100 ap system.

Btw, JA2 1.13 is really great and i really appreciate the effort that people put in this game. Two thumbs up.
Re: Single Click Installer for 1.13[message #254573] Tue, 22 June 2010 18:42 Go to previous messageGo to next message
Pimp
Messages:4
Registered:June 2010
Hi!

I installed a fresh Jagged Alliance 2 Gold and then the latest Single Click installer "JA2 1.13 3358 exe SVN@1224 Full.exe". I did not change anything before starting the game. I'm using Windows 7 32-bit and installed the game not into C:\Program Files but in D:\Games. I got this error message:
http://img13.imageshack.us/img13/4659/ja2113error.png
Full link: http://img13.imageshack.us/img13/4659/ja2113error.png
When I start the game for another time, the message won't appear again.
Is this error message to be expected? Is it harmless and I can start a new game and fully enjoy the patch, or has something gone seriously wrong wich may lead to unexpected results later in the game progress?

[Updated on: Tue, 22 June 2010 19:09] by Moderator

Re: Single Click Installer for 1.13[message #254630] Wed, 23 June 2010 03:56 Go to previous messageGo to next message
Hachiryoku

 
Messages:104
Registered:June 2009
I'm getting this message.

# Message
0 Can not open file 'C:\Users\etc\etc\JA2 1.13 3358 exe SVN@1224 Full.exe' as archive

History;
Have played 1.13 on this computer (windows 7). Last 1.13 download was December(?). I just deleted it all and installed a fresh JA2 gold in preparation for downloading the newest 1.13. I'm running it in admin mode and compatibility mode for XP SP3. Worked before, but not this time.

I also found another member on this string that had the same problem and I tried the solutions suggested for him. I moved the JA2 folder around to different areas. Didn't work.

EDIT **** I found the instructions for the manual SVN download and I'm working with the SVN program now. I think I've got the work around (Thanks MM. Good stuff).

I'm still curious to the problem though.

Any help would be appreciated.
BTW, thank you for all the work everybody has put into this. I've really been enjoying 1.13.

[Updated on: Wed, 23 June 2010 06:36] by Moderator

Re: Single Click Installer for 1.13[message #254639] Wed, 23 June 2010 07:52 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Will have a check of the archives later today. Odd that 3 errors pop up at once, that maybe due to a corrupted archive.

Clasko - I only host on the FTP. If you are having problems then use Firefox with the DownThemAll plugin as it's very reliable for problem downloads.

Pimp - it was just missing one of the JA2_Settings.ini files. If it didn't pop up again it won't be a problem any further.

Hachiryoku - The file you downloaded has corrupted. Re-download it and it should work. Again if having download issues I'd use Firefox with DownThemAll to make sure it gets down in one piece.

@All - The file is actually a 7zipped version of the SVN without SVN folders. It does NOT require 7zip to be installed as it's a self extracting exe file. Just so you all know Smile


Re: Single Click Installer for 1.13[message #254640] Wed, 23 June 2010 08:19 Go to previous messageGo to next message
Hachiryoku

 
Messages:104
Registered:June 2009
Thanks K.

I had actually downloaded it 3 or 4 times.

I've got it up and running with the SVN now (I feel so high speed using that).

Next question. Does the latest have a new mercedit.xml? I see it in the ini, but I'm not finding the application. Sorry if this is answered somewhere else already.

[Updated on: Wed, 23 June 2010 08:22] by Moderator

Re: Single Click Installer for 1.13[message #254641] Wed, 23 June 2010 09:12 Go to previous messageGo to next message
clasko
Messages:2
Registered:June 2010
I finally get it downloaded last night after failing once.

Btw, i also got that error the first time i run it. Then the second or third time the error is gone and i can play like usual.
Re: Single Click Installer for 1.13[message #254657] Wed, 23 June 2010 12:18 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Something must be up with the JA2_Settings.ini. Dunno what as my SVN drive failed completely this morning (yup it's another Seagate...). Awaiting arrival of my two 2TB Western Digital's and then I can sort this unfortunate situation out.

Hachi I have no idea about the mercedit.xml. TBH I am only grabbing the SVN when time allows and uploading it if it's significantly newer. Concentrating on the SMP project at the moment Wink


Re: Single Click Installer for 1.13[message #254689] Wed, 23 June 2010 19:54 Go to previous messageGo to next message
Pimp
Messages:4
Registered:June 2010
I decided to change ja2.ini to play the normal game in 800x600. I don't know if that's possible but that's what I understand reading the .ini explanation. I changed this:
; JA2 1.13
;VFS_CONFIG_INI = vfs_config.JA2113.ini

; JA2 Vanilla
VFS_CONFIG_INI = vfs_config.JA2Vanilla.ini

I started a new game and hired Fox, but she got no weapon but a magazine in her hand. How to fix?
Re: Single Click Installer for 1.13[message #254745] Thu, 24 June 2010 06:20 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
That won't change it to 800x600.

To change it to 800x600 open the INI Editor (INIEditor.exe) and using the drop down box to change the value between the three resolutions. Make sure to leave reverse what you did as all you did was point to an empty VFS setup.


Re: Single Click Installer for 1.13[message #255080] Mon, 28 June 2010 13:26 Go to previous messageGo to next message
Pimp
Messages:4
Registered:June 2010
Thank you for your work. It's really great to have an easy way of installing JA2 1.13.

However, I noticed that Mercenaries' Skills and Levels grow real fast compared to normal JA2 1.12. Seems like 2x, 3x or even more. Is that intended by the modders for balancing reasons? If not and it's a bug, then I would like to change the experience speed back to default 1.12 settings. But I don't know what the old 1.12 default values exactly are.
Re: Single Click Installer for 1.13[message #255086] Mon, 28 June 2010 16:27 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1542
Registered:March 2009
Location: Broadwurschd-City
This "sneaked" in a while ago.

You may change this in the ini - the part with the points to level (oss).
You may tune any single skill and leveling.

I personally tuned it down - realy down - day 201, appr. 900 dead enemies and only 2/29 of my mercs have leveled once.

Nr 30, a certain Mr.Gontarski was shot at touchdown.
Re: Single Click Installer for 1.13[message #255088] Mon, 28 June 2010 16:39 Go to previous messageGo to next message
Headrock

 
Messages:1781
Registered:March 2006
Location: Jerusalem
AFAIK there's no reason skills should go up faster in 1.13 compared to 1.12. So either it's an illusion, or you're playing higher difficulty levels (more enemies = more level increase).


Re: Single Click Installer for 1.13[message #255089] Mon, 28 June 2010 16:55 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1542
Registered:March 2009
Location: Broadwurschd-City
maybe
Re: Single Click Installer for 1.13[message #255177] Wed, 30 June 2010 21:25 Go to previous messageGo to next message
Thaliak
Messages:2
Registered:June 2010
Does anyone know if I could use my save games from the version on the wiki (2085) with the single-click installer (i.e., not just with HAM)? The new features look useful, but I'm as far as I've gotten, so I'd prefer not to restart.
Re: Single Click Installer for 1.13[message #255179] Wed, 30 June 2010 21:27 Go to previous messageGo to next message
Logisteric

 
Messages:3396
Registered:December 2008
Location: B
yes i do know that - you can't

welcome to the pit
Re: Single Click Installer for 1.13[message #255185] Wed, 30 June 2010 21:59 Go to previous messageGo to next message
Thaliak
Messages:2
Registered:June 2010
Thanks for the quick reply.
Re: Single Click Installer for 1.13[message #255229] Thu, 01 July 2010 11:09 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Yeah the blunt stick know as Logisteric is right, the 2085 saves are not compatible with current builds. Soon there is to be an updated HAM (v4 I believe) which will break current savegames again. However the tradeoff is a much better CTH (Chance to Hit) system than currently ingame.


Re: Single Click Installer for 1.13[message #255496] Mon, 05 July 2010 00:47 Go to previous messageGo to next message
Vegedus
Messages:2
Registered:July 2010
I'm a bit curious about the numbers in file name. I figure what's currently 3358 is essentially the version number, and when it increases, it means there's new features and updates and all that. But what is the second number? The one after the SVN@, currently 1224? Is that a new version too? Or just some odd SVN update majicky? Specifically, I played 1220 a while back and I was wondering if there's anything new in this one.

Also, hey there, newbie here, don't be hard on me, love JA2 forever, etc.
Re: Single Click Installer for 1.13[message #255516] Mon, 05 July 2010 05:40 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Yeah I made a mistake and re-upping them for a two digit difference didn't really make sense. Sorry mate the correct one is 3356 not 3358 for the exe revision and 1224 is the latest SVN revision I uploaded.

If there is a difference of SVN number but not exe number it means that things like guns and xml/ini settings have been fixed/added/removed. When the exe revision changes it means hardcoded things inside have been fixed/added/removed and the new exe will advance the SVN revision by one number.

BTW welcome to the board Vegedus Smile


LOL I'm having to download my own SCI's as my library is currently MIA Razz


Re: Single Click Installer for 1.13[message #255632] Wed, 07 July 2010 14:37 Go to previous messageGo to next message
Zarax

 
Messages:51
Registered:February 2007
Location: Italy
June brought 6110 downloads for the various SCI full versions!
Re: Single Click Installer for 1.13[message #255648] Wed, 07 July 2010 20:05 Go to previous messageGo to next message
Pimp
Messages:4
Registered:June 2010
Do you think it is a good idea to use 1.13 if you never finished the original JA2? My original JA2 progress is capturing 3 cities. I haven't seen or learned more of the original game yet.

Also, I read somewhere that you can't fully revert to the old 25 AP system because of some bugs. Is that true? I played a little with 1.13 and I saw that mercenaries who normally aren't supposed to have the full 25 AP in a battle have full 25 AP when they have their first fight (in Omerta).

Should I wait until a better version comes out?

Edit: I almost forgot, sometimes there seems to be no chance to hit improvement after you increase targeted AP. I use the option to display chance to hit cursor and then I saw this (the bar doesn't make progress for every right click). Is this just a display bug or is there really no improvement? Sometimes 1 step is no improvement, but 2 steps are.
Re: Single Click Installer for 1.13[message #255675] Thu, 08 July 2010 02:01 Go to previous messageGo to next message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
The new AP system is actually more accurate that the original one seeing as it's based on a 100AP setup. In the original there were a few bugs like running where you could run further than the coders originally intended and other things. Once reverted to 25AP (instead of 100) it plays very similarly to the stock JA2. No point waiting for another version.

The CTH bar is pretty intriguing. Seeing as HAM 3.6 is in the SVN a merc with high level and skill will be able to determine CTH better than say a just hired low level merc. The improvements shown are usually pretty accurate unlike the original where the cursor just zoomed it no matter whether you were getting an actual CTH improvement or not.

Most recommend completing it vanilla before trying 1.13, but if you have already got to 3 cities and wish to give it a go, you won't be missing much as you'll have basic gameplay sorted already. You'll be able to notice the improvements pretty quickly Wink


Re: Single Click Installer for 1.13[message #256070] Tue, 13 July 2010 03:44 Go to previous messageGo to next message
Goncyn

 
Messages:54
Registered:July 2010
When I first started playing last week, I apparently downloaded an old version 1183 because that's what the huge "Install JA2 v1.13" link at the top of the forum points to. Can I play my save games from that version in this new release? Also, is there a changelog anywhere? I don't like blindly updating without knowing what's changed. Thanks!
Re: Single Click Installer for 1.13[message #256074] Tue, 13 July 2010 04:22 Go to previous messageGo to next message
Shiv

 
Messages:5
Registered:October 2005
I have a question for y'all. Always enjoyed JA2 and found out about 1.13 a few days ago. Tried installing a different way but it didn't work (was missing a mod.dll file) so I tried the installer and it did work, in that it could run the game.

However, upon running the game I get several errors to start with upon loading (.ini settings not being set and it defaulting to seemingly random values, for instance) and I occasionally get runtime errors in game which makes it CTD.

I also get some items that have 'NADA' written, which I assume is the placeholder for missing items that are called but don't have a graphic that exists for them.

Also it seems to randomly crash when quick-saving, which of course corrupts that save file (and makes me very hesistant to quick save).

Additionally, and the part that just made me give up on 1.13 until I get this sorted out, is that I tried to travel from Omerta to San Mona and half my squad 1 stayed in the original sector I was traveling from! Naturally this lead to a crash when the game tried to call upon 3 squad members that were in Squad 1 but no longer existed in the destination sector.


So is 1.13 inherently unstable or did I install something incorrectly? I installed JA2, patched it to 1.12, and installed 1.13 through the installer on the first page of this topic. Was there anything I missed?


Edit: Oh also some of the graphics glitch (like when the new replacement mercenary for 'Buns' talks, his portrait glitches) which isn't really a problem, just a bug that I'm getting.

Also some of the guns don't report ammo values all the time. Machine guns give me '??' sometimes which I couldn't decide if it was a bug or a feature (or a bugged feature), but since it reverts to telling me how much is in the gun at times, I'm assuming it's a bug. Also sometimes it displays in what I assume is hex, since it'll change from a 'YN' to a 'YM' when I shoot one shot then a 'YL' when I shoot another.

[Updated on: Tue, 13 July 2010 04:31] by Moderator

Re: Single Click Installer for 1.13[message #256076] Tue, 13 July 2010 06:34 Go to previous messageGo to next message
usrbid

 
Messages:1558
Registered:December 2008
Hi Goncyn, Welcome to the board!! Very Happy

Save games may not work between revisions. You can install a completely new game in a new folder and test if the save game will load. This way you don't lose your old install.


Hi Shiv, The install is not working properly from what you described. Basically you have files with different versions and the game tries to make it work be defaulting. This pertains to INI settings, NADA items, and portrait glitches.

The ammo showing as ?? is a HAM feature, basically the soldier holding the gun forgot how many bullets are in it. This can happen with an unfired gun as well.

You don't need to upgrade to 1.12, just install JA2 and then copy 1.13 over it (follow the instructions if you have any). You need to start the game with the correct EXE meaning the 1.13 EXE not the original one.


Re: Single Click Installer for 1.13[message #256078] Tue, 13 July 2010 06:38 Go to previous messageGo to next message
Shiv

 
Messages:5
Registered:October 2005
Well I installed 1.13 to an unpatched version (1.10) but the only exe is the JA2.exe, I see no 1.13 exe.


Also it seems odd. In the last version, Omerta was the same, but Dedriana's palace and Miguel's bunker had changed. In this new install, Omerta has changed, but Dedriana's palace and Miguel's is the same. I now have no idea what is going on...

I once played Wildfire (never beat it as I came across a game breaking bug and well, that was that) and IIRC the first version that was bugged out looked like WF did (and I think the installer includes WF no?) but the new version doesn't seem to have. Also it has a different title screen than the first installation I tried. The options and inventory system are updated, however.



Oh additionally from what I read on the site that turned me onto 1.13, some of the characters had been changed, and in the previous version Buns was a dude and Blood was Chinese, not black. In the new version Buns is back to being Buns and Blood is now black.

[Updated on: Tue, 13 July 2010 06:45] by Moderator

Re: Single Click Installer for 1.13[message #256118] Tue, 13 July 2010 13:52 Go to previous messageGo to next message
Blindside
Messages:3
Registered:July 2010
Hi,
I try to download the single click installer from the first page, but after I click on it the side just keeps loading forever without actually starting the download. I have tried it on 3 different computers now and the result is always the same. Is it only me or is something wrong with the link. I am trying to use this link:
http://www.wmwiki.com/hosted/ja2/JA2%20Single%20Click%20Install/JA2%201.13%203356%20exe%20SVN@1224%20Full.exe

Edit: Nevermind, now it worked. Don't know what was going on.

[Updated on: Tue, 13 July 2010 14:36] by Moderator

Re: Single Click Installer for 1.13[message #256198] Wed, 14 July 2010 12:06 Go to previous messageGo to previous message
Kaerar

 
Messages:2067
Registered:January 2003
Location: Australia :D
Sometimes FTP protocol can cause a bit of an issue for downloading with some people or that the server was having a bit of downtime Wink

Glad you got it Blinside.

Shiv
Oh additionally from what I read on the site that turned me onto 1.13, some of the characters had been changed, and in the previous version Buns was a dude and Blood was Chinese, not black. In the new version Buns is back to being Buns and Blood is now black.

Sounds like a case of bad DBB (Cosplay mod). Glad it's all fixed now Smile


Previous Topic: Faster Miguel & Carlos INI option
Next Topic: sticom - comprehensive command line tool for processing STI files
Goto Forum:
  


Current Time: Sat Nov 17 10:58:38 EET 2018

Total time taken to generate the page: 0.01609 seconds