Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » UC/DL 1.13 & AFS » UC-1.13 Public Beta Discussion 1 (2009/10/29 to 2010/10/16)
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249394] Thu, 15 April 2010 22:44 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Tony is working just fine in the test install of the latest release. I haven't done anything with the new merchant options in the XML, but as far as I know, we cannot change which NPC/RPC is a merchant (yet).


Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249395] Thu, 15 April 2010 23:05 Go to previous messageGo to next message
Logisteric

 
Messages:3269
Registered:December 2008
Location: B
that code is already in the trunk - but not in the exe yet Very Happy

but it's still limited to 20 mercheants :hmm:
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249657] Mon, 19 April 2010 05:13 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Excellent, that means that Smitty can be turned into a real merchant again some day (as he was in Urban Chaos originally, and in 1.13 briefly due to that error on my part...)

I've produced a mini-mod for the last version of the UC-1.13 Hybrid so that Warmsteel's New Attachment System .exe can be used. It is my belief that major code changes should be tested beyond the stock Alrulco campaign/Data-1.13 after the initial testing is complete. And from what I've seen Warmsteel's project seems to be stable enough (considering what has changed). So in an effort to help with the testing of this promising new capability (and to facilitate its incorporation into mainstream 1.13); here it is:

Requirements are in order of installation
- working UC-113 Hybrid v20100411
- NAS 0.36a (or newer)
- UC-113 Hybrid NAS mini-mod v20100418.7z (found here http://www.esnips.com/web/ucja2113projectssStuff )

To launch use the INI Editor set the MOD to vfs_config.UC113NAS.ini and the JA2 v1.13 Executable to JA_EN_NAS0.36a.exe (or newer as it becomes available).

So far I've tested to make sure items and default attachments (of which the Hybrid has quite a few) appear correctly. I've also checked to make sure the combo merger to produce the flamethrower works.

Now for my purposes I am wanting to know a few things:
- do the attachments slots make sense? For instance I've eliminated many underbarrel accessory rails from the pistols. Too many pistols able to gain the RIS Bridge, however did I take it too far? Have I gone too far with the quad rail weapons?
- I've increased the AP for single shot and Draw Cost penalties for most of the underslung launchers to 25% (increase), and an effective Burst and Autofire AP penalty of 15% (increase). Do the increased AP costs make sense?
- If you run into any CTD's or other weirdness, please bear in mind that Warmsteel needs examples that can be easily found in "regular" JA2 1.13 (which means the base release which is built on the DATA-1.13 folder). Still, report the bugs, if necessary I can see about creating some analogue with the main data to demonstrate it.

Known problems:
- I forgot to set the RIS Bridge rail to add a lower attachment point Upper full Optics rail (I have to do it directly with Notepad as MS Excel 2003 does not like more than a single add and single remove slot definition)
- For now, try not to attach two of the same attachment at the same time, this does cause problems, that Warmsteel advises have been addressed in a newer version.

EDIT: Correction, I forgot to add the Upper RIS rail on the Bridge attachment.

[Updated on: Mon, 19 April 2010 05:30] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249690] Mon, 19 April 2010 17:47 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
A small question about the current non NAS release.

Did you intend for the enemy item drops settings in the .INI file supplied to not use the enemy item drop XML files in the UC113 folder?

At the moment the INI is set so that it uses the old drop system not the new XML one.



The NAS hybrid does look interesting. Will give it a go today.
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249691] Mon, 19 April 2010 18:17 Go to previous messageGo to next message
majki
Messages:3
Registered:April 2010
Location: Poland
Well, I' ve installed newest SVN 1220 and UC 1.13 and now I can't even start playing because the game freezes in main menu when I'm selecting any option:( With the older revisions of JA and UC I could play and I almost finished the game but constant freezes after about completing make me give up on it.

[Updated on: Mon, 19 April 2010 18:22] by Moderator

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249694] Mon, 19 April 2010 19:19 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
@Tango - I haven't created any .ini's based on the new system, for now please leave the .ini set to use the old system.

@majki - Does the game run (including starting a new game and the arriving in tactical) when in the INI Editor you set the MOD to the original vfs_config.JA2113?

EDIT: majik, are you referring to instability with original Urban Chaos, or earlier versions of the UC-1.13 Hybrid?

[Updated on: Mon, 19 April 2010 19:34] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249698] Mon, 19 April 2010 20:08 Go to previous messageGo to next message
majki
Messages:3
Registered:April 2010
Location: Poland
I meant earlier versions of the UC-1.13 hybrid before. With original vfs_config for ja2 1.13 I can play with no problem.

[Updated on: Mon, 19 April 2010 20:14] by Moderator

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249700] Mon, 19 April 2010 21:24 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
@majki - Delete the following folders:
- Data-UC
- Data-UC113
- Data-Graphics
- Profiles\UserProfile_JA2UC113

That will more or less fully uninstall UC-1.13. Reinstall from the latest v20100411 .7zip archive. Don't forget to also replace Data-UC from an original Urban Chaos download.


Proposed Balance change:
The RIS Bridge Rail (as long as it is fully defined to add both slots) is a very powerful add-on. I am considering the following changes to balance against it:

- All "Sniper" scopes will have a big Draw and AP for single shot penalty, 40% for 6x scope and 60% for 10x scope
- All "Sniper" scopes will have a CTH penalties for Burst and Auto fire (to be determined, but big enough to reinforce the idea that Burst and especially Auto while peering through a scope is a very bad idea)
- All weapons classed as "Sniper" rifles will have their Draw and AP for single shot costs brought down a bit so that they are more in line with single shot of other weapons with the same calibre
- Result, player will continued to be allowed to attach Sniper Scopes to pistols, and other RIS equipped weapons, only it will not be worth it (unless it is a sniper rifle, or a very high end Assault or Battle rifle)

If anyone wants to see what I mean about the RIS bridge:
1) open up folder: Data-UC113NAS\TableData file: AttachmentSlotAssign.xml in notepad
2) find the entry that looks like this:
	
		25
		540
		80
		23
		26
	


3) add 51 to the end so that it looks like
	
		25
		540
		80
		23
		26
		50
	


4) Save (not Save As)

EDIT: another balance change, is to add penalties directly to the RIS Bridge that still allows the Reflex and Adv.Reflex Sights to be beneficial, but not as much as they are stand alone on a SMG/AR/DMR. This penalty will of course make the use of a Hi-power scope on a pistol a bad idea.

EDIT2: sorry, I mean 50 not 51

[Updated on: Mon, 19 April 2010 21:35] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249701] Mon, 19 April 2010 22:02 Go to previous messageGo to next message
majki
Messages:3
Registered:April 2010
Location: Poland
Now it works fine, I dunno why I didn't try reinstall the UC-1.13 hybrid. Thanks a lot Wil:)
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249705] Mon, 19 April 2010 23:15 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
wil473
@Tango - I haven't created any .ini's based on the new system, for now please leave the .ini set to use the old system.


I meant the INI supplied with the old system (ie current non NAS release).

Sorry for not being very clear.

Couple of finds so far:

  • Attaching an item to one of the internal attachment slots of the Alice Butt Pack (combat pack size) will CTD the game. I.e. in non NAS version a 4x battle scope can be attached to one of the four internal slots of the item. Trying this with NAS will CTD, also reproducable with the KORSAK LAM. Personally I don't have a problem with not being able to attach it, seems like a holdover from the OIV but the 4 attachment slots might need to be grayed out.
  • PP-19-01 Vityaz cannot attach a Korsak LAM whereas it previously could. I can't work out the new XML structure enough to tell why. Will try to figure it out some more later, sorry.

Overall I like the concept a lot Razz.
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249706] Tue, 20 April 2010 00:19 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
That first one is an odd one, and the second one is another mistake I made.

There is are no attachment slots defined for the A.L.I.C.E. Field Pack, so I was under the impression that nothing could be attached. Moreover, I thought with the LBE items, NAS did not allow attachments anyways. What happens when you try to "attach" something to a "misc" item such as the sound suppressor?

I'll take a look at the PP-19-01 Vityaz when the computer all the production is done on is available. Just taking the opportunity to do a clean up on it after four months in service and make a new PING image of the boot/system partition.

EDIT: It is confirmed that the PP-19-01 is missing the LAM/KORSAK-1 slot; however I'm not entierely sure if this was a mistake. The Vityaz may be fitted with a RSA compatible scope, which will replace the basic laser sight slot with a LAM/KORSAK-1 slot. I think the plan, and I really should leave notes for myself, is that built-in KORSAK support is only meant for weapons that cannot mount a scope.

[Updated on: Tue, 20 April 2010 04:46] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249734] Tue, 20 April 2010 19:20 Go to previous messageGo to next message
Burzmali

 
Messages:242
Registered:March 2007
Location: Estonia
"- All "Sniper" scopes will have a CTH penalties for Burst and Auto fire (to be determined, but big enough to reinforce the idea that Burst and especially Auto while peering through a scope is a very bad idea)"

sure, when running. but prone, short bursts will work nicely. it's ages ago, but at night AK with night vision scope was way more practical than night vision headgear and AK without scope.

btw how it's going with the boat to the island :wave:
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249735] Tue, 20 April 2010 19:52 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Just to be clear the 3.5x-4x scopes (PO 3.5x21P and RIS Battle scope) are not part of this rebalance. So far I am only suggesting the RIS 6x and 10x scopes be modified in this way. The PSO-1 may also be included, but I have to take into account the UC intention to allow/encourage players to "trick out" the M4A1 with this Russian DMR scope.

I'm rethinking having the boat being able to traverse from the west edge all the way to the east. Too many maps have to be modified, though to be honest, how many people see these endgame maps with all the crashes the Hybrid seems to be prone to. The goal of UCC is to remove maps.

- New Port for Port Kip is more or less done
- Still have to work on widening the shipping lane to Port Kip
- Some work has been done to give southern coast maps a cliff line
- For now, it is probably best to have the boat start off from South East coast.
- Comments made by bartenders about General Marco require that the maps north of Drake be more or less untouched

EDIT: one question to anyone using the current version of the mod. Does the queen seem to be sending too many reinforcement? For years, I have increased the queen's pool of troops to make sure all those garrison's were staffed. But now it seems the queen is sending multiple 20man teams to retake Calistio, which is a problem with reinforcements turned off. (Standard difficulty, aggressive AI turned off)

EDIT2: Tango, I just replicted your CTD in NAS 0.40a using the default campaign. It seems that there is something funny with the attachment slots and LBE's in general.

[Updated on: Thu, 22 April 2010 04:21] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249928] Thu, 22 April 2010 19:02 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Can someone please post the UC-113 Hybrid v20100411.7z and UC-113 Hybrid NAS mini-mod v20100418.7z files to a site that does not require a special app to be installed on your machine along with a site registration intended to make you a spam target? Thanks.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249930] Thu, 22 April 2010 19:31 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
@ ShadoWarrior; Dont click the download button but click the file name of the file itself in the box above it.

@ Wil473

Couple of things:

NAS related:
  • The RPO-A as supplied with Rude Dog no longer has the default RPO round attached and so is unloaded.
  • The bug with attaching things to LBE items in the original slots seems to be sorted in NAS 0.40a. If you right click on a Alice Combat pack the slots are greyed out.
I've also only just noticed that the weapons as supplied in cache locations (presumably in the map data) are missing the appropriate stock. E.g. the AKSU-74 in C9. Perhaps as a work around Tony's and Bobby Rays could sell them?

This would also allow perhaps some other machine pistols to accept stocks and thus become useful backup weapons. For example the MP5K could become an MP5K PDW (with reduced autofire penalty and increased raise time) and the Stechkin machine pistol which came supplied with a wooden holster/stock combination.

Finally a police officer in Troy (H12 I think) was equipped with an M4 upper receiver which he was able to fire at me. However, when dropped it would then not fire (quite correctly) until mated with a lower. Possible making the uppers unable to accept magazines rather than having a disabled cursor might work better?

Cheers for all the hard work;

Tango
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249931] Thu, 22 April 2010 20:03 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Tango
@ ShadoWarrior; Dont click the download button but click the file name of the file itself in the box above it.
I am still asked to register when I do that.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249933] Thu, 22 April 2010 20:19 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
Very strange, could possible be region based?

ShadoWarrior check your PM's. Don't want to post a public link without getting an okay from Wil first.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249953] Fri, 23 April 2010 00:32 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Does UC113 ignore the Ja2_Options.cfg settings for IMP creation? I'm assuming it reads the copy in the Data-UC113 folder? I have changed the minimum skill level from its default of 35, but the game is ignoring my change.

There have been a lot of changes to 1.13 since I was last active on these forums, such as the inclusion of VFS, and I may have missed some key setting somewhere.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249957] Fri, 23 April 2010 01:24 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Tango, I have no problem with you reposting the mod, except for the fact I am about to release a new revision. Included in the fix list are several things you identifified over the last few days, though I am going to leave the PP-19-01 Vityaz with only the basic laser sight in NAS, if you want to attach the KORSAK-1, you will have to add either the PO 3.5x21P, Kobra reflex sight, or the Russian night scope.

ShadoWarrior, it has been a while. The settings you are looking for I think are in JA2_Options.ini near the top. Just make sure you edit the right one; the one in Data-UC113 for the normal game, Data-UC113NAS for NAS testing.

EDIT: This is what the next version should have

20100423
* Changed

[Updated on: Fri, 23 April 2010 01:54] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249960] Fri, 23 April 2010 02:58 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Thanks Will. I'd overwritten the large one with the smaller NAS one, and that's what was causing me grief. Since I have several 1.13 installs I'm going to use for testing, I just restored from one of the other games and then edited accordingly. All's fine now. Thanks. How are you? (paraphrasing Han's line from Star Wars)

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249961] Fri, 23 April 2010 03:15 Go to previous messageGo to next message
Mauser

 
Messages:770
Registered:August 2006
Location: Bavaria - Germany
ShadoWarrior
Does UC113 ignore the Ja2_Options.cfg settings for IMP creation? I'm assuming it reads the copy in the Data-UC113 folder? I have changed the minimum skill level from its default of 35, but the game is ignoring my change.

There have been a lot of changes to 1.13 since I was last active on these forums, such as the inclusion of VFS, and I may have missed some key setting somewhere.


man, you have no idea what you

☆★GL★☆
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249963] Fri, 23 April 2010 04:49 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Mauser
1.13 isn

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249973] Fri, 23 April 2010 07:31 Go to previous messageGo to next message
Marlboro Man

 
Messages:1203
Registered:October 2005
Location: USA
Quote:
Thanks for the warm welcome back!



Look what the cat dragged in. :blackcat:


Good to see you back man. :wave:


Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #249976] Fri, 23 April 2010 08:04 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Thanks MM! Yep, still alive, still kickin', still ornery. Razz

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250003] Fri, 23 April 2010 13:42 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
I'm having a weird problem. The people you can recruit along the way, like Rude Dog or that big guy in the starting sector (Rosebud?) have the correct pics and sound files, but their text names and stats are as per non-UC. For example, Rude Dog is "Miguel" and the big guy guy is "Ira" (complete with expert training skill). I suspect that some files didn't get overwritten when I copied UC over the 1.13, but I followed the posted instructions on the forum point by point.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250004] Fri, 23 April 2010 13:44 Go to previous messageGo to next message
Logisteric

 
Messages:3269
Registered:December 2008
Location: B
do they have correct names? me blind


i'd say your profdat is f*cked up - could you have a look with proEdit in both your 'data\binary_data' and 'data_(whatever it's called)\binary_data' - miguel is no 57

you either have a standard profdat in 'data_(whatever it's called)\binary_data' or no uc-profdat at all

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250006] Fri, 23 April 2010 14:02 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
The prof appears to be the correct one. I should also have mentioned that when I found Rude Dog he had the correct equipment (RPOs). It's only the names and stats/skills that are wrong.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250009] Fri, 23 April 2010 14:08 Go to previous messageGo to next message
Logisteric

 
Messages:3269
Registered:December 2008
Location: B
the equipment has no longer anything to do with profdat - equipment is stored in xmls
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250030] Fri, 23 April 2010 16:58 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
The relevant prof.dat should be in Data-UC113. ShadoWarrior, are you using the default folder structure, or are you reassembling all the files into the Data or Data-1.13 folder? The alternate install method you suggested in past should not be necessary anymore due to VFS. VFS even made the installer unnecessary.

Oh and are you playing the normal Hybrid or the NAS mini-mod?

I should have the new version posted tonight, among other things, it corrects a minor PROF related issue in the NAS .ini (NAS is based on an older version of the SVN, before they reordered the .ini structure, therefore the need for a seperate .ini).


EDIT: more shameless promotion - I remembered to add the RG6 (six shot grenade launcher) to the enemy items selection list. People may want to flip on "drop-all" to ensure they get this item.

EDIT2: On giving it more thought, if you have been rearranging the Data folders, and are using the NAS mini-mod, the symptoms you are describing could be caused by the "minor PROF related issue in the NAS .ini" I didn't see any point in continuing to update eight different prof.dat's when the option to force the use of the default prof.dat became available to use. That being said, I didn't delete the extra prof.dats, but if you have been consolidating the Data folders then the symptoms could be caused by the error in the .ini.

Please check in the relevant JA2_options.ini that ALWAYS_USE_PROF_DAT = TRUE

[Updated on: Fri, 23 April 2010 17:42] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250047] Fri, 23 April 2010 20:30 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
"ALWAYS_USE_PROF_DAT" no longer appears to exist in the file. I have the following set:

USE_DIFFICULTY_BASED_PROF_DAT = TRUE
READ_PROFILE_DATA_FROM_XML = TRUE
WRITE_PROFILE_DATA_TO_XML = TRUE

I suspect it may be the last two settings, which I had changed from their FALSE defaults.

Quote:
The relevant prof.dat should be in Data-UC113. ShadoWarrior, are you using the default folder structure, or are you reassembling all the files into the Data or Data-1.13 folder? The alternate install method you suggested in past should not be necessary anymore due to VFS. VFS even made the installer unnecessary.

Oh and are you playing the normal Hybrid or the NAS mini-mod?
Default UC113 structure with 5 data -related directories, including data-UC and data-UC113. NAS, but I consolidated the NAS files into the UC directories. I suspect that may be the root cause of my ongoing problems.

[Updated on: Fri, 23 April 2010 20:42] by Moderator


Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250048] Fri, 23 April 2010 20:36 Go to previous messageGo to next message
Logisteric

 
Messages:3269
Registered:December 2008
Location: B
nope - it's the first


USE_DIFFICULTY_BASED_PROF_DAT = false
the last two are profex-related

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250049] Fri, 23 April 2010 20:41 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
USE_DIFFICULTY_BASED_PROF_DAT = TRUE (Should be set to FALSE) is the new format .ini variable that the main SVN JA2.exe uses (non-New Attachment System).

I checked the Ja2_Options.ini in the old v20100411 and the soon to be released v20100423; both have it set to FALSE. As a failsafe I'll recopy the prof.dat for the difficulty based profs, but I make no promises about keeping them updated.

EDIT: I should warn everyone, I haven't checked v20100423 for savegame compatibility (SVN .exe or NAS .exe). As always, please try the Beta test with the default .ini; or be sure to tell me what settings you have changed when reporting issues found.

EDIT2 (Re-read Shadowarriors post): Ok by consolidating the NAS folder into one of the other Data folders, I am guessing that you are trying NAS. The variable you are seeing tends to indicate you are using the non-NAS .ini. The Data-UC113NAS folder contains its own Ja2_Options.ini based on the one found in Warmsteel's NAS releases. Due to code differences and timing, NAS uses an old format .ini (with its own added variables).

[Updated on: Fri, 23 April 2010 20:49] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250050] Fri, 23 April 2010 20:47 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Logisteric
USE_DIFFICULTY_BASED_PROF_DAT = false
I presume I have to start a new game for the change to show up? I made the change back and it (not surprisingly) seems to have no effect on a saved game.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250051] Fri, 23 April 2010 20:47 Go to previous messageGo to next message
Logisteric

 
Messages:3269
Registered:December 2008
Location: B
i'm not sure - just try it i'm still blind, lol

yeah start a new one
Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250053] Fri, 23 April 2010 20:50 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
Blind? Perhaps. Helpful? Definitely yes. Wink

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250054] Fri, 23 April 2010 20:51 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
ShadoWarrior, are you using the NAS .exe? And yes, you will need to start a new game.

Copy of Edit from above as we seem to be conversing in near real time: Ok by consolidating the NAS folder into one of the other Data folders, I am guessing that you are trying NAS. The variable you are seeing tends to indicate you are using the non-NAS .ini. The Data-UC113NAS folder contains its own Ja2_Options.ini based on the one found in Warmsteel's NAS releases. Due to code differences and timing, NAS uses an old format .ini (with its own added variables).

[Updated on: Fri, 23 April 2010 20:52] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250056] Fri, 23 April 2010 20:54 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
No, I am not using the NAS .exe. Stupid question, but should I be using the NAS.exe with UC113?

[Updated on: Fri, 23 April 2010 20:58] by Moderator


Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250058] Fri, 23 April 2010 20:59 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Ok, there are item availabiltiy and merger differences between normal (SVN) and NAS mini-mod.

If/when you try New Attachment System; NAS files should be installed as if there was no UC-1.13 Hybrid, per Warmsteel's instructions. Don't put Warmsteel's files into the Hybrid Data folders, as they will overwrite my customized NAS data XML's.

EDIT: Yup, for NAS mini-mod see below from the next release

In the INI Editor, please set before Launching Jagged Alliance 2:
JA2v1.13 MOD = vfs_config.UC113NAS.ini
JA2v2.13 Executable = JA2_EN_NAS_0.40a.exe (or newer version of NAS)

[Updated on: Fri, 23 April 2010 21:02] by Moderator



Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250059] Fri, 23 April 2010 21:07 Go to previous messageGo to next message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
I'm just going to "reinstall" UC. Doesn't take long since I already have multiple backup copies of 113.

Re: UC-1.13 Public Beta Discussion 1 (2009/10/29 to --/--/--)[message #250062] Fri, 23 April 2010 21:31 Go to previous messageGo to previous message
ShadoWarrior

 
Messages:248
Registered:January 2006
Location: Twilight Zone
After reinstalling UC113 and NAS, which Ja2_Options.ini file should I be editing to have the game play as I like: the one in the data-UC113 folder or the one in data-UC113NAS?

Previous Topic: UC-1.13 Hybrid
Next Topic: UC-1.13/DL-1.13/AFS Discussion 2 (2010/10/29 to 2011/04/18)
Goto Forum:
  


Current Time: Thu Nov 26 06:26:38 EET 2020

Total time taken to generate the page: 0.01484 seconds