Home » SIRTECH CLASSICS » Jagged Alliance 2 » The A.I.M. Library » XML editor problem
XML editor problem[message #262103] Fri, 10 September 2010 13:43 Go to next message
malec
Messages:1
Registered:September 2010
hey guys im new here and I have a question about XML editor
i wanted to edit ivan and his starting gear in inventories/merc starting gear
ive done everything good i choose cheytac m200 and in the game i have only a letter and ammo for cheytac...what i am doing wrong then ?? pls help i play ja2 1.13 and dbb mod
Re: XML editor problem[message #268107] Fri, 10 December 2010 19:32 Go to previous messageGo to next message
Arotashi
Messages:8
Registered:December 2010
Have you tried giving him a different gun? I have never seen that gun in the game and its possible that it was not completed.
Re: XML editor problem[message #268110] Fri, 10 December 2010 20:05 Go to previous messageGo to next message
RoWa21

 
Messages:2046
Registered:October 2005
Location: Austria
Where did you change the gear? In Data\TableData\MercStartingGear.xml or in Data-1.13\TableData\MercStartingGear.xml file?

Per default, 1.13 uses the "Data-1.13\TableData\MercStartingGear.xml" file.
Take a look in your ja2.ini to see which "Data" folder will be used.

Check if "READ_PROFILES_DATA_FROM_XML = TRUE" in your Data-1.13\ja2_options.ini.
If it is TRUE, then the game uses the MercStartingGear.xml file, otherwise (FALSE) it used the starting gear defined in the proper BinaryData\Prof*.dat file.

Also check, if your MercStartingGear has the following tags included, but only if you use one of the latest versions from 1.13 (eg: Tais single click installers).


...


EDIT: If that all does not work, edit your MercStartingGear.xml file with notepad instead of the XML Editor.

[Updated on: Fri, 10 December 2010 20:08] by Moderator



Re: XML editor problem[message #322192] Sat, 29 June 2013 08:58 Go to previous messageGo to next message
SharkD

 
Messages:344
Registered:July 2003
How do I change the 'Active Data Set'? I want to edit the merc starting gear for the SOG69 mod.

[edit]

I guess I should note that I am playing SOG69 with 6116/1678.

[edit]

Here's the path to MercStartingGear.xml:

D:\Jagged Alliance 2\Data-UB\AddOns\Data-Mod-SOG69-Vietnam\TABLEDATA\Items

[Updated on: Sat, 29 June 2013 09:49] by Moderator

Re: XML editor problem[message #322232] Sun, 30 June 2013 14:58 Go to previous messageGo to next message
Sam Hotte

 
Messages:2033
Registered:March 2009
Location: Middle of Germany
The data folder is set in XMLEditorInit.xml.
(at least used to be this way in older versions)
Re: XML editor problem[message #322271] Sun, 30 June 2013 22:25 Go to previous messageGo to next message
SharkD

 
Messages:344
Registered:July 2003
OK, in XMLEditorInit.xml I changed the datapath to:

	Data-UB\AddOns\Data-Mod-SOG69-Vietnam


and

	D:\Jagged Alliance 2\Data-UB\AddOns\Data-Mod-SOG69-Vietnam


But now the editor refuses to run. No error message either.

[edit]

Scratch that. I did get an error message after all. I simply didn't notice it.

http://i421.photobucket.com/albums/pp292/SharkD2161/Support/th_ja2_xmleditor_bug_01_zps55872884.png

[Updated on: Mon, 01 July 2013 00:54] by Moderator

Re: XML editor problem[message #322344] Tue, 02 July 2013 15:00 Go to previous messageGo to next message
pheloncab

 
Messages:265
Registered:August 2004
Location: So. Cal. or texas
at a guess your going to have to copy the SOG graphics files manually. I know some of the other 1.13 mods especially the hybrids take a bit of effort to get the editor to play nice.
Also make sure your editor EXE is newer than your game EXE if the change log tells you that any major new features or tags to items have been added.

Re: XML editor problem[message #322354] Tue, 02 July 2013 18:07 Go to previous messageGo to next message
SharkD

 
Messages:344
Registered:July 2003
Well, the error says it's missing a certain STI, so my guess would be that the editor doesn't think to look for the files used by default before the add-on gets loaded in the parent data directory (e.g. Data-UB).
Re: XML editor problem[message #322357] Tue, 02 July 2013 18:58 Go to previous messageGo to next message
Gambigobilla

 
Messages:719
Registered:July 2008
1. Backup your "\Data-UB\AddOns\Data-Mod-SOG69-Vietnam\" folder
2. Copy missing files from your "\Data-UB" folder" to "Data-UB\AddOns\Data-Mod-SOG69-Vietnam"
2.5 Copy and paste over the whole folder just in case (exclude "addons" folder)
3. Copy and paste over your back up back to "\Data-UB\AddOns\Data-Mod-SOG69-Vietnam"
4. If does not work reiterate all with Data-113 folder.
5. If still says missing files reiterate with "data" folder.
6. I don't think think steps 4 and 5 will work.
Re: XML editor problem[message #322368] Tue, 02 July 2013 21:56 Go to previous messageGo to next message
SharkD

 
Messages:344
Registered:July 2003
Gambigobilla

3. Copy and paste over your back up back to "\Data-UB\AddOns\Data-Mod-SOG69-Vietnam"
4. If does not work reiterate all with Data-113 folder.

You want to try explaining that again?
Re: XML editor problem[message #322371] Tue, 02 July 2013 22:51 Go to previous messageGo to next message
Gambigobilla

 
Messages:719
Registered:July 2008
Basicly what i'm saying is get missing files from your "data-ub" folder. If those file are not there, check your "data-113" folder. If you can't find them again check your vanilla "data" folder.

Edit before posting: I'm trying it now myself. But it's a huge mess of xml, you'd better manually edit those xml files.
Re: XML editor problem[message #322372] Tue, 02 July 2013 22:58 Go to previous messageGo to next message
SharkD

 
Messages:344
Registered:July 2003
Is the editor still under development? It would be better IMO to fix the problem there instead of adding unnecessary files to all the mods.
Re: XML editor problem[message #322374] Tue, 02 July 2013 23:42 Go to previous messageGo to next message
Gambigobilla

 
Messages:719
Registered:July 2008
Everything is under development here. XMLeditor is even not working properly with latest releases. At least with flashlight feature.

[Updated on: Tue, 02 July 2013 23:43] by Moderator

Re: XML editor problem[message #322375] Wed, 03 July 2013 00:30 Go to previous messageGo to next message
Flugente

 
Messages:3045
Registered:April 2009
Location: Germany
The necessary two flashlight changes are in two items though, so you can easily use the editor and reapply the changes later on.


Re: XML editor problem[message #322658] Sat, 13 July 2013 06:12 Go to previous messageGo to next message
SharkD

 
Messages:344
Registered:July 2003
Is there an ETA for when the XML Editor will be able to edit merc gearkits?
Re: XML editor problem[message #322664] Sat, 13 July 2013 11:49 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3728
Registered:July 2009
Last year


Re: XML editor problem[message #322684] Sat, 13 July 2013 21:15 Go to previous message
SharkD

 
Messages:344
Registered:July 2003
Oops! I didn't see that last column.
Previous Topic: Currently recommended patches/mods?
Next Topic: San Mona question
Goto Forum:
  


Current Time: Thu Mar 30 17:32:08 EEST 2017

Total time taken to generate the page: 0.00948 seconds