Home » PLAYER'S HQ 1.13 » v1.13 Solutions,Tips & Spoilers » Need help with X-ray detector!!
Need help with X-ray detector!![message #275010] Thu, 03 March 2011 19:03 Go to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
I am so frustrated, I have tried everything I knew from vanilla JA2Gold. I can't seem to find the way to create the X-Ray detector

Here is a pic of my inventory: http://img822.imageshack.us/i/combinar.jpg/

LameBoy Display + Copper Wire
FumblePack + Gum + X-Ray tube
Gameboy +
Re: Need help with X-ray detector!![message #275011] Thu, 03 March 2011 19:06 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
that looks totally wrong

- the lbd should be smaller with wire to the left and right
- you should see the x-ray tube in the fumblepack
Re: Need help with X-ray detector!![message #275013] Thu, 03 March 2011 19:08 Go to previous messageGo to next message
Dr_Bullet

 
Messages:14
Registered:June 2009
Location: Germany, near the Pott.
You need the Utility Knive to seperate the Display from the Gameboy.
I had the same problem and tried a whole hour 'till I figured it out... Wink

Have fun with your detector!
Re: Need help with X-ray detector!![message #275014] Thu, 03 March 2011 19:11 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
he already has a display - have a look at that pic
Re: Need help with X-ray detector!![message #275015] Thu, 03 March 2011 19:15 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1539
Registered:March 2009
Location: Broadwurschd-City
As long as he does't have an xray-tube he wont get an xray-detector.

who has eyes shall see
Re: Need help with X-ray detector!![message #275016] Thu, 03 March 2011 19:17 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Mmmh I see... thx you both but I can't figure it out. Here are my steps

1 Lame Boy Display only accepts one attachment, which is a single copper wire.
2 The FumblePack accepts 2 attachments, the X-Ray tube and the chewing gum

Now that I have these two devices separated... what do I need to merge them into a detector???

PS.- could it be a bug? could I be retarded?hahahahahaha

thx you both 4 the quick answers
Re: Need help with X-ray detector!![message #275017] Thu, 03 March 2011 19:17 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
Torres84
I am so frustrated, I have tried everything I knew from vanilla JA2Gold. I can't seem to find the way to create the X-Ray detector

Here is a pic of my inventory: http://img822.imageshack.us/i/combinar.jpg/

LameBoy Display + Copper Wire
FumblePack + Gum + [color:#FF0000]X-Ray tube[/color]
Gameboy +

[Updated on: Thu, 03 March 2011 19:18] by Moderator

Re: Need help with X-ray detector!![message #275018] Thu, 03 March 2011 19:22 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Ooooops, then it should change into a different LAMEBOY display but it doesnt??? mmmhh ok then thx u all !!

Where do I report this bug? here is my version (SCI_SVN1252_MPSVN3944_Vanilla113_20101204)

Is there any other way to get the detector? ini editor? savegame editor?

Re: Need help with X-ray detector!![message #275019] Thu, 03 March 2011 19:37 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1539
Registered:March 2009
Location: Broadwurschd-City
@ Logisteric

there is NO tube on his picture
Re: Need help with X-ray detector!![message #275020] Thu, 03 March 2011 19:41 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Gorro der Gr
Re: Need help with X-ray detector!![message #275022] Thu, 03 March 2011 19:44 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1539
Registered:March 2009
Location: Broadwurschd-City
so something is realy f*ed up.

there should be 2 differend picture (not the orginal with a green star)

LameBoy Display + Copper Wire
FumblePack + Gum + X-Ray tube
Re: Need help with X-ray detector!![message #275023] Thu, 03 March 2011 19:46 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Here is a "clearer" sight of my inventory

http://img688.imageshack.us/i/sinttulo2xi.jpg/
http://img856.imageshack.us/i/sinttulo1s.jpg/

As you can see, everything is attached but it doesn't seems to work
Re: Need help with X-ray detector!![message #275031] Thu, 03 March 2011 20:11 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
pack savegame+ini and send it to rowa
Re: Need help with X-ray detector!![message #275039] Thu, 03 March 2011 20:37 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Logisteric
pack savegame+ini and send it to rowa


Could you be more specific? This is my first bug report and I don't know which are the key .ini files to send. (I see a lot of them)

Re: Need help with X-ray detector!![message #275040] Thu, 03 March 2011 20:39 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
options.ini (data-1.13-folder) - sent him a pm to get his email-addy
Re: Need help with X-ray detector!![message #275042] Thu, 03 March 2011 20:44 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
mthis bug shoulg go to Starwalker, not me. I am not the item guru.


Re: Need help with X-ray detector!![message #275061] Fri, 04 March 2011 01:11 Go to previous messageGo to next message
Starwalker

 
Messages:768
Registered:October 2005
Location: Hannover, Germany
Well, it looks as if the merges do not work.

As others have pointed out here, the Lameboy Display should change into something different when the Copper Wire is attached, the Copper Wire should not stay as an attachment.

The Fumble Pak with just one attachment would look as it does in his inventory, but with both attachments it should change into a new item as well. Then both new items could be merged into the X-Ray Detector.

I'll have to check the merges, but why should they have gone missing now?
I'd guess this is a NAS issue, but I'll check the merges anyway.

EDIT: Ooops, I just saw that the OP uses a pre-beta version that should not have NAS, thus I'll only check the merges.

[Updated on: Fri, 04 March 2011 01:16] by Moderator



Re: Need help with X-ray detector!![message #275062] Fri, 04 March 2011 01:27 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Torres84, are you playing with Sci-fi mode active? I ran into an issue a few SCI's ago where mergers that create Sci-fi flagged items, are only valid in Sci-fi mode, and I think the X-Ray detector is flagged as Sci-fi in the v1.13 Data folder.

EDIT: by issue, I mean it is a new feature to prevent "illegal" items based on game mode from showing up.

[Updated on: Fri, 04 March 2011 01:28] by Moderator



Re: Need help with X-ray detector!![message #275084] Fri, 04 March 2011 04:41 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Yep Im into SCI FI (I just love cutting the hell out the bugs with my katanas)

http://img819.imageshack.us/i/sinttuloggt.jpg/ <---- here are the details.


BTW I've installed it on C:/program files x86/Jagged Alliance 2 Gold and I had no crashes neither any other problems with the mod, it's running soooo fine I just had so minor minor minoooor crashes. No savgames corruption, missing data, unplayable scenarios or whatsoever.

THE ONLY WEIRD THING is that by this point of the game aliens should be attacking and they are not showing and I am playing SCI-FI as you can check.

One last thing, I had only done some small changes in the INI EDITOR (like max head divisor damage, gun overall damage etc)
Re: Need help with X-ray detector!![message #275089] Fri, 04 March 2011 10:44 Go to previous messageGo to next message
Starwalker

 
Messages:768
Registered:October 2005
Location: Hannover, Germany
I had a look into the merges, and all the necessary entries are still there.

@Torres84, please try the following and tell us the result:

- attach a Copper Wire to a Platinum Watch
- attach Quick Glue and Duct tape to a Steel Tube

The first should make a Detonator, the second a Gun Barrel Extender


But why the hell is there a "attach 2 MERC wristwatches to a MERC wristwatch to get a MERC wristwatch" attachment merge? :confused:


Re: Need help with X-ray detector!![message #275095] Fri, 04 March 2011 13:11 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Ok I'm on it. I'll edit with the results. (sorry for the late reply, we are a different timezone) Very Happy

Edit:
Those are working just fine !! the game doesn't give you any hints (highlighting the items) but I can succesfully create a Gun Barrel Extender, a timed detonator and even a rod&spring !!

Is this just happening to me ?

[Updated on: Fri, 04 March 2011 13:19] by Moderator

Re: Need help with X-ray detector!![message #275121] Sat, 05 March 2011 01:05 Go to previous messageGo to next message
Starwalker

 
Messages:768
Registered:October 2005
Location: Hannover, Germany
Now that is very strange, because all of those are 'attachment merges' (except Rod & Spring, which is a standard merge). I have no idea why the game does allow the other merges, but not the parts of the X-Ray Detector Sad

Please try to get a new merges.xml from the SVN-Server (save the old one elsewhere as a backup), and try to merge the items again.


Re: Need help with X-ray detector!![message #275122] Sat, 05 March 2011 01:43 Go to previous messageGo to next message
ctiberious

 
Messages:606
Registered:March 2007
If you can upload a savegame, I'll take a look and see if I can't figure out what the code is doing incorrectly.

Re: Need help with X-ray detector!![message #275127] Sat, 05 March 2011 03:50 Go to previous messageGo to next message
Torres

 
Messages:181
Registered:June 2010
Location: Canary Islands
Tried with the new merges.xml from the server and didn't worked so far...

Here is the MegaUpload link to all of my savedgames (I tend to save a lot just in case I find a bug)

http://www.megaupload.com/?d=FO2J7R51
Re: Need help with X-ray detector!![message #275705] Mon, 14 March 2011 12:57 Go to previous messageGo to next message
manny2354

 
Messages:24
Registered:February 2011
Hi all. This is my first post. I have been playing JA1/DG/2 on and off since they came out and have assembled countless Xray Detectors. I know very well how it is supposed to work. I ran into this exact problem described (and screenshot-ed) by Torres84 a couple weeks ago and have I still not figured it out. I actually registered to ask about it, but I guess I forgot. Must be the Gasket in me.

The necessary pieces will not merge to create the Display unit or Xray unit. It happens to me with the TAIS SCI posted in January, v4057. I am in SciFi mode, new inventory, and new traits (stomp). No other merges seem to be broken.

The previous version I played was v3356, realistic, and had no problem making the merges. I know it is a long time between those versions, so I can't say when this crept in.

Let me know if you want me to try anything to test this.
Re: Need help with X-ray detector!![message #275715] Mon, 14 March 2011 17:04 Go to previous messageGo to next message
Starwalker

 
Messages:768
Registered:October 2005
Location: Hannover, Germany
It is also in 4117, I saw it myself now.

The problem is, that other attachment merges seem to work, like the Gun Barrel Extender (also tested it myself), and the merges for the X-Ray Detector are still in the right place.

So it is not a case of missing merges, I'd rather think that the code may be acting strange, though I have no idea how that can be (seeing that the other attachment merges still work).

At least it seems to be something that I cannot help to solve Sad

I could make the Lameboy Display + Copper Wire merge an ordinary merge, but that would still not help, because the other item is still a three-part attachment merge.


Re: Need help with X-ray detector!![message #275732] Mon, 14 March 2011 23:00 Go to previous messageGo to next message
manny2354

 
Messages:24
Registered:February 2011
As long as one of the resident geniuses here has seen the bug and knows about it, I guess there is not much I can do to help. I'm not much for coding, other than reading and editing text files like XML/INI. When I noticed it was broken, I assumed the merge was broken on purpose; I know some consider it unrealistic.




Re: Need help with X-ray detector!![message #275790] Tue, 15 March 2011 18:17 Go to previous messageGo to next message
ctiberious

 
Messages:606
Registered:March 2007
I see what the problem is with this. It's another issue relating to coolness being looked at during the merge process. I've corrected the function call that was interfering with this merge operation and committed the fix.

Re: Need help with X-ray detector!![message #275879] Wed, 16 March 2011 19:25 Go to previous messageGo to next message
Starwalker

 
Messages:768
Registered:October 2005
Location: Hannover, Germany
It's because the resulting item's Coolness is zero?


Re: Need help with X-ray detector!![message #276025] Thu, 17 March 2011 20:58 Go to previous messageGo to next message
ctiberious

 
Messages:606
Registered:March 2007
It was, yes. To make sure that invalid merges couldn't be created, all merges now check whether "ItemIsLegal" before allowing the merge to proceed. But this function ALSO checks for the coolness and anything with too low of a coolness (0 being too low) will be marked as not legal. But to fix a previous problem, I had already updated the ItemIsLegal function so we could tell it to ignore the coolness portion of the check. This was done for one type of merge but needed to be included for another. The fix is already in the dev branch (rev 4250) though there may not be a build available yet. I'm sure that a new build will be available in the next couple days.

Re: Need help with X-ray detector!![message #276027] Thu, 17 March 2011 21:03 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
could someone just up a file with all those coolness-entrie are fixed (=set to 1)
Re: Need help with X-ray detector!![message #276028] Thu, 17 March 2011 21:36 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
the fix was in the source, not in the xmls.

with the fix you can merge items with coolness = 0

[Updated on: Thu, 17 March 2011 21:37] by Moderator



Re: Need help with X-ray detector!![message #276029] Thu, 17 March 2011 21:40 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
but an xml where those 0s are replaced by 1s would do the trick and is far less to download
Re: Need help with X-ray detector!![message #276084] Fri, 18 March 2011 17:40 Go to previous messageGo to next message
ctiberious

 
Messages:606
Registered:March 2007
If you changed all the items to have coolness=1, that would work around the problem in older builds, but you'd get other issues. Coolness is one of the values the program uses to determine whether enemy soldiers should be able to get a particular item. Meaning it's used to determine if something should be available as "loot" when you kill enemy soldiers. Would you really want X-ray detectors to start showing up as item drops from killing enemies? What about things like royal jelly or treated and coated armor?

If you change an item from coolness=0 to anything else, you're simply telling the code that the item is acceptable for enemies to be issued which means you'll start seeing them being dropped by enemies. Obviously, if this is something that doesn't worry you in your game, go for it. Smile But changing the "official" xml files in this way ins't the correct solution.

Re: Need help with X-ray detector!![message #276086] Fri, 18 March 2011 18:29 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Hang on a minute, when did it become OK again to use coolness = 0 for item control? A while back didn't we all have to adjust our items.xml due to some merger or NAS fail safe being introduced.

Related, I thought EnemyItemChoices.xml controlled enemy non-gun "loot." Again, we were told it was unnecessary to use coolness = 0 to prevent items from appearing because only items in this file would appear.


Re: Need help with X-ray detector!![message #278207] Tue, 19 April 2011 19:30 Go to previous messageGo to next message
power
Messages:1
Registered:April 2011
Hi, I have a question about the x-ray detector (didn't want to start a new thread, and this seems relevant)

Does it only work for sci-fi mode?
Cause I have it created on my realistic game, have 1 battery attached to it and for some reason it's not working? am I missing something?
Re: Need help with X-ray detector!![message #278211] Tue, 19 April 2011 21:41 Go to previous messageGo to next message
RichieRich80

 
Messages:45
Registered:February 2010
You need to put it to the merc's main hand and then in tactical view first click right mouse button to change the cursor to an "electronic item cursor" and then click left mouse button to actually use it. Enemies will be shown in the minimap as red dots, which will disappear soon afterwards.

Edit: If you don't see any enemies when you use it, maybe there aren't any close by. X-ray detector has a limited range, don't know how long exactly.

[Updated on: Tue, 19 April 2011 21:53] by Moderator

Re: Need help with X-ray detector!![message #278213] Tue, 19 April 2011 21:51 Go to previous messageGo to next message
Logisteric

 
Messages:3401
Registered:December 2008
Location: B
as richierich says, it's a rich boy's toy (=comes without a readme) - your private teacher is supossed to tell you how it works
Re: Need help with X-ray detector!![message #278214] Tue, 19 April 2011 21:57 Go to previous messageGo to next message
Gorro der Grüne

 
Messages:1539
Registered:March 2009
Location: Broadwurschd-City
about a quarter of the Vanilla maps
Re: Need help with X-ray detector!![message #280699] Wed, 25 May 2011 11:17 Go to previous message
raycrasher

 
Messages:59
Registered:August 2010
Location: Philippines
I ran into this, and I observed that Merges.xml entries needs to be SORTED by , then by in order to work. In other words,


1
1


1
2


1
3


2
1


2
2


and so forth. Not doing so will result in the merge not loading into the internal merge tables.
Previous Topic: Dealing with Pablo
Next Topic: How to restore attributes?
Goto Forum:
  


Current Time: Mon Jun 25 02:55:38 EEST 2018

Total time taken to generate the page: 0.01318 seconds