Home » MODDING HQ 1.13 » v1.13 Multiplayer Development & Bug Reports » Crash after placing mercs
Crash after placing mercs[message #284802] Mon, 27 June 2011 00:10 Go to next message
Demon123
Messages:4
Registered:June 2011
The game crashes after me and my friend press done after placing our mercs on the map. Any idea what could be causing this? Thanks in advance!
Re: Crash after placing mercs[message #284804] Mon, 27 June 2011 00:14 Go to previous messageGo to next message
PasHancock

 
Messages:738
Registered:February 2011
Location: Estonia,Tallinn
Me and my friend had same problem.It can be High Ping,it depends on where you guys live.

[Updated on: Mon, 27 June 2011 00:14] by Moderator

Re: Crash after placing mercs[message #284805] Mon, 27 June 2011 00:17 Go to previous messageGo to next message
Demon123
Messages:4
Registered:June 2011
I dont believe its that. We live very close to each other, and are using hamachi.

[Updated on: Mon, 27 June 2011 00:18] by Moderator

Re: Crash after placing mercs[message #284809] Mon, 27 June 2011 00:23 Go to previous messageGo to next message
PasHancock

 
Messages:738
Registered:February 2011
Location: Estonia,Tallinn
what version of MP you play?
Re: Crash after placing mercs[message #284810] Mon, 27 June 2011 00:24 Go to previous messageGo to next message
Demon123
Messages:4
Registered:June 2011
We are using the latest version of 1.13.
Re: Crash after placing mercs[message #284811] Mon, 27 June 2011 00:25 Go to previous messageGo to next message
PasHancock

 
Messages:738
Registered:February 2011
Location: Estonia,Tallinn
make sure that you and your friend's firewall doesnt block Ja2
Re: Crash after placing mercs[message #284812] Mon, 27 June 2011 00:27 Go to previous messageGo to next message
Demon123
Messages:4
Registered:June 2011
We will try that tomorrow. Thanks Very Happy
Re: Crash after placing mercs[message #284813] Mon, 27 June 2011 00:29 Go to previous messageGo to next message
PasHancock

 
Messages:738
Registered:February 2011
Location: Estonia,Tallinn
Np,check mail By the way
Re: Crash after placing mercs[message #289412] Fri, 19 August 2011 02:48 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
Was there any solution to this yet?

I have the exact same problem..joining, Merc hiring and getting to the placement screen works, but as soon as both are DONE, the host (in this case me) crashes to desktop EVERY time.

We both have the same build, which we allready checked and which is the latest available with MP 1.7.

Similar to my single player problem (which is now seemingly gone) i get a crappy crash report with no info:

-----------------------------------------------------------
File:
C:\Spiele\Jagged Alliance 2 Gold\ja2.exe
Release v1.13.4462 (Official Release): Build 11.05.30. Z
-----------------------------------------------------------


over and over again.

JA2 Gold with 1.13.4462, running on Win7, port open and so on..

I have no clue and want to coop play that damn game!
Re: Crash after placing mercs[message #289413] Fri, 19 August 2011 02:57 Go to previous messageGo to next message
Tao

 
Messages:2140
Registered:August 2009
Location: The Known Universe
PasHancock
Me and my friend had same problem.It can be High Ping,it depends on where you guys live.


This is correct.

@statistx
Where do each of you geographically live?
Re: Crash after placing mercs[message #289416] Fri, 19 August 2011 04:18 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
I'm in austria and he is in america, though honestly, i dismissed that idea, cause i have a very good internetconnection and am always hosting other games without any lag.
Besides: shouldn't it just disconnect instead of CTD?
Re: Crash after placing mercs[message #289418] Fri, 19 August 2011 04:25 Go to previous messageGo to next message
Tao

 
Messages:2140
Registered:August 2009
Location: The Known Universe
Well, we did some testing a while back and it does in fact depend on geographical locations.
Re: Crash after placing mercs[message #289419] Fri, 19 August 2011 04:27 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
Ok thanks, so basically I'm fucked.
Re: Crash after placing mercs[message #289420] Fri, 19 August 2011 05:51 Go to previous messageGo to next message
Tao

 
Messages:2140
Registered:August 2009
Location: The Known Universe
Well, we were able to play a few games. When we had a third party, we were able to connect better. Truthfully I don't understand it very well.
Re: Crash after placing mercs[message #289951] Sun, 28 August 2011 03:29 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
Now tested it on a LAN.
Closer than being 1 seat away won't happen, since I have no wish to have someone sitting on my lap.
Still does not work., so there is another reason for that crash after placing mercs.
Too bad, cause it would be a pretty good multiplayergame
Re: Crash after placing mercs[message #289954] Sun, 28 August 2011 04:28 Go to previous messageGo to next message
RoWa21

 
Messages:2049
Registered:October 2005
Location: Austria
are you playibg the latest version (4552)?


Re: Crash after placing mercs[message #289956] Sun, 28 August 2011 05:08 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
I did miss the update, but after you wrote that i updated and still the same.
Crash of the host after placing mercs
Re: Crash after placing mercs[message #289958] Sun, 28 August 2011 09:13 Go to previous messageGo to next message
RoWa21

 
Messages:2049
Registered:October 2005
Location: Austria
does it always crash or only on specific maps?
I never had that problem, very strange...


Re: Crash after placing mercs[message #289966] Sun, 28 August 2011 13:11 Go to previous messageGo to next message
Grziwatzki

Messages:7
Registered:August 2011
Location: Germany
Hi Guys,

i have the exact same problem. My friend and i are living in the same town so i think the geographical thing is not the problem. Did anyone find a solution yet? The crashing is not map specific by the way.

Im operating a Win7 x64 system with the newest version of 1.13 and all router ports are open i think.
Re: Crash after placing mercs[message #289978] Sun, 28 August 2011 17:38 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
i tried to change the drop off point, so the solution from above where someone said it worked on another map part, is not a solution that solves every problem.

I would be more helpful, but my crashlogs say nothing.

As written above: it always crashes when both players hit "done" after placing their mercs.

I'd say my setup is bad or i messed up somewhere, but in this thread alone there are 3 people reporting it and i saw other threads about that too.

Re: Crash after placing mercs[message #289986] Sun, 28 August 2011 20:56 Go to previous messageGo to next message
Grziwatzki

Messages:7
Registered:August 2011
Location: Germany
I'm new to this JA2 Coop stuff so maybe the following has nothing to do with our problem. My Chat says "A Packet has been received for which i dont now what to do" when i start the server.

Is there any chance that the crashing has something to do with that?
Re: Crash after placing mercs[message #289988] Sun, 28 August 2011 22:05 Go to previous messageGo to next message
PasHancock

 
Messages:738
Registered:February 2011
Location: Estonia,Tallinn
no,it always says "A Packet has been received for which i dont now what to do",its not a problem
Re: Crash after placing mercs[message #290011] Mon, 29 August 2011 13:42 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
Too bad i know crap about programming, so my thoughts on why this happens, are very limited.
Is there probably some kind of Framelimiter to keep people with low connection from joining, which in return may have a bug that under certain circumstances, crashes a host after going to the tactical map?
Re: Crash after placing mercs[message #290021] Mon, 29 August 2011 16:59 Go to previous messageGo to next message
Grziwatzki

Messages:7
Registered:August 2011
Location: Germany
do we have to use the JA2 Gold Edition with the 1.13 patch or can i use use the normal JA2 version too? I am using the normal version, mybe this is the problem...
Re: Crash after placing mercs[message #290025] Mon, 29 August 2011 20:08 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
I use gold and have the problem, so i guess that is not the reason
Re: Crash after placing mercs[message #290026] Mon, 29 August 2011 20:35 Go to previous messageGo to next message
Logisteric

 
Messages:3422
Registered:December 2008
Location: B
you can dumb 1.13 into ANY ja2 -should be no problem for multiplayrt either
Re: Crash after placing mercs[message #290162] Wed, 31 August 2011 21:40 Go to previous messageGo to next message
Grziwatzki

Messages:7
Registered:August 2011
Location: Germany
Hmm so we wait for a new version of 1.1.3?
Re: Crash after placing mercs[message #290164] Wed, 31 August 2011 22:23 Go to previous messageGo to next message
Logisteric

 
Messages:3422
Registered:December 2008
Location: B
why not wait for someone to fix your bug

oh wait to dump into is not necessarily the city dump - in th is case its 'just copy it in ANY ja2'
Re: Crash after placing mercs[message #290178] Thu, 01 September 2011 01:51 Go to previous messageGo to next message
statistx

 
Messages:11
Registered:August 2011
would be cool if someone fixes the bug, but since no one knows what causes it, there won't be much happening in that direction Sad
Re: Crash after placing mercs[message #290182] Thu, 01 September 2011 11:57 Go to previous messageGo to next message
RoWa21

 
Messages:2049
Registered:October 2005
Location: Austria
Wait until the next official update. I made several changes to the connection problem and hope it will fix the bug. Also grenade throwing crash is fixed.


Re: Crash after placing mercs[message #299304] Sat, 18 February 2012 08:14 Go to previous messageGo to next message
Bosky
Messages:2
Registered:February 2012
I registered just to say my friend and I have the exact same problem Sad

This is build 4870 from Dec 28 2011. Basically for Deathmatch or Co-op, regardless of what options we tweak when hosting, the game will crash immediately after we both place our mercs.

We live in the same city and are using the same base version of JA 2 Gold.

So the prognosis is "wait for the next release"? Sad Has anyone tried from Subversion/SVN and had more luck?
Re: Crash after placing mercs[message #299681] Tue, 21 February 2012 13:22 Go to previous messageGo to next message
alfman
Messages:1
Registered:February 2012
I think i know why the Multiplayer Part is crashing after placing the Mercs . You cant use the "Einsteiger/Easy" Difficulty or the Game is crashing . You need to use one Difficulty Level after "Einsteiger/Easy" . For us the Game is running fine from now on Smile

The Screenshot is from the German Version but these Settings are running fine without any Problems Smile

http://www.abload.de/img/ja2-mpz3k08.jpg
Re: Crash after placing mercs[message #300241] Fri, 24 February 2012 23:36 Go to previous messageGo to next message
RoWa21

 
Messages:2049
Registered:October 2005
Location: Austria
@alfman: if that is the case, then it should be easy to fix.


Re: Crash after placing mercs[message #300287] Sat, 25 February 2012 11:24 Go to previous messageGo to next message
Bosky
Messages:2
Registered:February 2012
Confirming alfman, as I changed the difficulty from Novice to Experienced and this crash problem went away. Much appreciated, good find!

Now if only I could figure out how to deploy by my friend so we don't have to run across the map into each others zones!

[Updated on: Sat, 25 February 2012 11:25] by Moderator

Re: Crash after placing mercs[message #300304] Sat, 25 February 2012 15:34 Go to previous messageGo to next message
RoWa21

 
Messages:2049
Registered:October 2005
Location: Austria
@Bosky: Thats fine that this workaround is now working Smile

@Deployment: You can set the starting edge (north, south, east, west and center) for each player on the strategy screen, BEFORE the server unlocks the laptop!


Re: Crash after placing mercs[message #300441] Mon, 27 February 2012 22:53 Go to previous messageGo to next message
RoWa21

 
Messages:2049
Registered:October 2005
Location: Austria
Bug is fixed


Re: Crash after placing mercs[message #301096] Tue, 06 March 2012 09:00 Go to previous message
haydent

 
Messages:264
Registered:November 2007
Location: NSW, Australia
great.


Previous Topic: MP fixes?
Next Topic: JA2 1.13 Multiplayer Releases
Goto Forum:
  


Current Time: Wed Apr 25 07:57:10 EEST 2018

Total time taken to generate the page: 0.01345 seconds