Home » SIRTECH CLASSICS » Jagged Alliance 2 » JA2 Technical Department » Win. 7 64-bit & new system issues...
Win. 7 64-bit & new system issues...[message #289816] Thu, 25 August 2011 19:44 Go to next message
Kyle

 
Messages:34
Registered:December 2008
Hello!

Need help in getting JA2 with 1.13, Urban Chaos (the 1.13 compatible version), and Alrulco Folding Stocks working altogether in peace, love and harmony.

First, the all important listing of system specs
ASRock 870 Extreme 3 AM3 motherboard
AMD Phenom II x4 840 Edtition Deneb 3.2 GHz Quad-Core Processor
A-DATA XPG Gaming Series v. 2.0 4GB RAM
HIS Radeon HD 6850 1GB (256 bit) GDDR5 Eyefinity graphics card
Seagate Barracuda 7200.10 hard drive


Operating System

Win. 7 64-bit Professional

Software Used
JA2 purchased through GOG.com. It, along with the 1.12 Gold Patch, were installed to the Program Files (x86) directory.
I started up the game, and the "Start Game" screen showed up. I assumed that the game would've operated fine, but I didn't start a new game because I want to play it with the 1.13 mod, along with the 1.13-friendly versions of Urban Chaos and the Alrulco Folding Stocks mod.


From doing a keyword search here, I read that I shouldn't install the game into a "Programs" type directory, yet it wants to autoinstall to Program Files (x86), which I allowed it to do. The installation pathway looks like this:
Local Disk (C:)--->Program Files (x86)--->GOG.com--->Jagged Alliance 2

I installed the mods in the following order to the above mentioned Jagged Alliance 2 directory:
1.13 (latest version)
1.13 update (latest version)
Urban Chaos (without installing the optional Chance to Hit and SciFi quest files)
Urban Chaos 1.13 upgrade mod (UC-1.13_v3.55_20110723)
Urban Chaos 1.13 upgrade mod PATCH (UC-1.13v3.5820110820)
Alrulco Folding Stock v3.2020110821 mod

When I tried to startup JA2 using the shortcut provided by the 1.13 mod, I got the following error message:
JA2 Fatal Error [X]
File: .\sgp.cpp
Line: 735
Location: InitializeStandardGamingPlatform
Initializing Virtual File System failed

[OK]


Any step-by-step assistance on what I did wrong would be greatly appreciated. The more details, the better.

Thank you
in advance!
Kyle
Aug. 25, 2011

Re: Win. 7 64-bit & new system issues...[message #289817] Thu, 25 August 2011 19:47 Go to previous messageGo to next message
Logisteric

 
Messages:3396
Registered:December 2008
Location: B
just move it somewhere else -> zip it for further use -> apply tais' latest uc-sci on top -> if necessary update with wil473' updates -> have fun
Re: Win. 7 64-bit & new system issues...[message #289831] Thu, 25 August 2011 23:57 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
"Program Files (x86)"

I'm going to have to copy the warning I have in the Deidranna Lives!-1.13 installation tome to the other two mods.

Here is one based on something I prepared earlier:

0) install clean JA2 (retail), not in the default directory that includes "Program Files (x86)"
1) install Tais latest SCI to get: v1.13 rev 4553 (one fix newer than last official) and original UC data
2) delete some folders to clear the obsolete UC-1.13 v3.53 (see v3.55 upgrade instructions here: http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=286240#Post286240 )
3) install UC-1.13 v3.55 (full version)
4) install UC-1.13 v3.58 (cumulative patch)

5) install AFS v3.20

EDIT: oh and the UC-1.13 and AFS mods have their own subforum here: http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=postlist&Board=69&page=1

Both mods were built on a Win 7 (64bit system), inside the same production install of Jagged Alliance 2, and tested together in another (that happens to be based on the AIMNAS SCI so I could see if the newer .exe had any "unique" problems).

[Updated on: Fri, 26 August 2011 00:01] by Moderator



Re: Win. 7 64-bit & new system issues...[message #289834] Fri, 26 August 2011 00:24 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
Thanks for the feedback, but I have hit a MAJOR snag.

I wanted to be "extra thorough" in setting up a perfect installation of JA2+the mods, so I uninstalled JA2, reinstalled to its own directory on the C Drive, and when I went to install the 1.13 mod, it says that it's ALREADY installed!

But I uninstalled the original directory ---the one in the Program Files (x86)---, so how can it still exist if its parent directory is GONE?

For the heck of it, I tried installing 1.13's update, and its default installation was to the Program Files (x86)/GOG directory. What is WEIRD is that the words "GOG" and "Jagged Alliance 2" are listed in a ghosted font, but if I look at the Program Files (x86) files, "GOG" is no longer listed. So how is it possible that the 1.13 update application is finding a "nonexistent" directory?

Argh!!!!!!!

I've run Advanced SystemCare's registry fixer twice, and it's not finding any unusual issues. But something's wrong, that's for sure.

How do I make the ghost GOG and Jagged Alliance 2 listings go away, so that the 1.13 application can finally be installed in my fresh setup?
Re: Win. 7 64-bit & new system issues...[message #289836] Fri, 26 August 2011 00:31 Go to previous messageGo to next message
JMich

 
Messages:575
Registered:January 2011
Location: Greece
Go to control panel and uninstall the 1.13 release. The installer currently used leaves a few entries in the registry, even if JA2 is removed. The hotfix is using those entries to find the default installation path.

P.S. Use Tais' SCI, not the official release
Re: Win. 7 64-bit & new system issues...[message #289838] Fri, 26 August 2011 00:46 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Adding to what JMich said, Jagged Alliance 2 itself shouldn't care about registry entries. Just re-install your retail Jagged Alliance 2 (somewhere that doesn't inhibit copying & pasting), and proceed with the "Quick Install" instructions I left earlier. Tais SCI (Single Click Installer) for UC-1.13 v3.53 is not really an installer, but a spanned archive that can be easily extracted as many different places as you want (but try to only do it once). The SCI contains a fully working v1.13 rev 4553 and the original Urban Chaos data, which basically mean it will take care of most of the install process except for updating to v3.55 (last full version uploaded) and then v3.58 (most recent patch).

[Updated on: Fri, 26 August 2011 00:50] by Moderator



Re: Win. 7 64-bit & new system issues...[message #289839] Fri, 26 August 2011 00:48 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
Thanks for the prompt response JMich.

The problem is that the Control Panel does not list the mod at all.

I'm assuming that it's listed as something along the lines of either "Jagged Alliance 2 1.13" or "JA2 1.13," etc., etc., and there's nothing even close to it listed there. Not even plain old "1.13."

I have completely uninstalled the last installation of JA2 that I did (the one that's NOT in the "Program Files (x86)" directory). After I rebooted, I had ASC do another scan, I had it fix the four issues that it found, and then tried installing 1.13 without installing JA2. "Yes," 1.13 is still miraculously finding the uninstalled GOG/Jagged Alliance 2 folders.

What next?
Re: Win. 7 64-bit & new system issues...[message #289840] Fri, 26 August 2011 00:57 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Do not use the official v1.13 installer. In case you missed my edit:

0) re-install only the retail Jagged Alliance 2 (not in the default location, put it somewhere that lets you copy and paste stuff easily).
1) Tais' Single Click Installer for UC-1.13 v3.53; this one spanned archive includes:
- complete v1.13 revision 4553
- complete original Urban Chaos Data
- obsolete UC-1.13 v3.53 that you need to remove, see here: http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=286240#Post286240
2) Urban Chaos-1.13 v3.55 (you already have v1.13 and original UC Data, so just extract this to your root Jagged Alliance 2 folder)
3) Patch to UC-1.13 v3.58, it is a cumulative patch so don't bother with v3.56-57

[Updated on: Fri, 26 August 2011 00:57] by Moderator



Re: Win. 7 64-bit & new system issues...[message #289850] Fri, 26 August 2011 08:42 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
Thanks for the help folks.

So, just to be clear, if I'm using Tais' Single Click Installer, I do NOT have to install v1.13 because it is ALREADY integrated into Tais' work?

I hunted through the directory after installing Tais' mod, and could not find any of the obsolete files to delete. I'm talking about these ones from the thread that you linked me to...
Quote:
Delete Files:
vfs_config.UC113.ini
vfs_config.UC113OldMaps.ini

Delete Folders:
...\Data-UC113
...\Data-UC113DoNotEdit
...\Data-UC113Maps
...\Data-UC113OldMaps


Since I couldn't find them, I proceeded with the rest of the mod installation as noted. Alrulco was installed at the very end as part of this process.

Unlike before, I was able to start up JA2 without any issues, but it's too late in the night for me to start a new game. Does the Urban Chaos + 1.13 mod have a way of displaying to the Player that it is working? What I mean by this is that it's not uncommon for mods to change the startup screen so that the Player knows that they have a certain mod active. At this point in time, all of the screens look like the standard JA2 ones. Let me know if I should see a note or an image that clearly flags that the mod is active.

And one last request, if there is a way to fully uninstall my OLD installation of v1.13, I'd greatly appreciate it. No matter how "harmless" it is, it's more than a little bit unnerving that a program that should've been removed because its parent's directory was wiped out is still somehow functional. Is the v1.13 fully functional, or just a seemingly impossible-to-remove Registry entry that does nothing more than prevent the reinstallation of itself, or...? Any clarity on this would be greatly appreciated. Please keep in mind that it's not displaying itself through Windows' Uninstall A Program utility window.

Thanks again!
Re: Win. 7 64-bit & new system issues...[message #289851] Fri, 26 August 2011 11:01 Go to previous messageGo to next message
Logisteric

 
Messages:3396
Registered:December 2008
Location: B
Kyle
What I mean by this is that it's not uncommon for mods to change the startup screen so that the Player knows that they have a certain mod active. At this point in time, all of the screens look like the standard JA2 ones.


that should definately not be the case


https://sn2files.storage.live.com/y1pyaC7cRoF-WXPwx7iqr8RBdcrxneMnJ33ZEMBDX0EuM64p9TlzOszYc5fJBCqrHc4bZZbXex-Tik/uc-start.jpg

which of tais' installers did you use?

you need both parts from here for uc

[Updated on: Fri, 26 August 2011 12:40] by Moderator

Re: Win. 7 64-bit & new system issues...[message #289857] Fri, 26 August 2011 14:45 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Kyle
Thanks for the help folks.

So, just to be clear, if I'm using Tais' Single Click Installer, I do NOT have to install v1.13 because it is ALREADY integrated into Tais' work?

I hunted through the directory after installing Tais' mod, and could not find any of the obsolete files to delete. I'm talking about these ones from the thread that you linked me to...
Quote:
Delete Files:
vfs_config.UC113.ini
vfs_config.UC113OldMaps.ini

Delete Folders:
...\Data-UC113
...\Data-UC113DoNotEdit
...\Data-UC113Maps
...\Data-UC113OldMaps


Since I couldn't find them, I proceeded with the rest of the mod installation as noted. Alrulco was installed at the very end as part of this process.




That is not a promising start, those folders should be in your root Jagged Alliance 2 folder, no need to "hunt" for them as they should be in the first level of where you installed Jagged Alliance 2. Moreover, if you are missing the specified files for deletion, you are probably missing the original Urban Chaos data.

Adding to what Logisteric posted, Tais has three different current SCI's for three different mods. The current one for Urban Chaos is found in the link he supplied (also found in the post that you partially quoted). Did you download from Tais' MediaFire the following two files?

SCI_UC113v3.53_r4553_20110704.7z.001
SCI_UC113v3.53_r4553_20110704.7z.002

These two files make up the spanned 7zip archive you need to extract (in one 7zip operation) into your root Jagged Alliance 2 folder.

EDIT: as your description indicates that at the very least something went wrong with the installation via Tais' SCI, before you do anything else, please list off the full file names your downloaded, and the order in which you applied them. We need to know what the mistakes were before suggesting how to proceed.

[Updated on: Fri, 26 August 2011 15:59] by Moderator



Re: Win. 7 64-bit & new system issues...[message #289864] Fri, 26 August 2011 17:51 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
Thanks for the very helpful image Logisteric. I definitely do not have that startup screen, so Urban Chaos is not working properly.

I floated my cursor over Tais' two files, and the second one came up as being listed "not an archive" (or something like that). So, in case the file became corrupted during the download process, I have redownloaded file 2 from his MediaFire account. And "Yes," those were the files that I downloaded/extracted/installed.

Quote:
SCI_UC113v3.53_r4553_20110704.7z.001
SCI_UC113v3.53_r4553_20110704.7z.002


What strikes me as a bit strange is that when I extracted the above files together last night and this morning, only the ".001" file was actually listed as being extracted, and file ".002" was never explicitly stated as being extracted as part of this combined process. Perhaps .002 wasn't extracted, even though I selected both files before right-clicking on them and ordering that they be "Extracted here?" I was using 7zip.

Keep in mind though, that in the directions that were supplied via the thread that it states that only the "Data-UC" file was needed, and thus I did not install anything else into the "Jagged Alliance 2" parent directory.

Just checked that thread again. The directions are confusing.

Let's see if this is what was meant...

First, one needs to download Tais' OLD files entitled:
SCI_UC113v3.0_r4057_20110129.7z001
SCI_UC113v3.0_r4057_20110129.7z002
Only the "Data-UC" is needed, so extract only that, and then install into one's Jagged Alliance 2 directory.

Second, one needs to download Tais' newer all-in-one files entitled:
SCI UC113v3.53 r4553 20110704.7z.001
SCI UC113v3.53 r4553 20110704.7z.002
Using 7zip, extract both of these files TOGETHER in ONE operation. Search the extracted files, and delete the following:
Delete Files:
vfs_config.UC113.ini
vfs_config.UC113OldMaps.ini

Delete Folders:

...\Data-UC113
...\Data-UC113DoNotEdit
...\Data-UC113Maps
...\Data-UC113OldMaps

Once the deletions are done, install the remaining files into one's Jagged Alliance 2 directory.

Third, Patch to UC-1.13 v3.58, it is a cumulative patch so don't bother with v3.56-57

Fourth, one may also choose to install the optional Alrulco Folding Stocks.



So, what's the main difference between what I posted here versus what's posted in the other thread? It's more specific in spelling out that there are TWO mods that are needed from Tais. The way that I read it numerous times, is that there were two links to the same mod (which is not the case). It also defines what the name of mods' parts are, so that they can be more clearly referenced by the Player.

So, at this point in time, it looks like what I'm missing are:
(1) A partial install of Tais' older mod
(2) A complete install of Tais' all-in-one newer mod
(3) I'm assuming that if I do the above two steps, that I'll need to...
...reinstall the patch to Tais' newer work, and...
...reinstall teh Alrulco Folding Stocks mod.


Feel free to correct me if I'm wrong on any of this.

Just so you know, it's going to be a while till I'm able to respond to any postings here, as I'm leaving for a number of hours. It's likely that I won't be able to follow through on any of your recommendations till tonight.

Thanks again for you valuable assistance.


Re: Win. 7 64-bit & new system issues...[message #289867] Fri, 26 August 2011 18:08 Go to previous messageGo to next message
Logisteric

 
Messages:3396
Registered:December 2008
Location: B
ja2 (any) -> uc.sci (by tais/newest) -> updates -> lock and load

a tais-sci is always all inclusive (up to the day he made it)
Re: Win. 7 64-bit & new system issues...[message #289876] Fri, 26 August 2011 20:56 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
I'm not sure where the confusion is occurring, but you seem to be indicating to us that you've downloaded two of Tais' SCI's (four files), instead of just the latest (two files). Again, with file names where applicable, and with as small steps as I can think of over lunch:

1) Install clean Jagged Alliance 2 retail (the one you bought at GOG)
- - Do not use default folder

2) Download and extract Tais' latest SCI for UC-1.13
- - http://www.mediafire.com/tais113stuff#usll77n79e4jm,1
- - only two files from Tais (no more no less) for a spanned 7zip archive:
Quote:

SCI_UC113v3.53_r4553_20110704.7z.001
SCI_UC113v3.53_r4553_20110704.7z.002

- - it would be best if you extract the archive to your desktop first, then copy the contents into your root JA2 install
- - it is a spanned archive, so you should only have to open it once with 7zip, if you run into problems stop and ask pease
- - if you have extracting/copied the files correctly, you should get a prompt for overwriting the Data folder (click YES), if not then stop right there please

3) Delete the following, stop if you cannot find them:
Quote:

Delete Files:
vfs_config.UC113.ini
vfs_config.UC113OldMaps.ini

Delete Folders:
...\Data-UC113
...\Data-UC113DoNotEdit
...\Data-UC113Maps
...\Data-UC113OldMaps


4) Download and extract my Urban Chaos-1.13 v3.55 (Full) release
- - http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=236264#Post236264
- - probably best to extract to your desktop and copy (not cut) and paste to your Jagged Alliance 2 install
- - if things are going well, you will get a prompt concerning overwriting the Profiles folder (click YES), if not then stop right there please

5) Download and extract my UC-1.13 v3.58 (patch)
- - http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=289041#Post289041
- - several files and folders will be overwritten if the previous steps were done correctly (click YES for all)

At this point launch the game via the INI Editor supplied with v1.13, make sure the mod selected is one of the variants of the current UC-1.13 mod supplied: VFS_CONFIG.UC113.ini or VFS_CONFIG.UC113OldMaps.ini

Follow the above without deviation, do not add downloads or other files, if you run into problems, stop and ask please.


[Updated on: Fri, 26 August 2011 21:00] by Moderator



Re: Win. 7 64-bit & new system issues...[message #289899] Sat, 27 August 2011 06:53 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
Yeeeeeee-haaaaaa!!!!!

That worked.

PERFECTLY.

Thank you so much for all of your patience and detailed help!

Now, can I install the Folding Stocks mod into the game? Any special steps that I should be aware of? Should the INI Editor be used in a certain way?

Thanks again!
Re: Win. 7 64-bit & new system issues...[message #289918] Sat, 27 August 2011 13:26 Go to previous messageGo to next message
Logisteric

 
Messages:3396
Registered:December 2008
Location: B
the foldingstock-mod is part of the newest ucNAS - you are not supossed to install it, it is already in there
Re: Win. 7 64-bit & new system issues...[message #289919] Sat, 27 August 2011 13:48 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Alrulco Folding Stock is a stand-alone mod, I haven't gotten around to putting together a compilation release. Probably won't either. Last two full releases of UC-1.13 saw hundreds of downloads between Mediafire and ModDB (though the patch isn't doing nearly so well). AFS and DL only a few dozen combined. No point in re-cluttering UC-1.13, that and this lets me handle patching differently (ie. UC-1.13 is patched, but AFS and DL-1.13 are small enough, and simple enough, to have full releases each time I fix/update something).

As long as you got UC-1.13 working, yes, go ahead and drop Alrulco Folding Stock into your JA2 install. Consult the included PDF for game mode as it comes with a half dozen sub-mods governing how the AI is equipped. There is no change to the splash screen when AFS is active, though that is something to consider for future releases.

EDIT: if nobody minds, I'm going to see if I can move thread out of the Vanilla forum to the actual UC/DL sub-forum in the v1.13 forum. Never mind, I don't have the power outside the UC/DL sub-forum.

[Updated on: Sat, 27 August 2011 13:53] by Moderator



Re: Win. 7 64-bit & new system issues...[message #289936] Sat, 27 August 2011 18:30 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
Thanks for all of the feedback folks!

wil473, at the start of your response, it was stated that...
Quote:
Alrulco Folding Stock is a [color:#CC0000]stand-alone[/color] mod, I haven't gotten around to putting together a compilation release.


...yet at the end of the post, it's written...
Quote:
As long as you got UC-1.13 working, yes, go ahead and drop Alrulco Folding Stock into your JA2 install.


I do have UC-1.13 working, so as long as I install AFS properly, the two different mods, and in spite of AFS being "stand-alone" in its nature, the two mods will work well together? Just making sure before I go through the process.

Having looked through the FAQ, is there one particular way of having the AI handle stocks that you prefer personally? Could you explain why, so that I can better determine which approach to select?

There's an awesome mod for 7.62 mm. called The Blue Sun Mod, and amongst the enormous host of huge and important changes it makes, it also enhances weaponry so that stocks are adjustable, with believable ramifications regardless of how the stock is deployed. Those who are interested can find out a lot more about it from this thread: The Blue Sun Mod for 7.62 mm

In my mind, the AFS mod is an important one, and for a large list of reasons that seem quite obvious to me. I'm very grateful for all of the hard work that you've poured into these numerous releases.

Re: Win. 7 64-bit & new system issues...[message #289957] Sun, 28 August 2011 07:48 Go to previous messageGo to next message
Kyle

 
Messages:34
Registered:December 2008
I ended up backing up my working version of UC+v1.13, and installed AFS.

I set the .ini for "default." Does this mean that the AI get access to all of the weapons, or...?

I was surprised that when I used the INI Editor to launch the game, that it was the Alrulco campaign, which is fine, since it's been so long since I last played it anyway. Is the purpose of first installing UC or DL is so that their weapons are available in the standard Alrulco campaign, or...?

Had a blast with the very first mission. I am greatly impressed with all that I've seen so far.
Re: Win. 7 64-bit & new system issues...[message #289976] Sun, 28 August 2011 16:38 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
Sorry for the late reply, was out of town for most of yesterday.

Kyle


wil473, at the start of your response, it was stated that...
Quote:
Alrulco Folding Stock is a [color:#CC0000]stand-alone[/color] mod, I haven't gotten around to putting together a compilation release.


...yet at the end of the post, it's written...
Quote:
As long as you got UC-1.13 working, yes, go ahead and drop Alrulco Folding Stock into your JA2 install.


I do have UC-1.13 working, so as long as I install AFS properly, the two different mods, and in spite of AFS being "stand-alone" in its nature, the two mods will work well together? Just making sure before I go through the process.


There is no contradiction in my earlier post:
"Stand-alone" - does not say anything about interference or non interference with other mods, it only means that AFS (and my other current mods) are being distributed with a complete set of files, so they can be downloaded and installed independently.

I am using the Virtual File System (VFS) feature of JA2 v1.13, which allows multiple mods, if implemented correctly, to share a single Jagged Alliance 2 install. This is also why you have two sub-mods (old/new maps) with UC-1.13 v3.55+, and half a dozen with AFS v3.20. Files unique to each mod and sub-mod are kept in separate directories, and only assembled as "live" files if the .ini is selected.

EDIT: as far as I know, these mods compatible with the current release of JA2 v1.13 use VFS to allow for independent operation if they're in the same install:

stock v1.13 - it does not interfere with the "vanilla" sub-mod that it is distributed with
"vanilla" v1.13 - it does not interfere with the "stock" sub-mod that it is distributed with
AIMNAS - Smeagols big items and maps mods
Alrulco Folding Stock - my items mod for stock Alrulco campaign, no maps
DL-1.13 - my items mod for Deidranna Lives! campaign, only original DL maps as of v3.00
UC-1.13 - my items mod for Urban Chaos campaign, some new maps depending on sub-mod


EDIT2: my mods so far have not employed their own splash screens. Under UC-1.13 you are seeing the original Urban Chaos' splash screen, likewise for DL-1.13. This means that AFS displays the stock splash screen. It may be something I implement so that people have an immediate indication of the mod being active.

[Updated on: Sun, 28 August 2011 16:55] by Moderator



Re: Win. 7 64-bit & new system issues...[message #291209] Tue, 27 September 2011 22:44 Go to previous messageGo to next message
kyle2k
Messages:3
Registered:September 2011
Hello guys

I'm having the same "ja2 fatal error" issue, reported before:

JA2 Fatal Error

File: .\sgp.cpp
Line: 735
Location: InitializeStandardGamingPlatform
Initializing Virtual File System failed


In my case, i don't have any mods installed (yet), just a clean&fresh copy of JA2 Gold, with the 1.13 patch (build 4452) - with the 01 July 2011 upgrade - installed.

The problem seems to appear only when I install the second build 4452 file (the 01 july 2011 upgrade).

The problem is, if I ignore the second file and only install the 1.13 patch, JA2 Gold loads OK, but became highly unplayable, due to numerous bugs, like my mercs walking backwards and the impossibility to scroll the map with the mouse or keyboard (sorry for my bad english..).

Any suggestions?

My system specs: Intel I7 920, 6GB DDR3 RAM, Gigabyte MB, HD Radeon 6970 Graphics, Windows 7 Ultimate x64.

Thanks in advance, waiting for some savior here..
Re: Win. 7 64-bit & new system issues...[message #291210] Tue, 27 September 2011 22:49 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
Don't install under any path similar to C:\Programs, those are protected by UAC.

Quote:
like my mercs walking backwards and the impossibility to scroll the map with the mouse or keyboard
Hit [ALT] again after tabbing out of the game.


Re: Win. 7 64-bit & new system issues...[message #291217] Tue, 27 September 2011 23:40 Go to previous messageGo to next message
kyle2k
Messages:3
Registered:September 2011
Thanks man, but I didn't.

The game was installed in my C:\Games directory.

As to your second suggestion, I'm not sure if I understand (my bad english again). Could you be more specific?
Re: Win. 7 64-bit & new system issues...[message #291218] Tue, 27 September 2011 23:45 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
Your mercs walking backwards is usually caused by switching to another program via [ALT]+[TAB] and back, you can easily solve this by pressing the [ALT] key again after switching back to the game. They'll then move normally and you can scroll.


Re: Win. 7 64-bit & new system issues...[message #291219] Wed, 28 September 2011 00:01 Go to previous messageGo to next message
kyle2k
Messages:3
Registered:September 2011
I have not tested yet, but I think you're right, cause I really pressed Alt+Tab and returned to the game a few minutes later.

But the real problem is the 1.13 01 july upgrade causing the 'fatal error' issue described. Without the 01 july upgrade installed, the screen resolution seems to be 640x480.

Is there something I could try to circumvent this and have the upgrade working?

Much appreciated

[Updated on: Wed, 28 September 2011 00:30] by Moderator

Re: Win. 7 64-bit & new system issues...[message #291239] Wed, 28 September 2011 09:44 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
Use Tais' SCI instead of that stupid installer - just unpack on a clean JA2 install.


Re: Win. 7 64-bit & new system issues...[message #296398] Sat, 07 January 2012 04:21 Go to previous message
Kyle

 
Messages:34
Registered:December 2008
Found fix. (duh!) Thank you.

[Updated on: Sat, 07 January 2012 08:05] by Moderator

Previous Topic: How to change the music
Next Topic: Interlocking JSD structures
Goto Forum:
  


Current Time: Fri Aug 17 12:58:25 EEST 2018

Total time taken to generate the page: 0.01168 seconds