Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » Stracciatella Project (Platform Independent JA2) » Bug with Remote Control in Meduna
Bug with Remote Control in Meduna[message #294130] Fri, 25 November 2011 17:07 Go to next message
Taleman

 
Messages:15
Registered:October 2010
Location: Finland
Seems using the Remote Control twice in Meduna square O 3 crashes the game.

In other words, first opening the door and then using remote control again
when the door is already open makes a crash. Looks like this happens every time.
Re: Bug with Remote Control in Meduna[message #294137] Sat, 26 November 2011 00:23 Go to previous message
mgl

 
Messages:254
Registered:December 2007
Location: France
I don't clearly remember what the remote controller does on the map, but it could be a problem of overlapping objects ("levelnodes" in the code). I think it's unrelated if the controller doesn't move an object (from a tile to another).

At some point of the development, Tron made the game exit on error when two objects tried to be on the same tile while the original vanilla game ignored the case. Several maps couldn't be loaded anymore and Tron had to soften his policy when loading maps and in the editor.

But this case of self-modifying map by the game out of the loading functions and editor may have been overlooked.

There is a thread with some explanations by Tron on overlapping objects: Bug: Could not load xx.DAT

Or the bug you found could be unrelated to overlapping objects. I don't remember if I ever tried to use the remote controller of the secret passage twice before Tron changed the levelnode functions.

It's too bad you come two years after the end of stracciatella (november 2009 was the date of the last real update to the code).


Previous Topic: Helicopter refuses to move
Next Topic: COVER and LOS in Stracciatella
Goto Forum:
  


Current Time: Mon Aug 21 17:00:43 EEST 2017

Total time taken to generate the page: 0.00737 seconds