Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGS: NEW 1.13 RELEASE (4870)
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300234] Fri, 24 February 2012 22:51 Go to previous messageGo to next message
LootFragg

 
Messages:344
Registered:August 2009
Location: Berlin, Germany
Jormasteri
Assertion Failure when any merc tries to pick body armor when already wearing one.
Check the error message. It will provide you (or anybody else) with a file name (*.cpp) and a line number, plus an error text. This will be useful. Also, upload the savegame here, this'll make it easier for anyone to check out your bug.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300296] Sat, 25 February 2012 14:01 Go to previous messageGo to next message
Charlie_May

 
Messages:27
Registered:March 2009
Hey Rowa,

I was just wondering if you had had time to check and confirm the bug with learn to like and learn to hate in the .xml that me and Buggler reported?

Also, could anybody just do a simple test: fire a few dozen rounds with a psycho merc and either confirm that psychos never actually go psycho, or that they do (in which case I myself am psycho and regret bringing the issue to attention)?
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300303] Sat, 25 February 2012 15:22 Go to previous messageGo to next message
Sam Hotte

 
Messages:2020
Registered:March 2009
Location: Middle of Germany
They do. Had at least Haywire, Razor and a psycho IMP going psycho a few times.
But the better they get and the more you aim the less probable it gets them going psycho.
(4870 Release, no mods)
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300316] Sat, 25 February 2012 17:18 Go to previous messageGo to next message
Charlie_May

 
Messages:27
Registered:March 2009
Alright thanks. This probably explains my problem. I didn't know that experience level affected the tendency to go psycho. While I was running my tests I think the mercs were lvl 10 (part of another test...)
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300369] Sun, 26 February 2012 20:43 Go to previous messageGo to next message
Jormasteri
Messages:3
Registered:February 2012
Hmmm, wondering if this problem of mine can be caused by using
Map Editor to add items (different armor sets) to a map?
If newinv doesn't support all the items I add with map editor the game crashes?

If so, what body armor type is not supported by this newinv.

(The last time I tried to reproduce the bug JA2 just crashed without error message)
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300424] Mon, 27 February 2012 17:54 Go to previous messageGo to next message
JohnnySideburns

 
Messages:19
Registered:September 2007
uhm I just got knifed through a door
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300637] Thu, 01 March 2012 01:34 Go to previous messageGo to next message
chatumao
Messages:3
Registered:December 2011
i found one, too.
while in combat (or maybe also while in normal, didn't test) when inspecting sector inventory game crashes if specific item information are activated via right click. crash can be avoid though if the item is right-clicked again. after that it is safe to leave inventory window.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300649] Thu, 01 March 2012 04:52 Go to previous messageGo to next message
LootFragg

 
Messages:344
Registered:August 2009
Location: Berlin, Germany
Even though that report was missing everything from version information to mods used and settings and all that, I can confirm this. I have quickly tested it on Flugente's previous Overheating test build which is based on revision 4946 I think. Quickly went into a fight and tried opening the UDB in the sector inventory screen both in real-time and in turn-based, then closing the sector inventory. The former works, the latter crashes the game without error message. Can be reproduced. Bad bad bug.

Edit: Gotta add that the item that is being clicked on needs to be on the ground. When in a merc inventory, it works fine.

[Updated on: Thu, 01 March 2012 04:55] by Moderator

Re: BUGS: NEW 1.13 RELEASE (4870)[message #300653] Thu, 01 March 2012 08:01 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
@loot: thanks for the report. will take look later.

EDIT: I could reproduce the hard crash. Now it is "fixing" time ...

EDIT2: Just fixed the bug in the development source trunk

[Updated on: Thu, 01 March 2012 13:07] by Moderator



Re: BUGS: NEW 1.13 RELEASE (4870)[message #300684] Thu, 01 March 2012 16:23 Go to previous messageGo to next message
LootFragg

 
Messages:344
Registered:August 2009
Location: Berlin, Germany
And that's why I love you people. Your steady work amazes me. Keep fixing those bugs, folks. You rock.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300874] Sat, 03 March 2012 21:39 Go to previous messageGo to next message
chatumao
Messages:3
Registered:December 2011
ok, found another thing...
ja2 1.13 v4870
right know i'm training imp mercs with ira in marksmanship. she got 55 but she's training them far beyond it. game gave notice when marksmanship reached 30, as if no more experience could be gained by training, but skill stats just keep on improving. had this in the last version, too. i think back then i trained 6 imp mercs with lousy ira, everyone of them had 100 marksmanship eventually...
please ask if further information/savegame/log is needed.
i manipulated the ini a little, but didn't change anything like this AFAIR.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300880] Sat, 03 March 2012 22:13 Go to previous messageGo to next message
ActionHank
Messages:1
Registered:June 2011
When i use a scope and laser on the same weapon the laser aim bonus always overrides the scope aim bonus.

Not sure if this is a new feature but i'm sure this did't happen in previous versions.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300892] Sun, 04 March 2012 00:22 Go to previous messageGo to next message
schlappe89

 
Messages:19
Registered:October 2010
First of all the game crashes many times when I quick load the game during enemy turns or during my turn when it seems that there is something else going on e.g. I tell a merc to shoot an enemy and quick load right after.

Also the game crahes many times during the Drassen fuck up. I have my mercs in the bar (because otherwise you just cannot win). When I peek out with a merc the game crashes probably one in four times.

Then another interesting thing:
http://www.abload.de/img/ja2_1.13_bugtg2gs.png

Savegame here:
http://www.2shared.com/file/o2HYfCdb/QuickSave.html

I am using JA2 Gold english.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300895] Sun, 04 March 2012 00:45 Go to previous messageGo to next message
puzzlepiece87
Messages:4
Registered:March 2009
I have a bug for you all too. Thank you very much for all your hard work!

JA2 Vanilla 1.00 --> JA 1.13 v4870

Screenshot of error when I try to load my saved game:
http://tinypic.com/r/msyrua/5

Saved games:
The actual saved game: http://www.mediafire.com/?zhh582h7xfbx77b
The debug save the game made: http://www.mediafire.com/?t7hgg6ecnab4pv6

I'd be happy to help however I can Smile

Re: BUGS: NEW 1.13 RELEASE (4870)[message #300900] Sun, 04 March 2012 03:39 Go to previous messageGo to next message
BigCheeto
Messages:1
Registered:March 2012
Ran into bug going from G:3 Coastal Road to H:3 Grumm Mine

Message comes up

RUNTIME ERROR - PRESS TO EXIT
Assertion Failure [Line 826 in function PrePareEnemyForSectorBattle.in file. \Queen Command.cpp]
Attempting to do a debug save as Save Game97.sav (this may fail)

(ubNumElites) != (0) but they should be equal
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300913] Sun, 04 March 2012 08:39 Go to previous messageGo to next message
sabresandy

 
Messages:65
Registered:February 2012
Running the latest build, getting a nasty bug with the Hummer in M10. Attempting to move it several of other squares appears to make the pathfinding calculate that it should move through an ocean square south of Balime, at which point the game crashes.

EDIT: cancelling the route by unassigning everyone from the Hummer and sending them back in worked as a fix.

[Updated on: Sun, 04 March 2012 09:19] by Moderator

Re: BUGS: NEW 1.13 RELEASE (4870)[message #300962] Mon, 05 March 2012 00:10 Go to previous messageGo to next message
rishta

 
Messages:11
Registered:February 2011
Sam_Hotte
Jipeg
I didn't find the way to burst and aim at the same time.

Mousewheel.
Doesn't work in WINE. ([MOUSEWHEEL] works in other windows apps under wine though.)

[Updated on: Mon, 05 March 2012 00:19] by Moderator

Re: BUGS: NEW 1.13 RELEASE (4870)[message #300965] Mon, 05 March 2012 00:14 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
BigCheeto
Ran into bug going from G:3 Coastal Road to H:3 Grumm Mine

Message comes up

RUNTIME ERROR - PRESS TO EXIT
Assertion Failure [Line 826 in function PrePareEnemyForSectorBattle.in file. \Queen Command.cpp]
Attempting to do a debug save as Save Game97.sav (this may fail)

(ubNumElites) != (0) but they should be equal


savegame?


Re: BUGS: NEW 1.13 RELEASE (4870)[message #300966] Mon, 05 March 2012 00:16 Go to previous messageGo to next message
rishta

 
Messages:11
Registered:February 2011
Running 4870 + AIMNASv25:

- can't see general properties of a gun in tactical (assertion failure),
- Fatima says "ok, follow me, yada-yada" and she doesn't move, so I can't get to the rebel base,
- shipments arrive, but they don't appear anywhere (ca. 20 shipments, all lost, despite losing being turned off in .ini),

Is there a version of AIMNAS/WF guaranteed to work with 4870 OR 45xx?

[Updated on: Mon, 05 March 2012 00:19] by Moderator

Re: BUGS: NEW 1.13 RELEASE (4870)[message #300967] Mon, 05 March 2012 00:17 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
Sabre
Running the latest build, getting a nasty bug with the Hummer in M10. Attempting to move it several of other squares appears to make the pathfinding calculate that it should move through an ocean square south of Balime, at which point the game crashes.

EDIT: cancelling the route by unassigning everyone from the Hummer and sending them back in worked as a fix.


what was the route (sectors) you wanted to travell when it crashed? in which sector did it crash? do you have a savegame quite before getting the hummer?


Re: BUGS: NEW 1.13 RELEASE (4870)[message #300971] Mon, 05 March 2012 00:30 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3809
Registered:July 2009
rishta
Running 4870 + AIMNASv25:

- can't see general properties of a gun in tactical (assertion failure),
- Fatima says "ok, follow me, yada-yada" and she doesn't move, so I can't get to the rebel base,
- shipments arrive, but they don't appear anywhere (ca. 20 shipments, all lost, despite losing being turned off in .ini),

Is there a version of AIMNAS/WF guaranteed to work with 4870 OR 45xx?
v25 should only be used with HAM5 as it was specifically tailored to the new functions. Did you follow the instructions or otherwise mess around with the files? Aside from that:
1) might be a missing graphic somewhere, not sure
2) known issue with big maps (hint: smeag would be very happy if that was fixed, although I suspect deeper issues with the NPC scripts on big maps)
3) might be a faulty xml entry or looking at the wrong crate

As to the last question, we guarantee nothing, especially not that something works and above all, that Testversions work. v21 should work reasonably well though.

[Updated on: Mon, 05 March 2012 00:31] by Moderator



Re: BUGS: NEW 1.13 RELEASE (4870)[message #300975] Mon, 05 March 2012 01:03 Go to previous messageGo to next message
rishta

 
Messages:11
Registered:February 2011
DepressivesBrot
Did you follow the instructions[...]?
Which instructions? Sorry, but the chaos with the mods is overwhelming and frustrating. Nowhere to find is a step-by-step guide, compatibility tables or otherwise reasonable "vademecum" - instead, dead links and half-baked solutions in droves. To get the hang of what's where and where it fits I'd have to spare a week reading various threads around here. That should clarify why the 1.13 userbase isn't an order of magnitude bigger.

To answer your question I used vanilla JA2G + 1.13.4870 + v25T (SCI_AIMNASv20_r4561_20110709_fixed, as you see is for an older build of 1.13) + ran ini editor (which, by the way throws a "not implemented" error since always). I couldn't find English version of AIMNASv21 - care to point me to a repository?
Re: BUGS: NEW 1.13 RELEASE (4870)[message #300976] Mon, 05 March 2012 01:09 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3809
Registered:July 2009
Those instructions. You obviously found the SCI thread already, for completeness though >>>here<<<. Although I currently wouldn't use the absolutely newest unstable SCI, maybe r4900 or 4915.

[Updated on: Mon, 05 March 2012 01:11] by Moderator



Re: BUGS: NEW 1.13 RELEASE (4870)[message #300977] Mon, 05 March 2012 01:25 Go to previous messageGo to next message
rishta

 
Messages:11
Registered:February 2011
DepressivesBrot
Those instructions. You obviously found the SCI thread already, for completeness though >>>here<<<. Although I currently wouldn't use the absolutely newest unstable SCI, maybe r4900 or 4915.
[Russian] Tanks.

OK, No luck. JA2+1.13+HAM+AIMNASv25 -> shipments don't arrive (looked in both warehouses, the little one in the north and the one where the idiot airport manager is, used the cheat to order stuff quickly again and to reveal the shipment in tactical).

[Updated on: Mon, 05 March 2012 01:58] by Moderator

Re: BUGS: NEW 1.13 RELEASE (4870)[message #301266] Wed, 07 March 2012 21:51 Go to previous messageGo to next message
puzzlepiece87
Messages:4
Registered:March 2009
Rowa, do you need any help from me for this bug? Been checking back every few days to see if you need more information.

puzzlepiece87
I have a bug for you all too. Thank you very much for all your hard work!

JA2 Vanilla 1.00 --> JA 1.13 v4870

Screenshot of error when I try to load my saved game:
http://tinypic.com/r/msyrua/5

Saved games:
The actual saved game: http://www.mediafire.com/?zhh582h7xfbx77b
The debug save the game made: http://www.mediafire.com/?t7hgg6ecnab4pv6

I'd be happy to help however I can Smile

Re: BUGS: NEW 1.13 RELEASE (4870)[message #301267] Wed, 07 March 2012 22:14 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
@puzzlepiece87: I am currently busy with merging the Overheating-Feature from Flugente to the development trunk.

Later I will take a closer look at the bug.


Re: BUGS: NEW 1.13 RELEASE (4870)[message #301454] Sat, 10 March 2012 03:40 Go to previous messageGo to next message
DarkDogg

 
Messages:113
Registered:January 2012
Location: Moscow, Russia
Just a mistake, not a bug.
1.13 4870

terrorist Terry ID 064
Data\Speech
064_099
He says:
"Well... If you want to end our deal prematurely, that's fine by me."

But in the Data\Mercedt\064.EDT
In the quote #99 is written:
"I can't wait for this deal to be over."
Re: BUGS: NEW 1.13 RELEASE (4870)[message #301511] Sun, 11 March 2012 10:33 Go to previous messageGo to next message
Fozzie

 
Messages:184
Registered:April 2010
Location: Germany
I'm playing "pure" 1.13 v.4870 (German) and have come across several bugs/problems:

1. San Mona:
- Tony's video store: the whole building is always empty, no Hans, no Brenda, no Tony, at any time of day/night. I set the .ini to Tony being always at home.

- Boxing club: Darren never shows up.

- Kyle never shows up, I can rescue Maria and get the deed from Angel, but I can't finish the quest.

2. Meduna:
- In the Bloodcat Arena sector, disarming a mine next to the wall of one of the "corner watch rooms" causes enemies to "morph" through the spot as if there was a hole in the wall.

- In the Hedge Maze sector I was unable to find the last enemy, so I gave the moving order to the east-adjacent sector and on strategical map cancelled that order (right click) to have the mercs turn back immediately (leaving and reentering normally helps with that unfindable last enemy). At reentering the area, the sector map would only let me place my mercs at the opposite west side and since there's only ocean, the game would consequentially crash on trying to place the mercs with the error message displayed that the sector has no access point in that area. So I let my squad move completely to the eastern sector, then moved them back and it worked this time. I looked for the last enemy and found out that it was a tank that had been miraculously "replenished". I repeated it a few times and the specific tank being replaced changed randomly. After blowing it up again, though, the sector was declared enemy free and I could go on.

- Each and every time I entered Deidranna's palace through the secret tunnel to the fireplace, a strange bug occurred. Joe would taunt me, then after a short conversation attacks with turn-mode triggering, of course. Whenever I ended the turn, then, the cursor would switch to the eternal stopwatch of doom with the only option to end the game with Alt+X, any other hotkeys (like Quickload) and the graphical interface wouldn't work.

3. Militia training:
I trained militia in Grumm and wanted to get them to "all elite". When all garrison slots were filled with elites in the sector my trainers were in, the game would offer the option to train further, since in the surrounding sectors there were still regular militia. On completion of that training assignment, the game would crash with an assertion failure. This did not happen, though when I "spread" militia in town with the "Automatic" button in the garrison screen before the training was finished.

4. No "coolness" remarks:
On a complete playthrough, none of my mercs ever made a remark admiring the weapon being used (like Wolf mentioning firepower), not even on rather advanced guns like the DSR-1 or SCAR-H. This might be a problem with Sci-Fi mode, though. Cause I also had a hard time finding 7.62 ammo towards the end-game, since everybody and their uncle were almost exclusively using Rocket Rifles or some variant of the XM8 and thus 5.56 ammo. I have yet to play a campaign in Normal mode, maybe it won't be a problem, then. But regardless, I think even if it's tied to Sci-Fi, overall "coolness" threshold is a little off if nothing beneath an XM8 can trigger the "loving that gun" remarks.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302017] Mon, 19 March 2012 23:49 Go to previous messageGo to next message
gas

 
Messages:8
Registered:May 2011
Location: Italy
Hello, got a weird bug here with the JA2_113_FullRelease_English_4870.exe, reading other posts it seems its not common, so im asking if anyone have any idea how to solve it.

In most occasions mercs walk looking backwards (sometimes reloading the game they act normal for a while), i cant directly select mercs pressing the portraits but only using the left-right arrows in the bottom panel, also most of the keyboard shortcuts are not working.
It works the page up / page down / home / end /ins /del as intended, plus it works the shift+N while all the other keys dont do what is espected ( into specific spacebar, key L, F, I, J dont do nothing at all).

Im using Win 7 64, and its the first time i install ja2 on this os.

Previously i was using other 1.13 releases (i used more then one in the past, with or without wildfire maps, besdie the known bugs i always had no issues and im quite used to the ini files nowadays.

Any ideas ?
Thx
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302019] Mon, 19 March 2012 23:56 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3809
Registered:July 2009
Press [ALT] again after tabbing out of the game.


Re: BUGS: NEW 1.13 RELEASE (4870)[message #302024] Tue, 20 March 2012 00:41 Go to previous messageGo to next message
gas

 
Messages:8
Registered:May 2011
Location: Italy
hey and ty for the fast replay.

Actually alt tabbing helps with the issue of mercs walking backwards, it solves also all the other keybind issues so its allright now, anyway sometimes it returns not working again (into specific it seems the game reads a different keybind file as the key "F" in example enable the follow mode and the "L" key load the last saved game instead of turn/ready weapon).

Anyway the alt tab workaround is enough to go on thx.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302032] Tue, 20 March 2012 04:47 Go to previous messageGo to next message
Sam Hotte

 
Messages:2020
Registered:March 2009
Location: Middle of Germany
Alt+tab was not the workaround. Alt+tab is cause of the game "hanging" the alt-key. Just press the alt-key once you alt+tabed back into game and no merc walks backward nor do you quickload when you intended to look around.
The workaround is hence "press the alt key!" Smile
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302033] Tue, 20 March 2012 04:52 Go to previous messageGo to next message
LootFragg

 
Messages:344
Registered:August 2009
Location: Berlin, Germany
Hi gas. Read DepressivesBrot's reply again. You need to press the [Alt] key, not [Alt]+[Tab]. Alt-tabbing out of the game is the reason for this strange behaviour.

To be specific: What happens when you alt-tab to the desktop is that you press the [Alt] key which gets registered by the game as "[Alt] is now activated". If you release it, the game registers "[Alt] is now deactivated". If you alt-tab, however, your operating system leaves the game and it doesn't receive any more keyboard inputs. So when you let go off the [Alt] key, the game doesn't know that.

You go back into the game and the game still thinks your finger is on [Alt]. Whatever you do is now prefixed with the [Alt] key. [Alt]+[LMB] in tactical mode lets your mercs walk backwards. [Alt]+[L] is a quickload.

To fix this, you have to make sure the game knows you don't press [Alt] anymore. So press it one more time after going back into the game to send the two inputs to the game. "[Alt] is now pressed, I'll ignore that one since I already know that" - "[Alt] is not pressed anymore, I'll go back to normal".

Each keyboard stroke is two inputs. On and off. Hit the key, let go off it. You need to "let go" off the [Alt] key for the game to know that it's supposed to work "normally".

Glad to help.

Edit: Mine is bigger, Sam_Hotte. Mine is bigger.

[Updated on: Tue, 20 March 2012 04:53] by Moderator

Re: BUGS: NEW 1.13 RELEASE (4870)[message #302053] Tue, 20 March 2012 18:35 Go to previous messageGo to next message
Sam Hotte

 
Messages:2020
Registered:March 2009
Location: Middle of Germany
Crap: DB is faster than me and LF's is bigger. I feel weak and sad ...

Wink
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302275] Fri, 23 March 2012 23:29 Go to previous messageGo to next message
nhja2fan

 
Messages:27
Registered:March 2012
Here's a bug that has been in the game a while, so this might not be the best place to post this.

I'm running JA2 Gold Eng -> 1.12 -> 4870 (no other mods)

In H14, there is a Druganov with a 10x scope. In the original game this was fine, in this game,
it can cause problems with inventory in that sector. In this case, I had 112 items (no 10x scope listed) in the strategic inventory screen. If I entered tactictal, then back to strategic, all of these items are gone, replaced by an inaccessible 10x scope.

You are able to take all of these items out to another sector to avoid losing them. Then opening/closing the cabinet and desk in the small building made the 10x scope accessible.

The more permanent solution I did was to use the map editor to delete, then re-add the druganovs. This seemed to fix the problem, though I didn't replay the sector. I think it fixed the problem because, 1) it removed the warning about the 10x scope in the map editor and 2) it allowed going from strategic to tactical without loss of items.

So, not really a 4870 specific bug, but it's in there.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302277] Sat, 24 March 2012 00:11 Go to previous messageGo to next message
Johuotar

 
Messages:5
Registered:December 2010
So this happens after trading with Tony. It happened once before trading too, but I managed to get to trading interface which worked fine. The game has crashed just one other time and that was without message.

http://i.imgur.com/wpfUE.png

Save: http://www.mediafire.com/?7m3c0bg1ypkqt74
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302305] Sat, 24 March 2012 13:34 Go to previous messageGo to next message
Biernath_J

 
Messages:181
Registered:August 2003
Location: Poland
nhja2fan
Here's a bug that has been in the game a while, so this might not be the best place to post this.

I'm running JA2 Gold Eng -> 1.12 -> 4870 (no other mods)

In H14, there is a Druganov with a 10x scope. In the original game this was fine, in this game,
it can cause problems with inventory in that sector. In this case, I had 112 items (no 10x scope listed) in the strategic inventory screen. If I entered tactictal, then back to strategic, all of these items are gone, replaced by an inaccessible 10x scope.

You are able to take all of these items out to another sector to avoid losing them. Then opening/closing the cabinet and desk in the small building made the 10x scope accessible.

The more permanent solution I did was to use the map editor to delete, then re-add the druganovs. This seemed to fix the problem, though I didn't replay the sector. I think it fixed the problem because, 1) it removed the warning about the 10x scope in the map editor and 2) it allowed going from strategic to tactical without loss of items.

So, not really a 4870 specific bug, but it's in there.


Wow, so it's NOT map related!
In my current game (4968 + WF maps) I have 3 sectors with this bug. I created a separate thread about it too.
So, the solution to this is edit the maps and delete/replace those sniper scopes?
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302318] Sat, 24 March 2012 17:09 Go to previous messageGo to next message
Gambigobilla

 
Messages:718
Registered:July 2008
I had a bug like this in UC(tais SCI of UC4915) i was trying to reproduce it to report wil but hdd crashed.
Re: BUGS: NEW 1.13 RELEASE (4870)[message #302319] Sat, 24 March 2012 17:16 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
Johuotar
So this happens after trading with Tony. It happened once before trading too, but I managed to get to trading interface which worked fine. The game has crashed just one other time and that was without message.

http://i.imgur.com/wpfUE.png

Save: http://www.mediafire.com/?7m3c0bg1ypkqt74


This bug is fixed.


Re: BUGS: NEW 1.13 RELEASE (4870)[message #302379] Sun, 25 March 2012 20:03 Go to previous messageGo to previous message
Biernath_J

 
Messages:181
Registered:August 2003
Location: Poland
nhja2fan
Here's a bug that has been in the game a while, so this might not be the best place to post this.

I'm running JA2 Gold Eng -> 1.12 -> 4870 (no other mods)

In H14, there is a Druganov with a 10x scope. In the original game this was fine, in this game,
it can cause problems with inventory in that sector. In this case, I had 112 items (no 10x scope listed) in the strategic inventory screen. If I entered tactictal, then back to strategic, all of these items are gone, replaced by an inaccessible 10x scope.

You are able to take all of these items out to another sector to avoid losing them. Then opening/closing the cabinet and desk in the small building made the 10x scope accessible.

The more permanent solution I did was to use the map editor to delete, then re-add the druganovs. This seemed to fix the problem, though I didn't replay the sector. I think it fixed the problem because, 1) it removed the warning about the 10x scope in the map editor and 2) it allowed going from strategic to tactical without loss of items.

So, not really a 4870 specific bug, but it's in there.


I opened three WF maps (that suffer from the same error) in map editor today. It seems that in one case, there's an SKS with a sniper scope, in other cases it seems to be a remington 870 with a sniper scope. At least, that's what editor says.

I was not able to find those guns on the maps though, nor the scopes. No clue what to do next.
Previous Topic: Got a crash upon entering a sector -- SAVEGAME INCLUDED [7249]
Next Topic: Black screen when choose 30+ traits and view the personnel management
Goto Forum:
  


Current Time: Sat Nov 17 11:27:24 EET 2018

Total time taken to generate the page: 0.02268 seconds