Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » JA2 Wildfire » install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325680] Wed, 25 September 2013 15:16 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
That map works fine for me. Do you have this issue on every map or just sector O9? It may be related to some setting in the graphics driver. Other than that I have no idea. :dontknow2:

This is how the sector should look like:
http://img708.imageshack.us/img708/1411/pp9b.jpg

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325684] Wed, 25 September 2013 18:09 Go to previous messageGo to next message
egovir

 
Messages:5
Registered:September 2013
I have this bug on good amount of the sectors, that one is just example. I'm not even sure myself what to do about it. It's for the first time i see this thing...

edit:
this is some evil voodoo, because i've just reloaded the game, and that black thing has gone, but the other occurred:
http://s16.postimg.org/8sdkm381d/snap000208.jpg
can't imagine what can go wrong in just copying files : /

Toggle Spoiler

[Updated on: Wed, 25 September 2013 18:30] by Moderator

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325687] Wed, 25 September 2013 18:59 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
You didn't install in C:\Program Files\... , did you? That is known to cause problems with file access rights.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325689] Wed, 25 September 2013 19:59 Go to previous messageGo to next message
RoWa21

 
Messages:2039
Registered:October 2005
Location: Austria
silversurfer
You didn't install in C:\Program Files\... , did you? That is known to cause problems with file access rights.


also run the game with administrator rights.


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325690] Wed, 25 September 2013 21:17 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
RoWa21

also run the game with administrator rights.

Either that or use a gaming partition/folder and assign your non-Admin user full access rights to this partition/folder.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325694] Wed, 25 September 2013 22:09 Go to previous messageGo to next message
egovir

 
Messages:5
Registered:September 2013
No, i have the ja2 folder on separate drive as admin logged in, and all of the compatibility settings like admin rights, winxp, etc.
I've installed different mods before, like Arulco Revisited, DL, UC. And that's why i'm confused about this case. Very Happy
I think i might try this with different SCI.
Thanks for suggestions so far though.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325716] Thu, 26 September 2013 11:27 Go to previous messageGo to next message
Faalagorn

 
Messages:157
Registered:February 2012
Location: Poland
Maybe try to delete the Temp and ShadeTables folder under \Profiles\UserProfile_XXXXX (where XXXXX is the name of your mod) folder?
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #325738] Thu, 26 September 2013 16:46 Go to previous messageGo to next message
egovir

 
Messages:5
Registered:September 2013
Alright, i fixed it. I pretty much did the same thing over again and there was no problem.
Probably magic windows 8 gnomes.
Thanks for the support. Very Happy
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326470] Fri, 11 October 2013 09:26 Go to previous messageGo to next message
mor

 
Messages:13
Registered:October 2013
niculinux
1) Someone may be so kind to post a link where to get wildfire mod 6.07 for JA2 1.13, if it is
still avaiable?


can we get a sticky with download links?! there is a sticky for 5.0 version. here I see a request for 6.07 version, which might not be available, so what is the stable version, what it includes and where I can download it ?!
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326480] Fri, 11 October 2013 14:18 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
You can find the download link for WF Maps Mod in my signature now. This is an SVN server so you need some SVN client (like Tortoise SVN) to download the files unless you prefer to download them one by one with your browser. Wink

WF Maps 6.06 has the old WF maps that are compatible with official JA2 1.13 release 4870.
WF Maps 6.07 contains updated files and only runs with the current development release of JA2 1.13. You will need the current SCI from DepressivesBrot for that.

WF Maps mod contains the WF maps that have been done by Jax and Smeagol. This is a maps only mod with a few interface graphic changes. You will not find new items, quests and so on in this mod. Therefore it should be compatible with item mods. I'm trying to keep version 6.07 up-to-date when new features are available that affect its data. Version 6.06 is not maintained and will die in the future because it doesn't make sense to maintain two releases.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326536] Sat, 12 October 2013 18:08 Go to previous messageGo to next message
Laxtqjc
Messages:2
Registered:October 2013
Is it possible to install 1.13 on Steam Release? i seem to fail at it

lost my Gold Edition CD, now i only have http://store.steampowered.com/app/215930/ from Indie Bundle

[Updated on: Sat, 12 October 2013 18:10] by Moderator

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326540] Sat, 12 October 2013 18:45 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
I don't have the steam version so I don't know if there are special configuration tasks that need to be done. I just don't see a reason why this mod should not work with the steam version.

First you need to install Ja2, then the 1.13 mod (latest SCI) and after that WF 6.07 map mod.

edit: Didn't see that you have retail Wildfire. Like Depri says, you can't use that for Ja2 1.13.

[Updated on: Sat, 12 October 2013 21:36] by Moderator


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326546] Sat, 12 October 2013 19:50 Go to previous messageGo to next message
Laxtqjc
Messages:2
Registered:October 2013
could be because Steam has 6.04 version?
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326548] Sat, 12 October 2013 20:04 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
You can not use Retail Wildfire as a basis for any substantial mod. Get JA2/JA2Gold


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #326817] Sat, 19 October 2013 11:03 Go to previous messageGo to next message
mor

 
Messages:13
Registered:October 2013
silversurfer
You can find the download link for WF Maps Mod in my signature now. This is an SVN server so you need some SVN client (like Tortoise SVN) to download the files unless you prefer to download them one by one with your browser. Wink

WF Maps 6.06 has the old WF maps that are compatible with official JA2 1.13 release 4870.
WF Maps 6.07 contains updated files and only runs with the current development release of JA2 1.13. You will need the current SCI from DepressivesBrot for that.

WF Maps mod contains the WF maps that have been done by Jax and Smeagol. This is a maps only mod with a few interface graphic changes. You will not find new items, quests and so on in this mod. Therefore it should be compatible with item mods. I'm trying to keep version 6.07 up-to-date when new features are available that affect its data. Version 6.06 is not maintained and will die in the future because it doesn't make sense to maintain two releases.


Looking at later post, I suggest that you un-stick the old/uninformative thread "I need the patch for Wildfire 5.0" and the confusing/broken links "JA2 Wildfire Official Links"

Instead add a new sticky with this ^ information and the one in the readme file, with installation instructions for both i.e. something like:

Installing 6.07
1.Clean Install JA2 (Gold)
2.Latest JA2 1.13. (link)
3.SVN Magic.
4.anything else? do you have to rename one of the "Data-WildFire6.0x" folders?

preferably replacing step 3 with some current snapshot for those of us who have regard SVN as some kind of curse word. Bonus points for screenshot that show maps(this is a map mod no?) Otherwise this is subforum and your effort is wasted.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327040] Wed, 23 October 2013 21:29 Go to previous messageGo to next message
Itoka
Messages:2
Registered:March 2012
Why do so many enemies and run to the jeep as if praying for him?
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327041] Wed, 23 October 2013 22:06 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Enemies should ignore an empty vehicle. At least this is the case in the current development build. In older builds they would try to destroy it. I fixed that some weeks ago. I can't tell you exact revision numbers at the moment because I'm not at my main PC but you are on the safe side with the latest SCI.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327046] Wed, 23 October 2013 22:58 Go to previous messageGo to next message
Itoka
Messages:2
Registered:March 2012
Enemies do not shoot at the empty car. They gather around of it and do not look for me.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327070] Thu, 24 October 2013 08:19 Go to previous messageGo to next message
sevenfm

 
Messages:1583
Registered:December 2012
Location: Soviet Russia
Is it possible to run wildfire with AFS or Overhaul? Should i expect broken quests or something or lot of NADAs?
Want to play with NCTH but base 1.13 NCTH weapon values are not playable as i remember.


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327102] Thu, 24 October 2013 19:35 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Well, except for Mod_Settings.ini there are no option modifiers in WF 6.07 maps mod. Mod_Settings.ini is mandatory however.
Apart from that you can use any items mod with its own settings.

Base 1.13 weapon values are playable. I'm playing with them myself. You may want to adjust some ini settings though or use the adjusted inis of the item mod.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327112] Thu, 24 October 2013 22:25 Go to previous messageGo to next message
Parkan

 
Messages:445
Registered:April 2010
Location: Russia,Sevastopol

AFS and Overhaul uses ja2set.xml if try to play with AFS\overhaul xml file-the WF maps will be in a mess(tilesets problems)if delete this file-maps will not work.it is need to edit manualy that file(how exatly-i don't have idea)to play AFS with WF maps.If play with AFs you can spot just a little part of NADA on maps so no big trouble.(that was on early versions of AFS)
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327121] Thu, 24 October 2013 23:45 Go to previous messageGo to next message
sevenfm

 
Messages:1583
Registered:December 2012
Location: Soviet Russia
silversurfer
Do you use [USE_NEW_CTH_CALCULATION = TRUE] option?
What ini settings are good for base NCTH weapons, from your experience?


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327133] Fri, 25 October 2013 09:52 Go to previous messageGo to next message
Toma777

 
Messages:57
Registered:October 2013
Location: serbia
download wildfire map mod from svn in folder Data-WildFire6.06 edit Ja2Set.dat.xml file like this:

after this line:
wirefram.sti

add this lines if you want to use afs:

smp4items.sti
smp5items.sti
smp6items.sti

and if you want to use Overhaul add:

smp4items.sti
smp5items.sti
smp6items.sti
smp7items.sti
then replace Ja2Set.dat.xml from afs or Overhaul with modified Ja2Set.dat.xml
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327141] Fri, 25 October 2013 16:16 Go to previous messageGo to next message
Parkan

 
Messages:445
Registered:April 2010
Location: Russia,Sevastopol

toma777
download wildfire map mod from svn in folder Data-WildFire6.06 edit Ja2Set.dat.xml file like this:

after this line:
wirefram.sti

add this lines if you want to use afs:

smp4items.sti
smp5items.sti
smp6items.sti

and if you want to use Overhaul add:

smp4items.sti
smp5items.sti
smp6items.sti
smp7items.sti
then replace Ja2Set.dat.xml from afs or Overhaul with modified Ja2Set.dat.xml



And that's all?Oh my,i don't think that is will be so easy.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327146] Fri, 25 October 2013 19:02 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Please don't use WF6.06 anymore. This one is outdated and won't work properly with current SVN builds.
The only version that I try to keep updated is version 6.07. We will remove the 6.06 folder anyway in the future.
At the moment there is no Ja2Set.dat.xml in WF6.07 because it was not needed. I'm not sure if I can simply use the one from WF6.06 folder.


Sevenfm
silversurfer
Do you use [USE_NEW_CTH_CALCULATION = TRUE] option?
What ini settings are good for base NCTH weapons, from your experience?

Yes, I use USE_NEW_CTH_CALCULATION = TRUE. Also I use weapon overheating but no dirt system.

In CTHConstants.ini I have the following changed values:
IRON_SIGHT_PERFORMANCE_BONUS = 15.0

LASER_PERFORMANCE_BONUS_HIP = 25.0
LASER_PERFORMANCE_BONUS_IRON = 15.0
LASER_PERFORMANCE_BONUS_SCOPE = 10.0

GRAVITY_COEFFICIENT = 10.0

AIM_TOO_CLOSE_SCOPE = -2.0


In Item_Settings.ini I use the following changed values:
OVERHEATING_JAM_THRESHOLD_LMG_MODIFIER			= 4.0
OVERHEATING_DAMAGE_THRESHOLD_LMG_MODIFIER		= 4.0

HANDLING_SHOTGUN_MODIFIER	= 0.8


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327150] Fri, 25 October 2013 19:46 Go to previous messageGo to next message
Toma777

 
Messages:57
Registered:October 2013
Location: serbia
without of Ja2Set.dat.xml AFS or Overhaul wont work with WF6.07. I think that tileset is same for WF6.07 and WF6.06. I tested it and so far no errors. Can you make Ja2Set.dat.xml for WF6.07 for compatibility with AFS and Overhaul or future modt that require modified Ja2Set.dat.xml?
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327152] Fri, 25 October 2013 20:23 Go to previous messageGo to next message
sevenfm

 
Messages:1583
Registered:December 2012
Location: Soviet Russia
silversurfer
Thanks, and what about NORMAL_SHOOTING_DISTANCE and SCOPE_RANGE_MULTIPLIER?
I think these settings are very important in NCTH?



Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327155] Fri, 25 October 2013 20:49 Go to previous messageGo to next message
Parkan

 
Messages:445
Registered:April 2010
Location: Russia,Sevastopol

toma777.yes your suggestion about xml file work.but playing with afs it is a lot a very a lot of NADA on maps.it is little frustating,but i think it playble.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327158] Fri, 25 October 2013 21:31 Go to previous messageGo to next message
Toma777

 
Messages:57
Registered:October 2013
Location: serbia
nada item is relatet to AFS mod not to map tilset
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327159] Fri, 25 October 2013 21:52 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
toma777
without of Ja2Set.dat.xml AFS or Overhaul wont work with WF6.07. I think that tileset is same for WF6.07 and WF6.06. I tested it and so far no errors. Can you make Ja2Set.dat.xml for WF6.07 for compatibility with AFS and Overhaul or future modt that require modified Ja2Set.dat.xml?

I take your word for it that this will work. At least those lines that you posted are the only difference between stock 1.13 and the mods.
In the WF6.07 folder I created example files for tileset compatibility with AFS and Overhaul.

I only hope that I'm notified if the mod authors add more files to that XML so I can update.

Parkan
toma777.yes your suggestion about xml file work.but playing with afs it is a lot a very a lot of NADA on maps.it is little frustating,but i think it playble.

I wonder how this can happen. WF6.07 has no NADA items with stock 1.13 item data. AFS and Overhaul should have more items and not less so where do the NADAs come from?


Sevenfm
silversurfer
Thanks, and what about NORMAL_SHOOTING_DISTANCE and SCOPE_RANGE_MULTIPLIER?
I think these settings are very important in NCTH?

NORMAL_SHOOTING_DISTANCE = 70
SCOPE_RANGE_MULTIPLIER = 1.0

Hmm, I had SCOPE_RANGE_MULTIPLIER set to 0.7 in the past which worked better. I think that I must have changed it back to 1.0 for testing. Very Happy Now I know why my CTH has gone down lately. :rofl:
In the past I also had AIM_TOO_CLOSE_SCOPE = -4.0 (default) which worked fine with SCOPE_RANGE_MULTIPLIER at 0.7. I think I will change both back to my old values...

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327165] Fri, 25 October 2013 23:20 Go to previous messageGo to next message
Toma777

 
Messages:57
Registered:October 2013
Location: serbia
I think that in AFS is more weapon but index of them is different from 1.13 in item.xlm like this:
AFS:

66
Nada
Auto-generated Nothing Item
Index 66
1
100




1.13:
66
Hartford 6
Modified EMF Hartford 6 Shooter
This is a .357 caliber, six shooter modified for Tex Colburn. It has a ten inch barrel and a sculptured ivory handle with TEX engraved in 14kt gold flake.
Modified EMF Hartford 6 Shooter
This is a .357 caliber, six shooter modified for Tex Colburn. It has a ten inch barrel and a sculptured ivory handle with TEX engraved in 14kt gold flake.
2
1
66
3
76
16
1
2
788
-1
1
1
1
1
1
1
22
100.0
10
20.0




Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327166] Fri, 25 October 2013 23:43 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Hmm, this is a problem. WF maps relied on AIMNAS item pool as far as I know. This pool was stock 1.13 + bonus. I already had to remove some items from the maps which were from the bonus part.
If a mod author adds new items with a high index and leaves some low indexes empty you can get the NADA stuff because the map may contain items with these low indexes (which are valid in stock 1.13). I can't do anything about that. Sorry.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327168] Sat, 26 October 2013 00:48 Go to previous messageGo to next message
Gambigobilla

 
Messages:717
Registered:July 2008
I have a feature request about this if it's not too much off a work. How about some sort of item translation tables. For example map has preplaced item id 549 which should be glock 17 but item mod xmls has glock 17 at item id at 897, so in translation table (maybe an xml) direct item 549 to 897. This way we could make easy compatibility patches between item mods and map mods.

This is just an idea as i have no idea about c++ and ja2 code, if you think this is stupid/very difficult/not worth it please just ignore it.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327169] Sat, 26 October 2013 01:07 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
What poor bastard is supposed to maintain those tables?


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327172] Sat, 26 October 2013 01:52 Go to previous messageGo to next message
Gambigobilla

 
Messages:717
Registered:July 2008
No one specific. Probably community itself can take care of it. I think it would be no different than sharing XMLs or INIs.
Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327173] Sat, 26 October 2013 01:58 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
I don't think you quite get it ...
For mods like AIMNAS and the AFS family, you'll have to literally cross index a thousand items by hand - because none of them lines up with 1.13 at all (or at least only in the absolutely necessary vanilla items)


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327178] Sat, 26 October 2013 03:07 Go to previous messageGo to next message
Gambigobilla

 
Messages:717
Registered:July 2008
No, I totally i get it. Even this is coded there will be massive work to be done for the actual tables, but there are even greater works done by citizens of bear's pit like be it modding, coding or mapping. Also if table are done once, they will require only little maintenance because newest items are generally appended at the end of files. Another thing is i have a little visual basic experience but enough to make a thing or two about it. Reading szlongitemname while storing uiindex from both files then comparing them with like operator then finally dumping them to xml if they are a match is no rocket science, put some extra precaution and hand edit the remaining, voila, we'll have our tables.

As i said this is just and idea and i don't even know if it's feasible or not. And it's not like i demand coders do it. If anyone thinks this worth their time they can code this or just simple ignore it. No hard feelings.

P.S: It might feel like tryharding but really its just a wild idea combined with me being bad at English.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327194] Sat, 26 October 2013 10:50 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Not practicable. Stock 1.13 has its historic item table which gets items added sometimes (e.g. tripwires, Molle). These items are appended at the end. We will have mismatches all the time.
I don't know why a modder would leave undefined items in his items.xml but if he does he should fix his tables instead of the coders creating some strange translation table.

Mismatching indexes are not breaking the game. Yes, one might find item 4711 which could be a nail file in stock 1.13 and an AS50 in mod x. So what?
Leaving empty indexes in the XMLs is worse in my opinion.

Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327197] Sat, 26 October 2013 11:58 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3801
Registered:July 2009
He does because they are sorted by categories with room to append new stuff in the right places, it works so nothing wrong with it. The whole issue doesn't arise until you mix and match stuff that wasn't meant to go together.


Re: install and run wildfire 6.07 mod (1.13) with latest JA2 1.13 mod?[message #327202] Sat, 26 October 2013 20:54 Go to previous messageGo to previous message
Moa

 
Messages:58
Registered:September 2013
It works? Because an item shows up in game does not mean it works.
Empty indexes are bad. There are several loops which have an early break if an item index is empty. There is nothing wrong whith an early break.
Previous Topic: JA2 1.13 Wildfire 6.06
Next Topic: question to wildfire version
Goto Forum:
  


Current Time: Thu Aug 16 16:59:30 EEST 2018

Total time taken to generate the page: 0.02036 seconds