Home » MODDING HQ 1.13 » Depri's v1.13 Builds and Packages » Depri's Builds and Packages - Get your combat supplies here!  () 4 Votes
Depri's Builds and Packages - Get your combat supplies here![message #311288] Thu, 18 October 2012 21:15 Go to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
Disclaimer: You are hereby informed that the material offered in this thread represents the latest Development Version of the 1.13 mod. By downloading and installing any of these files, you agree to being a guinea pig Beta Tester. There will be bugs and we ask you to file informative and detailed reports when you encounter any of them. If you can't accept that and instead feel the need to complain about the mods and/or their creators, then these are not the droids you are looking for.

Over the past months, you may have noticed a slowing down of my initial turnaround time, this means that asking when the next one is up will get you a snarky remark.

Having now cleared the formalities, lets get to the content:

1.13 SCI
This is the basic SCI package like several users offered over the years. It contains all the latest bells and whistles added to the development trunk.
>>>Download!<<<< - MS OneDrive on hold since May 2020, more recent versions see link below
>>>Archive<<< - Kermi's FTP mirror, older versions can be found here if one drive is down
please check file size before downloading, the latest versions are around 380MB

How to get: latest 1.13, 7609, feature-descriptions and more - links to further download-sources for 1.13, 7609+AI, 7609-SCI, mods, feature-descriptions and more


How to use:
0) Install JA2 in a mod friendly location (NOT Progam Files(x86), Program Files or similar folders that are under special UAC protection since Vista)
1) Download the latest SCI
2) Extract the downloaded file over your JA2 installation, allowing it to overwrite existing files
3) Use JA2.exe to play

[TIP] If you are not asked whether to overwrite stuff, something is awry and you probably hit the wrong folder
If you are on Windows 8, please install the Windows 8 compatibility fix, to be found in the 'Docs' folder!

1.13 Builds
The smallest of the available packages, these are simply the zipped game exe and mapeditor that could be found in my signature for nearly half a year now. They basically cover two usecases:
(I) You are updating your gamedir via SVN but can't or won't compile yourself.
(II) There's been some fix in the code that only affected the exe, not the game data. In this case, they can be used as patches / hotfixes to replace an older exe.
>>>Download!<<<
[TIP]The files are called JA2_####.exe - The #### stands for the 4 digit revision number of the exe, you'll have to adjust shortcuts or rename the exe if you aren't starting it directly from the folder

I have also added a number of localized builds >>>HERE<<<. Due to the time required, this will likely be a very infrequent thing on the order of once or so per year unless something significant comes up in between.

AIMNAS
AIMNAS is now on >>>GitHub<<<!
Since that page comes with a native ability to download-as-zip, separate downloads have been discontinued while full installers are currently impractical due to the heavy WiP nature of the project. Please check the AIMNAS Forum for further information, questions or bug reports. Please be aware AIMNAS is still not fully playable in regard to quests and most maps are devoid of items.


Bugs
When reporting bugs, please mention/include:


  • the exe and data revision, both are given as four digit numbers in the archive name



  • any additional files you installed - patches, additional mods, ...



  • changes you made to the inis and xmls



  • a screenshot of the bug or at least the exact error message (especially for Assertions!)



  • *a savegame if applicable




In general, please look around first if there's already a topic dealing with your bug. Also, if the bug is obviously related to a specific new feature, use the according thread to report bugs if it exists.

FAQ
What does SCI stand for anyway?
Single Click Installer - While technically not totally accurate, it underscores the ease of use compared to other setup methods.

I can't open the archive!/What tool did you use for the archives?
The archives were packed with 7-zip 9.20 on 'Ultra' compression, older or different programs might have trouble with this.

The game still shows [some older version] on startup!
The version is written in one of the code files and only gets manually updated once in a blue moon. Don't Panic! The archive/file names are accurate.

Is Unfinished Business stuff stiil working?
Previously there were files missing and some UB-GameDir were still outdated, resulting in red warnings in starting screen. A fix came out and reports suggest there is nothing game-breaking (Taunt-settings, some missing stuff in skill-settings-ini, etc). Still proceed with caution or better still report broken data or problems here.

Will you update this thread?
No. At least not for every new version but a bunch of busy bears will attempt to notify gamers when newer content is available.

Is there a changelog?
There are txt files with the svn log in every package.

What about savegame compatibility?
No guarantees. Developers try to avoid it for as long as possible, but you have to be aware that every update is a risk and make backups. It's the cost of using the cutting edge version.

What about compatibility with mod [x]?
Modders will generally specify a version of 1.13 that their mod was developed for. Unless you already are an experienced user, use that version and don't attempt to glue something together, it will more than likely break something.

I need further support!
Just ask here in the thread or visit the Discord channel >>>here<<< Note that the usual residents there are mostly European, 0300 GMT might not be the best time to look for support. Also, give some life sign when entering so we don't assume you're another lurker and don't worry if it takes a few minutes for someone to respond, it's also recommended you set up an account using the same username you have here on the Pit to avoid confusion.happy

[Updated on: Sat, 31 October 2020 03:32] by Moderator



Re: Depri's Builds and Packages - Get your combat supplies here![message #311291] Thu, 18 October 2012 22:06 Go to previous messageGo to next message
Gambigobilla

 
Messages:705
Registered:July 2008
GJ Depri. You might want to include "delete original JA2.exe" in your installation instructions. After 1.13 installation running JA2.exe instead of JA2_XXXX.exe makes whole installation go FUBAR. If your SCIs won't overwrite the original exe you'll probably hearing many players (especially new ones) complaining about not able to run the game.
Re: Depri's Builds and Packages - Get your combat supplies here![message #311292] Thu, 18 October 2012 22:42 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
Thanks for the notice, renamed the file to overwrite ja2.exe.


Re: Depri's Builds and Packages - Get your combat supplies here![message #311384] Mon, 22 October 2012 10:39 Go to previous messageGo to next message
Hanakin

 
Messages:35
Registered:June 2008
Location: Czech Rep.
Thanks for the SCI, Depri! I was just recently installing 1.13 through SVN and... it didn't go as planned. I will give this a spin - surely I can't screw anything up now!
Re: Depri's Builds and Packages - Get your combat supplies here![message #311385] Mon, 22 October 2012 11:28 Go to previous messageGo to next message
lockie

 
Messages:3819
Registered:February 2006
Location: Scotland
The thing with SVN is , once installed , it's easy to update all your files . It is a little bit challenging to get it started , but , follow the instructions exactly and it does work .


Re: Depri's Builds and Packages - Get your combat supplies here![message #311391] Mon, 22 October 2012 11:47 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
True, the thing is however, for anyone but longtime followers like us it hardly redeems. SVN has an initial setup of, depending on weather, three to five hours. With a decent connection, you can load an archive in less than ten minutes, even from the oft-chided mediafire.

Of course, you can spend the afternoon you originally planned on playing 1.13 instead browsing the forum to avoid the worst surprises ... you are just as likely to spend the time reading fruitless discussions and the umpteemth request for [Feature X] though.


Re: Depri's Builds and Packages - Get your combat supplies here![message #311460] Tue, 23 October 2012 22:29 Go to previous messageGo to next message
Randok

 
Messages:304
Registered:March 2004
JA2+SCI 5638/1547
When I add Retractable slope (for example, efficiency of 90% - bar) into the slot then the bar disappears (0%).
The same problem when I put the grenade into the fifth from the top slot in Milkor MGL-140 Grenade Launcher.
Re: Depri's Builds and Packages - Get your combat supplies here![message #311863] Wed, 07 November 2012 16:06 Go to previous messageGo to next message
gouki
Messages:1
Registered:November 2012
DepressivesBrot, i just wanted to thank you, and also indirectly thanking all people still working on 1.13 and related projects, keep on doing the good work. i mean the jagged alliance community is not the most active nor biggest in the world anymore, but its good some people still care.
Re: Depri's Builds and Packages - Get your combat supplies here![message #312243] Mon, 19 November 2012 08:42 Go to previous messageGo to next message
knightofni

 
Messages:100
Registered:August 2011
Hi Depressive Brot,

I seem to be experiencing a problem with Laser sights. In my game they don't appear to improve the mag factor.

Here is an Ots39 with an integral aiming laser module, mag factor of 2.2, range of 300. No magnification is shown.
http://i.imgur.com/2uQax.png

And here is suppressed Makarov with a laser sight (the basic pistol one), mag factor of 1.3. Again, no magnification shown.
http://i.imgur.com/ZlbKP.png

1. r5676
2. Other mods : UC1.13 v3.75 (ADCAP5)
3. Using UC1.13 mod & wil's ini files
Re: Depri's Builds and Packages - Get your combat supplies here![message #312316] Wed, 21 November 2012 18:55 Go to previous messageGo to next message
Fragnifico

 
Messages:22
Registered:April 2012
Guys, i need some help on this version (SCI_Unstable_Revision_5693_on_GameDir_1564)

How do i slow down the game?

Its really too fast, i can barelly see the enemy moving and my mercs run way too fast... in fact, all the game is faster than normal, everyone is like on drugs LOL

I like this feature compared to the orginal JA2 (since it was too damm slow). But cmom... its kinda ridiculous lol

Can i slow down a bit their movements, bullet speed and all???
If so, can someone plz tell me?

Thx guys!!

[Updated on: Wed, 21 November 2012 18:56] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #312317] Wed, 21 November 2012 20:10 Go to previous messageGo to next message
wanne (aka RoWa21)

 
Messages:1979
Registered:October 2005
Location: Austria
@Fragnifico:

1.) Go the ingame options on the last page and disable the "fast enemy turns". It is one of the last entries

2.) Start the INI-Editor and select the "Data-1.13\ja2_options.ini". In the tree select the "Clock Settings" section. Change the "CLOCK_SPEED_PERCENT" to a lower value. Save the INI and start the game again.


Re: Depri's Builds and Packages - Get your combat supplies here![message #312319] Wed, 21 November 2012 20:24 Go to previous messageGo to next message
Fragnifico

 
Messages:22
Registered:April 2012
RoWa21
@Fragnifico:

1.) Go the ingame options on the last page and disable the "fast enemy turns". It is one of the last entries

2.) Start the INI-Editor and select the "Data-1.13\ja2_options.ini". In the tree select the "Clock Settings" section. Change the "CLOCK_SPEED_PERCENT" to a lower value. Save the INI and start the game again.


Got it!!!!

Perfect man, thx a lot!!!! Very Happy
Re: Depri's Builds and Packages - Get your combat supplies here![message #312403] Sat, 24 November 2012 15:52 Go to previous messageGo to next message
knightofni

 
Messages:100
Registered:August 2011
knightofni
Hi Depressive Brot,

I seem to be experiencing a problem with Laser sights. In my game they don't appear to improve the mag factor.

(....)


I should probably have checked this from the beginning, but this also happens without any mods.
Re: Depri's Builds and Packages - Get your combat supplies here![message #312419] Sat, 24 November 2012 19:56 Go to previous messageGo to next message
Tobias

 
Messages:32
Registered:July 2006
Location: Munich, GERMANY
Hello DepressivesBrot,

I just downloaded your SCI.zip file. But it contain only the English ja.exe where can I download the german.exe? I couldn't find a link for it.

Thanks for your help!
Re: Depri's Builds and Packages - Get your combat supplies here![message #312420] Sat, 24 November 2012 20:21 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
I never wrote I'd make German exes :headscratch:


Re: Depri's Builds and Packages - Get your combat supplies here![message #312555] Tue, 27 November 2012 19:03 Go to previous messageGo to next message
Randok

 
Messages:304
Registered:March 2004
I wrote about the new SCI and not a new exe.
I have a new exe 5702.
Re: Depri's Builds and Packages - Get your combat supplies here![message #313785] Wed, 02 January 2013 13:54 Go to previous messageGo to next message
lockie

 
Messages:3819
Registered:February 2006
Location: Scotland
ok , so putting on the option for finding those last few redshirts on a big map ( latest aimnas ).... doesn't seem to do anything , is there a hotkey or something ? I'm missing one leetle enemy soldier but have spent 20 minutes looking .

Help !


Re: Depri's Builds and Packages - Get your combat supplies here![message #313787] Wed, 02 January 2013 16:24 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
You're looking at the overview map, right? That's the one you get when pressing [INS].

@all:
I'm back home, new builds will be up within an hour or so.


Re: Depri's Builds and Packages - Get your combat supplies here![message #313792] Wed, 02 January 2013 18:35 Go to previous messageGo to next message
lockie

 
Messages:3819
Registered:February 2006
Location: Scotland
Tried that , map came up with 2 of 6 mercs (mine) and no red sign . Finally tripped over the little git hiding in among sandbags .


Re: Depri's Builds and Packages - Get your combat supplies here![message #313793] Wed, 02 January 2013 20:03 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
Weird ...
Can you post your resolution and the last section of options.ini (the one that deals with the overview map)? And look if it's activated in the preferences. Oh, and a screen for showing '2 of 6 mercs' might also help.


Re: Depri's Builds and Packages - Get your combat supplies here![message #313797] Wed, 02 January 2013 23:19 Go to previous messageGo to next message
lockie

 
Messages:3819
Registered:February 2006
Location: Scotland
Forgotten how to screen print again , will do it later , using 1024x768 res ,(max soldiers left is at 1) before reveal .


Re: Depri's Builds and Packages - Get your combat supplies here![message #313799] Thu, 03 January 2013 00:07 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
Did you scroll around a bit? 1024 can't display the whole map at once.


Re: Depri's Builds and Packages - Get your combat supplies here![message #313824] Thu, 03 January 2013 10:00 Go to previous messageGo to next message
lockie

 
Messages:3819
Registered:February 2006
Location: Scotland
hmm , I'll try that , thanks Smile


Re: Depri's Builds and Packages - Get your combat supplies here![message #313950] Sun, 06 January 2013 08:34 Go to previous messageGo to next message
Slax

 
Messages:1433
Registered:July 2006
Location: People riding polar bears...
Small flub.
AIMING_LEVELS_REDUCTION_ON_ALTWEAPHOLD = 50;

Re: Depri's Builds and Packages - Get your combat supplies here![message #314057] Wed, 09 January 2013 19:22 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Just downloaded the svn version i click on the exe, it does not work..

No error, no warning, game icon appears on task bar then disappears ...

Help?
Re: Depri's Builds and Packages - Get your combat supplies here![message #314059] Wed, 09 January 2013 19:35 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Happy Birthday DepressivesBrot

@Dr-D, what OS are you running this under and where did you install JA2?


Re: Depri's Builds and Packages - Get your combat supplies here![message #314061] Wed, 09 January 2013 19:46 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Win 8

D:\Jogos\JA2\

Apparently it has something to do with 16bit or less color (Windows 8 is not liking it that well)

What i did not liked is the lack of a log with the error....
Re: Depri's Builds and Packages - Get your combat supplies here![message #314062] Wed, 09 January 2013 19:49 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Nope, the error is presistant, even with 16bit mode, the game just exits before 1st screen, without any error
Re: Depri's Builds and Packages - Get your combat supplies here![message #314063] Wed, 09 January 2013 19:55 Go to previous messageGo to next message
Sam Hotte

 
Messages:1997
Registered:March 2009
Location: Middle of Germany
There are some useful hints regarding JA2 with win8 here:
http://www.ja-galaxy-forum.com/board/ubbthreads.php/ubb/showflat/Number/312900/Searchpage/2/Main/20560/Words/windows+8/Search/true/Re_Jagged_Alliance_2_on_Window.html
Re: Depri's Builds and Packages - Get your combat supplies here![message #314173] Sat, 12 January 2013 06:12 Go to previous messageGo to next message
jaredh

 
Messages:8
Registered:June 2006
Location: Dallas Tx
I'm running build 5521 and I've found what I suspect is a bug.

Most of the LBE gear that allows for 40mm grenades is suggesting when I click on the spaces that it will hold ammo clips. Selecting one of these essentially bugs the game...it goes into a non-responsive runaway that never comes back (I gave it 2 days on one computer as a test).

This happens with the Police Vest and the 40mm Grenade Panel so I assume it happens on all 40mm slots.

This was with build 5521. Has this been reported yet anywhere?
Re: Depri's Builds and Packages - Get your combat supplies here![message #314211] Sun, 13 January 2013 09:03 Go to previous messageGo to next message
johrael

 
Messages:25
Registered:June 2011
I updated my game via SVN to the latest version (Build 5780?) and used the latest ja2.exe downloaded from Depri's skydrive. The changelog mentions about MERC having kit options but when I start a new game, there's none but I do see that there is an optional cost for equipment.

Did I do something wrong or the SVN isn't updated yet? Appreciate the good work there btw, just only learning to use Tortoise SVN.
Re: Depri's Builds and Packages - Get your combat supplies here![message #314212] Sun, 13 January 2013 09:52 Go to previous messageGo to next message
Buggler

 
Messages:210
Registered:November 2009
Thanks for reporting.

It's a 1.13 bug, i need to investigate.

Working in vanilla classic & AIMNAS, did not test on 1.13. Check back SVN for e fix.

E screenshot is from AIMNAS. 1.13 only has a 1 kit for MERC. In e meantime u can buy them for free Smile

Edit: It's a 1.13 mercstartinggear.xml bug. Here's e fix for MERC_OptionalCost_Fix for r1589 only if cant wait for SVN.
[Link Removed, Committed in r1592]

Edit2: Oops, was using e old xml directory path. Corrected.

Cheerz,
Buggler

[Updated on: Mon, 14 January 2013 02:38] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #314444] Sun, 20 January 2013 17:43 Go to previous messageGo to next message
Randok

 
Messages:304
Registered:March 2004
@DepressivesBrot
Do you specifically do not give SCI on MediaFire?
SkyDrive SCI yes ( 5791,5795 )
MediaFire SCI not
Re: Depri's Builds and Packages - Get your combat supplies here![message #314445] Sun, 20 January 2013 17:47 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
I have a script that does everything from updating my various SVN folders to dumping the stuff I share in a synced directory. Unfortunately, only SD supports such a directory so I copy the stuff to MF whenever I remember/have the time/feel like it. So stop bothering me about it after every update.
Edit:
Or get a live account, it's not like you actually have to tell them anything in those forms.

[Updated on: Sun, 20 January 2013 17:50] by Moderator



Re: Depri's Builds and Packages - Get your combat supplies here![message #314486] Mon, 21 January 2013 11:18 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3705
Registered:July 2009
Nothing in the list is supposed to break saves, you can just copy the saves and settings from you current installation and continue playing.


Re: Depri's Builds and Packages - Get your combat supplies here![message #314598] Tue, 22 January 2013 18:42 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Sam_Hotte
There are some useful hints regarding JA2 with win8 here:
http://www.ja-galaxy-forum.com/board/ubbthreads.php/ubb/showflat/Number/312900/Searchpage/2/Main/20560/Words/windows+8/Search/true/Re_Jagged_Alliance_2_on_Window.html


I still have the same problem with the SVN release.

Its true that Windows 8 does not like JA2 very much and some steps are needed.
But if i install the old 4870 Release, I can play the game without any problem as long as i run it on 16bit color, windowed, and without intro.
Playing in full screen make the game graphics very slow.

So the problem is something added from 4870 to 5520(svn version).

Would it be that difficult to make sure every CTD has a log?
If that's already implemented, where is that log?

And, lets face it, in a few years, lots of ppl will be playing on Windows 8, so, removing windows 8 support is a project killer.

HELP!!!!
Re: Depri's Builds and Packages - Get your combat supplies here![message #314599] Tue, 22 January 2013 18:56 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
I can even add some more info.

AIMNAS 5521 build still runs if windowed, 16bit/ no intro.

The problem is directly related to SVN on top of 4870.

So here are my steps

Installed ja2 gold
Downloaded 4870 extracted to ja2 gold dir (same with 4870 patch)
Crated a new dir and used svn client to download a check out to that dir.
Selected every thing on svn dir and copied to ja2 gold dir.
Edited ja2.ini (with editor)
Set 16bit on exe.
Cliked on exe

Do i need anything else?
Re: Depri's Builds and Packages - Get your combat supplies here![message #314602] Tue, 22 January 2013 19:14 Go to previous messageGo to next message
Sam Hotte

 
Messages:1997
Registered:March 2009
Location: Middle of Germany
Dr-d,
You need according .exe fitting to your SVN game dir revision. You cannot expect the 4870-exe to work with 55xx unstable version.
Read the very first post of this very thread; it's all there.
Re: Depri's Builds and Packages - Get your combat supplies here![message #314604] Tue, 22 January 2013 19:30 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Dont reply if you don't have a clue of what I'm talking about man.
This is no anime release forum where it counts if you are the 1st to post.
Just spams the forum with useless replies.

I tried the full(not only exe) 4870 release , downloaded from http://ja2v113.pbworks.com/w/page/4218339/FrontPage
It works with minor settings.

I tried AIMNAS XMAS full(not only exe) release.
It works with minor settings.

I tried SVN FULL(not only exe) release
It does not work!
It crashed to desktop, with no error, with no screen, with no log.

Im guna give it a try with SCI_Unstable_Revision_5795_on_GameDir_1597.7z

Edit: it works with SCI_Unstable_Revision_5795_on_GameDir_1597.7z

So is SVN exe broken?

[Updated on: Tue, 22 January 2013 19:47] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #314609] Tue, 22 January 2013 20:02 Go to previous messageGo to previous message
Sam Hotte

 
Messages:1997
Registered:March 2009
Location: Middle of Germany
I told you. But you preferred flaming ...

So you'll get just a "RTFM!" (Maybe, upon excusing someone might explain it to you ... Wink )

Goto Forum:
  


Current Time: Tue Dec 01 17:12:43 EET 2020

Total time taken to generate the page: 0.01487 seconds