Home » MODDING HQ 1.13 » Depri's v1.13 Builds and Packages » Depri's Builds and Packages - Get your combat supplies here!  () 4 Votes
Re: Depri's Builds and Packages - Get your combat supplies here![message #314610] Tue, 22 January 2013 20:10 Go to previous messageGo to next message
Thor

 
Messages:430
Registered:February 2007
Location: Belgium
SVN needs the latest (or one of the latest) .exe(s) that you can find in the first page. like (5791, 5795)... Be sure afterwards not to use the original exe because it messes everything up if you use it.. You can remove that one...
Re: Depri's Builds and Packages - Get your combat supplies here![message #314611] Tue, 22 January 2013 20:22 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
You mean the 'SVN FULL Release' which includes a file called "ja2.exe.download.txt" which tells you to
Download latest ja2.exe (Development version) directly from D.Brot's SkyDrive:
https://skydrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083%21202
That 'SVN FULL release'?
Don't come to my thread and flame helpful people if you got no clue what the hell you're doing.

PS: I've seen the other thread Thor, currently compiling so exe should be up in 20'-30'

[Updated on: Tue, 22 January 2013 20:24] by Moderator



Re: Depri's Builds and Packages - Get your combat supplies here![message #314612] Tue, 22 January 2013 21:29 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
LOL, what about 1st thread has it all?

the dude came here asking for it, he posted a comment with 0 help and 100% flames.

I answered acording to it.

Anyway, Im happy now, got something to play.

So lets leave it on the near past shall we?

Anyway (2) i'm now reporting a really slow graphics response on full screen (on windows Cool. And its not related with screen resolution, the same resolution works good on window mode and very bad on full screen
Re: Depri's Builds and Packages - Get your combat supplies here![message #314614] Tue, 22 January 2013 21:41 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
If by 'that dude' you mean Dr-D, I agree fully.


Re: Depri's Builds and Packages - Get your combat supplies here![message #314616] Tue, 22 January 2013 22:02 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Fine, I'm bad person and i apologize.

Sam_Hotte
I'm sorry for not understanding that you were trying to say that SVN no longer bring an updated exe build.

It is not that clear on 1st page that svn does not bring an updated exe, especially since it realy brings an exe and its one incompatible with the game dir.

So to avoid any problems like this on the future. explicitly saying that SVN does not have an exe and removing the ja2_ub_5520.exe from svn would be great.

Now i will explain why i reacted so badly.

I have been 12 days now trying to play JA2 with some near latest exe with out any success. after 12 days asking here about it, with out an working answer, i got frustrated.

But apparently, bashing some one dear to you got me 3 working replys(sorry about that).

keep up the good work Smile

Re: Depri's Builds and Packages - Get your combat supplies here![message #314618] Tue, 22 January 2013 22:18 Go to previous messageGo to next message
Sam Hotte

 
Messages:1997
Registered:March 2009
Location: Middle of Germany
Apology accepted. :cheers:

JFTR: i pointed you to first posting HERE where infact it's written, that updaters via SVN need the .exe file:
Quote:
Unstable 1.13 Builds
[..] these are simply the zipped game exe [..] They basically cover two usecases:
(I) You are updating your gamedir via SVN but can't or won't compile yourself.[..]

And there is the link to thread about using SVN that is saying:
Quote:
[color:#CC0000]there is no JA2.exe coming with the SVN repository[/color]


Problem was and is, everybody is assuming that somebody using SVN for JA2 has read the linked SVN thread in order to get access to the repository. So i thought you knew and just forgot.

And there was no flame at all in my post. If i flamed, you'd feel the heat for real ... Very Happy



[Updated on: Tue, 22 January 2013 22:19] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #314622] Tue, 22 January 2013 22:50 Go to previous messageGo to next message
Thor

 
Messages:430
Registered:February 2007
Location: Belgium
As to #314611: Thanks mate, got it! Wink
Re: Depri's Builds and Packages - Get your combat supplies here![message #314626] Wed, 23 January 2013 00:10 Go to previous messageGo to next message
Dr-D

 
Messages:98
Registered:July 2005
Location: Portugal
Sam_Hotte
Apology accepted. :cheers:

JFTR: i pointed you to first posting HERE where infact it's written, that updaters via SVN need the .exe file:
Quote:
Unstable 1.13 Builds
[..] these are simply the zipped game exe [..] They basically cover two usecases:
(I) You are updating your gamedir via SVN but can't or won't compile yourself.[..]


I guess it wont be hard to put in big red chars "There is no EXE on SVN, you need to Download it your self"

Sam_Hotte
Problem was and is, everybody is assuming that somebody using SVN for JA2 has read the linked SVN thread


Some like me have been using svn way before that warning and don't feel the need to keep rereading the post.
Re: Depri's Builds and Packages - Get your combat supplies here![message #315312] Mon, 11 February 2013 15:23 Go to previous messageGo to next message
Slax

 
Messages:1432
Registered:July 2006
Location: People riding polar bears...
Some in-your-face 5862 bugs.

Something's gone screwy with the tactical cursor and right-click menu. (I'm running the AFS 4.xx preview but that shouldn't be a problem. 1024x768.) Once you first enter a map the right-click menu's stuck up in the upper left corner of the screen. Blank. Going to the map screen fixes it. The right-click menu still has a screwed up stand/walk icon though.

Now, the cursor problem. Seems it wants to be at two places at once. It's best to try the exe and see for yourself since it's always there. Going to an underground level and back fixes it... until you restart the game.

Oh, and aiming with NCTH stops rendering rain temporarily.

[Updated on: Tue, 12 February 2013 05:02] by Moderator


Re: Depri's Builds and Packages - Get your combat supplies here![message #315388] Wed, 13 February 2013 20:30 Go to previous messageGo to next message
Slax

 
Messages:1432
Registered:July 2006
Location: People riding polar bears...
Some more stuff, regarding posture changes and grenades. These bugs have been around for a while now.

Blowing stuff up in your hands can be very helpful. Too helpful, since it won't drain any APs. You still require stated amount of APs to do the action but you'll always be able to do it for free. (Could be this works the same for other "transformations" as well. Not tested.)

Say you're standing up and you throw a grenade. Chuck, boom. Oh no, you're in someone's line of fire so you change posture... for free! Don't know about going prone but you're always able to crouch down for free. Doesn't matter if you have the APs for it or not.

Re: Depri's Builds and Packages - Get your combat supplies here![message #315592] Wed, 20 February 2013 03:15 Go to previous messageGo to next message
Peal

 
Messages:260
Registered:August 2007
Location: Germany
Thank you Depri, for your stunning work!
Re: Depri's Builds and Packages - Get your combat supplies here![message #315847] Sat, 02 March 2013 13:07 Go to previous messageGo to next message
Kiele_Daniels

 
Messages:16
Registered:April 2011
Location: Philippines
Hello there mates, long time lurker here.

Sorry if I may seem an idiot but...

I'ved overwritten SCI 5882 over a fresh JA2 Gold install(1.12 patched), but the game still says version 5521 at startup. Even with overwriting the exe with the separate 5882 exe download.

Is this correct or did I do something stupid? :headbanger:
Re: Depri's Builds and Packages - Get your combat supplies here![message #315848] Sat, 02 March 2013 13:12 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
See point 3 of the FAQ


Re: Depri's Builds and Packages - Get your combat supplies here![message #315849] Sat, 02 March 2013 13:25 Go to previous messageGo to next message
Kiele_Daniels

 
Messages:16
Registered:April 2011
Location: Philippines
Oh, I see, versions stated are rarely updated. Thanks for the quick reply, Depri. Very Happy

However, is 5882 compatible with AIMNAS lightweight?

I've tried installing it over but I get a list of INI errors at startup and some gun sprites are incorrect. (Although I can still play)

Is this a given? Or should I overwrite the INI or something? :dontknow2:

Thanks again.
Re: Depri's Builds and Packages - Get your combat supplies here![message #316481] Fri, 22 March 2013 21:09 Go to previous messageGo to next message
Istrebitel

 
Messages:213
Registered:December 2009
Location: Russia, Saint-Petersburg
Every time I come back to JA2, I have to remember the old drill I forgot by now. Stupid, I know...

Please, remind me again Sad

I want to play AR 1.4 with "tripwire traps", "sandbag placement" features. Meaning - i need a version newer than 4780 stable.

In the faq, AR 1.4 states that it is made to be somewhat compatible with unstable version up to 5778, gamedir 1589. Where can I get gamedir of that version, and what is lastest exe that is compatible with gamedir 1589 (and where can I get it, because DepressivesBrot's link sdrv.ms/MaiNiT does not work - shows an error page of MS SkyDrive)

Thanks!

[Updated on: Fri, 22 March 2013 21:24] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #316506] Sat, 23 March 2013 15:26 Go to previous messageGo to next message
Sam Hotte

 
Messages:1997
Registered:March 2009
Location: Middle of Germany
Istrebitel
https://skydrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083!202

Try manually replacing the '[color:#FF0000]![/color]' in the link by '[color:#33CC00]%21[/color]'
Re: Depri's Builds and Packages - Get your combat supplies here![message #317350] Thu, 11 April 2013 23:55 Go to previous messageGo to next message
wolf00

 
Messages:1147
Registered:September 2006
Location: Czech Republic

db: thx you very much[fresh new exe to dowload] ....
Re: Depri's Builds and Packages - Get your combat supplies here![message #317480] Tue, 16 April 2013 18:11 Go to previous messageGo to next message
Randok

 
Messages:305
Registered:March 2004
JA2 + SCI_Unstable_Revision_6007_on_GameDir_1650.7z .
CTD or Error: Number of tilesets in code does not match data file.
Re: Depri's Builds and Packages - Get your combat supplies here![message #317485] Tue, 16 April 2013 22:44 Go to previous messageGo to next message
Wil473

 
Messages:2840
Registered:September 2004
Location: Canada
Randok
JA2 + SCI_Unstable_Revision_6007_on_GameDir_1650.7z .
CTD or Error: Number of tilesets in code does not match data file.


I am able to replicate the above with SCI_Unstable_Revision_6007_on_GameDir_1650 copied onto a clean install of Jagged Alliance 2 Gold. I am guessing there is one or more missing file(s), as installing SCI_Unstable_Revision_5986_on_GameDir_1639 first, then SCI_Unstable_Revision_6007_on_GameDir_1650 works just fine.

On a happier note, the included (optional) Win 8 fix worked to speed up mouse response on my little Win 8 media box to a reasonable level.

[Updated on: Tue, 16 April 2013 22:47] by Moderator



Re: Depri's Builds and Packages - Get your combat supplies here![message #317486] Tue, 16 April 2013 23:34 Go to previous messageGo to next message
Randok

 
Messages:305
Registered:March 2004
JA2 + SCI_Unstable_Revision_5990_on_GameDir_1641.7z + SCI_Unstable_Revision_6007_on_GameDir_1650.7z -> working Smile Thank you.
Still do not know the trouble with Win8. I'm using XP HE Smile
Re: Depri's Builds and Packages - Get your combat supplies here![message #317492] Wed, 17 April 2013 00:38 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
Found the error, got no exe in the SCI^^


Re: Depri's Builds and Packages - Get your combat supplies here![message #317597] Sun, 21 April 2013 01:04 Go to previous messageGo to next message
Maxtor

Messages:2
Registered:April 2013
Hi, i am big fan of ja2 and 1.13, been playing 1.13 since its *under 1000* revisions. Lately i ve been trying to play some newest 1.13 with AR 1.4 mod. I played likke 30-40 hours on revision 5963 and was quiet happy with it, untill i found i could not install bombs and that broke the game for me. So now i am pretty much checking any new unstable releases to try to find one that would not have any game breaking bugs.
As for why i decided to finnaly register, i found a bug in 6020 release. Last enemies on the map via "insert" key feature is not working.
Re: Depri's Builds and Packages - Get your combat supplies here![message #317600] Sun, 21 April 2013 03:32 Go to previous messageGo to next message
Flugente

 
Messages:3539
Registered:April 2009
Location: Germany
Hi Maxtor, welcome to the pit!

Showing the last enemy does work in 6020. So
  • is MARKER_MODE in the Data-1.13/Ja2Options.ini > 0?
  • is the current number of enemies <= MAX_SOLDIERS_LEFT?
  • check wether TOPTION_SHOW_LAST_ENEMY in Profiles/UserProfile_JA2113 is TRUE


Re: Depri's Builds and Packages - Get your combat supplies here![message #317626] Sun, 21 April 2013 20:25 Go to previous messageGo to next message
Maxtor

Messages:2
Registered:April 2013
Thank you for your reply. Indeed TOPTION_SHOW_LAST_ENEMY was set to false. It is strange to me because i never had to change that option in all my previous games. It was just on by default. It works correctly now. Thank you.
Re: Depri's Builds and Packages - Get your combat supplies here![message #317824] Thu, 25 April 2013 04:48 Go to previous messageGo to next message
turtlemoviesco

 
Messages:18
Registered:April 2013
Location: UnitedStates
Downloaded and installed the latest version a minute ago.
Would like to know if its possible to slow the game down to normal speed... I dont like how fast the mercs shoot and move. Read another post on page 1, it answers this.

Also I had a runtime error do to an unhandled loop is there a special place I am suppose to post errors?
(I have noticed that the crash seems to only occur right after aiming at a enemy, hope this helps)

Assertion Failure Line 1911 in file sgp.cpp, at the moment occurs when you stop aiming at someone, like if I am about to shoot there is no crash until my cursor leaves the body of the person.
Also tested shooting at a road, it crushes as soon as the cursor changes since there is no person.

2 ways to stop the crash for people having it.
1. When you aim at an enemy make sure your cursor stays on him until you no longer have enough ap to shoot, and only point your cursor at the enemy if you intend to shoot him.
-If you shoot them in the leg and they fall, make sure your cursor stays on him beacuse if you still have ap and he does not die then it will most likely crash.

2. Right when your merc starts to shoot you can quickly move your cursor away, but if your merc finishes shooting before you finishing moving the cursor away from the enemy then the game will crash.



[Updated on: Thu, 25 April 2013 15:49] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #317849] Thu, 25 April 2013 13:41 Go to previous messageGo to next message
turtlemoviesco

 
Messages:18
Registered:April 2013
Location: UnitedStates
DepressivesBrot
I could, but since few people understand the concept of split archives, I can't be bothered to explain that each week again.


You could just give them a link to a wikipage that explains it Smile
Re: Depri's Builds and Packages - Get your combat supplies here![message #317872] Thu, 25 April 2013 17:40 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
That wouldn't change the nature of the thing. Anyway, found a suitable solution.


Re: Depri's Builds and Packages - Get your combat supplies here![message #317875] Thu, 25 April 2013 17:52 Go to previous messageGo to next message
turtlemoviesco

 
Messages:18
Registered:April 2013
Location: UnitedStates
Has the crash involving aiming at enemies already been posted by someone else, and do you know if it will be fixed in the next release?
Re: Depri's Builds and Packages - Get your combat supplies here![message #317898] Thu, 25 April 2013 19:45 Go to previous messageGo to next message
Randok

 
Messages:305
Registered:March 2004
JA2 + SCI_Unstable_Revision_6022_on_GameDir_1655.7z.
Number of tilesets in code does not match data file
Sad
Re: Depri's Builds and Packages - Get your combat supplies here![message #317907] Thu, 25 April 2013 20:26 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
Gahhh! FLUGENTE!!!!!!
Does none of you guys check his commits anymore???

/note to self: try to add error handling to the script

[Updated on: Thu, 25 April 2013 20:26] by Moderator



Re: Depri's Builds and Packages - Get your combat supplies here![message #317938] Fri, 26 April 2013 01:39 Go to previous messageGo to next message
Sam Hotte

 
Messages:1997
Registered:March 2009
Location: Middle of Germany
Don't shoot the coding duck, it's still needed to spill out new features ... Very Happy
Re: Depri's Builds and Packages - Get your combat supplies here![message #317939] Fri, 26 April 2013 01:44 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
Don't worry, I just slapped him a bit.


Re: Depri's Builds and Packages - Get your combat supplies here![message #317961] Fri, 26 April 2013 09:37 Go to previous messageGo to next message
Randok

 
Messages:305
Registered:March 2004
Thank you for a new place for SCI and new SCI (it works). Smile
Re: Depri's Builds and Packages - Get your combat supplies here![message #318024] Fri, 26 April 2013 23:45 Go to previous messageGo to next message
turtlemoviesco

 
Messages:18
Registered:April 2013
Location: UnitedStates
DepressivesBrot
Gahhh! FLUGENTE!!!!!!
Does none of you guys check his commits anymore???

/note to self: try to add error handling to the script


Could someone please tell me where to find these comments so in the future I don't post know issues?
Re: Depri's Builds and Packages - Get your combat supplies here![message #318026] Fri, 26 April 2013 23:54 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
Huh?
As it seems that comment needs some explaining:
Flug forgot a file when he committed the then latest SVN changes.
Thus my build failed.
Thus there was no exe in the packages.
Which finally leads to the tileset mismatch error.
Nothing to do with any of your bugs, just that it's the third or fourth time this week that my builds fail due to sloppy SVN commits.


Re: Depri's Builds and Packages - Get your combat supplies here![message #318032] Sat, 27 April 2013 03:01 Go to previous messageGo to next message
turtlemoviesco

 
Messages:18
Registered:April 2013
Location: UnitedStates
Oh, ok well thank you for the explanation.

The bug I mentioned was fixed in the newest version.
Re: Depri's Builds and Packages - Get your combat supplies here![message #319364] Sat, 11 May 2013 14:52 Go to previous messageGo to next message
Thor

 
Messages:430
Registered:February 2007
Location: Belgium
Missing exes in Ja2 v.1.13 r6071 minimal build, only the ChangeLog. And cannot open the download in Kermi's archive (with winzip)... Wink

[Updated on: Sat, 11 May 2013 14:57] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #319365] Sat, 11 May 2013 15:03 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3704
Registered:July 2009
Drat, thought I had the error handling now. Time to slap some coders :grimreaper:
Also, I did mention that kermi's updates live and you are supposed to wait until the full file is up, haven't I? (need to update the size though)


Re: Depri's Builds and Packages - Get your combat supplies here![message #319366] Sat, 11 May 2013 15:08 Go to previous messageGo to next message
Thor

 
Messages:430
Registered:February 2007
Location: Belgium
Probably have missed the part on Kermi's archive... I've read a lot around here, but not everything. Thanks for explaining.

Aha, alright, found it - damn, those big red letters must have blinded me! :headbanger:

[Updated on: Sat, 11 May 2013 15:15] by Moderator

Re: Depri's Builds and Packages - Get your combat supplies here![message #320308] Thu, 23 May 2013 17:53 Go to previous messageGo to previous message
sean10mm

 
Messages:38
Registered:February 2007
One oddity I noticed going from SCI_Unstable_Revision_6077_on_GameDir_1676.7z to the stable release version is that the text is often harder to read on the unstable revision, especially the load/save screen text. This was at 1024x768 full screen for both, and I did a full uninstall in-between the two.
Goto Forum:
  


Current Time: Wed Jan 20 14:41:04 EET 2021

Total time taken to generate the page: 0.01769 seconds