Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » UC/DL 1.13 & AFS » UC-1.13 Discussions and Bug Reporting (2013/03/07 to 2018/11/04)
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320096] Sun, 19 May 2013 23:44 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3803
Registered:July 2009
I have no problems with the LZ btw.
(Yes, I'm actually playing your mod for once, you may be worried now Razz )



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320097] Mon, 20 May 2013 00:21 Go to previous messageGo to next message
Kyle

 
Messages:31
Registered:December 2008
.

Quote:
AFS/DL-1.13/UC-1.13 are separate mods, not some kind of joined campaign. They must be selected separately in the INI Editor. The purpose of integrating them is to save space


Got it. Thank you for the added information. I thought that there was the possibility that they were "blended" together into one large "macro" mod. It's good to know that they're not.

Your hard work is greatly appreciated. The expansion of tactical possibilities in JA2 now is easily quadrupled because of efforts such as yours and others around this fantastic community.

All of you are fantastic!

Smile
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320098] Mon, 20 May 2013 02:26 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
wil473

Yes, I am seeing some stability issues, but not in the landing map. Then again, I didn't make any changes to the landing map so I haven't tested it yet.


Seemed to occur when the enemy tried to reinforce. I.e. a few seconds after exiting turn based after the enemy was first alerted.

Got past it using GABBI codes and no further issues so far. Including when reinforcements have occurred.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320099] Mon, 20 May 2013 02:27 Go to previous messageGo to next message
ddarz

 
Messages:9
Registered:August 2007
Yep, I just got the same black screen hang when the fight starts in the entry sector:(
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320101] Mon, 20 May 2013 06:46 Go to previous messageGo to next message
Kyle

 
Messages:31
Registered:December 2008
.
Getting an insertion error immediately upon game's start. All I ever see is the airliner coming in for a landing at the base.

Additional info from the message:
Line 2923.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320102] Mon, 20 May 2013 07:39 Go to previous messageGo to next message
wsmithjr2013

 
Messages:49
Registered:March 2013
Location: New Jersey
I get the black screen hang at varying times. It has happened on both Oldmaps and Newmaps multiple times, but different spot each time in the initial battle for the airport. I did not see any problems when running the normal 1.13 INI through several sectors with the same installation: SCI_Unstable_Revision_6077_on_GameDir_1676

Don't see any error messages. Just crashes and hangs and need to close it out with Task Manager.

[Updated on: Mon, 20 May 2013 07:40] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320103] Mon, 20 May 2013 09:29 Go to previous messageGo to next message
Spookylizard

 
Messages:12
Registered:March 2013

I don't want to the be the pedantic That Guy, but I.E. is short for Id Est, which translates to "that is", where as e.g. is exempli gratia, or 'for example'. ie is used more specifically "A Mod Friendly location, ie, NOT Program Files (x86)" becomes "A Mod Friendly location, that is, NOT Program Files (x86)" as opposed "A Mod Friendly location, eg, NOT Program Files (x86)" which is "A Mod Friendly location, for example, Program Files (x86)".

Kyle, since Windows Vista, there have been more restrictions set on the Program Files director(ies), that require admin priveledges to change. You can disable this one way or another, but it really helps to just start installing your games to something like C:\Games\JA2UC113 or what have you instead futzing about with that other crap.

That said, I've been playing this (slightly cheated, because holy fuck BR's availability from Day 1 and All. That. Juice.), but man oh man I'm so glad Ivan is a cheap merc now, because people die from a sideways glance from him. It's also really nice having nCTH be not awful and just piles and piles of attachments, railz, AR upper and lowers, AK bullpup kits, .22lr machineguns (who doesn't want .22lr machineguns), old as balls SOE era suppressed pistols (hi standards, welrods) goddamned pulse rifles and a Carter Special, all the Matebas. It's really wonderful.

Though i've noticed a few 'off' things, like G3KA4's with fixed stocks. Should be G3KA3 instead, no? I think there are MP5 variants that do the same thing.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320104] Mon, 20 May 2013 10:30 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3803
Registered:July 2009
So I was killing the cops in A10 and doing inv management afterwards. The unload button produced a NADA#2384.


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320108] Mon, 20 May 2013 14:04 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
DepressivesBrot
So I was killing the cops in A10 and doing inv management afterwards. The unload button produced a NADA#2384.


Odd, that's in the old ammo range. According to one old plan, item 2384 was the 9x18mm SMG Mag, 30. I wonder if all these crashes have to do with left over items from past item indexing schemes. The last time the UC-1.13 had mysterious crashes it was only fixed when I took time to flush every item from the map one at a time.

EDIT: oh and I fixed Boss' A.I.M. bio, had forgotten that my numbering in the EDT file was slightly different for Boss.

I'll reword the install instructions after work today.

EDIT2: now that I think about it, if someone is having problems with Old Maps then flushing the items shouldn't fix crashes unique to UC-1.13. Original JA2 and DL maps should be crashing the other two mods just as badly...

For now, could someone turn off reinforcements and see if that helps a new game please.

[Updated on: Mon, 20 May 2013 14:18] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320111] Mon, 20 May 2013 15:14 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
Have started a game with reinforcements only allowed in cities. Still getting a black screen crash in the first sector (I cheat coded past this point to continue) but no further black screen crashes.

Have captured most of Calisto some reinforcements have occurred without crashes.

Getting the odd exception error but they seem to be more to do with the .exe than UC, same ones occur in normal 1.13.

Very strange indeed.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320112] Mon, 20 May 2013 15:26 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
Another thing that I am concerned with is how I hacked in the bayonets and flashlights into many enemy/militia item lists. I'm going to double check them in the XML Editor (via tedious renaming to the old file name, clearing the XML Editor Cache... OK, it is not that bad, only 3 files in all reality and 3 reloads of the XML Editor without the cache).

EDIT: if the crashes are reinforcement related, an error in the gear XML's may be the cause.

I'm still going to need to sweep the maps for NADA's however.

[Updated on: Mon, 20 May 2013 15:33] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320124] Mon, 20 May 2013 20:00 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
wil473
Another thing that I am concerned with is how I hacked in the bayonets and flashlights into many enemy/militia item lists.
You do realise that the AI cannot properly handle having flashlights? They try to flee the light, which is rather comical, as its always in front of them Smile


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320136] Mon, 20 May 2013 23:07 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
Wil, don't know if it helps but I'm getting NADA items when unloading the police weapons in C14 but not in B13 or C13.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320141] Tue, 21 May 2013 01:40 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
Flugente
wil473
Another thing that I am concerned with is how I hacked in the bayonets and flashlights into many enemy/militia item lists.
You do realise that the AI cannot properly handle having flashlights? They try to flee the light, which is rather comical, as its always in front of them Smile

In retrospect, this does seem like something I should have anticipated, but no I didn't actually think of this. Indeed I went out of my way to swap the OFF versions of the LAM-200 and LAM/Flashlight Combo for the ON versions.

Mysterious lockups (again) and NADA all over the place aside, how are the new factions working out. Are they getting angry with you across maps (eventually)?

[Updated on: Tue, 21 May 2013 02:03] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320143] Tue, 21 May 2013 05:56 Go to previous messageGo to next message
Kyle

 
Messages:31
Registered:December 2008
I just finished uninstalling JA2 from the Program Files directory, and have now installed it into its own directory in plain old "C."

Before I did that, however, I backed up my entire installation of all of the mods, but after reading this...
Quote:
Mysterious lockups (again) and NADA all over the place


...should I just wait till the files are once again upgraded, or...?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320245] Wed, 22 May 2013 22:46 Go to previous messageGo to next message
mrguy123

 
Messages:7
Registered:May 2013
im using 4.45 and im having black screen crashes on the first map, always on the enemy turn, any idea what could have been causing this? i did some changes to the INI file to have more enemies and reinforcements, could this be the cause?

i tried replaying the map a few times but it always happens sooner or later, the militia just cant wipe out the soldiers fast enough before this crash and then it happens, and i cant do much either since i dont have any guns at the beginning
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320272] Thu, 23 May 2013 02:05 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
Well there is one big difference between AFS/DL-1.13 vs. UC-1.13 that may account for the crashes: UC-1.13 maxes out the enemy/civs/militia per sector.

Here are the relevant sections of Ja2_Options.INI

DATA-AFS
;------------------------------------------------------------------------------------------------------------------------------
; Use these to adjust the numbers of various sorts of "people" that can appear in the same sector in TACTICAL mode.
;------------------------------------------------------------------------------------------------------------------------------

; Enemies (i.e., soldiers), valid values 16 through 64, default is 32
MAX_NUMBER_ENEMIES_IN_TACTICAL = 32
; Creatures (i.e., bloodcats and crepitus), valid values 16 through 40, default is 32
MAX_NUMBER_CREATURES_IN_TACTICAL = 32
; Rebels (i.e., militia), valid values 16 through 64, default is 32
MAX_NUMBER_MILITIA_IN_TACTICAL = 32
; Civilians, valid values 16 through 40, default is 32
MAX_NUMBER_CIVS_IN_TACTICAL = 32

;------------------------------------------------------------------------------------------------------------------------------



DATA-UC113
;------------------------------------------------------------------------------------------------------------------------------
; Use these to adjust the numbers of various sorts of "people" that can appear in the same sector in TACTICAL mode.
;------------------------------------------------------------------------------------------------------------------------------

; Enemies (i.e., soldiers), valid values 16 through 64, default is 32
MAX_NUMBER_ENEMIES_IN_TACTICAL = 64
; Creatures (i.e., bloodcats and crepitus), valid values 16 through 40, default is 32
MAX_NUMBER_CREATURES_IN_TACTICAL = 40
; Rebels (i.e., militia), valid values 16 through 64, default is 32
MAX_NUMBER_MILITIA_IN_TACTICAL = 64
; Civilians, valid values 16 through 40, default is 32
MAX_NUMBER_CIVS_IN_TACTICAL = 40

;------------------------------------------------------------------------------------------------------------------------------


Do we have anyone wanting to lower the numbers of "people" down to those of stock Data-1.13 (which is where AFS gets its INI directly from) to see how the game handles?


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320275] Thu, 23 May 2013 05:10 Go to previous messageGo to next message
mrguy123

 
Messages:7
Registered:May 2013
i changed it and im still getting crashes

is there anyway to disable the airport combat? or anyway to skip it with some kind of command? otherwise i think ill have to rollback to the previous version until this is fixed

[Updated on: Thu, 23 May 2013 05:12] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320299] Thu, 23 May 2013 15:25 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
I'm working on new Enemy/Militia Item XML's (not guns as there were no changes between 4.45 and the previous release), but won't have them out till tomorrow.

One thing that I should have asked earlier, which Map set are people running into the crash on 1st map with? New Maps are set as a default, and Old Maps are selected via the INI Editor. For that matter, games not running into these crashes, may I ask if you are running Old or New maps?


EDIT: @mrguy123, try rolling back just the .exe to rev.6038 which was the part of the UC-1.13 v4.42 requirements. No flashlights or bayonets, but you will still be able to use the added mercs of v4.45. Also, I want to see if it is .exe or the mod causing these crashes - this is presuming you were running v4.42 under JA2.exe rev.6038 with no problems.

[Updated on: Thu, 23 May 2013 15:29] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320473] Fri, 24 May 2013 03:48 Go to previous messageGo to next message
Kyle

 
Messages:31
Registered:December 2008
Quote:
which Map set are people running into the crash on 1st map with?


As far as I know, I attempted launching the game with the newer maps. But all of that was before I reinstalled JA2 to its own folder under the "C" drive directory. I've decided to hold off on reinstalling the mod till I hear more.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320682] Fri, 24 May 2013 23:03 Go to previous messageGo to next message
joemeier2
Messages:4
Registered:July 2010
wil473
For that matter, games not running into these crashes, may I ask if you are running Old or New maps?


New maps

I got the error message "Unhandled exception. Unable to recover."
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320694] Fri, 24 May 2013 23:45 Go to previous messageGo to next message
joemeier2
Messages:4
Registered:July 2010
I also tried it with Old maps, but it crashed too.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320698] Fri, 24 May 2013 23:55 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
A small civ faction hostility update:

Spoiler for giving away quite a lot about game locations.

Toggle Spoiler

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320722] Sat, 25 May 2013 03:13 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
I've been able to replicate the 1st map crash with JA2.exe rev.6077 as well as rev.6088.

Under Rev.6038, the last listed requirement for the prior UC-1.13 v4.42 release, the initial militia battle was completed by the militia with no assistance or problems.

Now proceeding to test with the JA2 revision specified for the last AFS and DL-1.13 release (hopefully it works as it includes both bayonet and flashlight features).

EDIT: Bad news, crash occurring under rev.6068 as well.

EDIT2: I've systematically tested a few more of the unstable builds on DepressivesBrot's SkyDrive and found that the entire militia battle could be completed without problems up to and including rev.6059. The 1st map crashes under then next available rev.6061 within a few enemy turns.

EDIT3: by the way, so far I cannot find a cause that I can influence directly. The following have been found to be ineffective:
- disabling reinforcements completely
- new enemy/militia item selections
- cutting enemy/civ/militia/creature populations down to 32 of each

[Updated on: Sat, 25 May 2013 04:42] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320741] Sat, 25 May 2013 10:47 Go to previous messageGo to next message
JayM

 
Messages:83
Registered:May 2013
I managed to get the UC / 1.13 hybrid up and running, I followed the instructions from Box MacLeod (https://www.youtube.com/watch?v=69HZ-m2WDm0) and used the same files he posted in the description - I assume they are the latest since his video is only a few days old.

The game keeps crashing during the first sector right after landing when the militia is battling the enemy, right after a few turns. Never crashed when I was recruiting mercs, doing the IMP test etc.

I realise that the SCI I used is "unstable" but this is extremely unstable as the game is not playable Sad

Any ideas? I'm running a regular Windows 7 laptop, starting the game from the INI editor with a resolution of 1366x768. Is there a different, more stable SCI I should use?

Thanks - and thanks for actually creating all this in the first place!

[Updated on: Sat, 25 May 2013 11:05] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320754] Sat, 25 May 2013 12:51 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
See the post just above yours. The crashes seem to be due to the .exe, at least the crashes go away if you go back to rev.6059, available as a small download courtesy of DepressiveBrot here: Depri's Builds and Packages - Get your combat supplies here! under "Unstable 1.13 Builds."

For a moment last night I thought I had found an XML cause: copied the entire Item 0 definition from DATA-1.13's ITEMS.XML and the militia was able to fight through the fist battle once under Rev. 6077. Tried it two more times, once under EXPERT and a second time back under EXPERIENCED difficulty and the game crashed within a few enemy turns on these next two tries.

EDIT: using rev.6059, four of four runs of the 1st battle were completed without problems.

[Updated on: Sat, 25 May 2013 13:04] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320757] Sat, 25 May 2013 13:01 Go to previous messageGo to next message
JayM

 
Messages:83
Registered:May 2013
thanks wil - I'm really new to all this modding stuff so it is a bit hard to get my head round it Smile

do I have to reinstall everything from scratch and use 6059 instead? or can I just put 6059 over my installed files and it will replace the "old newer" SCI?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320760] Sat, 25 May 2013 13:08 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
JayM
thanks wil - I'm really new to all this modding stuff so it is a bit hard to get my head round it Smile

do I have to reinstall everything from scratch and use 6059 instead? or can I just put 6059 over my installed files and it will replace the "old newer" SCI?


Just drop Rev.6059 over the existing install. You still need the 1676 Game Data folder for the DG Mercs added/updated in v4.45. Somewhat awkward but the requirements still include SCI_Unstable_Revision_6077_on_GameDir_1676 even though you have to drop in an older exe.

Remember to select the older exe in the INI Editor. Non-SCI unstable exe's are all numbered.


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320761] Sat, 25 May 2013 13:12 Go to previous messageGo to next message
JayM

 
Messages:83
Registered:May 2013
wil473
Just drop Rev.6059 over the existing install.


ok I just did that, overwrote the existing files.

wil473

You still need the 1676 Game Data folder for the DG Mercs added/updated in v4.45. Somewhat awkward but the requirements still include SCI_Unstable_Revision_6077_on_GameDir_1676 even though you have to drop in an older exe.

Remember to select the older exe in the INI Editor. Non-SCI unstable exe's are all numbered.


I'm afraid you've lost me completely there?
1676 game data folder? which one is that? where do I find it?

sorry if I'm being difficult :S
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320762] Sat, 25 May 2013 13:19 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
JayM
1676 game data folder? which one is that? where do I find it?
if you followed the original installation instructions, you have it already.


JayM
ok I just did that, overwrote the existing files.
As long as you extracted JA2_6059.EXE and relaunch the INI Editor, it will be in the INI Editor's drop down list for "Start Executable-File."



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320763] Sat, 25 May 2013 13:19 Go to previous messageGo to next message
JayM

 
Messages:83
Registered:May 2013
ok I just started the game again and despite some error message about some merc_stat_value 0 in the splash screen I got past the first battle without problems Smile

hope that is sorted now (else I'll bug you again anyway Wink)

thanks for the help wil!
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320799] Sat, 25 May 2013 18:28 Go to previous messageGo to next message
Vampyre
Messages:1
Registered:May 2013
Installed the latest of all the mods for UC 1.13, all is up to date, but on launching game the AIM Mercs have no weapons in the selection and my created merc has a NADA as a weapon if I'm lucky to get one at all.

Any ideas on why there would be no weapons on creation or with the mercs for hire?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320800] Sat, 25 May 2013 18:32 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3803
Registered:July 2009
Because commercial airliners don't like you bringing machineguns aboard their planes ... or even a measly pistol come to think of it ... or a nail file. They are really pickly like that.

[Updated on: Sat, 25 May 2013 18:34] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320801] Sat, 25 May 2013 18:51 Go to previous messageGo to next message
lockie

 
Messages:3890
Registered:February 2006
Location: Scotland
Find your own weapons Vampy , there are things to be found , survive till then ... Razz


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320805] Sat, 25 May 2013 20:21 Go to previous messageGo to next message
spelid

 
Messages:8
Registered:August 2007
Minor problem but in Mercprofiles.xml Deadeye Flinte uiIndex 163 is a type 5 merc i.e a vehicle.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320811] Sat, 25 May 2013 20:56 Go to previous messageGo to next message
Flugente

 
Messages:3461
Registered:April 2009
Location: Germany
Hmm. Altough I've written that somewhere, might as well state it again: 6061 (dynamic flashlights) had very bad performance. This was fixed with 6068. Do not use 6061-6067, they are bad, hmmkay?

There was also another important bug fixed in 6099...


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320826] Sat, 25 May 2013 22:21 Go to previous messageGo to next message
Tango

 
Messages:106
Registered:July 2006
Weirdly the Civ factions (police and blackshirts) in I13 turned hostile after reloading and first capturing the other sectors. Does Civ Faction hostilty take time to propogate ie is it refreshed at the start of every game day?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320877] Sun, 26 May 2013 04:22 Go to previous messageGo to next message
Wil473

 
Messages:2861
Registered:September 2004
Location: Canada
Flugente
Hmm. Altough I've written that somewhere, might as well state it again: 6061 (dynamic flashlights) had very bad performance. This was fixed with 6068. Do not use 6061-6067, they are bad, hmmkay?

There was also another important bug fixed in 6099...


I was just systematically going though the available .exe's to see at what point the crashes stopped.

Speaking of which, just completed 2 of 2 first map tests under Rev.6099 with no crashes. Not sure about the SCI with the Rev.6098 .exe yet, but the SCI_Unstable_Revision_6077_on_GameDir_1676 + JA2_6099 seem to play through that first map ok.


EDIT: just ran through the first maps with no problems under a clean install with SCI_Unstable_Revision_6098_on_GameDir_1678 substituted in as the v1.13 component. Still, if you are going to be downloading a new unstable revision, might as well grab the above Rev.6099 just to get the bug fixes.

One thing I'm noticing is that Militia are ignoring dying enemies with the consequence that the battle does not end until you find and punch that last enemy to death.

[Updated on: Sun, 26 May 2013 05:06] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320885] Sun, 26 May 2013 13:13 Go to previous messageGo to next message
ddarz

 
Messages:9
Registered:August 2007
Just set up an installation with SCI_Unstable_Revision_6098_on_GameDir_1678, rev.6099 and UC 4.45

No crashes on the first turn:)

Some errors are thrown up by the new JA2_options.ini though.
There are about 40 new lines in the new one.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #320887] Sun, 26 May 2013 14:07 Go to previous messageGo to previous message
Hazapuza

 
Messages:264
Registered:February 2009
Location: Finland
wil473
One thing I'm noticing is that Militia are ignoring dying enemies with the consequence that the battle does not end until you find and punch that last enemy to death.

Shouldn't the battle automatically end if all the remaining enemies are in the "dying" state?

Did you change the 4.45 download yet to include the corrected enemy/militia XMLs you mentioned a few days ago?

Edit: I see you didn't. Any estimate on when the fix will be online?

[Updated on: Sun, 26 May 2013 16:40] by Moderator

Previous Topic: Arulco Folding Stock Discussions & Bug Reports - (2013/04/20 - 2018/11/04)
Next Topic: Garden Herbicide in UC
Goto Forum:
  


Current Time: Sun Oct 20 22:10:02 EEST 2019

Total time taken to generate the page: 0.01560 seconds