Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » UC/DL 1.13 & AFS » UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #334889] Sat, 09 August 2014 16:11 Go to previous messageGo to next message
Headhunter

 
Messages:268
Registered:November 2009
Location: Sweden
I'm getting this crash message:

"Runtime Error

Assertion Failure [Line 3009 in file renderworld.cpp] Attempting to do a debug save as SaveGame247.sav (this may fail)"

I'm getting this consistenly with 7307/2059 and 7205/2033 on UC-4.48 20140518.

I've recently started playing with zombies and I've only had this error since then.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #334891] Sat, 09 August 2014 16:46 Go to previous messageGo to next message
Flugente

 
Messages:3173
Registered:April 2009
Location: Germany
Headhunter
I'm getting this crash message:

"Runtime Error

Assertion Failure [Line 3009 in file renderworld.cpp] Attempting to do a debug save as SaveGame247.sav (this may fail)"

I'm getting this consistenly with 7307/2059 and 7205/2033 on UC-4.48 20140518.

I've recently started playing with zombies and I've only had this error since then.
Unfortunately this error doesn't say much, just that it had a problem rendering a surface. When does this happen - is it related to zombies themselves, or is it enough just to play with that option turned on?


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #334892] Sat, 09 August 2014 18:09 Go to previous messageGo to next message
Headhunter

 
Messages:268
Registered:November 2009
Location: Sweden
It typically happens after a while in a firefight, say 10-20 turns in, and always at the start of my turn. That's when dead humans rise as zombies, could that have something to do with it?

I haven't ever experienced it with the zombie option turned off, that's why I bring it up.

Edit: I tried turning off zombies, loaded a save which have given me that crash for a couple of days now and whaddaya know, no crashing...

Edit 2: Turned zombies back on, 2 turns later I get the same crash...

[Updated on: Mon, 11 August 2014 19:10] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #334960] Tue, 12 August 2014 17:30 Go to previous messageGo to next message
Headhunter

 
Messages:268
Registered:November 2009
Location: Sweden
Here is a save file just before (less than 5 turns) the game crashes, and the JA2options.ini from the Data-UC113 folder.

Save file
Ini

Allow zombies, take some potshots at any enemies and just let things progress naturally, it will crash.

[Updated on: Tue, 12 August 2014 17:31] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #335417] Wed, 03 September 2014 12:09 Go to previous messageGo to next message
fallschirmjager

 
Messages:42
Registered:June 2005
Location: Darwin, Australia

Hmm maybe I'm missing something but I'm trying to play a new game of UC-1.13 but there's something odd going on.

I'm trying to play with enemies drop all items but all they drop is a primary weapon and whatever ammunition they can fit in their pockets. No one is dropping any armour, webbing, packs, food, water. Just a weapon and a small quantity of ammunition. It's like they aren't spawning with this equipment.

I tested both the previous v4.48 and the patched v4.48 with the corresponding unstable gamedir as stated.

What have I done wrong?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #335420] Wed, 03 September 2014 13:12 Go to previous messageGo to next message
Flugente

 
Messages:3173
Registered:April 2009
Location: Germany
Well, do they get gear in the first place in the EnemyItemChoices.xmls?


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #335421] Wed, 03 September 2014 13:27 Go to previous messageGo to next message
fallschirmjager

 
Messages:42
Registered:June 2005
Location: Darwin, Australia

Can't confirm, Flugente, I haven't edited anything.

This is what I've got.

I installed JA2 Gold to C:/JA2

Copied v1.13 SCI_Unstable_Revision_7337_on_GameDir_2071 over it. I tested that and it works, did a quick check with GABBI and Alt-O, enemies drop all types of gear there fine.

Copied the Urban Chaos Data file to the directory and titled Data-UC. Copied Urban_Chaos-1.13_v4.48_20140518 and subsequently the above patch.

Game loads and runs fine (played UC multiple times on v1.13 in the past and everything seems legit). The enemy just don't drop anything apart from a weapon and minimal ammunition.

EDIT: Checked the INI Editer and EnemyItemChoices. It's set as 1 = Use the new drop item system from XML-Files (EnemyWeaponDrops.xml, EnemyAmmoDrops.xml, EnemyArmourDrops.xml, EnemyExplosiveDrops.xml, EnemyMiscDrops.xml) for enemies (and militia).




[Updated on: Wed, 03 September 2014 13:34] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #335436] Wed, 03 September 2014 23:48 Go to previous messageGo to next message
Flugente

 
Messages:3173
Registered:April 2009
Location: Germany
Well, perhaps UC comes without those files, so the game falls back upon stock xmls, and if those item numbers are different, perhaps nothing is spawned?


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #335527] Sat, 06 September 2014 10:02 Go to previous messageGo to next message
fallschirmjager

 
Messages:42
Registered:June 2005
Location: Darwin, Australia

Hmm maybe, not quite sure. It has to be a problem with the UC AFS release as the ordinary AFS works fine.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #336471] Sun, 05 October 2014 16:36 Go to previous messageGo to next message
Gigagames

 
Messages:33
Registered:January 2013
The Wire Cutter doint work correctly,
if i try to use it it have a Hammer icon and not the wire cutter icon, and i need over 300 AP to use it
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #336472] Sun, 05 October 2014 20:13 Go to previous messageGo to next message
Flugente

 
Messages:3173
Registered:April 2009
Location: Germany
gigagames
The Wire Cutter doint work correctly,
if i try to use it it have a Hammer icon and not the wire cutter icon, and i need over 300 AP to use it
This happens if the wirecutter and the object you want to interfere with are used in fortifications. Remove the faulty entry in StructureDeconstruct.xml.


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #336498] Tue, 07 October 2014 23:35 Go to previous messageGo to next message
Gigagames

 
Messages:33
Registered:January 2013
Ok thanks, that helpt

The AK-105 doint have any attachments but says "Hide Muzzle Flashs - Yes" i think this is a bug ?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #336651] Mon, 13 October 2014 23:37 Go to previous messageGo to next message
Flugente

 
Messages:3173
Registered:April 2009
Location: Germany
Well, does the gun have that property in itself, or does it have a hidden muzzle flash attachment?


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #336796] Sat, 18 October 2014 22:05 Go to previous messageGo to next message
Gigagames

 
Messages:33
Registered:January 2013
@Flugente the first,
i CAN attach a Hidden muzzle , but the gun DOINT have one attecht, but says "hide Muzzle ... yes"
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #336966] Wed, 22 October 2014 04:16 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
I think sometime in the past, back when Attachments.XML was the only way to attach things*** the AK-105 was supposed to have a built-in flash hiding muzzle device. Times moved on so I'll see what should be done going forward - either clear the flag, or adjust attachment definitions.


***yes I'm ignoring launchers to underscore a point

[Updated on: Wed, 22 October 2014 04:16] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337374] Thu, 30 October 2014 12:43 Go to previous messageGo to next message
Sophos

 
Messages:11
Registered:February 2005
Location: Kolham
I've recently started playing UC 1.13 as I needed my fix of JA2 again and I've played the main game a dozen of times. I've tried it before but found it too hard back then, and Microsoft Mary as the villain annoyed me. This time around I'm a lot more patient and skilled and really like the game.

Anway to cut to the chase, and this has probably been asked before, but I seem to be able to only train militia in the sectors where the original game has cities, is this intentional or should I be able to train militia in other city sectors as well?

(Awesome to see this board is still so active for an old game, I hope you guys have a lot of influence on JA: Flashback!)

EDIT: I did find this in a post from November 3rd 2011:
Quote:
City Sector Militia Garrisons - Original Urban Chaos had city sectors defined by hardcoded values from original Jagged Alliance 2, and the use of city sectors that cannot be filled via the city militia management interface continues with UC-1.13 due to the following despite city sector definitions being externalized some time ago:
- - the militia management interface is still 3x3 sectors
- - there is a limit to total number of sectors that may have a garrison
- - some sectors that can permit a garrison do not have one to speed up game play (excess militia training lead to unnecessarily slow games in some cases)
- - the advent of Mobile Militia provides a workaround to current City Militia limits


Is this still current information?

[Updated on: Thu, 30 October 2014 12:57] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337506] Mon, 03 November 2014 03:24 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
@Sophos - as far as training militia, the sector must contain a facility that allows training. This is a v1.13 addition, but in general police stations (as listed in the facilities) will allow for training, along with various in-city military facilities.

The quote is generally accurate, but covers where militia are allowed to be garrisoned.

Toggle Spoiler



AK-105 (as well as 102 and 104) have a different muzzle device than their full size counterparts. I'm considering just given them a flash hider as default and clearing the flag. The problem with default barrel attachments is that it actually reduces their flexibility for the AI in that there is no random chance of a better or worse attachment. If only we could use random items as a default attachment.


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337519] Mon, 03 November 2014 16:23 Go to previous messageGo to next message
Sophos

 
Messages:11
Registered:February 2005
Location: Kolham
Thanks Wil, so for sectors without facilities I need to use the Mobile Militia? As I cannot redistribute militia to 2 sectors in Calisto it seems.

Also, is there a way to prevent new police and gun runners from respawning? I've killed all of them in a sector, but whenever the enemy attacks one of my sectors and I'm there to defend it there's also a new police force present.

[Updated on: Mon, 03 November 2014 18:22] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337612] Fri, 07 November 2014 16:22 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Sophos
Also, is there a way to prevent new police and gun runners from respawning? I've killed all of them in a sector, but whenever the enemy attacks one of my sectors and I'm there to defend it there's also a new police force present.


Which maps is this happening in? The game likes to repop all civ factions if all civ units are wiped out from a map - the workaround, which is still in use, is to add a few neutral civ units to affected maps. Often this is just a single cow added to the corner of the map.


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337668] Mon, 10 November 2014 15:31 Go to previous messageGo to next message
Sophos

 
Messages:11
Registered:February 2005
Location: Kolham
wil473
Sophos
Also, is there a way to prevent new police and gun runners from respawning? I've killed all of them in a sector, but whenever the enemy attacks one of my sectors and I'm there to defend it there's also a new police force present.


Which maps is this happening in? The game likes to repop all civ factions if all civ units are wiped out from a map - the workaround, which is still in use, is to add a few neutral civ units to affected maps. Often this is just a single cow added to the corner of the map.


This happened to me at Calisto Airport and the sector besides that with the gun runners (the gun runner sector only spawned one enemy though, perhaps the gunrunner fled from the map and came back?). Come to think of it I only started attacking the police until I was in the sector underneath the airport, it is possible I did not yet deal with the police at the airport until the counter attack came.

Anway, great work! I'm having a great time playing Urban Chaos.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337709] Thu, 13 November 2014 10:04 Go to previous messageGo to next message
Sophos

 
Messages:11
Registered:February 2005
Location: Kolham
I came across something else, I've escorted Blair and Elizabeth to the Calisto Airport with Elhi, but they don't recognise the airport and don't thank me for bringing them there and all. I've searched the forums but found no-one else with this issue. Also, one of the subway maps I think the Artremo was has the destinations mixed up the one that says east actually goes to Port Kip and west goes to Calisto. One last thing, I'm in Sheraton now but I don't have a MOC list, was I supposed to get that from Carmen in Artremo? I only received a laptop. If so, is there any way to edit a save file so that I do have the item?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337710] Thu, 13 November 2014 12:58 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Are you playing the old or new map modes of UC-1.13? Old Maps have no modified maps, meaning all map related issues, such as hostile civ repopulation and missing head miner (original UC bug) are present.

Have you escorted Blair and Elizabeth into the airport? This one is an overall JA2 issue.

No need to edit the save, all is as was intended in original UC...


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337713] Thu, 13 November 2014 17:27 Go to previous messageGo to next message
Mikemcn
Messages:2
Registered:November 2014
Location: United States
SO i install UC 1.13 following the Hybrid instructions. It starts fine, I set up my squad, but as soon as I try and transition to the opening area i get an "assertion failure: [line 2999 in worlddef.cpp] Attempting to create a debug save.... this may fail"

The game also starts up with error messages on the splash screen but I don't think that's the problem since it continues.

Here's the splash error just in case
Toggle Spoiler


Really excited to try out UC, thanks for the help!

Edit: Ok i reinstalled in a new folder, with the latest JA 1.13 dev build, and the latest UC 1.13 i could find, the splash screen has no error, and the menu looks like it should, but when I start new game, i watch the intro and then get the following...

[Updated on: Thu, 13 November 2014 20:18] by Moderator

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337715] Thu, 13 November 2014 21:35 Go to previous messageGo to next message
Sophos

 
Messages:11
Registered:February 2005
Location: Kolham
wil473
Are you playing the old or new map modes of UC-1.13? Old Maps have no modified maps, meaning all map related issues, such as hostile civ repopulation and missing head miner (original UC bug) are present.

Have you escorted Blair and Elizabeth into the airport? This one is an overall JA2 issue.

No need to edit the save, all is as was intended in original UC...


I followed the FAQ guide in this section and am running vfs_config.UC113.ini. Yes, I walked across almost the whole sector in tactical screen but nothing was triggered.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337721] Fri, 14 November 2014 04:14 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Mikemcn
SO i install UC 1.13 following the Hybrid instructions. It starts fine, I set up my squad, but as soon as I try and transition to the opening area i get an "assertion failure: [line 2999 in worlddef.cpp] Attempting to create a debug save.... this may fail"

The game also starts up with error messages on the splash screen but I don't think that's the problem since it continues.

Here's the splash error just in case
Toggle Spoiler


Really excited to try out UC, thanks for the help!

Edit: Ok i reinstalled in a new folder, with the latest JA 1.13 dev build, and the latest UC 1.13 i could find, the splash screen has no error, and the menu looks like it should, but when I start new game, i watch the intro and then get the following...



Sophos
wil473
Are you playing the old or new map modes of UC-1.13? Old Maps have no modified maps, meaning all map related issues, such as hostile civ repopulation and missing head miner (original UC bug) are present.

Have you escorted Blair and Elizabeth into the airport? This one is an overall JA2 issue.

No need to edit the save, all is as was intended in original UC...


I followed the FAQ guide in this section and am running vfs_config.UC113.ini. Yes, I walked across almost the whole sector in tactical screen but nothing was triggered.


Both are due to missing lines in the LUA scripts. The latter can be fixed by copying Overhead.lua from Data-1.13, the former however requires some work (already done in my production copy). Problem is, I was not planning on a v4.50 Release Candidate (RC) for UC-1.13 until the less complicated AFS v4.50 was more or less ready. As soon as I get the exploding roofs working in AFS, I'll port the changes over to UC-1.13 and release RC's for the two (perhaps three if there is demand for a stopgap fix for DL-1.13).

[Updated on: Fri, 14 November 2014 04:16] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337724] Fri, 14 November 2014 08:42 Go to previous messageGo to next message
Mikemcn
Messages:2
Registered:November 2014
Location: United States
Ok, maybe i'll try an earlier build of each? Or I can wait, Thanks for all the work though, it's awesome that you're doing this.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337764] Sun, 16 November 2014 03:07 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Due to the broken scripts I've moved forward a "Preview" for UC-1.13 v4.50.

[s]Urban Chaos-1.13 Preview v4.50 20141115[/s]
Obsolete now, see later posts

Minimally tested with today's SCI_Unstable_Revision_7654_on_GameDir_2184 courtesy of DepressivesBrot. Specifically, I just finished testing:

1) Game Start
2) Ambassador/airport scripting
3) Roof collapse
4) Carmen paying (1x heads, should work for a 2nd, perhaps a 3rd)
5) Exploding ammo works
6) End game sequence functional

The following seem to be broken/need some work:

1) variable power scopes CTD during some, but not all transformations
2) some M-LBE's are not fitting
3) I'm not sure if the tag is not working or if my guess for what it does is wrong (haven't actually looked it up yet)
4) FRAG-12 seems to be producing smoke, not sure if I accidentally set a buddy effect

[Updated on: Sun, 14 December 2014 19:19] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337793] Mon, 17 November 2014 11:38 Go to previous messageGo to next message
sevenfm

 
Messages:1454
Registered:December 2012
Location: Under the Mountain
UC 4.5 doesn't start with stable 7435

DL and AFS start fine with stable release.

Also it cannot find option in skills_settings.ini
The value [Covert Ops][COVERT_ELITES_DETECT_NEXTTILE] = "" in file [Skills_Settings.ini] is neither TRUE nor FALSE. The value TRUE will be used.


Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #337795] Mon, 17 November 2014 12:49 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Sevenfm
UC 4.5 doesn't start with stable 7435

DL and AFS start fine with stable release.

Also it cannot find option in skills_settings.ini
The value [Covert Ops][COVERT_ELITES_DETECT_NEXTTILE] = "" in file [Skills_Settings.ini] is neither TRUE nor FALSE. The value TRUE will be used.


It looks like the fix to the LUA scripting issue that lead to the rushed release of the UC-1.13 v4.50 Preview for the Unstable SCI is not compatible with 2014 Stable.

Commenting out the following allows the game to start:
SetStartingCashDifLevel(newDIFFICULTY_LEVEL)



This is not good, the reason I was unhappy with v4.49 was that it wasn't "smoothly" compatible with Stable, now v4.50 is just incompatible.

[Updated on: Mon, 17 November 2014 12:56] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338043] Sun, 30 November 2014 01:36 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Obligatory recognition that I am double posting to announce:

[s]Urban Chaos-1.13 Preview 2 v4.50 20141129[/s]
Obsolete now, see later posts

Thanks to a reminder from Buggler of methods used by UC-1.13 in the past for these kind of situation, Preview 2 includes a more elegant solution to compatibility with 2014 Stable 1.13 Release (7435) + JA2_113_UpdateForRelease7435_English_7609. Yes this time I actually tested game start and end game with the current Stable release of v1.13. If you use the "Stable" v1.13 release please select the VFS config that mentions "2014 Stable"

  • Tested with SCI_Unstable_Revision_7654_on_GameDir_2184
  • Tested with 2014 Stable 1.13 Release (7435) + JA2_113_UpdateForRelease7435_English_7609
  • Added RPG-2, based on original graphic from Urban Chaos, by Mod Squad
  • Added PG-2 HEAT, based on original graphic from IoV
  • Added M1 Bazooka, from IoV
  • Added M6A1 Bazooka Rocket, from IoV
  • Added Airtronic Mk.777, from IoV
  • Added AT4, from IoV
  • Added MEI HELLHOUND, from IoV
  • Added MEI Mercury, from IoV (this one is not in AFS Preview 2)
  • Added Integral Thermal Weapon Sight, from IoV
  • Changed Anti-Tank Rifle Grenade:
    - - Damage = 55, was 75
    - - Stun Damage = 10, was 33
    - - Final Radius = 1, was 2
    - - Volume = 40, was 65
    - - #Fragments = 50, was 0
    - - Fragment Damage = 5, was 0
    - - Fragment Range = 40, was 0
  • Changed M72A4 LAW, Coolness = 5, was 7
  • Changed Carl Gustaf M3:
    - - = 8, was 9
    - - = Integral - Optics
    - - = Integral Scope Sight (1.5X)
  • Changed RPG-7 Launcher, = 5, was 8
  • Changed RPG-26, = 7, was 8
  • Changed RPG-27, = 8, was 9
  • Changed Mark 153 SMAW
    - - = Optics - All Tac Rail
    - - = Battle Scope (4X)
  • Changed RPO-A
    - - copied from
    - - = Optics - All Tac Rail
    - - = Integral Scope Sight (1.5X)
  • Changed BS-1 "Tishina," now "GL - BS-1 "Tishina"
  • Changed VG-70 Grenade Launcher, now "GL - VG-70"
  • Changed Pallad-M, now "GL - Pallad-M"

    Specific to UC-1.13
  • Updated all FacilityTypes, added missing tags
  • Added compatibility VFS configurations and supporting files for 2014 Stable 1.13 Release (7435) + JA2_113_UpdateForRelease7435_English_7609
  • Fixed Items.XML, cleaned up numerous errors with
  • Fixed TonyInventory.XML, removed several non-weapon items
  • Rest of v4.50 Preview details

[Updated on: Sun, 14 December 2014 19:18] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338070] Tue, 02 December 2014 12:26 Go to previous messageGo to next message
Sophos

 
Messages:11
Registered:February 2005
Location: Kolham
If I use build 7514 will I be able to use this without screwing up my game? I used a FAQ thread somewhere on these boards to get UC installed.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338154] Mon, 08 December 2014 15:26 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Sophos
If I use build 7514 will I be able to use this without screwing up my game? I used a FAQ thread somewhere on these boards to get UC installed.


See: General Release Post for UC-1.13
I am not sure about the differences between build 7514 and 7516 found in the recommended Single Click Installer, SCI_Unstable_Revision_7516_on_GameDir_2145, so it is use at your own risk. Additionally, v4.49 has been tested with 2014 Stable 1.13 Release (7435), though naturally Stable has fewer features than more recent SCI's.

For more information see also: Urban Chaos-1.13 Hybrid FAQ & Spoilers




Moving forward, for anyone interested in the v4.50 Preview, I've done a brief test with the current Preview 2 of UC-1.13 under the current SCI as of this date, SCI_Unstable_Revision_7667_on_GameDir_2186, didn't see any warnings at game start, but the change log notes some spelling fixes that I need to manually work into some of the XML's.

[Updated on: Mon, 08 December 2014 15:29] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338161] Mon, 08 December 2014 20:58 Go to previous messageGo to next message
mrclark20
Messages:4
Registered:June 2012
Location: CALIFORNIA

I am playing UC 1.13 with the ja2 1.13, 2014 Official 1.13 Release (7435) with 7609 Update, and

Urban Chaos-1.13 v4.49. I have rescued Blair and his wife and brought them to the airport in Calisto, but it is not letting me finish the quest. Any suggestions?
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338165] Tue, 09 December 2014 00:05 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
mrclark

I am playing UC 1.13 with the ja2 1.13, 2014 Official 1.13 Release (7435) with 7609 Update, and

Urban Chaos-1.13 v4.49. I have rescued Blair and his wife and brought them to the airport in Calisto, but it is not letting me finish the quest. Any suggestions?


Known issue with v4.49, options:

1) Grab v4.50 Preview 2, from the last page - enjoy the new anti-tank stuff (though with the Stable, no moving tanks)
2) Wait a few more weeks for the final release of v4.50 - enjoy the new anti-tank stuff, new guns, and new golf course map...

[Updated on: Tue, 09 December 2014 00:17] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338215] Thu, 11 December 2014 19:03 Go to previous messageGo to next message
mrclark20
Messages:4
Registered:June 2012
Location: CALIFORNIA
Thank you, I will try that.
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338256] Sat, 13 December 2014 16:00 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
Ok, looks like we are a go for big maps, baring one little problem. Instead of creating a brand new map (I actually kept crashing the map editor in my ineptitude) I simply enlarged the original O6 to 360x360. Now that I have a big modified O6 I decided to see if it still crashed if entered from the wrong side - good news is that I could enter the modified map from any direction. Bad news is that the place mercs screen is still formatted for the old size (spread mercs is the only way to get the battle going). I'm going to bug Smeagol for help on this one.

EDIT: Well, I feel like an idiot - after taking a break from trying to find way to resize the map (and producing a bunch of hand cannon graphics) I just figured out that the merc placement screen can be scrolled by the arrow keys. I think I'll be taking another long break from modding after v4.50 is released. Sorry for the panic.

v4.50 Preview 3 for UC-1.13 will be out tomorrow...

[Updated on: Sun, 14 December 2014 03:20] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #338268] Sun, 14 December 2014 19:15 Go to previous messageGo to next message
Wil473

 
Messages:2820
Registered:September 2004
Location: Canada
...and now it is tomorrow, time to double post.

Last of the v4.50 previews, still a few things to clean up like resizing all the MDR-C variants (incorrectly legal attachment for a medium NIV slot, despite the graphic being too big). No new plans except for bug fixing and other polish from now till the final v4.50 release near years end - please report any issues found.


[s]Urban Chaos-1.13 Preview 3 v4.50 20141214[/s]
Obsolete now, see later posts
  • Tested with SCI_Unstable_Revision_7667_on_GameDir_2186 (Nov 30 SCI)
  • Tested with 2014 Stable 1.13 Release (7435) + JA2_113_UpdateForRelease7435_English_7609

  • Implemented "Magnum Research Desert Eagle" calibre conversion system
    - - added: Desert Eagle Frame & Slide, Desert Eagle .357Mag 6" kit, Desert Eagle .44Mag 6" kit, Desert Eagle .50 AE 6" kit, Magnum Research Desert Eagle .357 10," Magnum Research Desert Eagle .44 10," Magnum Research Desert Eagle .50 AE 10," Desert Eagle .357Mag 10" kit, Desert Eagle .44Mag 10" kit, and Desert Eagle .50 AE 10" kit
    - - only Magnum Research Desert Eagle .357 buyable as new from Bobby Rays (web)
    - - item transformation used to: "Disassemble" / "Unload magazine, then remove the barrel and bolt assembly." all Desert Eagle variants
    - - item (easy) mergers used to assemble Desert Eagle variants
  • Changed Pockets.XML
    - - 11. Pistol Holster no longer fits size 4, only 0 and 3
    - - 57. Large Pistol Holster now set for sizes 0 3 4
  • Changed Items.XML, all occurrences of "Magnum Research" in now replaced by "M.R."
  • Changed Large Holster, now uses Large Pistol Holster
  • Changed PH-PDW and variants, Size = 6, was 3
  • Changed Baikal Margolin, Size = 4, was 5
  • Changed Welrod Mk.II, Size = 5, was 4
  • Changed Baikal MCM, Size = 4, was 6
  • Changed Beretta U22 Neos, Size = 4, was 5
  • Changed Beretta U22 Neos Inox, Size = 5, was 4
  • Changed Br

    [Updated on: Mon, 22 December 2014 22:22] by Moderator



Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #339235 is a reply to message #338268] Tue, 03 February 2015 22:45 Go to previous messageGo to next message
Funo
Messages:9
Registered:April 2012
Hello !

After a while i got a taste for a ja2 1.13 game ( Flashback still has a long way to go cheeky ), as always i picked urban chaos mod for 1.13. First of all , how big was my mistake for choosing 4.50 UC 1.13 version with SCI_unstable_revision_7723 ? big grin
To get to the point, after i start the game i do not get the right amount of starting money on the set difficulty STARTING_CASH_INSANE = 95000 ( Ja2_Options.INI ) , i always get 15000 only. The second thing , after i create a IMP character i pay 3370 money even if i have set the amount to 3000 in Ja2_Options.INI . Should i stick to the recommended SCI revisions because i was to greedy for new features ? big grin
Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #339236 is a reply to message #339235] Tue, 03 February 2015 22:59 Go to previous messageGo to next message
silversurfer

 
Messages:2223
Registered:May 2009
In newer exe version you need to modify TableData\DifficultySettings.xml in order to change starting cash. Newer Ja2_Options.INI don't have this parameter anymore. I don't know if you will run into any more issues with UC.

If you used the new IMP starting gear selection screen the cost for your IMP can be higher. It depends on what items you select.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: UC-1.13 Discussions and Bug Reporting (2013/03/07 to 201-/--/--)[message #339239 is a reply to message #339236] Wed, 04 February 2015 01:23 Go to previous messageGo to previous message
Funo
Messages:9
Registered:April 2012
silversurfer wrote on Tue, 03 February 2015 21:59
In newer exe version you need to modify TableData\DifficultySettings.xml in order to change starting cash. Newer Ja2_Options.INI don't have this parameter anymore. I don't know if you will run into any more issues with UC.

If you used the new IMP starting gear selection screen the cost for your IMP can be higher. It depends on what items you select.


Thank you for your help. Yeah i forgot about the feature with the starting gear, it explains the change in price. About the TableData\DifficultySettings.xml, the 1.13 modders are trying to ditch the .ini configuration system? Or is this just because of some stability/error/bug trouble why they are stoping to support some settings in the .ini file or files (skills_settings, mod_settings etc)? Can you give me the thread/source with the explanation/number of the changes in the ja2_options.ini or other .ini files?
Previous Topic: The 2nd Weapons & Items Requests for UC-1.13/DL-1.13/AFS thread
Next Topic: Arulco Folding Stock Discussions & Bug Reports - (2013/04/20 - 20--/--/--)
Goto Forum:
  


Current Time: Wed Jan 17 09:06:41 EET 2018

Total time taken to generate the page: 0.01809 seconds