Home » MODDING HQ 1.13 » v1.13 Bug Reports » Map editor problem - losing items
Map editor problem - losing items[message #331544] Fri, 28 March 2014 18:31 Go to next message
Uriens

 
Messages:330
Registered:July 2006
Using exe and ini editor 7093 version + WF maps 6.07 version and AFS RC 6.

How to recreate:
1. Install above mentioned mods. Copy/paste content of Data-WildFire6.07 to Data-AFS folder.
2. Load map editor and go to Drassen mine one (D13)
3. Open up sector and place Luger P08 Parebellum pistol somewhere on it and note the location.
4. Save sector map.
5. Load the map again and check it out. The pistol won't be anywhere on the map.

This appears to happen to SOME items you place in the map editor. Stuff like Che Guevarra Canteen's and others are saved properly, but some items are just not saved. It's weird problem and currently I can't make heads or tails of what will be saved and in what sectors and what will be deleted. For example, when I tried to place above mentioned Luger in A9 sector not far from Fatima, it got saved properly and was there when I reloaded that sector. For some reason, it seems that different sectors have problems saving different items. Luger, for example, can't be saved in the D13 sector but is saved properly in the A9 sector.
It's a big problem when you edit maps or try to fix/make compatible existing maps and dubble with hundreds of items only to find out that almost half of them got erased in the end. Basically makes editor unusable.

Edit. Also another test with D13 sector.
1. Same as before. Also make sure you don't have anything saved in profiles/AFS/Maps folder for D13 sector (delete, move or rename if you already have). This will make sure you load orginal WF maps.
2. Open up D13 map in Map editor
3. Note the ACA building in it and check the items on the shelves there. All shelves have items on them (some are nada too but that is not important right now).
4. Don't edit anything, just save the map as it is.
5. Load the map again.
6. Look at those shelves again. Some will be empty while others will have less items.

So it's not just the items you try to place from AFS mod, it affects some of the items that were placed previously by the map creator.

[Updated on: Fri, 28 March 2014 18:43] by Moderator

Re: Map editor problem - losing items[message #331547] Sat, 29 March 2014 00:04 Go to previous messageGo to next message
silversurfer

 
Messages:2462
Registered:May 2009
*sigh*

Looks like I have to update the maps to new format so this doesn't happen again...

The reason for this problem is that the maps are in old format and when you save them without unchecking the "save in vanilla format" checkbox before you save, all items above a certain index are lost.

Before you ask - this is working as intended.

Re: Map editor problem - losing items[message #331549] Sat, 29 March 2014 00:24 Go to previous message
Uriens

 
Messages:330
Registered:July 2006
Thanks for that info. Smile
Then all I have to do is uncheck 'save in vanilla format' and it will work fine. I always thought that option was just for large map's. Didn't think it affects items.

:cheers:

Previous Topic: Is revision 7117 not supposed to have a log entry?
Next Topic: Formatting on the bug report wiki?
Goto Forum:
  


Current Time: Thu Nov 15 15:19:54 EET 2018

Total time taken to generate the page: 0.01791 seconds