Home » MODDING HQ 1.13 » v1.13 Coding Talk » Experimental Project 7
Re: Experimental Project 7[message #347558 is a reply to message #347557] Fri, 18 November 2016 16:41 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
And first bug encountered - entering bloodcat lair starts combat with bloodcat turn, and turn progress gets stuck near the start, seemingly after the first bloodcat finishes action. I know there is 30 second timeout for AI and I know I saw it in action few times in the past, but this time it does not work. I tried the same save with regular ja2.exe, I immediately see a lot of bloodcats and they normally do their turn. With AI exe, I even do not get to see them (strangely).
Re: Experimental Project 7[message #347559 is a reply to message #347558] Fri, 18 November 2016 17:15 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
weidox wrote on Fri, 18 November 2016 19:41
And first bug encountered - entering bloodcat lair starts combat with bloodcat turn, and turn progress gets stuck near the start, seemingly after the first bloodcat finishes action. I know there is 30 second timeout for AI and I know I saw it in action few times in the past, but this time it does not work. I tried the same save with regular ja2.exe, I immediately see a lot of bloodcats and they normally do their turn. With AI exe, I even do not get to see them (strangely).

Do you have a save with bloodcat bug? (with used mod/changed settings description)
As for x-ray balance - I understand the problem with it's limited use, need to think how to make it more useful without that 'cheating' feeling, maybe add some 'noise' to enemy positions or add fake enemy spots.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347563 is a reply to message #347559] Fri, 18 November 2016 17:46 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
I wonder what good people were making of x-ray so it felt like cheating. I guess I don't know something.. As I used it only for tactical planning, adding some noise to enemy positions would make no difference to me, as enemies could change position anyway till I move nearer to them. But if that helps with any other kind of cheating, it would be good solution as it would not hurt it's use for tactical planning. Fake spots I think would be more complicated as it would force use to try twice to deduce fakes - would be even worse.
About the bug, I have the save. I had to produce it again from earlier save in which hummer was moving into lair, and bug did not repeat. Then tried once more, and bug repeated. So I have the save with bug, and save before bug which may or may not reproduce bug (if that would help). Where I should upload or send saves?

Using Arulco Revisited 1.4 with additional patch from there http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=22968&goto=344511&#msg_344511:
http://kermi.pp.fi/JA_2/Mods_v1.13/Arulco_Revisited/v1.4/Stable_Release_2014/
http://kermi.pp.fi/JA_2/Mods_v1.13/Arulco_Revisited/v1.4/Stable_Release_2014/Patches/CVB/

[Updated on: Fri, 18 November 2016 17:48]

Re: Experimental Project 7[message #347564 is a reply to message #347563] Fri, 18 November 2016 17:59 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
weidox wrote on Fri, 18 November 2016 20:46
I wonder what good people were making of x-ray so it felt like cheating. I guess I don't know something.. As I used it only for tactical planning, adding some noise to enemy positions would make no difference to me, as enemies could change position anyway till I move nearer to them. But if that helps with any other kind of cheating, it would be good solution as it would not hurt it's use for tactical planning. Fake spots I think would be more complicated as it would force use to try twice to deduce fakes - would be even worse.
About the bug, I have the save. I had to produce it again from earlier save in which hummer was moving into lair, and bug did not repeat. Then tried once more, and bug repeated. So I have the save with bug, and save before bug which may or may not reproduce bug (if that would help). Where I should upload or send saves?

A save with a bug should be enough, you can upload it on any file hosting service like dropbox or send me to sevenfm@gmail.com



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347565 is a reply to message #347564] Fri, 18 November 2016 18:01 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
Uploaded at
https://drive.google.com/open?id=0B8a0YbeQMG9xYjRhaWViWGIwbEE
Re: Experimental Project 7[message #347568 is a reply to message #347559] Fri, 18 November 2016 21:09 Go to previous messageGo to next message
edmortimer

 
Messages:1214
Registered:January 2015
Location: Home Free
I just encountered the bloodcat freeze also in current version of AV. It freezes as the Bloodcat strikes. If you need another save I can send it.

[Updated on: Fri, 18 November 2016 21:13]





Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: Experimental Project 7[message #347569 is a reply to message #347568] Sat, 19 November 2016 19:14 Go to previous messageGo to next message
johnson

 
Messages:59
Registered:September 2015
Same here using latest AV, bloodcat ambushes tend to freeze on the second turn, only way to avoid it is by using cheats to kill them all.

Otherwise I have had a very positive experience with enemy AI.

[Updated on: Sat, 19 November 2016 19:42]

Re: Experimental Project 7[message #347572 is a reply to message #347558] Sat, 19 November 2016 23:19 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
weidox wrote on Fri, 18 November 2016 19:41
And first bug encountered - entering bloodcat lair starts combat with bloodcat turn, and turn progress gets stuck near the start, seemingly after the first bloodcat finishes action. I know there is 30 second timeout for AI and I know I saw it in action few times in the past, but this time it does not work. I tried the same save with regular ja2.exe, I immediately see a lot of bloodcats and they normally do their turn. With AI exe, I even do not get to see them (strangely).

edmortimer wrote on Sat, 19 November 2016 00:09
I just encountered the bloodcat freeze also in current version of AV. It freezes as the Bloodcat strikes. If you need another save I can send it.

johnson wrote on Sat, 19 November 2016 22:14
Same here using latest AV, bloodcat ambushes tend to freeze on the second turn, only way to avoid it is by using cheats to kill them all.

The bug can be reproduced with any Ja2+AI release and also with Ja2+fix, so it's something very old.
Stock 1.13 7609 works well and probably can be used to fight bloodcats until the bug is fixed.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347588 is a reply to message #347572] Tue, 22 November 2016 23:03 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
Ja2+AI update:

- lowered laser bonus when aiming: bonus = 2 * bonus / (2 + AimTime) (lasers are mostly used when hip firing or with little aim)
- LocationToLocationLineOfSightTestExt: use max sight
- DecayPublicOpplist: decay knowledge if enemy spot is incorrect
- CheckForChangingOrders: don't change orders for ENEMY_TEAM when defending town or underground and not under fire currently, for CIV_TEAM change orders only if not neutral and seen enemy or under fire
- FindBombNearby: check line of sight only when deciding to raise alert
- lowered range check for AICheckShortWeaponRange (now DAY / 2)
- CalcBestShot: fix bug caused by not initializing fSuppression in a loop (this should fix random problem when enemy was not allowed to attack if he had no auto capable weapon, resulting in melee attacks)
- RED AI: allow cautious move (reserving AP for shooting) when in dangerous spot
- CalcCoverValue: instead of dividing by number of seen enemies, use weight function based on distance, advance tweaks (so AI will give more weight to close enemies that can attack him instead of assuming that enemy can attack any recently seen opponent no matter how far he is)
- use Mini-14 instead of Glock 17 for CTGT test
- AI soldiers will not seek enemies that are too far, depending on orders
- moved ambient sounds from Sounds to Ambient folder
- r8340 Fix: incorrect underground check for cave vision bonus and scouting
- ClosestReachableFriendInTrouble: only help friends in buildings when defending in town
- fix: don't make a copy of a gun when disarming tripwire (disarmed object keeps all it's attachments)
- fix: can attach rubber band only to grenade with normal type explosion (only normal type grenade can activate attached explosives using detonation)
- fix: can attach duct tape only to explosives of normal type
- fix: negative discount from backgrounds for betterprices_gun and betterprices (assigning negative value to unsigned variable resulted in bug)
- take into account trap difficulty when performing disarm check (previously trap level had no effect on trap disarming, only on detecting)
- removed wirecutter bonus when disarming tripwire (use items with <DisarmModifier> tag)
- fix: positive modifier from trap level when disarming door (it was easier to disarm trap that had high trap level)
- examining trap gives 1 + Random(bDetectLevel / 2) bonus
- neutral civilians always avoid player mines (CIVILIANS_AVOID_PLAYER_MINES has no effect)

In this release, changed AI behaviour when defending town - enemy will not change orders automatically and will not seek too distant enemy, this should prevent "sit and wait for enemy attacking me" tactics when assaulting towns, instead it's player who needs to advance and take control on town.
AI with SEEKENEMY orders and attacking/reinforcing AI will use old "seek enemy and attack" behaviour.

Download:
https://www.dropbox.com/s/bdl2ecpz3g27bfq/ja2_7609en%2BAI_r314.exe?dl=0

[Updated on: Wed, 23 November 2016 12:25]




7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347593 is a reply to message #347588] Wed, 23 November 2016 07:46 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
@sevenfm

I like to play JA2+AI. Can provide Chinese version? Or provide source patch? Thanks.

----

In additon, I have question to consult you:

I recently in the correction "IoV MOD"(929beta). When hire AIM merc(eg. Reaper), Reaper's Gun is "Colt XM177-E2/XM-148 Combo"(define in MercStartingGear.xml). But Reaper lost his Gun. And when buy this gun from BR. This gun's ammo is lost(0 in mag).

I check "Colt XM177-E2/XM-148 Combo"'s ammo is: Caliber 5.56mm M193, Capacity 20. And I check Magazines.xml, this ammo have defined.

Then I use XML Editor.exe Check this gun and this ammo. No problem found. But this gun's ammo in Itemx.xml, uiIndex is 2098. When I use XML Editor to Change this ammo's uiIndex to < 1960(eg. 1000). Repear's gun is OK.

Then I check a lot of similar, it is need to change ammo's uiIndex below 1960 to work.

So, my question is: add Ammo to game, have any rules limit? how to avoid the definition of gun lost because of the magazine?

But I used ja2+AI.exe to play 1.13Statle + IoV, Without any problems.

Sorry for my poor English. Don't know whether you understand what I said.
Re: Experimental Project 7[message #347596 is a reply to message #347593] Wed, 23 November 2016 08:46 Go to previous messageGo to next message
Toma777

 
Messages:57
Registered:October 2013
Location: serbia
zwwooooo wrote on Wed, 23 November 2016 05:46
@sevenfm

I like to play JA2+AI. Can provide Chinese version? Or provide source patch? Thanks.

----

In additon, I have question to consult you:

I recently in the correction "IoV MOD"(929beta). When hire AIM merc(eg. Reaper), Reaper's Gun is "Colt XM177-E2/XM-148 Combo"(define in MercStartingGear.xml). But Reaper lost his Gun. And when buy this gun from BR. This gun's ammo is lost(0 in mag).

I check "Colt XM177-E2/XM-148 Combo"'s ammo is: Caliber 5.56mm M193, Capacity 20. And I check Magazines.xml, this ammo have defined.

Then I use XML Editor.exe Check this gun and this ammo. No problem found. But this gun's ammo in Itemx.xml, uiIndex is 2098. When I use XML Editor to Change this ammo's uiIndex to < 1960(eg. 1000). Repear's gun is OK.

Then I check a lot of similar, it is need to change ammo's uiIndex below 1960 to work.

So, my question is: add Ammo to game, have any rules limit? how to avoid the definition of gun lost because of the magazine?

But I used ja2+AI.exe to play 1.13Statle + IoV, Without any problems.

Sorry for my poor English. Don't know whether you understand what I said.

Contcat edmortimer or smeagol they can give you hints
Re: Experimental Project 7[message #347597 is a reply to message #347593] Wed, 23 November 2016 09:07 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
zwwooooo wrote on Wed, 23 November 2016 10:46
@sevenfm

I like to play JA2+AI. Can provide Chinese version? Or provide source patch? Thanks.

----

In additon, I have question to consult you:

I recently in the correction "IoV MOD"(929beta). When hire AIM merc(eg. Reaper), Reaper's Gun is "Colt XM177-E2/XM-148 Combo"(define in MercStartingGear.xml). But Reaper lost his Gun. And when buy this gun from BR. This gun's ammo is lost(0 in mag).

I check "Colt XM177-E2/XM-148 Combo"'s ammo is: Caliber 5.56mm M193, Capacity 20. And I check Magazines.xml, this ammo have defined.

Then I use XML Editor.exe Check this gun and this ammo. No problem found. But this gun's ammo in Itemx.xml, uiIndex is 2098. When I use XML Editor to Change this ammo's uiIndex to < 1960(eg. 1000). Repear's gun is OK.

Then I check a lot of similar, it is need to change ammo's uiIndex below 1960 to work.

So, my question is: add Ammo to game, have any rules limit? how to avoid the definition of gun lost because of the magazine?

But I used ja2+AI.exe to play 1.13Statle + IoV, Without any problems.

Sorry for my poor English. Don't know whether you understand what I said.

Here's Chinese version of Ja2+AI, please let me know if it works:
https://www.dropbox.com/s/w77d0rpzirlcv5d/ja2_7609ch%2BAI_r314.exe?dl=0

There's a special patch in Ja2+AI to allow it to work with IoV929 mod.
There was a problem in mod with ammo magazines caused by search optimization in the code - the code stops searching magazine when it finds first item with usItemClass = 0, so there's probably an empty NADA item somewhere between magazines in items.xml, if you check all items and make sure they all have non-zero uiIndex and usItemClass, the magazines should start to work.
In Ja2+AI this optimization was removed, so it should work well with IoV929 or other mods with magazine problems.
I also added Flugente's r8312 fix from main trunk:
Code change: When loading gun/looking for a default magazine for a gun while no mag with fitting magsize exists, instead take a magazine of same calibre and ammotype that has magsize bigger (but close to) the originally requested magsize.

If you want to make stable 7609 or main trunk ja2 1.13 compatible with IoV929's magazines, you need to remove optimizations in the items.cpp (I removed them all):
Toggle Spoiler

[Updated on: Wed, 23 November 2016 12:32]




7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347598 is a reply to message #347597] Wed, 23 November 2016 16:43 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
@sevenfm Thank you for your detailed analysis.

Quote:
Here's Chinese version of Ja2+AI, please let me know if it works:
https://www.dropbox.com/s/w77d0rpzirlcv5d/ja2_7609ch%2BAI_r314.exe?dl=0

Chinese version of Ja2+AI work well. If you can, update following files from 2014 source svn8341 for Chinese Version in next version of JA2+AI, Thanks.
Standard Gaming Platform/WinFont.cpp
Utils/_ChineseText.cpp

Quote:
There's a special patch in Ja2+AI to allow it to work with IoV929 mod.
There was a problem in mod with ammo magazines caused by search optimization in the code - the code stops searching magazine when it finds first item with usItemClass = 0, so there's probably an empty NADA item somewhere between magazines in items.xml, if you check all items and make sure they all have non-zero uiIndex and usItemClass, the magazines should start to work.
In Ja2+AI this optimization was removed, so it should work well with IoV929 or other mods with magazine problems.
I also added Flugente's r8312 fix from main trunk:...


According to your analysis. I have check Items.xml of IoV. And fixed all empty usItemClass in Items.xml. Now IoV work well for 7609, and compatible with the XML Editor.(I has been updated in the old IoV topic, If someone need.)

Thanks a lot.
Re: Experimental Project 7[message #347601 is a reply to message #347598] Wed, 23 November 2016 18:04 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
zwwooooo wrote on Wed, 23 November 2016 19:43
Chinese version of Ja2+AI work well. If you can, update following files from 2014 source svn8341 for Chinese Version in next version of JA2+AI, Thanks.
Standard Gaming Platform/WinFont.cpp
Utils/_ChineseText.cpp

Update:
- r8320: WinFont adjustments
- uploaded _ChineseText.cpp from official stable 7609
Download:
link removed, see main post

Please test.

[Updated on: Fri, 25 November 2016 04:41]




7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347608 is a reply to message #347601] Fri, 25 November 2016 04:24 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
@sevenfm

report: These two days I test on "1.13 7609 + IoV Revised929v007" and "1.13 7609 + AV1.08". Temporarily not found any problems. Thank you for updating.
Re: Experimental Project 7[message #347609 is a reply to message #347608] Fri, 25 November 2016 08:00 Go to previous messageGo to next message
smeagol

 
Messages:2739
Registered:June 2008
Location: Bremen, Germany
Any chance to port a couple of tested features to main branch any time soon?


Re: Experimental Project 7[message #347613 is a reply to message #347609] Sat, 26 November 2016 09:15 Go to previous messageGo to next message
Cerhio

 
Messages:107
Registered:March 2013
smeagol wrote on Fri, 25 November 2016 07:00
Any chance to port a couple of tested features to main branch any time soon?


Wow, can't wait to see some of these features in the main branch!
Re: Experimental Project 7[message #347614 is a reply to message #347609] Sat, 26 November 2016 09:27 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
@sevenfm

Hi, I found ja2_7609ch+AI_r319.exe,ja2_7609ch+AI_r320.exe,ja2_7609ch+AI_r323.exe are not the latest _ChineseText.cpp. The svn7609 version haven't updated perfect translation of Chinese. So, Please use following _ChineseText.cpp to replace. (ja2_source_official_2014 svn8341). Thanks.

http://www.mediafire.com/file/4t23xi1hcz4c397/_ChineseText_113stable_source_svn8341.7z



Re: Experimental Project 7[message #347615 is a reply to message #347609] Sat, 26 November 2016 10:21 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
smeagol wrote on Fri, 25 November 2016 11:00
Any chance to port a couple of tested features to main branch any time soon?

I plan to add enemy gun jams and some AI fixes to the main trunk, and also anything else players want to see if it's not too complex.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347616 is a reply to message #347614] Sat, 26 November 2016 10:43 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
zwwooooo wrote on Sat, 26 November 2016 12:27
@sevenfm

Hi, I found ja2_7609ch+AI_r319.exe,ja2_7609ch+AI_r320.exe,ja2_7609ch+AI_r323.exe are not the latest _ChineseText.cpp. The svn7609 version haven't updated perfect translation of Chinese. So, Please use following _ChineseText.cpp to replace. (ja2_source_official_2014 svn8341). Thanks.
http://www.mediafire.com/file/4t23xi1hcz4c397/_ChineseText_113stable_source_svn8341.7z

Updated:
https://www.dropbox.com/s/zrykb37hd6g0mmx/ja2_7609ch%2BAI_r325.exe?dl=0



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347617 is a reply to message #347616] Sat, 26 November 2016 15:27 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
sevenfm wrote on Sat, 26 November 2016 08:43

Updated:
https://www.dropbox.com/s/zrykb37hd6g0mmx/ja2_7609ch%2BAI_r325.exe?dl=0


Hi,

The problem is still. Please see the screenshot:

http://i.imgur.com/FGJfGtc.jpg

Whether the version issue: following is 1.13 source svn8341's _EnglishText.cpp and _ChineseText.cpp

http://i.imgur.com/EuaXO1B.jpg

Can you put the AI's _EnglishText.cpp sent to me? I compare, make a AI version of _ChineseText.cpp. Thanks.

Re: Experimental Project 7[message #347618 is a reply to message #347617] Sat, 26 November 2016 15:57 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
@zwwooooo
Removed zombie defines:
https://www.dropbox.com/s/q6xjrv83672indh/ja2_7609ch%2BAI_r326.exe?dl=0



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347619 is a reply to message #347618] Sat, 26 November 2016 16:22 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
@sevenfm

I have to send you the _ChineseText.cpp for ja2_7609+AI. But you delete the zombie defines is essentially the same.
Re: Experimental Project 7[message #347620 is a reply to message #347619] Sat, 26 November 2016 16:40 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
@zwwooooo

Updated with your file:
https://www.dropbox.com/s/1g83c0twdo0o2re/ja2_7609ch%2BAI_r327.exe?dl=0

@all
Can someone test if Ja2+AI works correctly with German language?
I don't have German Ja2 so I cannot test it, there were reports of some strange bugs.

[Updated on: Sat, 26 November 2016 17:29]




7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347621 is a reply to message #347620] Sat, 26 November 2016 18:49 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
@sevenfm
A small bug on Chinese Version: lost Chinese char '%':

ja2_7609ch+AI_r327.exe
http://i.imgur.com/FdbthPP.jpg

then I compile r327, It's no problem.

http://i.imgur.com/KRTka2q.jpg

Is this Encoding problem?
Re: Experimental Project 7[message #347622 is a reply to message #347621] Sat, 26 November 2016 18:55 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
zwwooooo wrote on Sat, 26 November 2016 21:49
Is this Encoding problem?

I don't know.
What I do is comment ENGLISH
//#define ENGLISH

and uncomment CHINESE in Language Defines.h
#define CHINESE

As far as I know there are no problems with English and Russian versions, so I have no idea what happens with '%' char.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347623 is a reply to message #347622] Sun, 27 November 2016 04:32 Go to previous messageGo to next message
zwwooooo

 
Messages:83
Registered:February 2009
sevenfm wrote on Sat, 26 November 2016 16:55

I don't know.
What I do is comment ENGLISH
//#define ENGLISH

and uncomment CHINESE in Language Defines.h
#define CHINESE

As far as I know there are no problems with English and Russian versions, so I have no idea what happens with '%' char.

Don't know what version from the start we have some questions for this method to compile a Chinese Version. But another compile method is no problem: edit ja2.props first PropertyGroup below:
  <PropertyGroup Label="UserMacros">
    <JA2Config>JA2</JA2Config>
    <JA2LangPrefix>CN</JA2LangPrefix>
    <JA2Language>CHINESE</JA2Language>
  </PropertyGroup>

I don't know why. I don't know much about vc++.

Re: Experimental Project 7[message #347624 is a reply to message #347623] Sun, 27 November 2016 07:03 Go to previous messageGo to next message
Cerhio

 
Messages:107
Registered:March 2013
Hey guys, quick question: is it possible to implement the JA2+AI features into another mod that uses the same JA2113 stable such as UC113? If so, what would be the install order? I read a comment about UC113 in an earlier comment here yet cannot find instructions on how I would do it.
Re: Experimental Project 7[message #347626 is a reply to message #347624] Sun, 27 November 2016 09:29 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
Cerhio wrote on Sun, 27 November 2016 10:03
Hey guys, quick question: is it possible to implement the JA2+AI features into another mod that uses the same JA2113 stable such as UC113? If so, what would be the install order? I read a comment about UC113 in an earlier comment here yet cannot find instructions on how I would do it.

1. Install UC-1.13 for stable 7609 in usual way.
2. Run Ja2+AI.exe instead of Ja2.exe



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347657 is a reply to message #347588] Wed, 30 November 2016 19:48 Go to previous messageGo to next message
edmortimer

 
Messages:1214
Registered:January 2015
Location: Home Free
Have you had a chance to take a look at the Bloodcat Freeze issue? The latest JA2+AI (r325) I am experiencing freezes immediately upon entering the sector on a Bloodcat ambush.




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: Experimental Project 7[message #347658 is a reply to message #347657] Wed, 30 November 2016 20:00 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
edmortimer wrote on Wed, 30 November 2016 22:48
Have you had a chance to take a look at the Bloodcat Freeze issue? The latest JA2+AI (r325) I am experiencing freezes immediately upon entering the sector on a Bloodcat ambush.

It's a known problem, unfortunately I have no fix for that.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347659 is a reply to message #347658] Wed, 30 November 2016 20:04 Go to previous messageGo to next message
edmortimer

 
Messages:1214
Registered:January 2015
Location: Home Free
Bummer! Is there a workaround?




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: Experimental Project 7[message #347660 is a reply to message #347659] Wed, 30 November 2016 20:05 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
edmortimer wrote on Wed, 30 November 2016 23:04
Bummer! Is there a workaround?

Use official 1.13 ja2.exe to fight bloodcats.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347661 is a reply to message #347660] Wed, 30 November 2016 20:48 Go to previous messageGo to next message
silversurfer

 
Messages:2601
Registered:May 2009
Hey Seven, remember the assertion you fixed in 8300? That assertion was happening in the bloodcat lair. Maybe the conditions you implemented disabled some important part of the code which now leads to a deadlock? You might want to look at that code again.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Experimental Project 7[message #347671 is a reply to message #347661] Fri, 02 December 2016 13:27 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
Ja2+AI update with some fixes and AI improvements (no detailed description yet.):

https://www.dropbox.com/s/izrrht9gurfigr7/ja2_7609en%2BAI_r336.exe?dl=0



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347674 is a reply to message #347671] Fri, 02 December 2016 18:41 Go to previous messageGo to next message
weidox

 
Messages:43
Registered:March 2013
Another bug. Impossible to collect royal jelly from queen (r299). Works correctly with original ja2.exe. When collecting jelly, there is an area on map which turns red when trying to collect. In original ja2.exe, the area is 3x3 square, and in ja2AI the area is only 1x1 square in the center of the original 3x3. That as I understand makes it impossible to reach it. Using Arulco Revisited mod, but I don't think it could be the root cause (except maybe changing the area where queen lies).
Re: Experimental Project 7[message #347675 is a reply to message #347674] Fri, 02 December 2016 18:55 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
weidox wrote on Fri, 02 December 2016 21:41
Another bug. Impossible to collect royal jelly from queen (r299). Works correctly with original ja2.exe. When collecting jelly, there is an area on map which turns red when trying to collect. In original ja2.exe, the area is 3x3 square, and in ja2AI the area is only 1x1 square in the center of the original 3x3. That as I understand makes it impossible to reach it. Using Arulco Revisited mod, but I don't think it could be the root cause (except maybe changing the area where queen lies).

Can you provide a save with description, preferably just before the queen is killed?
I don't remember changing anything even close related to royal jelly and queen.
Also, it's better to update your ja2+AI version to at least r336 as old versions have some bugs.



7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347676 is a reply to message #347675] Fri, 02 December 2016 22:14 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
Another small Ja2+AI update:
https://www.dropbox.com/s/gx6jz2j674g9eb7/ja2_7609en%2BAI_r344.exe?dl=0

[Updated on: Sun, 04 December 2016 18:22]




7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347694 is a reply to message #347676] Sun, 04 December 2016 23:56 Go to previous messageGo to next message
sevenfm

 
Messages:1934
Registered:December 2012
Location: Soviet Russia
Playing against improved AI (r344). Omerta fighting.



And second attempt was more successful:

[Updated on: Mon, 05 December 2016 09:40]




7609+fix | 7609+AI (r1168) | Unofficial modpack | Win8+ fix | Experimental project | Youtube

"It's already "dog-eat-dog", friend. Not sure what worse a bunch of zombies could do."


Re: Experimental Project 7[message #347708 is a reply to message #347675] Fri, 09 December 2016 11:27 Go to previous messageGo to previous message
weidox

 
Messages:43
Registered:March 2013
sevenfm wrote on Fri, 02 December 2016 17:55
weidox wrote on Fri, 02 December 2016 21:41
Another bug. Impossible to collect royal jelly from queen (r299). Works correctly with original ja2.exe. When collecting jelly, there is an area on map which turns red when trying to collect. In original ja2.exe, the area is 3x3 square, and in ja2AI the area is only 1x1 square in the center of the original 3x3. That as I understand makes it impossible to reach it. Using Arulco Revisited mod, but I don't think it could be the root cause (except maybe changing the area where queen lies).

Can you provide a save with description, preferably just before the queen is killed?
I don't remember changing anything even close related to royal jelly and queen.
Also, it's better to update your ja2+AI version to at least r336 as old versions have some bugs.

Just tried with r344, the same issue. Uploaded save games with .ini file, two saves after killing in two different ways plus save before killing (one i think was grenade, another mustard gas):
https://drive.google.com/open?id=0B8a0YbeQMG9xcy1WUC1ILVZxamM
Using Arulco Revisited 1.4 with additional patch from there http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=22968&goto=344511&#msg_344511
http://kermi.pp.fi/JA_2/Mods_v1.13/Arulco_Revisited/v1.4/Stable_Release_2014/
http://kermi.pp.fi/JA_2/Mods_v1.13/Arulco_Revisited/v1.4/Stable_Release_2014/Patches/CVB/


Previous Topic: [WIP] Extended Music Mod Alpha
Next Topic: New Attachment System Beta
Goto Forum:
  


Current Time: Sun Sep 15 21:25:55 EEST 2019

Total time taken to generate the page: 0.04902 seconds