Home » MODDING HQ 1.13 » v1.13 Bug Reports » JA2 1.13 Windows 8.1 -- Consistent Freezes  () 1 Vote
JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335812] Tue, 16 September 2014 09:47 Go to next message
beginattackrun
Messages:3
Registered:September 2014
I'm trying to get Jagged Alliance 2 with 1.13 to work on my computer, and I thought I had sorted out all of the problems, but one dastardly issue remains that I haven't been able to find an online solution for. Let me start out by describing my specific situation:

-using a Windows 8.1 laptop

-installed Jagged Alliance 2

-installed v1.13

-ran into a black screen issue where launching JA2 presented a permanent black screen; I modified ja2.exe's properties, setting it to run in compatibility mode for Windows XP (SP3), checked the box 'Reduced color mode' and set it to 16-bit color, and checked the box for "Run this program as an administrator"; this fix eliminated the black screen problem

-verified the framerate issue was present, then applied the wined3d.exe framerate fix by copying over "ddraw.dll", "libwine.dll", and "wined3d.dll" to my JA2 directory -- this fixed it

-though the intro hasn't caused me any problems similar to what people have been mentioning online, I've disabled it for the sake of troubleshooting ease

With all of these initial issues dealt with, I've been able to play JA2 a little. However, after a short period of gameplay, my game always freezes. I've experienced these freezes both in-menu (like at the virtual laptop) and in tactical view. The mouse cursor disappears, though the music keeps playing (though sometimes the music does not resume after a track has ended). I have to alt-tab / ctrl-alt-delete in order to close the game at that point. I've tested this multiple times with both the Steam and GOG versions, and the freezes continue to occur, so I'm confident that they're not just going to go away with time. The freezes have basically made JA2 1.113 unplayable for me, which is unfortunate given my enthusiasm to get into the game.

For clarification, I've tried both the Steam version of Jagged Alliance 2: Gold Pack and the GOG.com version of Jagged Alliance 2. I left the Steam version in its default location, but (after uninstalling the Steam version) I installed the GOG version outside of the Program Files folder, instead putting it in a new folder named 'C:\Games'.

I would very much appreciate any and all assistance on this matter.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335813] Tue, 16 September 2014 10:36 Go to previous messageGo to next message
grim

 
Messages:288
Registered:July 2006
Location: France
I don't know why you have such freezes.

Anyway, keep those :

Quote:
putting it in a new folder named 'C:\Games'.
-> Good!
Quote:
-verified the framerate issue was present, then applied the wined3d.exe framerate fix by copying over "ddraw.dll", "libwine.dll", and "wined3d.dll" to my JA2 directory -- this fixed it
-> Good!
Quote:
I modified ja2.exe's properties, setting it to run in compatibility mode for Windows XP (SP3), checked the box 'Reduced color mode' and set it to 16-bit color, and checked the box for "Run this program as an administrator"; this fix eliminated the black screen problem
-> Can't be bad!

Now, can you specify the 1.13 version you are using?
Did you try launching the original game (JA2 without 1.13), and what was the game behavior (freezes too?)?
Did you change something in 1.13 files?

By the way, with dev version 7492 and win7, i'm having short freezes from time to time, but they are not game breaking.

[Updated on: Tue, 16 September 2014 10:39] by Moderator

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335841] Wed, 17 September 2014 01:50 Go to previous messageGo to next message
beginattackrun
Messages:3
Registered:September 2014
I'm using Build 7435 (dated 28 Auguest 2014).

Per your advice, I installed JA2 without 1.13 and tested it out for about an hour. I didn't encounter any freezes--the gameplay progressed smoothly.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335852] Wed, 17 September 2014 09:20 Go to previous messageGo to next message
beginattackrun
Messages:3
Registered:September 2014
Also, my freezes w/ JA2 1.13 tended to occur within 5-20 minutes of starting the game, and they seemed permanent. I think I waited at least 5 minutes in one instance to see if one freeze would go away, though of course, it did not. And like I mentioned, the mouse cursor in the game always disappears for me in the event of a freeze.

How long were your freezes? I'm assuming that they were far shorter.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335861] Wed, 17 September 2014 11:32 Go to previous messageGo to next message
grim

 
Messages:288
Registered:July 2006
Location: France
So your problem seems to be caused by 1.13 stable code or its parameters... I can't help you much there.
The last things you could test are graphical settings. Try to change the screen resolution in JA2.INI (0, 1 or 4 for optimized resolutions). Try the windowed mode if that does anything good.
In Ja2_Options.INI, look for the graphical options, and try changing the vertical synchronisation (VERTICAL_SYNC).
I hope someone has a better idea.

My freezes are just a few seconds long (3 to 5), with no mouse cursor disappearance, and seem to happen only in tactical.

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335921] Fri, 19 September 2014 01:36 Go to previous messageGo to next message
Sabot
Messages:2
Registered:September 2014
Hey TS I have the exact same configuration and same problem here.

Changing vsync and lowering the parameter dead lock delay helped me.

Freezes are not gone but much less.

I could finish a whole sector without freeze. Before the changes I got freezes every 30-60 seconds of gaming and had to restart the game after killing it with the task manager.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335945] Sat, 20 September 2014 05:06 Go to previous messageGo to next message
Buggler

 
Messages:210
Registered:November 2009
Did a 2+ hour test run on my 7-year-old Win8.1 integrated Intel GPU laptop.

This is all that's required to run properly on my system:
- Set Windowed Mode as TRUE ('1' in Ja2.ini)
- Set Play Intro as FALSE ('0' in Ja2.ini)
- Reduced Color Mode (16-bit) under 'Compatibility' tab in Ja2.exe 'Properties'
('XP SP3' compatibility mode & copying of the dlls not required in my case)

Most coders/modders run game in windowed mode for quick window switching, so they won't encounter the same situation even if on Win8.

Another possible explanation could be due to laptop hybrid GPUs or desktop multi-GPUs. Would be good to state your GPU configurations if problem still exists even after running in windowed mode.

Gameplay Tip: 'Ctrl + Z' to lock/release mouse cursor to game window for easier tactical screen sector traversing & mouse scrolling (windowed mode only)

@ beginattackrun & Sabot
Welcome to e Pit! :wave:

Edit:

@ Sabot
Please run it in windowed mode and report back whether does it still freezes when browsing Bobby Ray. Thanks.
(I'm suspecting Ja2 in general does not work well in Win8 full screen mode)

[Updated on: Sat, 20 September 2014 14:33] by Moderator

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335951] Sat, 20 September 2014 11:39 Go to previous messageGo to next message
Sabot
Messages:2
Registered:September 2014
CPU i7 2720
RAM 8 Gb 1600 Mhz
SSD 240 Gb
Intel HD 3000 Graphics
Win8.1

Just a business laptop. No extra GPU

I can run it in fullscreen with my "workaround". The only freezes I encounter since I changed vysnc and dead lock parameter is when I have the JA Laptop open for a longer amount of time e.g. browsing bobby rays.

[Updated on: Sat, 20 September 2014 11:47] by Moderator

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #335983] Sun, 21 September 2014 12:59 Go to previous messageGo to next message
grim

 
Messages:288
Registered:July 2006
Location: France
Buggler

This is all that's required to run properly on my system:
- Set Windowed Mode as TRUE ('1' in Ja2.ini)
- Set Play Intro as FALSE ('0' in Ja2.ini)
- Reduced Color Mode (16-bit) under 'Compatibility' tab in Ja2.exe 'Properties'
('XP SP3' compatibility mode & copying of the dlls not required in my case)

I've tested these parameters on win7, no more freezes as far as i've played.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #337071] Thu, 23 October 2014 23:50 Go to previous messageGo to next message
Zefurion

 
Messages:11
Registered:September 2012
same story here, cant fix it ;/ Windowed mode Solution doesn't work on 8.1
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #337074] Fri, 24 October 2014 00:12 Go to previous messageGo to next message
sevenfm

 
Messages:1186
Registered:December 2012
Location: Russia
Another windows 8 magic:
(from here, post 13)
make a new .reg file with notepad with the following content:
Windows Registry Editor Version 5.00 
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers] 
"C:\\games\\ja2\\ja2.exe"="~ DWM8And16BitMitigation Layer_ForceDirectDrawEmulation 8And16BitAggregateBlts" 

Note: change the path to your ja2 installation.

Run .reg file and apply changes.

Disable intro.

This should work without additional DLLs


Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #337096] Fri, 24 October 2014 13:21 Go to previous messageGo to next message
RoWa21

 
Messages:2046
Registered:October 2005
Location: Austria
Sevenfm
Another windows 8 magic:
(from here, post 13)
make a new .reg file with notepad with the following content:
Windows Registry Editor Version 5.00 
 
[HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers] 
"C:\\games\\ja2\\ja2.exe"="~ DWM8And16BitMitigation Layer_ForceDirectDrawEmulation 8And16BitAggregateBlts" 

Note: change the path to your ja2 installation.

Run .reg file and apply changes.

Disable intro.

This should work without additional DLLs


Thanks, I updated the "Windows 8 Fix.zip" file from the "Docs" folder to include the Registry-File.


Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #337103] Fri, 24 October 2014 15:21 Go to previous messageGo to next message
Zefurion

 
Messages:11
Registered:September 2012
I am afraid that this does not work, still got crashes on 8.1
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #337493] Sun, 02 November 2014 19:33 Go to previous messageGo to next message
falconsfury

 
Messages:16
Registered:March 2012
Having a freezing issue with windows 8 , windowed mode

http://www.ja-galaxy-forum.com/ubbthreads.php/topics/337417#Post337417
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #337520] Mon, 03 November 2014 16:27 Go to previous messageGo to next message
Zefurion

 
Messages:11
Registered:September 2012
Try use Win 95 instead of windows XP SP3 in preferences, for me it works, but it drops game speed a bit.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #338787 is a reply to message #337520] Wed, 07 January 2015 03:34 Go to previous messageGo to next message
ok3721
Messages:3
Registered:January 2015
I found one useful suggestion on the Chinese forum

Try set only one CPU working for Ja2.exe

I have tried playing for 2 hours and it seems working for me. I also got all other fixes as well (I am running on Win7 compatibility mode, WineD3D dlls and registry fix)

Here is tutorial for setting CPU (I just registered so cant put any web link, try google 'task manager processor affinity')
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #338830 is a reply to message #338787] Thu, 08 January 2015 21:46 Go to previous messageGo to next message
RoWa21

 
Messages:2046
Registered:October 2005
Location: Austria
thanks for the tip.


Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #338911 is a reply to message #338830] Sun, 11 January 2015 14:32 Go to previous messageGo to next message
RoWa21

 
Messages:2046
Registered:October 2005
Location: Austria
@all: I just updated the "Windows 8 Fix" inside the "Docs" folder for the Stable and Development GameDir with the additional fix (set ja2.exe processor affinity to only ONE CPU).


Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339486 is a reply to message #338911] Wed, 18 February 2015 02:27 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
OK... wow. I spent 16 hours trying different settings after upgrading to the 7609 build (prev was using the 4870 build on win8.1 w/o issues), before stumbling on this thread. happy

Frustrating when I couldn't get through the very first battle.

FYI "Windows 95" compatibility changes affinity to CPU0 automatically.

But I prefer XPSP3 compatibility and manual set to CPU1. Sound stutters a little but otherwise the game is stable.

Keeping fingers crossed.. happy

System info:

Dual GPU (tried manually setting to both, same issue)

The 8.1 freeze issue in combat (disappearing cursor) happened on BOTH my Samsung laptop with dual GPU (tried manually setting each one w/ no benefit), as well as on my Microsoft Surface Pro (w/ only Intel GPU)

So far I've been playing windowed (to be able to set processor affinity) @ 1920x1080 for an hour now and it hasn't locked up. Previous record before that was 2 minutes. Save at end of turn was only way I could make ANY forward progress.

Also, freeze happened sitting at Laptop building team of mercs before initial deployment so the issue is NOT limited to combat.

Also, each time it freezes I get an ambient.slf entry logged to one of the log files. Music stops playing after a while and then the game completely stops responding. (Prior to that after a freeze I can still use END/DEL to highlight merc view, but can't do anything else)

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339505 is a reply to message #339486] Wed, 18 February 2015 22:23 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
OK I made it 6 hours straight last night without any lockups or issues. Down with the flu bug so nothing else to do. happy

One other oddity.

I use Logitech G930 wireless headphones when playing. When this issue was happening, after JA2 would freeze, I would hit task manager and end task. The JA2.exe instance was fully gone. However if I restarted the game without restarting my laptop I'd get no sound. When I would go to sound properties I couldn't hit "Test" as Windows would say the sound device is locked by a different process. (??) With the G930 I could remove the USB wireless dongle and plug it back in to remove / re-add the sound driver. However when using stock onboard sound I had to restart the entire machine to get the deadlock cleared up on sound.

I think something with the sound engine is not playing well with multithreading in Windows 8.1.

Was the sound engine upgraded at some point after 4870? I played that version a LOT over the last couple of years with zero issues before upgrading to 7609 Monday, and experiencing these freezes. (A vehicle bug killed my savegame and halted forward progress in the old 4870 version about 50% through my last playthrough so I came on here looking for an upgrade.)

Also,

WOW holy crap have you guys added a lot of stuff since 4870!


It's like a whole new game now.

Much thanks for all the hard work you guys have put in over the years. happy

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339506 is a reply to message #339505] Wed, 18 February 2015 23:36 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
OK One other update.

Not all is well with single CPU.

I didn't realize it until I'd got some militia trained up, but there's a problem (at least on my system) with single CPU affinity turned on.

It breaks militia.

The game stutters and stalls when it's their turn to move. They move (at most) two squares in a jerky fashion (each militia unit), then their turn ends. It makes them completely ineffective in combat as they A. can't close to engage hostile forces and B. when they do, they don't DO anything (shoot, etc). They just stand there and get shot. angry

If I add a CPU (e.g. set affinity to CPU4&5, which is a core + hyperthreaded core), they go back to walking just fine.

Also "auto fast forward" breaks with single CPU. Add in another core and it functions properly again. (also sound issues caused by single CPU affinity quit happening.)

Tried clock speed 100/150 manually in INI file, no changes. Militia still staggers and stammers when it is their turn and single CPU affinity is set. Enemy still works but does not fast forward.

With two CPU's assigned (e.g. 0/1, 2/3, etc) the combat issues go away, militia work fine... but the game starts crashing again. (Couldn't even get an IMP team assembled in the laptop, it locked up as I was making the 4th merc.)

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339507 is a reply to message #339506] Thu, 19 February 2015 00:55 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
OK I just played 1.5 hours without any issues whatsoever, with all 8 CPU cores active on my machine, compatibility mode shut off (Win8.1 native)

But I did it after disabling sound drivers completely on my laptop.

It really sucks playing without sound but the game runs flawlessly on win8.1 with the sound driver disabled.

This 100% confirms that this is a sound engine issue in the game... introduced sometime after release 4870...
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339512 is a reply to message #339507] Thu, 19 February 2015 09:52 Go to previous messageGo to next message
silversurfer

 
Messages:2080
Registered:May 2009
Have you tried playing without music? Lowering music volume to 0 will turn music off. It may be worth a try just to see if it's the music system locking the game up.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13 %20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339523 is a reply to message #339512] Fri, 20 February 2015 03:56 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
Yes I tried with all three volumes turned all the way down when I first suspected sound issues (from that ambient.slf entry in the log files).

The game still crashed. (Oddly enough some sounds still played with all sliders at 0 - some reaction voices)

I removed WINE3D files, and with music on, and CPU affinity not set, still crashed. Oddly enough frame rates and everything were just fine - maybe even better - with Wine3D removed.

So I don't need wine anymore on Win8.1. I would view that as a plus if I wasn't having other problems. happy

I tried a newer version of Wine3D on windows thinking that the issue is a hiccup with directsound, but was unable to get the game to launch with the dx7/ddraw hex edit hack that the newer versions indicate. (from source sourceforge.net/projects/wined3d4win/files/ - can't post full URL as I don't yet have 10 posts on the forums)

The only way I can reliably get the game to play right now without glitching, is with sound drivers 100% disabled in Windows. The CPU affinity 'fix' works, as far as keeping the game stable, but breaks militia movements and auto fast forward, as well as making sounds stutter periodically.

[Updated on: Fri, 20 February 2015 03:56]

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339526 is a reply to message #339523] Fri, 20 February 2015 04:17 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
I'm trying something new right now.

20 minutes no hiccups. I noticed yesterday that under properties there is a "Windows 8" compatibility type. Giving it a try now with audio turned on.

I'll post again later.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339530 is a reply to message #339526] Fri, 20 February 2015 06:47 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
Well that went south fast. My upgrade to 7740 happened mid battle in my main save game. Turns out after I won that (drassen, huge fight), 10 minutes in to the strategic map and it crashes.

Same with a new game. After beating A9, 10 minutes in to the game on the strategic map it gives an assertion.

Posted details and link to save game / ini download in bugzilla.

I'll have to wait for the next update (hopefully with that assertion fixed) or revert to an older version to continue testing on Win8.1
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339687 is a reply to message #335812] Fri, 27 February 2015 04:53 Go to previous messageGo to next message
Nitem4re

 
Messages:12
Registered:April 2008
Location: America

Happening to me too, really annoying. Also on 8.1... the game just randomly freezes sometimes while the music keeps playing... been trying all kinds of compatibility settings without luck, only disabling the soundcard seems to help.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339745 is a reply to message #335812] Sat, 28 February 2015 19:53 Go to previous messageGo to next message
Nitem4re

 
Messages:12
Registered:April 2008
Location: America

Doens't happens with 6688, but it's present in 7435... something changed between this that triggers the freeze. I'm trying to debug but couldn't figure it out yet.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339749 is a reply to message #339745] Sat, 28 February 2015 20:59 Go to previous messageGo to next message
silversurfer

 
Messages:2080
Registered:May 2009
It would be great if you could find the source of the problem or even fix it. I can't even reproduce it as I don't have Windows 8.1.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13 %20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339766 is a reply to message #339749] Sun, 01 March 2015 03:15 Go to previous messageGo to next message
Buggler

 
Messages:210
Registered:November 2009
@Nitem4re

Assuming no knowledge of compiling Ja2.exes, here's how u could help in narrowing down e bug:
1. Clean original Ja2 installation in a new folder
(Ja2 is portable. Easy step if already backed up and then safely locked up Ja2 box in a time capsule.)

2. Download 1.13 SCI 7393 http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=20380&prevloaded=1&&start=0
(Do not use any revisions higher as there's changes that would not run without the new LUA script.)

3. Verify bug present in 7393 in Win8.1.
(Stop n reply if bug not present here.)

4. Download e 1.13 Builds from the same link above and test those revisions. Just need to extract the Ja2_XXXX.exe.
(Quickest way to narrow down is by verifying e revision right in between e working n bugged versions.)
E.g. 6688 (Working) /7393 (Bugged): verify ~7043. If 7043 working, 7043/7393: verify ~7218. If 7043 bugged, 6688/7043: ...

Would need ur response on what's e last working Ja2.exe and e first bugged Ja2.exe.



No savegame (just before e bug occurs), no cure.

'Not everything that counts can b counted, n not everything that can b counted counts' - Albert Einstein
I may answer/reply in my old public posts & prefer PM over e former [FUDforum's PM suxx]
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #339778 is a reply to message #339766] Sun, 01 March 2015 18:31 Go to previous messageGo to next message
Nitem4re

 
Messages:12
Registered:April 2008
Location: America

Didn't had time to check all the revisions, but the constant freezes goes away when you use one of the three optimized resolutions... doesn't matters if it's windowed/full-screen of if vsync settings are changed... Well at least I get to play now.

[Updated on: Sun, 01 March 2015 18:31]

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341065 is a reply to message #335812] Wed, 20 May 2015 03:29 Go to previous messageGo to next message
orexisx89
Messages:2
Registered:May 2015
I'm also having these issues, I've taken the steps listed here, and nothing so far has worked, windowed mode freezes as soon as I start (before even getting to Omerta) I've gone back and tested with version 7393 The error is still present. at the current I don't really have the bandwidth to keep going back further revisions though. The freezes for me only occur while in combat, I'm going to see if I can do a turn by turn save so that we will have a save uploaded from immediately before the freezing occurs (also have tried all optimized resolutions, have tried messing with other settings. The game is installed in a non write protected directory outside of Program files, I have the intro disabled, and have changed the registry entry.

(this testing came about because the latest version wasn't playing well)

it seems to me to that it might be an AI problem, the freeze still occurs for me with my sound drivers completely disabled, and the freezing only occurs during enemy or militia phases. I'll update as I try more options to fix the problem.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341070 is a reply to message #341065] Wed, 20 May 2015 09:44 Go to previous messageGo to next message
orexisx89
Messages:2
Registered:May 2015
Update: the previous Stable release 4870 does not have this problem, That leaves me a lot of revisions to sort through as I have time. I really want to play with the new features, etc. but what I'm thinking is take another machine Identical to this laptop, and setting up a test environment so that I can go through revision by revision (or if I was clever basically do a bisectional search until I find the first revision in which this bug occurs for me.

While I'm happy to be able to play on the older branch for now, I'd really like to help track this down and hopefully there will be a solution in the future that is better than what I've got to work with right now.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341409 is a reply to message #335812] Sat, 13 June 2015 08:51 Go to previous messageGo to next message
Phantom3D

 
Messages:13
Registered:June 2015
Hello, I am new here, but played since Deadly Games.
I am also having trouble with newest 1.13 and windows 8.1.
However, on my Lenovo Miix 3 10" pad, it runs flawlessly with sound! That is windows 8.1 with Bing.
On my Alienware M18 I get freezes or errors all the time (Not tried without sound, but I am guessing that would work).
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341486 is a reply to message #341409] Sat, 20 June 2015 22:10 Go to previous messageGo to next message
Phantom3D

 
Messages:13
Registered:June 2015
Update: It does not run flawlessly on my Miix 3 with win 8.1. I can usually only get to Omerta before it freezes and sound continues.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341607 is a reply to message #341486] Sun, 05 July 2015 19:13 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
Yeah I've tried the latest branch from 6/15 and .. same thing. Still freezes. Sound continues but UI is non-responsive. Couldn't even get through IMP character creation.

exited, saved, then tried creating one at a time, finally got a group of 4 IMP mercs put together. Started playing w/ save at end of each turn. Took 3 reloads to get through first combat.

Then moved to next omerta sector. Freeze while walking to talk to carlos.

Reload. Get to carlos, locks up while he's speaking.

It's 100% totally unplayable on Windows 8.1 still.

ETA: Which sucks, a lot, because I'm really jonesing for a JA2 game and the earlier version that works on win81 .. well, it doesn't have all the new snazzy features.

[Updated on: Sun, 05 July 2015 19:13]

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341608 is a reply to message #341607] Sun, 05 July 2015 19:23 Go to previous messageGo to next message
TrentL

 
Messages:68
Registered:February 2015
Location: United States
Also worth mentioning if you guys need help tracking down which version is bugged/not bugged, I'm moving soon and the new house will have 150mbps bandwidth (opposed to crap bandwidth where I am at now).

I should be able to help test and narrow it down.

You guys have a link to a post somewhere about compiling new exe's? What dev tools do you use?

I've been a C++ / .NET developer for 20 years now, with experience on multithreaded code in win32 api, if there's a way to attach a debugger and see something besides assembly, I might be able to help track it down.

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341609 is a reply to message #341608] Sun, 05 July 2015 22:02 Go to previous messageGo to next message
silversurfer

 
Messages:2080
Registered:May 2009
You can use this guide which covers the basics and should get you started.

I guess most coders use VS2008 or VS2010 but one could never be sure without asking around.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13 %20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #341922 is a reply to message #341609] Sat, 01 August 2015 15:30 Go to previous messageGo to next message
Phantom3D

 
Messages:13
Registered:June 2015
Ok, I think I bring good news towards Windows 10 with 7435 and update. I have played for a bit over 3 hours with no faults now.
I have talked to Miguel, Carlos, Ira, taken over the airport. Talked to several AIM members through the website.
I also loaded an old save from my windows 7 machine, and continued from there a bit, talking to NPC's and a few battles. No problems.

Here is how I got it running:

First I also got a black screen i fullscreen mode. Then I changed to windowed mode, and i changed the compability of ja2.exe:
Run in XP sp3 mode.
Reduced color 16 bit
Run as admin.

I also set win 98 compabitly mode to true in the INI editor. (Might not be needed).

Now I got in the game, but I kept getting "Assertion error" or something similar.
Then I added the three DLL files from the "win8 fix".
ddraw.dll, libwine.dll and wined3d.dll and put them in my JA2 directory.

Now it runs perfectly, both in windowed mode and in fullscreen.
Re: JA2 1.13 Windows 8.1 -- Consistent Freezes[message #344519 is a reply to message #341922] Sun, 13 March 2016 22:35 Go to previous messageGo to previous message
raecer

 
Messages:12
Registered:October 2008
I'm having the same trouble on windows 10. Intro will crash game in fullscreen mode. Game will run extremely slow in fullscreen.

The only thing that has worked for me is setting reduced color 16 bit and running it in windowed mode.

I did not need to set compatibility mode, the three DLL:s or running it as admin (this did not help fullscreen). Bare in mind however that i did not play for an extended amount of time. I only checked the fps i got.

Only problem now is... I don't really feel like playing it in windowed mode. Has anyone else discovered a fix?

[Updated on: Sun, 13 March 2016 22:38]

Previous Topic: LBE Bug "NADA"?
Next Topic: Graphical Glitch
Goto Forum:
  


Current Time: Tue May 23 13:52:59 EEST 2017

Total time taken to generate the page: 0.01205 seconds