Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » UC/DL 1.13 & AFS » UC1.13 Hybrid Problem (After selecting the options and starting the game, it crashes.)
UC1.13 Hybrid Problem[message #339863] Thu, 05 March 2015 19:02 Go to next message
Lexa92
Messages:1
Registered:March 2015
Hi guys,

I just installed fresh JA2, I applied SCI_Unstable_Revision_7763 patch (1.13), took the original UC data folder, renamed it Data-UC and placed it in the game folder.

Then I applied Urban_Chaos-1.13_v4.48_20140518. I launched INI Editor and chose vfs_config.UC113.ini and it launches the game perfectly fine, I can even change the settings, but when I try to start a new game it gives me an error and crashes the game.

Runtime Error
Press ESC to exit
File: F:\SVN\SVN_Source_Official\lua\lua_function.h
Line: 71
Function: LuaFunction:Call
Execution of lua function 'initNewGame' failed : [string "scripts\GameInit lua"]520: attempt to call global 'GetStartingCashExperienced' (a nil value).

This happens with every difficulty the 'GetStartingCash-' changes to Novice/Expert etc.

I don't know how to fix this. The regular 1.13 mod runs just fine without any errors.

If anyone has an answer to this it would be much appreciated. Thanks.

-Lexa

Re: UC1.13 Hybrid Problem[message #340782 is a reply to message #339863] Tue, 28 April 2015 21:17 Go to previous messageGo to next message
Labiel

 
Messages:5
Registered:September 2009
Location: Poland
Fixed the problem by copying GameInit.lua from Data-1.13
Re: UC1.13 Hybrid Problem[message #340842 is a reply to message #340782] Sun, 03 May 2015 00:02 Go to previous messageGo to next message
Wil473

 
Messages:2830
Registered:September 2004
Location: Canada
A little late, but I should ask why you are running v4.48? The mod was at v4.50 at the time of the opening post.



More weapon features and upgrade options, via (mis)use of v1.13 for vanilla Arulco, Dedrianna Lives! and Urban Chaos campaigns.


Re: UC1.13 Hybrid Problem[message #342508 is a reply to message #339863] Sun, 20 September 2015 21:36 Go to previous messageGo to next message
JA2UCplayer
Messages:2
Registered:September 2015
Hi guys,

I have the same problem, trying to play a new game of Urban Chaos. I have a fresh install, not played and followed the right installation guide of Urban Chaos. Everything works fine untill the intromovie has stopt. Runtime error same as above, and when i want to look for the file that is causing the problem or that is missing i cant find it anywere.

Please help me as i want to play this Urban Chaos mod badly. Im a big fan of Jagged Alliance.

Thanks in advance
Re: UC1.13 Hybrid Problem[message #342509 is a reply to message #340842] Sun, 20 September 2015 21:42 Go to previous messageGo to next message
JA2UCplayer
Messages:2
Registered:September 2015
Anyone has a solution for this problem ? I have the same problem. Fresh JA 2 install on a fresh windows xp. When the intro movie stops i get the same runtime error. Cant find this gameinit.lua file anywere or what it is. Please help me as i really wanna play this mod
Re: UC1.13 Hybrid Problem[message #342512 is a reply to message #342509] Mon, 21 September 2015 15:48 Go to previous messageGo to next message
svean

 
Messages:66
Registered:August 2005
@JA2UCplayer:
In general: try to reinstall game and mod following step by step instructions (including vanilla UC installation and folder renaming/moving).

My UC 1.13 is working well (on JA2 exe 7987) but sometimes killing specific people makes game to hang.
I think this might be connected with non-army enemies, because this happened to me with people like Sheriff in Calisto Factory (NPC) sector or in Subway sectors (unnamed Satan's Sons gang member).

Game just hangs when I kill such person and since I'm playing Iron Man this pissed me off, but killing enemies in different order, or partially (after killing some enemies I left sector and then came back to kill rest of them) allows to "get through" that bug.
This might be not a big issue (since it can be avoided), but it's still a bug.
Re: UC1.13 Hybrid Problem[message #346020 is a reply to message #342512] Mon, 27 June 2016 04:32 Go to previous messageGo to next message
Cerhio

 
Messages:103
Registered:March 2013
Hey guys, I'm having the exact same problem after trying to install the latest patch for UC113. I followed the directions to the dot but haven't been able to start a new game. I get the exact same message as OP. I'm running Windows 7 64bit. Please help me out, I really want to play the game.
Thanks in advance!
Re: UC1.13 Hybrid Problem[message #346841 is a reply to message #346020] Fri, 09 September 2016 11:58 Go to previous messageGo to next message
Panzer

 
Messages:82
Registered:February 2016
Location: Altis, Sometimes Tanoa
Same as the above. Stable Version.
anyone know to where he copied the GameInit.Lua He says he copied it and fixed it, but to where, same folder, do I overwrite?
Edit. NVM turns out I was using the UC113 mod, rather than the 2014stable UC113.

[Updated on: Fri, 09 September 2016 12:58]




I have no Wife, Children, or real Job. This also means I have 24 hours a day and 7 days a week to think of a rebuttal. You have been warned.

"I got another problem: I am being overrun by Dinosaur Nazis on Hoverboards!" -Ravenhugger

"Before you judge a man, walk a mile in his shoes. After that who cares? He's a mile away - and you've got his shoes!" - Unknown Criminal
Re: UC1.13 Hybrid Problem[message #346949 is a reply to message #339863] Sun, 18 September 2016 02:57 Go to previous messageGo to next message
Cerhio

 
Messages:103
Registered:March 2013
Okay so the solution to this issue is copying GameInit.lua from Data-1.13/Scripts to Data-UC113/Data-Stable2014/Scripts.

Re: UC1.13 Hybrid Problem[message #346963 is a reply to message #346949] Sun, 18 September 2016 22:47 Go to previous message
wolf00

 
Messages:1148
Registered:September 2006
Location: Czech Republic

svn 2270/exe 7974 & urban chaos full experimental 3 v4.6x . first you directory with your ja2,secon step is copy sci in directory,next step is copy of vanila urban chaos data directory,last step is add files required for urban chaos 1.13 .this working for me,i dont have any error mesages at start ...



caliber's: .41Lc,.45Lc,.455british,.380[9x17].410 . not in game at this time ...Dr Zelenka can help you ;o}R.M SgAmb asrock a75m amd x6 3670be 4gb ram hdd 1tbb sgt,zvuk creative x-fi extreme audio case z-7
Previous Topic: Changing Merc Relations?
Next Topic: POW's
Goto Forum:
  


Current Time: Tue Aug 21 05:53:12 EEST 2018

Total time taken to generate the page: 0.01636 seconds