Home » MODDING HQ 1.13 » v1.13 Bug Reports » Bugs: Unofficial releases (SCI's), unstable and DEV builds (Read the first post before posting!)
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353124 is a reply to message #353123] Fri, 13 April 2018 19:00 Go to previous messageGo to next message
edmortimer

 
Messages:1062
Registered:January 2015
Location: Home Free
Quote:
Yes, since Flugente fixed it in GameDir 2419.


Sorry, I was looking at the ancient r7609 - I didn't realize someone had removed it since then.




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353150 is a reply to message #353124] Sun, 15 April 2018 16:33 Go to previous messageGo to next message
Flugente

 
Messages:3387
Registered:April 2009
Location: Germany
While finishing something else, I stumbled upon a minor but very confusing bug. If one uses a release exe without debug info, when we first see a member of the creature team, their colour pin on the radar/overhead map will not be shown in the correct colour. If one then saves while seeing the creature and reloads the save, the colours are fixed. As this only happens in release builds, this is naturally a bitch to track.

https://i.imgur.com/NyFdihG.png

On the right side is a situation with the stock colours. On the left is the situation after replacing the normal pin (RGB values: 255/0/255) with another pin from the sti file (RGB values: 206/0/206).

The issue seems tied to the colour pink itself. RGB values of 248/0/248 show the same behaviour, 247/0/247 works fine.

I am naturally baffled by this - as this works when we start the exe and load a savefile where we already see a creature, it doesn't seem to be a case of a non-initialized variable. At the same time, we don't store map pin colours on soldiers, so... the only thing left would be to dive deep into our obscure undocumented assembler draw functions, which I loathe to do. I am unaware of this ever being reported previously, so perhaps this is also a Win 10 issue? Or a VS2017 issue? No idea.

As a fix, as of r8553, I'm now simply changing the pin colours to values that work.

[Updated on: Sun, 15 April 2018 16:35]




“What are you doing?” Joffrey interrupted him.

“… can’t a man give a few last words for his son to carry?”

“…Who told you your son was making it out of this field alive?”

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353151 is a reply to message #353150] Sun, 15 April 2018 16:36 Go to previous messageGo to next message
Flugente

 
Messages:3387
Registered:April 2009
Location: Germany
Due to morale calculation somehow leaving them abolutely hopeless (or no calculation happening at all), zombies rarely ever moved, which is suboptimal for a melee-only class. As of r8552, they are always fearless.



“What are you doing?” Joffrey interrupted him.

“… can’t a man give a few last words for his son to carry?”

“…Who told you your son was making it out of this field alive?”

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353159 is a reply to message #353151] Sun, 15 April 2018 21:55 Go to previous messageGo to next message
Jolly_Reaper

 
Messages:47
Registered:August 2002
Location: The Netherlands

I'm spell-checking the various .xml files and came across this:

	<BACKGROUND>
		<uiIndex>4</uiIndex>
		<szName>Mercenary/Car Mechanic</szName>
		<szShortName>Mercenary/Mechanic</szShortName>
		<szDescription>Working day and night in her car repair shop when she's
not travelling around the world, Vicky is a very versed mechanic.
But she never overcame her fear of confined spaces.</szDescription>
		<ap_assault>3</ap_assault>
		<ap_height>-8</ap_height>
		<ap_urban>3</ap_urban>
		<ap_airdrop>-10</ap_airdrop>
		<ap_fortify>-2</ap_fortify>
		<travel_car>10</travel_car>
		<resistance_suppression>7</resistance_suppression>
		<disarm_trap>5</disarm_trap>
		<capitulation>10</capitulation>
		<sleep>-1</sleep>
		<no_male>1</no_male>
		<no_female>1</no_female>
	</BACKGROUND>


It initially said "fear of heights", so I changed that. But I'd love to know if <ap_height>-8</ap_height> should be replaced with something claustrophobia-related or simply be removed.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353160 is a reply to message #353159] Sun, 15 April 2018 22:51 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Thank you. I changed the text and removed the ap_height and ap_airdrop tags in GameDir 2421.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353332 is a reply to message #353160] Wed, 25 April 2018 10:47 Go to previous messageGo to next message
Reffy

 
Messages:14
Registered:August 2011
I have a weird bug regarding training militia.

I just started a new game and I've cleared Drassen airport. I want to train militia in there, but when I click on that option it says: "Drassen is full of militia" Even though there isn't any militia there at all.
What's also weird is that I can't move my squad in the map screen. It says the sector is hostile, even though there isn't anyone there. I even checked with cheats and there are no hostiles.

Do I have to clear ALL of Drassen before I can train militia? I didn't had to do that before.

Using build 8545.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353334 is a reply to message #353332] Wed, 25 April 2018 11:37 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Reffy wrote on Wed, 25 April 2018 09:47

I just started a new game and I've cleared Drassen airport. I want to train militia in there, but when I click on that option it says: "Drassen is full of militia" Even though there isn't any militia there at all.
What's also weird is that I can't move my squad in the map screen. It says the sector is hostile, even though there isn't anyone there. I even checked with cheats and there are no hostiles.

Do I have to clear ALL of Drassen before I can train militia? I didn't had to do that before.

Drassen airport has an A.C.A building so you can train militia there as soon as you have this sector and a merc capable of training militia. I just tested it in a clean 1.13 install and it worked fine.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353341 is a reply to message #353334] Fri, 27 April 2018 10:16 Go to previous messageGo to next message
Reffy

 
Messages:14
Registered:August 2011
silversurfer wrote on Wed, 25 April 2018 10:37
Drassen airport has an A.C.A building so you can train militia there as soon as you have this sector and a merc capable of training militia. I just tested it in a clean 1.13 install and it worked fine.


I think I messed up something.
I'm using the 8548 sci build, but had used the 8555 exe. I also used cheats (to kill every enemy in a sector). I later played with the 8548 exe, but the problem still persists.

Currently I have mercs capable of training militia, but the message says it's full and the sector is hostile (even though it isn't).
What's going on here? Or should I just start a new game?
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353343 is a reply to message #353341] Fri, 27 April 2018 11:16 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
I don't know what's going on in your game. Best use the latest SCI and start a new game.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353344 is a reply to message #353343] Fri, 27 April 2018 12:48 Go to previous messageGo to next message
shady lady
Messages:2
Registered:April 2018
Location: SE Asia
Hi, I'm having the same problem. Playing the latest SCI 8555/2420 (shows 8554 on screen?).I've cleared B13-Drassen Airfield, D13-Drassen Mine, H8-Cambria Mine and I8 Central SAM site. I can't train militia because the sectors are full of militia already (but they're not) and I can't move my mercs in tactical because all of these sectors are hostile (but they aren't). All help, advice, suggestions welcome. Saved games are available if required. Thank you.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353345 is a reply to message #353344] Fri, 27 April 2018 23:13 Go to previous messageGo to next message
Jolly_Reaper

 
Messages:47
Registered:August 2002
Location: The Netherlands

I had the same problem a few times. After killing all enemies in a sector the game would still think there are more enemies.
What I do is leave the map and immediately come back (travel and cancel travel, no need to load another map). When I do that, there are more enemies to kill, and after that it's cleared. Maybe that works for you as well.

I think the game has real trouble handling reinforcements/invasions when there are too many enemies involved. Apart from the above problem I also have some game crashes when enemies invade and see me upon entering.



On a different note: Bloodcats sometimes seem really uninterested in attacking me. (8548.)
In my current playthrough I pretty much cleared the bloodcat den without any of them attacking me. I was just picking them off left and right as they were standing around. Same for a few random encounters.
If there's an option to change their behaviour so they really go after your blood, then I'd definitely go for it.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353346 is a reply to message #353345] Sat, 28 April 2018 00:24 Go to previous messageGo to next message
townltu

 
Messages:219
Registered:December 2017
Location: here
If these "ghosts" are tied to too many enemies, 28 are already too many with enemies etc set to a max of 32 each in taxtical,
as i recently got 8 icons remaing although all of the 28 listed soldiers had been killed
(scout in team saw no dots in adjacent sectors, also no reinforcements allowed, nevertheless also frequencies jammed)

On the other side i also had zero enemy icons on strategic map and still iirc 8 enemies present in sector.

Another occasion where the game fails to count, probably not connected to above bug,
is frequently in the battle reports, since long,
most obvious in high numbers(3 digit) of civilians, although no civs in sector,
apparently caused by disguised mercs,
btw despite rarely losing disguise, which would explain it if new diguise counts as new civ.
Additionally sometimes i see 1 or more wounded soldiers in the report although none escaped into another sector.


Note this happend with sci r8517, like also in perhaps related bug posted here.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353355 is a reply to message #353346] Fri, 04 May 2018 22:37 Go to previous messageGo to next message
townltu

 
Messages:219
Registered:December 2017
Location: here
Not sure whether bug of feature,
just noticed that Barrys morale went down from drinking,
confirmed to be valid also for other mercs.

Morale starts to drop with the 2nd canteen, appears to be not linear or perhaps random,
but multiple canteens will eventually bring it dowm to near zero.

Should be quickly reproduceable by running with ammo crate etc,
but will upld save if desired.

Note it happens with SCI r8517, but the last SCIs log shows no related entries since 8517,
and full search for canteen, drink or morale showed no hits,
so i saw no reason to finally complete the install of latest SCI and confirm that it also happens there.


If its intended to work that way for whatever reason,
take this as an objection as it also affects normal gameplay.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353359 is a reply to message #353355] Sat, 05 May 2018 11:24 Go to previous messageGo to next message
Taleman

 
Messages:43
Registered:October 2010
Location: Finland
What I remember from Vanilla JA2, drinking lowered morale when sobering up. So I believe it has always been like that.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353360 is a reply to message #353345] Sat, 05 May 2018 12:43 Go to previous messageGo to next message
shady lady
Messages:2
Registered:April 2018
Location: SE Asia
Hi Jolly Reaper, thanks for the advice. I think it's a zombie problem. I've won a few battles by taking all of the enemy prisoner (so no-one dies) and everything's ok. I can train militia etc. Now I've turned zombies off and there's no problem anymore (except I like playing the game with zombies allowed). Sorry I can't help you with your Bloodcat problem, I've never experienced that. I usually mow them down from the comfort of my Hum-Vee big grin
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353361 is a reply to message #353359] Sat, 05 May 2018 13:50 Go to previous messageGo to next message
townltu

 
Messages:219
Registered:December 2017
Location: here
Taleman wrote on Sat, 05 May 2018 11:24
What I remember from Vanilla JA2, drinking lowered morale when sobering up. So I believe it has always been like that.

Checks in a runing game of an 7609 + AV install
and a new game in same sci r8517 install confirmed that morale drop from much drinking does not happen by default.

My r8517 install appears to be ok,
comparing files date/size/unique_existance with a new r8517 install
revealed only files of which i am aware that they were changed, in particular the usual .ini files
and all the .sti files that were added during portrait tests.
None of those i can imagine to be realted in any way to morale loss.

On a side note, during the drinking_affects_morale_check of new game in existing r8517 install,
when entering a sector i noticed Iras portrait popped up and the text window contained a message of my imp,
later she got the text of Razor i nanother sector.
(no idea which soundfile was played or any at all, clicked too fast;)


Note i had temporarily changed eye&mouth coords in mercprofiles.xml,
and i am not sure whether i may have accidentially continued normal gaming
while y/x coords of Manuel where all still changed to zero.


tldr:
Bug is gone on new game in same install,
will keep an eye on it whether its reproduceable in future when using untouched installs
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353365 is a reply to message #351701] Sat, 05 May 2018 20:35 Go to previous messageGo to next message
melm
Messages:2
Registered:May 2018
foo23 wrote on Tue, 05 December 2017 21:02
I found a bug, using SCI revision 8508 on GameDir 2399

If someone is prone and takes enough suppression to cower in fear, they stand up. I don't mind so much when it happens to the enemy, but when it happens to my guys, well



Uriens wrote on Mon, 18 December 2017 12:09
There seems to be a bug with suppression. When a prone suppressed unit gets suppressed again it stands up. Sometimes it just stands, sometimes it will run a standing reload animation halfway making screen fixed on it. Since it never finishes that animation it will keep the screen centered on it until that unit can move again or you somehow manage to shoot/suppress it again. This sometimes leads to enemy preventing you from moving your mercs (you cant see or move because screen is always snapping to bugged unit) and forcing you end turn/reload game.
I'm guessing this is a problem with animations themselves but units that are already prone and suprressed should stay prone on any additional suppression.
The most easiest way to reproduce this is to play with AIMNAS since it has increased suppression values.


This bug is still present in the latest (8558 on 2422) SCI, and at least as far back as 8506 on 2398. I vaguely remember something similar happening when I first played 1.13 in 2012, but I might be imagining it. Very easy to reproduce by simply turning suppression effectiveness way up and forcing an enemy to cower.

edit: The bug is NOT present in 8488 on 2391. Maybe it has something to do with the new animations that were added shortly later?

[Updated on: Sat, 05 May 2018 21:54]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353369 is a reply to message #353360] Sun, 06 May 2018 13:10 Go to previous messageGo to next message
Jolly_Reaper

 
Messages:47
Registered:August 2002
Location: The Netherlands

8548: Second playthrough: Carmen disappeared again after giving him the last head and thus completing the quest.
It's like there's some script that removes him from the game world after the quest is done, so he doesn't get the chance to stick around and give you your money a few days later. I'm obviously just making assumptions here, I don't know what's going on, but maybe someone wants to take a look.

8548: I found this one by accident. If you place a merc all the way to the right side of the tactical map and try to change his/her job (like practice marksmanship) the game will crash, presumably because it can't fit the pop-up windows inside the screen.

shady lady wrote on Sat, 05 May 2018 11:43
Sorry I can't help you with your Bloodcat problem, I've never experienced that. I usually mow them down from the comfort of my Hum-Vee big grin

I didn't expected you to, I'm just reporting it here in case one of the devs wants to take a look. happy Also, nice tactic. big grin
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353398 is a reply to message #353369] Wed, 09 May 2018 15:59 Go to previous messageGo to next message
Penta

 
Messages:54
Registered:May 2008
OK, this is starting to bug me.

Before I go on, note that I have a Dell Desktop running win 8.1. I can provide further specs if needed, but suffice to say, 1.13 should have no problems with responsiveness and, prior to 8558, has not had problems.

Anyway. So, I did a full uninstall, full reinstall of JA2 Gold from GoG into C:/Jagged Alliance 2, SCI of 8558. Modded ini files to taste, but nothing that should remotely impact performance - literally just copying changed sections from older ini files used with 8548 and 8555 to the new ini files.

8548 ran *fine* on this machine, smooth as silk. 8555 ran *fine* on my Win 10 laptop that I use while traveling. 8558, well. It runs slow as molasses on this desktop, which is my primary machine at home. The game takes up to a second or two to respond to my inputs, dialogue interfaces (say for Fatima) take seconds to load, etc. It's noticable on the main menu screen, even, the cursor moves veeeerry

What the heck changed to make performance so slow?
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353571 is a reply to message #352713] Wed, 23 May 2018 17:35 Go to previous messageGo to next message
UBAH

 
Messages:17
Registered:October 2007
3iff wrote on Tue, 20 March 2018 14:07


file "BATTLESNDS\bad0_hit.wav" does not exist



i think i know the reason. correct names of this files are bad*_hit*.wav, not bad*_hit.wav (bad0_hit1.wav, bad0_hit2.wav, bad1_hit1.wav etc) thats why game cannot find this files and enemy keep silent when our bullet hits him (at least in my game - version 8560 on gamedir 2424 - i have same messages in the log and cannot hear wounded enemyes)

[Updated on: Wed, 23 May 2018 17:36]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353599 is a reply to message #352682] Sun, 27 May 2018 19:38 Go to previous messageGo to next message
UBAH

 
Messages:17
Registered:October 2007
3iff wrote on Tue, 13 March 2018 14:15
I can confirm the fix for the log overwriting the bottom of a mercs inventory on low res is now fixed. Many Thanks.



Still observing this trouble in version 8560 on gamedir 2424 on resolution 1280x720. On resolution 800x600 all OK.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353673 is a reply to message #353599] Sun, 03 June 2018 20:17 Go to previous messageGo to next message
Penta

 
Messages:54
Registered:May 2008
Fatal error when trying to load 8566 on gamedir 2424:

JA2 Fatal Error is the title of dialog box. Contents:

================ Sun Jun 03 13:13:32 2018 =========================
File: ..\src\Core\vfs_init.cpp
Line: 286
Location: vfs_init::initVirtualFileSystem

Could not initialize library [ Data\Binarydata.slf ] in : profile [ SLF libs ], path [ Data\Binarydata.slf ]
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353674 is a reply to message #353673] Sun, 03 June 2018 21:09 Go to previous messageGo to next message
silversurfer

 
Messages:2312
Registered:May 2009
Penta wrote on Sun, 03 June 2018 19:17
Fatal error when trying to load 8566 on gamedir 2424:

JA2 Fatal Error is the title of dialog box. Contents:

================ Sun Jun 03 13:13:32 2018 =========================
File: ..\src\Core\vfs_init.cpp
Line: 286
Location: vfs_init::initVirtualFileSystem

Could not initialize library [ Data\Binarydata.slf ] in : profile [ SLF libs ], path [ Data\Binarydata.slf ]

Seems like a problem with your installation to me. Build 8566 starts just fine on GameDir 2424 for me. Check that all files are there and that JA2.ini and its corresponding vfs_config have the correct entries.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353679 is a reply to message #353674] Mon, 04 June 2018 17:22 Go to previous messageGo to next message
Penta

 
Messages:54
Registered:May 2008
Uninstalling completely and reinstalling appeared to fix it. It still runs very slow in terms of responding to cursor activity, however.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353884 is a reply to message #353679] Mon, 25 June 2018 21:51 Go to previous messageGo to next message
townltu

 
Messages:219
Registered:December 2017
Location: here
Typo on RIS "about us" page,
in last section, its reads " Note that you will reveive less Intel if outside ... "


Not 100% sure if latest version,
noticed in YT LP which apparently less than 24h ago switched from 7609 to last build.

[Updated on: Mon, 25 June 2018 21:51]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353912 is a reply to message #341931] Sat, 30 June 2018 07:58 Go to previous messageGo to next message
NIWIADGaming
Messages:3
Registered:June 2018

Hello guys,

well, my first so I'm sorry if it's not exactly according to what is necessary.

I'm using SCI build 8573 (Gamedir 2426, do not know if this is relevant), and somebody (do not know who it is in this community, but at YouTube he goes by the name Klaus Niemand) has spotted something awry on my gameplay videos on YouTube and commented that it indeed looked like a bug. After giving it some thought, I convinced myself I would not die by posting it here.
I do not have the savegame as I did not think about posting it at the time, but I'll give the description of the bug and the link for the video on youtube where you can spot it happening.

Drassen, low retaliation attack to sector C13 (Bar and Doreen's workshop). After defending that part of town for some time, two enemies kinda looked like they had surrendered (they were in cowered crouched position and surronded in a funny way by some gluey militia). After killing all the other enemies in the map, only those two were left. After realising I could not imprison them (I had never tried that mechanic before), I decided to just kill them outright. Right after doing so, everybody got up and the sector was clear, apparently, but the battle music never stopped. When I went back to the management screen, the battle music was still going on and the sector had those red squares indicating combat in the area. The auto-combat screen poped-up, only for showing no enemies at all. I clicked auto-resolve, and was instantly teleported back down to the map, but no combat happened, all was good. When I came back to management screen, the red squares on the sector had disappeared, but not the combat song. Luckly, I thought about saving at that moment, and after some small talk, I ended the recording. Now, offscreen, I thought to myself it would be interesting to manage my squad's equipement, but as soon as I clicked the inventory on the sector, the game crashed.
I was able to load the savegame and try to reproduce the bug again, but now, everything was fine, the game did not crash and I moved on.

And well... apparently I cannot post links until I have posted more than 5 messages, so I cannot send the YouTube link.
If you think it would be interesting to see the recording of part of the bug (Only the part before the crash), search for "NIWIADGaming" on Youtube and see the video titled "Jagged Alliance 2 [Down With The Queen of No Hearts] - Episode 3 (Adressing Drassen)". It is right at the end of it, 1 minute before ending (2:14:00 is a good time to begin).

I am sorry I could not be of more help with this bug, I did not think about posting or reserving the savegame. I'll try doing that next time (And there may be one, cause I got myself able to reproduce a TNT activation bug repeatedly)

Anyway, thanks for the amazing mod and for still making this game be kicking awesomely after so much time!



For Jagged Allaince 2 and other games gameplays, access my YouTube channel!
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353914 is a reply to message #353912] Sat, 30 June 2018 15:32 Go to previous messageGo to next message
townltu

 
Messages:219
Registered:December 2017
Location: here
Hello and welcome NIWIADGaming!


Link to video, at ~ 1h36m the game also appears to "behave" weird
by zooming into tatical without recognizeable reason.

Iirc also in same vid the game confuses message and related portrait,
i.e. Iras portrait is shown but Igors txt "All enemies have been defeated and disgraced" pops up and the game plays his audio file.
That bug occured here occasionally with 8517 as the last release i played, perhaps also earlier releases,
but it always only a single instance and then disappeared, until it reoccured on next rare occasion.



Combat not ending correctly sounds similar to bugs I reported here,
and a perhaps a bit far off here & here mentioned as "2nd bug" in messages 3rd section
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353915 is a reply to message #353914] Sat, 30 June 2018 17:15 Go to previous messageGo to next message
NIWIADGaming
Messages:3
Registered:June 2018

Thanks for posting the video link and giving more information about the other bug at 1:36:00, I had completely forgotten about it!

About the portrait thing. It happens to me very often, generally with Ira repeating what a mercenary said after clearing a map from enemies in tactical mode (i.e. if Igor says "All enemies are defeated and disgraced", Ira's portrait will popup after his with the same text, but without sound). You can pretty much see this happening on all my videos after resolving a combat on tactical mode.



For Jagged Allaince 2 and other games gameplays, access my YouTube channel!
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353917 is a reply to message #353915] Sun, 01 July 2018 03:10 Go to previous messageGo to next message
NIWIADGaming
Messages:3
Registered:June 2018

So guys, I've got a savegame here that well... sometimes cause a crash if you follow exactly what I did:

(I've just conquered the SAM site near Drassen)
- Go to tactical screen
- Get the TNT to Dimitri's hand
- Arm it for any amount of turns (I've tested with 2 and 4, and it crashes anyway)
- Close the tactical inventory Screen
- Voilà, it crashes as the screenshot shows
Edit: So, further investigation has led me to conclude that the trigger for the bug is to close the tactical inventory screen with the activated TNT on Dimitri's hand. The bug will not happen if the TNT is thrown or put on the floor if the inventory screen is open and it will also not happen if the TNT is not activated on Dimitri's hand.

I have a screenshot, but I still cannot use links, so... welp
The crash says:
"Asserting failure [Line 10838 in file items.cpp]. Attempting to do a debug save as SaveGame247.sav (this may fail)
GetRateOfFireBonus would crash"

if anyone wants the savegame that can reproduce this crash, please send me an email on niwiadgaming@gmail.com

I'm using SCI build 8573 (Gamedir 2426, still do not know if this is relevant)
No other mods

I hope this helps!

[Updated on: Sun, 01 July 2018 04:51]




For Jagged Allaince 2 and other games gameplays, access my YouTube channel!
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #353993 is a reply to message #353917] Wed, 11 July 2018 13:51 Go to previous messageGo to next message
Neitronus

 
Messages:30
Registered:October 2014
I need some help with providing information about one bug. Thing is, it's floating, so i'm not sure i'm able to describe a stable way to reproduce it, it occurs randomly for me. All those occasions do actually have some things in common: All of them appear on modded maps (Wildfire 6.07, Arulco Revisited) with modded itemsets (AIMNAS, AFS) and any conbination of themm (WF + AIMNAS, WF + AFS, AR + AIMNAS, AR + AFS). Thing is that game freezes unresponsively after me trying to end my turn in tactical (Usually, aproximately 95%+ chance, is that this happens on the end of my 3rd turn). Also it's important to notice that it works for sectors with possible enemy reinforcements and without them (tried to capture SAM near Drassen while no patrols nearby, still got that crash several times). There's a workaround however: It seems like attacking this exact sector at some other time (like 1 ingame hour later) solves the problem sometimes. Please, anybody who have any idea to what this might be relevant, please ask me for some specific additional info, because it's jut I have no idea what's important and what's not. I'm pretty sure that i messed something up while adapting mods, but still, where else would i go with bug this unstable? (Win7-10 compatibility patches applied, no use)

P.S. Sorry for my english, it's not my native, but third language.

[Updated on: Wed, 11 July 2018 14:53]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #354006 is a reply to message #353993] Fri, 13 July 2018 12:01 Go to previous message
General_Chaos
Messages:4
Registered:July 2018
Hello everyone!

I have a bug in my v.8517 (WinXP x86). May be it is already fixed in current versions, but, anyway... I have a well-progressed campaign, with many liberated cities, crowds of militia and about 11 000 moneys of daily expenses. I decided to start a new game, and, well, I get the same 11 000 of daily expenses at day 1, with 0 militias, 0 mercs, 0 anything. I 've found that the problem is localized in Quicksave file - when I remove it from the SaveGames folder, I can start a new campaign normally, with 0 expenses. It is just a minor issue, but I want you to know about it.
Previous Topic: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update
Goto Forum:
  


Current Time: Thu Aug 16 14:46:04 EEST 2018

Total time taken to generate the page: 0.02388 seconds