Home » MODDING HQ 1.13 » v1.13 Bug Reports » IMP losing Energy (Bug Hunting)
IMP losing Energy[message #343434] Thu, 10 December 2015 15:02
edmortimer

 
Messages:1190
Registered:January 2015
Location: Home Free
I've run into a hard to track down bug in my modding that causes IMPs to lose Energy inordinately fast -- even when doing nothing. I wonder if anyone else has run into this problem, so I am posting this. Hired Mercs are normal, no problem. But IMPs use a lot more energy than they should. I can't run them from one end of a map to the other, unencumbered, without them falling over exhausted. In battle, they fall over exhausted while recruited characters are still 75-80% -- without doing anything different than the recruited characters

In trying to figure this out I have another question: why, in MercProfiles.XML do IMPs have the following attributes set at a number that is not zero or minus 1?

<bLifeMax>15</bLifeMax>
<bLife>15</bLife>
<bStrength>1</bStrength>
<bAgility>1</bAgility>
<bDexterity>1</bDexterity>
<bWisdom>1</bWisdom>
<bMarksmanship>0</bMarksmanship>
<bExplosive>0</bExplosive>
<bLeadership>1</bLeadership>
<bMedical>0</bMedical>
<bMechanical>0</bMechanical>
<bExpLevel>1</bExpLevel>
<bEvolution>0</bEvolution>


Any help will be appreciated.

Edit: I should point out that the IMPs have had Health & Strength of 75-81 in all tests, and are not otherwise different than IMPs I've made in the past. I've even made test IMPs with Athletics, Bodybuilding, Melee & Hand-to-Hand that suffer the same fate.

[Updated on: Thu, 10 December 2015 15:10]





Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Previous Topic: Hiring Mike instantly
Next Topic: LAW. out of range
Goto Forum:
  


Current Time: Mon Feb 18 04:24:14 EET 2019

Total time taken to generate the page: 0.00882 seconds