Home » PLAYER'S HQ 1.13 » v1.13 Solutions,Tips & Spoilers » My savegame just got corrupted and I don't know why
My savegame just got corrupted and I don't know why[message #345682] Thu, 26 May 2016 02:29 Go to next message
gimmehints

 
Messages:140
Registered:May 2016
Hi! (Release 7435: 25 October, 2014 (Build: 7609), windows vista laptop)

I've been playing an experienced game for a good while now, and have conquered drassen, chitzena and cambria. After a counterattack on the cambria SAM I carefully took out ~50 enemies in there, then saved. I did a bunch of maintenance, set people to repair and train milita, sold all excess stuff to locals, then saved again.

I was going to ferry maddog to my drassen stash (so he, dynamo and shank could airdrop ammo etc whereever needed), but suddenly dynamo (who was hanging out in drassen repairing things) died! No attack, no wounds, nothing, he just suddenly died. So I reloaded and tried again. This time Monks contract suddenly runs out despite having 26 days left, so I reloaded again. This time, the heli didnt even reach maddog, but the game crashes with a runtime error or something.

Now when I try to reload the save is corrupted! I got a backup save pre-SAM attack, but I don't want to slog through it again. Is this a known issue, and can it be prevented? I was very happy I didn't get any more crashes when fighting with milita in the same sector, but this sucks and I'm not too keen on playing on if that sort of thing can be expected to happen.

edit: if it matters, it was the quicksave slot. Tell me to add any info that might be important!

edit 2: I decided to re-tackle the SAM site and do away with the ruined save. For the record, I'm not running any mods besides that version of 1.13, and have no outrageous edits. I only used the INI editor, and have not messed with any other files besides that primary INI. No outrageous settings, I have a max IMP count (although I'm only using 5 or 6) and team size of 10, that's about it. Both of those settings have worked fine so far. My team count is 22.

edit 3: it worked this time, no strange behavior post SAM site. Still, probably the most disturbing bug I have seen to date.

edit 4: while I'm here - *one* strange thing is going on: for some reason, there are items I can't access in the sector inventory in drassen airport. These include gear left behind by someone I hired and fired (after 2 days). I've looked around the map, but I can't even find the stuff. Merging and stacking doesnt help.

[Updated on: Thu, 26 May 2016 10:27]

Re: My savegame just got corrupted and I don't know why[message #345685 is a reply to message #345682] Thu, 26 May 2016 12:41 Go to previous messageGo to next message
sevenfm

 
Messages:1169
Registered:December 2012
Location: Russia
Corrupted saves are usually result of conflict with antivirus software - disable monitoring of your ja2 folder.
Usually quicksaves are corrupted, as far as I know.
Don't rely on quicksaves only, always save game progress to different slot after every important battle or periodically.
Enable autosave each N hours in options, this can help.
Save corrupting should not happen in 1.13 normally, it's rarely reported issue.
I never had save corrupting issue on my ja2 1.13 7609 or any other version since I disabled antivirus check for my ja2 folder.
The bad thing - if the save you are using is already broken in some way - it's unknown if it will work well in the future if some important data is changed.



Stable 7609+fix (14.09.2016)
Stable 7609+AI (r381 29.01.2017)
Improved weapon sounds
Youtube channel


Re: My savegame just got corrupted and I don't know why[message #345697 is a reply to message #345685] Thu, 26 May 2016 23:16 Go to previous message
gimmehints

 
Messages:140
Registered:May 2016
Thanks! I am using the autosave feature already, and had a strategic map save just before entering the SAM site, which I've continued a couple of weeks now without further problems (the unreachable item thing was there before the corruption, and while it's unsolved still it's not a huge problem).

I excluded the JA2 directory from my AVS and hope things like this won't reoccur.
Previous Topic: Right click menu weirdness.
Next Topic: Can't find the entrance to the lower levels of Alma mine
Goto Forum:
  


Current Time: Sun Mar 26 16:06:33 EEST 2017

Total time taken to generate the page: 0.00797 seconds