Home » MODDING HQ 1.13 » v1.13 General Development Talk » Which 1.13 to install?
Which 1.13 to install?[message #347144] Mon, 03 October 2016 15:24 Go to next message
wpmaura
Messages:5
Registered:January 2016
I found the links for 1.13, is 8301 the latest build? I get it to boot up create a merc, but when I go to choose more mercs from aim, it locks up.
Re: Which 1.13 to install?[message #348127 is a reply to message #347144] Sat, 07 January 2017 11:52 Go to previous messageGo to next message
Rambo919

 
Messages:15
Registered:July 2012
Location: South Africa
Last time I checked the wiki said "next version: 2015"....
Somewhere someone might have forgotten about stable builds completely.

I'd suggest that if the latest build is horrible for you try one a few months earlier and see what happens. Usually though I stick to the official stable one from the wiki, outdated by years as the current one is.
Re: Which 1.13 to install?[message #348230 is a reply to message #348127] Fri, 13 January 2017 17:17 Go to previous messageGo to next message
Czert

 
Messages:106
Registered:August 2007
do you have latest exe ?
Re: Which 1.13 to install?[message #352405 is a reply to message #347144] Wed, 14 February 2018 01:33 Go to previous messageGo to next message
mbr.to

 
Messages:17
Registered:February 2018
are the SCIs downwards compatible?
Re: Which 1.13 to install?[message #352409 is a reply to message #352405] Wed, 14 February 2018 09:52 Go to previous messageGo to next message
silversurfer

 
Messages:2230
Registered:May 2009
Downwards compatible to what exactly? A savegame without mods? To a certain degree - yes. With mods - not necessarily. Usually the mod has to be updated if new features require new game data.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Which 1.13 to install?[message #352411 is a reply to message #352409] Wed, 14 February 2018 15:34 Go to previous messageGo to next message
mbr.to

 
Messages:17
Registered:February 2018
sorry for the ambiguous question.
i mean is the latest SCI supposed to work with an older builds?
there are a lot of old builds available on depriĀ“s onedrive, but the SCIs only date back to 2015.

based on the changelogs i suspect that i would need a specific SCI for certain builds.
Re: Which 1.13 to install?[message #352417 is a reply to message #352411] Wed, 14 February 2018 19:13 Go to previous messageGo to next message
silversurfer

 
Messages:2230
Registered:May 2009
An SCI includes both game data and the exe that work together. It makes little sense to try old game data with a much newer exe and even less sense to try new game data with an old exe. It may work but why would anyone try to play a combination that was never meant to be played? Of course you can try whatever you like. Just don't ask for support for such experiments. ;-)



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Which 1.13 to install?[message #352489 is a reply to message #352417] Tue, 20 February 2018 17:37 Go to previous message
mbr.to

 
Messages:17
Registered:February 2018
yes, but not all builds come with a new SCI.
thats ok, because not every change in the code requires a change in the game data.

for the latest build i just use the latest SCI and it usually works.
but is there any way to know which SCI would be correct for a specific older build?
Previous Topic: Guide to debugging?
Next Topic: Music modding query
Goto Forum:
  


Current Time: Tue Feb 20 21:22:37 EET 2018

Total time taken to generate the page: 0.01601 seconds