Home » MODDING HQ 1.13 » v1.13 Modding, Customising, Editing » v1.13 Modding, Customising, Editing » Some Questions about my first Modding Attempts (Issues with frequent crashes after creating custom IMP Mod)
Some Questions about my first Modding Attempts[message #349810] Wed, 17 May 2017 19:31
MoreDread
Messages:1
Registered:May 2017
EDIT: NVM issue is solved, had nothing to do with the mod, the windows 8/10 fix has changed since the last time i used it.



Hey guys, long time lurker and finally decided to make an account because i ran into an issue that i would like to get some feedback on.

So i've been reinstalling ja2v1.13 every year or so for a few days of nostalgia, absolutely thrilled to see how theres something new to discover every time.
I often mod the games i play but rarely release anything.. this time around i wanted to attempt an idea i have been playing with for a while.

basically i like the idea of recruiting maria after her sidequest so she can take revenge, so i set up a little mod for it...
its nothing fancy, really just exposing her face and a custom voiceset based on the NPC one that exists already so she can be recreated as an IMP

now that i started a new game, set up my team, did some training and completed her quest and created the IMP version of her i'm starting to get alot of crashes tho.

i'm using SCI_Unstable_Revision_8403_on_GameDir_2363
and here is what i did:

i copied her face stis to data-1.13\impfaces without any changes
extracted all her speech WAV and GAP files as well as her EDTs, which i extended to 78 empty entries, duplicating the WAV files enough times to make sure theres no missing file
i duplicated some of the BattleSNDS as well to make sure all the required files are there
then i set up the correct folder structure and modified the XMLs

now i did change the ID# for her voiceset to 305 (88 is the orignal ID)
since we can now easily add an infinite amount that just works like a charm
i changed her face ID to 203 replacing a custom face i wasn't gonna use anyway, then proceeded to create the IMP, setting her name up properly and using similar stats to what the NPC has
created a test imp to see if it works, it did, everysthings fine

then i started a new game playing until i was able to do her quest, went back to omerta and loaded the character
started training, and a few days into that i was starting to get random crashes while passing time in the strategical overview screen, which is odd
i am used to odd behaviour, typically crashes when i'm entering/leaving sectors every now and then... and the occasional random crash would show up here and there, but this was way more frequent

after it happened the first time, i recieved an email from kingpin asking me to hunt down maria and angel who are hiding in a farm, this must be a relatively new addition.
i'm wondering if my Maria IMP is causing some odd conflicts here...

i am trying to find them now to see what happens
i was getting random crashes in tactical as well... way more common than what i'm used to

i am not sure that these things are related.. i also made some changes in the .ini
i remember activating a new website feature that was turned off by default without looking into it at all, that may not have been a good idea
i think its called the briefing room? just an empty input field, no idea what it does.

any ideas on whats going on or insights on what i could do to debug this would be appreciated.

it may have nothing to do with my messing with the files, might just be a i picked a particularly unstable revision for all i know.

oh i should mention i'm running this on windows 10 (win xp sp3 compatibility mode, 16 bit color mode activated)
in the somewhat odd resolution of 2580x1080 because i have one of those ultrawide monitors.



cheers!





[Updated on: Wed, 17 May 2017 23:14]

Previous Topic: New Voicepack
Next Topic: Creating tiles quick and easy
Goto Forum:
  


Current Time: Mon May 29 05:02:36 EEST 2017

Total time taken to generate the page: 0.00712 seconds