Home » MODDING HQ 1.13 » v1.13 Bug Reports » Game Freeze to death. (Game Freeze to death)
Game Freeze to death.[message #353188] Tue, 17 April 2018 03:13 Go to next message
Mobius1

 
Messages:5
Registered:July 2017
I have my current save for around 3 patches and the issue is still happening, in the next day, at 09:00 the game will freeze and crash.
I don't know what to do to fix it.
Creating a new game will still cause this issue, sometimes around day 14, sometimes around day 20, sometimes around day 12. Tried with different combinations of game modes, difficulty and other configuration tweaks. I'm using the default settings that comes with the latest patch, didn't edit any configs.

Can't attach the savegame on this post, so I've posted it on dropbox, the link is below:
www.dropbox.com/sh/wjthjav1rwfifuw/AABEgqWfCz6YxhHt2_dXLphXa?dl=0

EDIT: Forgot to add the important stuff: I'm playing JA2 with latest patch on SCI repo (8548) with AIMNAS also on the latest version on github (90). Using Win10 x64 8GB RAM i5 4440.

[Updated on: Tue, 17 April 2018 03:26]

Re: Game Freeze to death.[message #353211 is a reply to message #353188] Wed, 18 April 2018 18:09 Go to previous messageGo to next message
Jolly_Reaper

 
Messages:47
Registered:August 2002
Location: The Netherlands

Tried playing without AIMNAS? Perhaps it's some conflict between version 8548 and that mod?
I have no idea, just tossing it out there.
Re: Game Freeze to death.[message #353408 is a reply to message #353211] Thu, 10 May 2018 00:59 Go to previous messageGo to next message
Mobius1

 
Messages:5
Registered:July 2017
I haven't tried pure vanilla, yet but I'll test it out this weekend to see if the same thing happens.
Btw, not sure if its related or not but I have drassen freed before day 60 and playing on extreme diff. I also found Hamous before freeing the city.
Re: Game Freeze to death.[message #353430 is a reply to message #353408] Fri, 11 May 2018 12:09 Go to previous messageGo to next message
CareBear

 
Messages:117
Registered:April 2016
This is AIMNAS bug, i've encountered it too. Nothing really you can do about it, load earlier save and hope it wont happen again. Just save often and crawl through campaign. Still the map isnt fully done, so deidranna palace is just a small map, with aimnas weapons the last fights are trivial.
Re: Game Freeze to death.[message #355879 is a reply to message #353430] Sat, 17 November 2018 03:35 Go to previous messageGo to next message
HellsWind

 
Messages:33
Registered:October 2018
Location: Netherlands
I've managed to encounter this bug in two versions of SCI in AIMNAS

Jagged Alliance 2 Gold - SCI_JA2v1.13_Revision_8595_on_GameDir_2437
Jagged Alliance 2 Gold - SCI_JA2v1.13_Revision_8633_on_GameDir_2449

After a while in game, after visiting the airfield and clearing it the game will crash at around 9:00. If I don't visit the airfield I can continue playing without encountering the bug and I've heard somewhere that around 9:00 the Bobby Ray's shop gets "updated", so.. That might be bug related, not sure.

If I start the game up again, and load that save before the crash fast forwarding time, sometimes the games clock will stop working and game will not crash.

Any help would be appreciated though.

Edit, some additional info:
It appears such, but I'm not sure that error message related to this bug goes a little bit like this:

'Assertion Failure in line 2959, strategic movement.cpp'

[Updated on: Sat, 17 November 2018 03:40]

Re: Game Freeze to death.[message #356063 is a reply to message #355879] Sat, 01 December 2018 17:16 Go to previous message
IbexiSterlinfa
Messages:1
Registered:December 2018
Hello everyone, I just created this forum account because I don't have any solution to this problem and it's quite frustrating. I have had this bug happen for probably about a year now, across four different mods. I have had it happen in vanilla 1.13, AIMNAS, Vacations and now it is happening in Urban Chaos. I always use the latest 1.13 version from the one-drive, so I am confident that it is still an unsolved bug. As one member asked in this forum, it's not specific to AIMNAS, it is a bug within the 1.13 base mod. I currently have a save that displays this bug in Urban Chaos. In my past playthrough in AIMNAS I was able to guide my game through the bug by edging up to 8:59, saving, crashing the game by going to 9:00, restarting and letting it successfully proceed to 9:00, saving and then crashing at 9:01, and loading my second save and it would go on for another 24 hours only to happen again. This time in Urban Chaos it does not let me guide it over the crash, so it has effectively ended my game right here at day 54. I have messed around with the XMLs in most of my playthroughs, but nothing extensive enough to continually cause this bug to appear in each mod.

If anyone wants to tackle this bug, please let me know if I can assist you, because I have never actually been able to complete the game due to this bug and I have been continually plagued by it. I can provide any file you need from my files, as well as any logs that might help.

Thanks very much.
Previous Topic: MOLLEs cant hold gas type grenades
Next Topic: Unable to deploy soldiers properly when entering a new sector
Goto Forum:
  


Current Time: Fri Apr 26 04:57:40 EEST 2019

Total time taken to generate the page: 0.00836 seconds