Home » MODDING HQ 1.13 » v1.13 Modding, Customising, Editing » v1.13 Modding, Customising, Editing » Need a bit of help with graphic moding
Need a bit of help with graphic moding[message #354132] Mon, 23 July 2018 23:59 Go to next message
goc_man

 
Messages:114
Registered:November 2007
Location: Croatia
Hi all,
I'm doing a bit of item graphic modding and have a problem.

First of all, Im not a total noob. I know how to mod item graphics and have already edited / created lots of new item graphics that work just fine in-game.
Also I'm using JA2 1.13 - Revision_8548_Gamedir_2418

The problem is using GraphicType 4 with a new color pallet for my items. I'm missing something and I can't get it to work.
I've created the "p4itemXY.sti", "MDP4ITEMS.sti" and "SMP4ITEMS.sti" with apropriate palletes. Whenever the game loads an item to which I assigned the "<ubGraphicType>4" it crashes!

I think that something is wrong with my MDP4ITEMS.sti file, but I don't know what.

Is there an INI option, or special requirement for using GraphicTypes other then the existing P1, P2 and P3 ones?
Is it something to do with a specific color pallet requirement?

Any help is much appreciated.

[Updated on: Tue, 24 July 2018 00:00]

Re: Need a bit of help with graphic moding[message #354134 is a reply to message #354132] Tue, 24 July 2018 00:19 Go to previous messageGo to next message
Flugente

 
Messages:3424
Registered:April 2009
Location: Germany
Have you changed NUM_P_ITEMS in Ja2_Options.ini?



"Is there any way to get the blood to flow up the walls?"
"I don't see why not."

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: Need a bit of help with graphic moding[message #354150 is a reply to message #354134] Thu, 26 July 2018 01:29 Go to previous messageGo to next message
goc_man

 
Messages:114
Registered:November 2007
Location: Croatia
Thanks Flugente!

That was it. I know it had to be something simple hehehe
Re: Need a bit of help with graphic moding[message #355344 is a reply to message #354134] Sun, 14 October 2018 20:52 Go to previous message
goc_man

 
Messages:114
Registered:November 2007
Location: Croatia
Now a have a new problem:

I created a new MDP4ITEMS.sti file and the proper color palette in Photoshop and imported to STI Edit.
The palette has the first color blue RGB (0,0,255) for transparency and the second-to-last and last color Green and Red -> (0,255,0) and (255,0,0) as it should be.

It all works fine ingame except that I can't get the green color highlighting to work properly (example for compatible attachments...)
The green outline is always displayed on the item and doesn't work as intended. Something must be wrong with the palette but for the life of me, I can't figure out what!
I checked and double and triple checked, and the problem persists.

Any help is much appreciated.

[Updated on: Sun, 14 October 2018 20:53]

Previous Topic: JA2 New music MOD
Next Topic: JA2 NEW Faces MOD
Goto Forum:
  


Current Time: Thu Dec 13 06:55:53 EET 2018

Total time taken to generate the page: 0.00926 seconds